Subject: RE: [16NG] Comments on IPv4CS subnet model and ARP

From: 김상언[무선인터넷개발담당]<[email-masked]>
Date: Wed, 18 Jul 2007 19:02:44 +0900

7.  Address Resolution Protocol

The IEEE 802.16 frame header does not contain the source and
destination MAC addresses, instead it uses the Connection Identifier
(CID) for the delivery of MAC frames.  This makes classical Address
Resolution Protocol (ARP) [3] trivial and unnecessary. > Also, IEEE
802.16 IPCS cannot classify the ARP packets as ARP runs directly over
 Ethernet and does not contain IP header.  Thus ARP packets are not
transmitted over IEEE 802.16 air interface when using IPCS.

Proposed Changes: The IEEE 802.16 frame header does not contain the
source and destination MAC addresses, instead it uses the Connection
Identifier (CID) for the delivery of MAC frames.  This makes classical
Address Resolution Protocol (ARP) [3] trivial and unnecessary. Also,
IEEE 802.16 IPCS cannot classify the ARP packets as ARP runs directly
over Ethernet and does not contain IP header. Thus ARP packets are not
  transmitted over IEEE 802.16 air interface when using IPCS. However
MS requires to proxy ARP function compatible with legacy IP host.

[SC>] Let's discuss the last sentence. MS requires to proxy ARP function compatible with legacy IP host: What is the expected configuration of the scenario in this case? The legacy IP host will not be on the same Wimax IPCS
link; thus our assumption was that they would be on different subnets.
Please clarify.

[sekim] For example, legacy IP host is a notebook PC with IEEE802.16 wireless interface on Window by Microsoft.
IP hosts send a packet to the Base Station (BS) by unicast. Because IEEE 802.16 does not support broadcast among the nodes.
The uplink, from node to BS, supports unicast.
The downlink, from BS to node, supports multicast and broadcast.
Therefore, [RFC1207] should be used to support ARP capabilities for point to multipoint mode in IEEE 802.16 networks.
 If not, legacy host should use broadcast like IEEE 802.3. This means multicast and broadcast scheme are required in IEEE802.16 networks.

_______________________________________________
16NG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/16ng

---

From: "Samita Chakrabarti" <[email-masked]>
Date: Sun, 22 Jul 2007 01:22:23 -0700

Thanks for the reply. Please see in-line.

-------->

[SC>]  In case of IPCS, there is no MAC address involved. A BS should be aware of that. I am not sure why it  would try to do ARPing on the downlink although it is capable of broadcasting in that direction. BS may do ARPing for IP-over-ethernet CS link.  One question remains : what would be the behavior of ASN-GW when a node is on IP-over-EthCS link corresponding to a node with IPCS link ? Should we allow this kind of configuration? This brings in complexity; we can limit a single type of access CS per gateway ?

[SC>] Not sure what you mean here. Do you mean that a legacy host should be able to use the 802.16 network without any change in the IP/ARP mechanism?  I am thinking this example as today’s implementations to connect as an IP/Ethernet connection vs IP/Point-to-point connection. For point-point case, there is no MAC address used, thus usually the implementation does not do ARP. We can draw the analogy of point-to-point link with IPCS link. 

Before sending the PDU down the IP layer should know where it is sending the data to. If the link is a IPCS link, then it does not require ARPing.  But I understand that the draft is not clear about how/whether a IPCS link should interoperate with a regular 802.3 style MAC device.

Thanks,

-Samita