Subject: Re: [16NG] Request for review of draft-ietf-16ng-ip-over-ethernet-over-802-dot-16 from a DSL perspective

From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
Date: Sun, 4 Jan 2009 20:33:18 +0100

Hi Frank,

Thanks for your comments. We would appreciate to get some more
information on your general comments to reach better understanding for
making appropriate modifications in the document.

1) What would be the benefits of putting the public access
recommendation part into a separate Informational RFC on 'IPoETHo802.16
access in Broadband Networks'? Common broadband access networks e.g. DSL
accesss according to TR-101 can be configured either way, in public
access configuration or for Transparent LAN Service. I have the feeling
that the document would end up quite similar to the
draft-ietf-16ng-ip-over-ethernet-over-802-dot-16 document.
Is there anything, we should add in informational annexes to adapt the
applicability better to broadband access networks?

2) We agree that distributed bridging functionality is hard to implement
when a centralized database is needed. This led to the current approach
to show the applicability of the distributed bridging architecture in
the public access scenario, when forced forwarding allows to concentrate
the data base in one particular location. It seems, more extensive
considerations on the bridging architecture may be helpful for better
understanding the issues. Would you agree that we should provide more
text on the pros and cons of centralized vs distributed bridging
architectures.

Bye
Max

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Frank Xia
Sent: Wednesday, December 10, 2008 17:47
To: [email-masked]; Mark Townsley
Cc: [email-masked];
[email-masked]
Subject: Re: [16NG] Request for review of
draft-ietf-16ng-ip-over-ethernet-over-802-dot-16 from a DSL perspective

Hi Folks

General comments include:
1)removing public access recommendation part.
  We can have an informational draft on
  "IPoEo802.16 access in Broadband Network".
2)re-considering distributed bridging funcionalities.
  It is hard to implement when a centralized database needed.

Please check the detailed comments:
1) Section 8
  "Therefore, the AR in the  public access link model
   SHOULD assign common IPv6 prefixes to all SSs
   served by the AR"
  IP addresing is still under discussion in Broadband Forum.
  However, IMO, these is almost a consensus that each
  SS uses a unique IPv6 prefixe.

2)Section 7.3.
 When a network-side bridge receives an ARP request
  from a host behind subsriber-side bridge, the network
  side bridge should discard the request if the destination
  host is also behind the same subscriber-side switch.

3)Appendix B.
  I propose that the edge network-side switchs
  are responsible for host database maitenance, and
  responsing ARP request as a proxy.
  No centralized database is needed.

4)Section 7.2
   It is better to remove TR101 stuff from this section.

BR
Frank

----- Original Message -----
From: <[email-masked]>
To: "Mark Townsley" <[email-masked]>; "Frank Xia" 
<[email-masked]>
Cc: "Jari Arkko" <[email-masked]>; "Soohong Daniel Park" 
<[email-masked]>;
<[email-masked]>;
<[email-masked]>
Sent: Tuesday, November 18, 2008 6:01 PM
Subject: Request for review of
draft-ietf-16ng-ip-over-ethernet-over-802-dot-16 from a DSL perspective

> Hi Mark and Frank,
>
> Your names have been offered as people who are familiar with DSL 
> network deployments.
>
> We would like to request your review of a 16ng draft that may have 
> some similarities with those deployments:
>
> http://tools.ietf.org/html/draft-ietf-16ng-ip-over-ethernet-over-802-d
> ot-16-07
>
> This draft is in AD review, and Jari asked the WG to close the loop on

> this draft with DSL-savvy folks. The idea is not that they should 
> match, but that DSL deployments have some similarities, hence you 
> might have good insight and feedback on this draft.
>
> Please feel free to forward to other DSL experts you may be aware of. 
> If at all possible, we would like to get some feedback by December 12,
2008.
>
> Thanks in advance,
>
> Gabriel and Daniel, 16ng co-chairs
>
> 

_______________________________________________
16NG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/16ng
_______________________________________________
16NG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/16ng

---

From: Frank Xia <[email-masked]>
Date: Mon, 05 Jan 2009 10:02:13 -0600

Hi Max

Happy new year!

Please see my in-line reply...

BR
Frank
----- Original Message ----- 
From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
To: "ext Frank Xia" <[email-masked]>; <[email-masked]>; 
"Mark Townsley" <[email-masked]>
Cc: <[email-masked]>; 
<[email-masked]>
Sent: Sunday, January 04, 2009 1:33 PM
Subject: RE: [16NG] Request for review of 
draft-ietf-16ng-ip-over-ethernet-over-802-dot-16 from a DSL perspective

Hi Frank,

1) What would be the benefits of putting the public access
recommendation part into a separate Informational RFC on 'IPoETHo802.16
access in Broadband Networks'? Common broadband access networks e.g. DSL
accesss according to TR-101 can be configured either way, in public
access configuration or for Transparent LAN Service. I have the feeling
that the document would end up quite similar to the
draft-ietf-16ng-ip-over-ethernet-over-802-dot-16 document.
Is there anything, we should add in informational annexes to adapt the
applicability better to broadband access networks?
Frank=>You have  constructive recommendation to Broadband Network,
however,  I don't see the consistence with on-going technical choice
in Broadband network.  Just I highlighted in my email, you recommends
different users SHARE a IPv6 prefix, IMHO, it is not the case in Broadband
Network.

Even in IPoETHo802.16 access scenario, user isolation principle is
also supposed to be observed.  That is , different subscriber
is supposed to have different VLAN (or other mechanims, such
as MAC force forwarding..) .

I am not clear how to implement these in BRAS/DSLAM/SWITCH
after my reading this document.
is BRAS needed to extend to support PKM authentication?
is any GRE tunnel required for traffic between DSLAM and BRAS?
is any extra interface needed such as R6 in WiMAX ?
However, these clarificiations are not very related to this document,
while they are helpful when applying  IPoETHo802.16 to Broadband Network.

2) We agree that distributed bridging functionality is hard to implement
when a centralized database is needed. This led to the current approach
to show the applicability of the distributed bridging architecture in
the public access scenario, when forced forwarding allows to concentrate
the data base in one particular location. It seems, more extensive
considerations on the bridging architecture may be helpful for better
understanding the issues. Would you agree that we should provide more
text on the pros and cons of centralized vs distributed bridging
architectures.
Frank=>I dont know if it is proper when we design a STANDARD
while leaving some important issues for implementer.
I prefer to having a choice based on the WG talents.

Bye
Max

-----Original Message-----

Hi Folks

2)Section 7.3.

3)Appendix B.

4)Section 7.2

BR
Frank

----- Original Message -----
From: <[email-masked]>
To: "Mark Townsley" <[email-masked]>; "Frank Xia"
<[email-masked]>

2008.

---

From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 7 Jan 2009 16:49:04 +0100

Hi Frank,

I admit that it is not so obvious to see how the public access scenario
maps to the DSL access network based on Ethernet aggregation. But we
should keep in mind that the DSL access network does not only serve
IPoETH but as well PPPoETH and Transparent LAN Service.
Deployment of IEEE802.16 in DSL access network must support all three
modes of operation, while the 16ng I-D only addresses the IPoETH aspects
in a generic sense.

A comprehensive specification for deployment of WiMAX in DSL access
networks is currently created by a joint activity between the WiMAX
Forum and the Broadband Forum. The resulting specification might provide
you the DSL specific answers for implementation, you are looking for.
The IETF may not be the most appropriate place to write a specification
with recommendations tailored for DSL access networks.

Nevertheless we should take care that the 16ng I-D is in line with the
design decisions by the BBF for IPv6oETH in the public access.
Unfortunately the IPv6 related specifications in the BBF are still work
in progress, which means that the documents are not visible to the IETE
16ng.

Frank, what would propose to get alignment of the design decisions for
IPv6 in BBF and in 16ng. Is it only the IPv6 prefix issue, or do we have
other discrepancies?

Bye
Max

>From: ext Frank Xia [mailto:[email-masked]] 
>Sent: Monday, January 05, 2009 5:02 PM
>To: Riegel, Maximilian (NSN - DE/Munich); [email-masked];
Mark Townsley
[email-masked]

---

From: Frank Xia <[email-masked]>
Date: Wed, 07 Jan 2009 11:17:28 -0600

Hi Max

Thank for you detailed explanation.
Please check my response..

BR
Frank

----- Original Message ----- 
From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
To: "Frank Xia" <[email-masked]>; <[email-masked]>; "Mark 
Townsley" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, January 07, 2009 9:49 AM
Subject: RE: [16NG] Request for review of 
draft-ietf-16ng-ip-over-ethernet-over-802-dot-16 from a DSL perspective

Hi Frank,

I admit that it is not so obvious to see how the public access scenario
maps to the DSL access network based on Ethernet aggregation. But we
should keep in mind that the DSL access network does not only serve
IPoETH but as well PPPoETH and Transparent LAN Service.
Deployment of IEEE802.16 in DSL access network must support all three
modes of operation, while the 16ng I-D only addresses the IPoETH aspects
in a generic sense.
Frank=> IPoETH  should be the MAIN deployment in the future.
PPPoX is fading out.  Transparent LAN is mainly for enterprise users.

A comprehensive specification for deployment of WiMAX in DSL access
networks is currently created by a joint activity between the WiMAX
Forum and the Broadband Forum. The resulting specification might provide
you the DSL specific answers for implementation, you are looking for.
The IETF may not be the most appropriate place to write a specification
with recommendations tailored for DSL access networks.
Frank=>I have been keeping an eye on the joint activities.
In fact, I also agree that IETF is not the most appropriate place
to specify this.  However, I don't it is necessary
to bother readers with SDO specific knowledge,
unless you can make it clear enough :-)

Nevertheless we should take care that the 16ng I-D is in line with the
design decisions by the BBF for IPv6oETH in the public access.
Unfortunately the IPv6 related specifications in the BBF are still work
in progress, which means that the documents are not visible to the IETE
16ng.
Frank=>This is also my concern  on this document.
IPv6 work is ongoing in BBF, while you give some
recommendation which is probably not in line with it.
It seems improper.

Frank, what would propose to get alignment of the design decisions for
IPv6 in BBF and in 16ng. Is it only the IPv6 prefix issue, or do we have
other discrepancies?
Frank=>Only IPv6 prefix issue.  If I were you, I would
like to prioritize my choice as following
1)removing this part, and leaving it to WiMAX/BBF joint work.
2)Keeping this part, and waiting for  IPv6 progress in BBF for alignment

Bye
Max

Mark Townsley
[email-masked]

---

From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 8 Jan 2009 11:19:16 +0100

Thanks Frank for the conclusion. We will remove the IPv6 prefix
recommendation in the public access section to prevent collisions with
the upcoming BBF specification. Instead we will provide 802.16 specific
guidance for either prefix configuration to help network architects to
deploy 802.16 in their IPv6 enabled public access networks.

Thanks for the clarification of the IPv6 prefix issue. All your comments
will be addressed in the next revision of the I-D.

Bye
Max

-----Original Message-----
From: ext Frank Xia [mailto:[email-masked]] 
Sent: Wednesday, January 07, 2009 6:17 PM
To: Riegel, Maximilian (NSN - DE/Munich); [email-masked]; Mark
Townsley
Cc: [email-masked]

Hi Max

BR
Frank

----- Original Message ----- 
From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
To: "Frank Xia" <[email-masked]>; <[email-masked]>;
"Mark 

Hi Frank,

Bye
Max

Mark Townsley
[email-masked]

---

From: "Frank Xia" <[email-masked]>
Date: Thu, 8 Jan 2009 08:26:27 -0600

Hi Max

Thank you!
See the published RFC soon!

BR
Frank
----- Original Message ----- 
From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
To: "ext Frank Xia" <[email-masked]>; <[email-masked]>; 
"Mark Townsley" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, January 08, 2009 4:19 AM
Subject: RE: [16NG] Request for review of 
draft-ietf-16ng-ip-over-ethernet-over-802-dot-16 from a DSL perspective

Bye
Max

-----Original Message-----
From: ext Frank Xia [mailto:[email-masked]]
Sent: Wednesday, January 07, 2009 6:17 PM
To: Riegel, Maximilian (NSN - DE/Munich); [email-masked]; Mark
Townsley
Cc: [email-masked]

Hi Max

BR
Frank

----- Original Message ----- 
From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
To: "Frank Xia" <[email-masked]>; <[email-masked]>;
"Mark

Hi Frank,

Bye
Max

Mark Townsley
[email-masked]