Subject: [6lo] Revised draft Milestone for 6lo

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 11 Oct 2013 17:36:11 +0000

Hello All:

Ulrich and I worked on a revised version of the Milestone. It incorporates input from Ralph, Carsten, Anders and Benoit.

Please note that it is a tentative milestone for early thoughts - we are going to discuss the milestones and timeline during the Nov f2f meeting.

Dec 2013    WG decision on adoption for
           1) draft-bormann-6lowpan-ghc-05.txt
           2) draft-brandt-6man-lowpanz-02.txt
           3) draft-lynn-6man-6lobac-02.txt

March 2014  Discuss draft-ersue-constrained-mgmt-03

May   2014  WG review to determine adoption of:
           1)   draft-schoenw-6lowpan-mib-xx.txt
           2)   draft-mariager-6lowpan-v6over-dect-ule-xx.txt
           3)   Backbone Router document
           4)   draft-thubert-roll-forwarding-frags-xx.txt

May     2014 WG last call for adopted 6lo MIB document

June    2014 WG last call for adopted IPv6-over-foo I-Ds

June    2014 First draft of a generic guideline on IPv6-over-foo
          Review the following:
            draft-bormann-6lowpan-roadmap-03.txt
            draft-bormann-intarea-alfi-02.txt
            Any new drafts for general guideline

July   2014 6lo Documents  on information model and data model work starts
             - generic 6lo models are encouraged
             - MIB module development should leverage existing 6lowpan-mib document

July     2014  IESG submission of advanced wg documents
August   2014  WG adoption of  generic guideline/roadmap document
Sept     2014  WG LC for the other selected wg documents

Nov      2014  Re-charter if needed

Dec      2014  WG LC of guideline/roadmap document

Thanks,
-Samita

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 11 Oct 2013 20:12:11 +0200

>              - MIB module development should leverage existing 6lowpan-mib document

What does "6lo Documents on information model and data model work
starts" mean in the light of the May 2014 milestone?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 11 Oct 2013 20:40:04 +0200

On Oct 11, 2013, at 19:36, Samita Chakrabarti <[email-masked]> wrote:

> Please note that it is a tentative milestone for early thoughts – we are going to discuss the milestones and timeline during the Nov f2f meeting.
>  

Sounds good (actually this should be done by the end of November).

(GHC-06 expired a couple of days ago, I was waiting for 6lo approval and will now resubmit as "draft-bormann-6lo-ghc-00".)

>            3) draft-lynn-6man-6lobac-02.txt                    

Let's feedback with Kerry about this -- there was some work back at the BACnet base that needed to be done.
I don't know how far advanced that is.  (I hope we can have a resubmit as -6lo before the deadline, too.)

>            1)   draft-schoenw-6lowpan-mib-xx.txt

This has already received some review in 6LoWPAN, so I think it could be in the 2013 bucket.

>            2)   draft-mariager-6lowpan-v6over-dect-ule-xx.txt

Similar comment as with 6lobac.

>            4)   draft-thubert-roll-forwarding-frags-xx.txt

These sound about right for May 2014, we should have finished the necessary discussion by then.

> May     2014 WG last call for adopted 6lo MIB document

(This only makes sense if we adopt it earlier, and may be a bit late actually.)

I'm missing a milestone for GHC WGLC.

> June    2014 WG last call for adopted IPv6-over-foo I-Ds

These could come earlier or later, depending on foo.
Do one milestone per foo.

>             Any new drafts for general guideline

Interesting idea.  Let's talk about that in Vancouver.

>              - MIB module development should leverage existing 6lowpan-mib document

Same question as Juergen has.  Do we have the energy for something like this?

> July     2014  IESG submission of advanced wg documents

Again, I'd do this per document.

> Dec      2014  WG LC of guideline/roadmap document

I'm not sure the roadmap document should turn RFC at this point already, but we can discuss this in Vancouver.

Grüße, Carsten

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 11 Oct 2013 18:52:11 +0000

Hi Carsten,

Thanks for the feedback.

The milestone is in a drafty form now.  The drafts are grouped and the timeline indicates the boundary timeline. Some of them can be done earlier than the deadline - for example the GHC and LowpanZ drafts by Nov if they are ready to proceed.

As for the 6lowpan-mib document, we can start discussing the document and ask the wg for input.

Let's discuss the rest in the wg meeting and come up with a more realistic milestone timeline after that.

-Samita

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Friday, October 11, 2013 11:40 AM
To: Samita Chakrabarti
Cc: [email-masked]
Subject: Re: [6lo] Revised draft Milestone for 6lo

Grüße, Carsten

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 11 Oct 2013 18:58:21 +0000

Hi Juergen,

The milestone is a draft one - we need to discuss and modify it after Nov meeting.

The information model and MIB development request came as one of the IESG requirements/comments.
Hence it is holding a place in the Milestone so that we make sure we hold a discussion on a need of an information model that applies to 6lo technologies.
MIB development might be already covered by your draft - but it is helpful to have a discussion around it as the scope of 6lo and 6lowpan are different.

Hope it clarifies the question below.

Regards,
-Samita

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Friday, October 11, 2013 11:12 AM
To: Samita Chakrabarti
Cc: [email-masked]
Subject: Re: [6lo] Revised draft Milestone for 6lo

>              - MIB module development should leverage existing 

What does "6lo Documents on information model and data model work starts" mean in the light of the May 2014 milestone?

/js