Subject: [6lo] Benoit Claise's Block on charter-ietf-6lo-00-04: (with BLOCK and COMMENT)

From: "Benoit Claise" <[email-masked]>
Date: Thu, 10 Oct 2013 05:16:51 -0700

Benoit Claise has entered the following ballot position for
charter-ietf-6lo-00-04: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/charter-ietf-6lo/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

I have no general concern about chartering this WG but I would like to
see a
clarification with respect to this point:

"6lo focuses on Internet Area work that is needed for constrained node
networks with the characteristics of:"

What does Internet Area work mean?
Btw, you want a MIB module, should we add OPS in there?
Proposal: remove "Internet Area"

Same remark for "6lo works on small, focused pieces of Internet Area
work."
It clashes with

    2. Information and data models (e.g., MIB modules) for these
    adaptation layers for basic monitoring and troubleshooting.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Via email, Carsten proposed: "I think the decision that the current one
will be a MIB module should be in the milestones, and the charter should
say how we arrive at these decisions."

The proposed milestones addition would be a plus.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 10 Oct 2013 14:24:55 +0200

On Oct 10, 2013, at 14:16, "Benoit Claise" <[email-masked]> wrote:

> Internet Area

Interesting comment.  What was meant was that the MIB modules (IMs/DMs) will be *about* things that we traditionally put into the INT area of the IETF (counters for packets etc., link layer state, not some application layer monitoring), because that is the domain of expertise of the WG.

It is my understanding that those IMs/DMs have traditionally often been done by the same groups that did the IP-over-foo spec, so it seemed expeditious to subsume this under an INT area working group.  (I don't think anybody is trying to subsume the entirety of OAM under INT...)

Grüße, Carsten

---

From: Brian Haberman <[email-masked]>
Date: Thu, 10 Oct 2013 08:32:29 -0400

Hi Benoit,

> http://datatracker.ietf.org/doc/charter-ietf-6lo/

I would have problem dropping the references to "Internet Area".  You
are correct that there are some work items that cross area boundaries.

I have the chairs pulling milestones together.  I will make sure this
gets added to their list.

Regards,
Brian

---

From: Brian Haberman <[email-masked]>
Date: Thu, 10 Oct 2013 08:34:32 -0400

Hi Carsten,

> It is my understanding that those IMs/DMs have traditionally often been done by the same groups that did the IP-over-foo spec, so it seemed expeditious to subsume this under an INT area working gro…

You are correct that we are not subsuming OAM, but the suggested change
is not going to impact the work that needs to be done.

Regards,
Brian

---

From: Benoit Claise <[email-masked]>
Date: Thu, 10 Oct 2013 14:49:13 +0200

On 10/10/2013 14:32, Brian Haberman wrote:
> I would have problem dropping the references to "Internet Area".
No problem with me, but then define what you mean.
Honestly, I don't know what's meant by "Internet Area work".

Regards, Benoit
> You

---

From: Brian Haberman <[email-masked]>
Date: Thu, 10 Oct 2013 08:51:30 -0400

> Honestly, I don't know what's meant by "Internet Area work".

Darn typos change the meaning of everything. :)

What I meant to say was that I would have "no" problem dropping the
reference to Internet Area.

Brian

---

From: Ralph Droms <[email-masked]>
Date: Thu, 10 Oct 2013 09:08:33 -0400

> reference to Internet Area.

Did we insert "Internet Area" to address someone else's concern about 6lo work scoping?  

To me, "Internet Area" means "work appropriate to the IETF Internet Area".  Perhaps "Internet Area" is redundant considering 6lo's position as an INT Area WG.

I don't feel strongly about keeping or dropping "Internet Area".  I honestly don't think it makes a difference.

- Ralph

> 
> Brian
> 
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: Ralph Droms <[email-masked]>
Date: Thu, 10 Oct 2013 09:27:27 -0400

> reference to Internet Area.

I don't have easy access to the charter.  Is there the usual "recharter for new topics" included somewhere?  Can we make a case that 6lo's position in INT Area is implicit and sufficient limit on its scope to pass the IESG?

- Ralph

---

From: Brian Haberman <[email-masked]>
Date: Thu, 10 Oct 2013 09:48:49 -0400

Ralph,

> I don't have easy access to the charter.  Is there the usual "recharter for new topics" included somewhere?  Can we make a case that 6lo's position in INT Area is implicit and sufficient limit on i…

No.  There is no text in the charter that currently says the WG will
re-charter to take on new work.

Brian

---

From: Ralph Droms <[email-masked]>
Date: Thu, 10 Oct 2013 10:04:04 -0400

> re-charter to take on new work.

Carsten reminded me there is other scope-limiting text in the charter.

For the IESG - as 6lo is in the INT Atea, and there is other scope-limiting texr in the charter, are there any objections to dropping "Internet Area" from the intro paragraph of the charter?

- Ralph

---

From: Benoit Claise <[email-masked]>
Date: Thu, 10 Oct 2013 16:30:52 +0200

> For the IESG - as 6lo is in the INT Atea, and there is other scope-limiting texr in the charter, are there any objections to dropping "Internet Area" from the intro paragraph of the charter?
Not for me.
Note: there is a second instance

    6lo works on small, focused pieces of Internet Area work. 6lo does not take on
    larger cross-layer efforts. The working group will continue to reuse existing
    protocols and mechanisms whenever reasonable and possible.

Regards, B.

> .

---

From: Ulrich Herberg <[email-masked]>
Date: Thu, 10 Oct 2013 08:44:38 -0700

I agree that it is implied by being an INT area WG. Removing the word
"Internet Area" would result in:

===================
OLD
6lo focuses on Internet Area work that is needed for constrained node
networks with the characteristics of:

NEW
6lo focuses on work that is needed for constrained node
networks with the characteristics of:
===================

and

===================
OLD
6lo works on small, focused pieces of Internet Area work.

NEW
6lo works on small, focused pieces of work.
===================

Alternatively for the latter:
===================
OLD
6lo works on small, focused pieces of Internet Area work. 6lo does not
take on larger cross-layer efforts.

NEW
6lo works on small, focused pieces of work and does not take on larger
cross-layer efforts.
===================

Regards
Ulrich

On Thu, Oct 10, 2013 at 7:30 AM, Benoit Claise <[email-masked]> wrote:
> I don't have easy access to the charter.  Is there the usual "recharter for
> new topics" included somewhere?  Can we make a case that 6lo's position in
> INT Area is implicit and sufficient limit on its scope to pass the IESG?
>
> For the IESG - as 6lo is in the INT Atea, and there is other scope-limiting
> texr in the charter, are there any objections to dropping "Internet Area"
> from the intro paragraph of the charter?
>
> Not for me.

---

From: Benoit Claise <[email-masked]>
Date: Fri, 11 Oct 2013 12:49:54 +0200

Hi Ulrich,

Personally, I prefer the second option.
Anyway, I clear my BLOCK.

Regards, Benoit