Subject: [6lo] TR: New Version Notification for draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks-00.txt

From: "Popa, Daniel" <[email-masked]>
Date: Mon, 31 Mar 2014 01:51:08 +0000

Hello all,

A new draft has been submitted to 6lo WG with the objective of getting WG adoption.  

This draft describes the transmission of IPv6 packets over IEEE 1901.2 narrowband powerline communication networks. 

Regards,
Daniel

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : lundi 31 mars 2014 03:10
À : Popa, Daniel; Jonathan W. Hui
Objet : New Version Notification for draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks-00.txt

A new version of I-D, draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks-00.txt
has been successfully submitted by Daniel Popa and posted to the IETF repository.

Name:		draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks
Revision:	00
Title:		6LoPLC: Transmission of IPv6 Packets over IEEE 1901.2 Narrowband Powerline Communication Networks
Document date:	2014-03-31
Group:		Individual Submission
Pages:		5
URL:            http://www.ietf.org/internet-drafts/draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks-00.txt
Status:         https://datatracker.ietf.org/doc/draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks/
Htmlized:       http://tools.ietf.org/html/draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks-00

Abstract:
   This document updates [RFC 4944], "Transmission of IPv6 Packets over
   IEEE 802.15.4 Networks", and [RFC 6282], "Compression Format for IPv6
   Datagrams over IEEE 802.15.4-Based Networks", and specifies the
   6LoPLC technology: the transmission of IPv6 packets over IEEE 1901.2
   narrowband powerline communication networks.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Samita Chakrabarti <[email-masked]>
Date: Tue, 1 Apr 2014 01:13:44 +0000

Hi Daniel/Jonathan:

This work seems to make sense to me for PLC communication.

Out of curiosity, is it Homeplug that might be interested in this draft?  Do you have any plans/dependency of your draft with another SDO?

By reading the draft briefly , I see there are two major differences : no fragmentation  at 6lowpan layer is recommended and  the MTU size at MAC layer is 1280 byte and at L2, IEEE 1901.2 takes care of the fragmentation due to lower PHY MTU size.

Other thing I notice that it mandates (MUST) RFC6282.

Question: Why is the fragmentation "NOT RECOMMMENDED"  as opposed to "MUST NOT" ?

The draft mentions that PLC supports Mesh and star topology support like IEEE 802.15.4.  Does 6lowpan implementation on IEEE 1901.2 use any mesh L2 implementation underneath?

Does 6lo-over-PLC need RFC6577 support at all?  Please add a section on its impact on 6lowpan-nd. If it is used, then what sections are used. If it does not, then please provide a few lines of explanations and describe how the IPv6 addresses are assigned and the nodes are rebooted with IPv6 addresses and communicate with each other.

Also please review the 6lowpan-mib document and see if that can be used for this stack as well ? 

Best regards,
-Samita

-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of Popa, Daniel
Sent: Sunday, March 30, 2014 6:51 PM
To: [email-masked]
Cc: [email-masked]'; Cisco-Johnathan Hui
Subject: [6lo] TR: New Version Notification for draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks-00.txt

Hello all,

Regards,
Daniel

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] Envoyé : lundi 31 mars 2014 03:10 À : Popa, Daniel; Jonathan W. Hui Objet : New Version Notification for draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
6lo mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lo