Subject: [6lo] Quick comments on http://tools.ietf.org/html/draft-ietf-6lo-lowpanz-04

From: Samita Chakrabarti <[email-masked]>
Date: Tue, 18 Mar 2014 01:13:21 +0000

Hi Anders,

I have a quick question/comment on the v-04 of your draft:

1)      Introduction says:

If using

   that method, Duplicate Address Detection (DAD) is not needed.

   Alternatively, IPv6 addresses may be assigned centrally via DHCP,

   leading to a "non-link-layer-derived IPv6 address".  Address

   registration is only needed in certain cases.

Comment:  It is not clear when address registration is needed. "certain cases" is ambiguous. Do we need it when DHCPv6 assigned addresses are used? Please clarify

2)      In privacy section, it talks about using centrally assigned Ipv6 addresses by DHCP. Do you want to clarify DHCP assigned addresses with short lease period or short lifetime and ability to obtain a different IPv6 address upon renewal of the lease?  If there is a pointer to a document which defines how DHCPv6 address allocation can be used for privacy - referencing that would have been nice.

Will do some more review later.

Thanks,
-Samita

---

From: Anders Brandt <[email-masked]>
Date: Fri, 21 Mar 2014 13:58:12 +0000

Samita,

Thanks for your comments.

1)
> Quote: ".  Address registration is only needed in certain cases."
> It is not clear when address registration is needed. "certain cases" is ambiguous.
> Do we need it when DHCPv6 assigned addresses are used? Please clarify

I agree that the particular sentence seems unclear but this is the introduction and
the idea was to warn the user of that fact without getting into details in the introduction.

Fortunately, the principle of the draft is very clear:
Address registration is always needed in route over mode and it is needed in mesh under mode if DHCP is used.

Alternative proposal:
Address registration is not needed in mesh-under mode when using link-layer-derived IPv6 addresses.

Though I prefer the existing one...

2)
>Do you want to clarify DHCP assigned addresses with short lease period or short lifetime
> and ability to obtain a different IPv6 address upon renewal of the lease?
> If there is a pointer to a document which defines how DHCPv6 address allocation can be
> used for privacy - referencing that would have been nice.

I am not aware of a pointer as such, except for a statement in the 6man WG session in London that DHCPv6 provided good privacy properties when the DHCP
server is configured correctly. This should just be considered as a deployment guidance.

Alternative proposal (first line unmodified from draft -04):
  While intended for central address management, DHCPv6 address assignment also decouples the
  IPv6 address from the link layer address. Addresses may be made dynamic by the use of a short DHCP
  lease period and an assignment policy which makes the DHCP server hand out a fresh IP address every time.

Thanks,
  Anders.

From: Samita Chakrabarti [mailto:[email-masked]]
Sent: 18. marts 2014 02:13
To: Anders Brandt
Cc: [email-masked]
Subject: Quick comments on http://tools.ietf.org/html/draft-ietf-6lo-lowpanz-04

Hi Anders,

1)      Introduction says:

If using

Thanks,
-Samita

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 28 Mar 2014 02:22:34 +0000

Hi Anders,

Please see in-line.
From: Anders Brandt [mailto:[email-masked]]
Sent: Friday, March 21, 2014 6:58 AM
To: Samita Chakrabarti
Cc: [email-masked]
Subject: RE: Quick comments on http://tools.ietf.org/html/draft-ietf-6lo-lowpanz-04

Samita,

1)

I agree that the particular sentence seems unclear but this is the introduction and
the idea was to warn the user of that fact without getting into details in the introduction.
[SC>] Ok. Fair enough. I'll read again.

Alternative proposal:

Though I prefer the existing one...
[SC>] Yes, I like the existing line as well.   It might make sense to add the sentence (alternative proposal) for clarity in the spec, if it is not mentioned in another relevant place in the draft.

2)

[SC>] This one looks more clear to me.

Thanks,
-Samita

From: Samita Chakrabarti [mailto:[email-masked]]
Sent: 18. marts 2014 02:13
To: Anders Brandt
Cc: [email-masked]<mailto:[email-masked]>
Subject: Quick comments on http://tools.ietf.org/html/draft-ietf-6lo-lowpanz-04

Hi Anders,

1)      Introduction says:

If using

Thanks,
-Samita