Subject: [6lo] About updates in draft-ietf-6lo-btle-12.txt

From: "Savolainen Teemu (Nokia-TECH/Tampere)" <[email-masked]>
Date: Tue, 19 May 2015 06:26:39 +0000

Hi all,

We received good offline feedback from Erik Rivard regarding some details in the header compression sections, and the feedback is now addressed in this -12 version.

The changes remove some ambiguities that might have caused interoperability issues, fix an actual bug in CID-field handling, and improve compression performance in case 6LN is using multitude of non-link-local addresses with random IIDs. The multiple addresses for a compression context-case was not that well handled in previous draft versions. 

We don't think the changes are big enough to warrant returning of the document to the WG process, but please have a check anyway in case you disagree with that assessment.

Best regards,

Teemu

-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of ext [email-masked]
Sent: 19. toukokuuta 2015 9:15
To: [email-masked]
Cc: [email-masked]
Subject: [6lo] I-D Action: draft-ietf-6lo-btle-12.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IPv6 over Networks of Resource-constrained Nodes Working Group of the IETF.

        Title           : IPv6 over BLUETOOTH(R) Low Energy
        Authors         : Johanna Nieminen
                          Teemu Savolainen
                          Markus Isomaki
                          Basavaraj Patil
                          Zach Shelby
                          Carles Gomez
	Filename        : draft-ietf-6lo-btle-12.txt
	Pages           : 18
	Date            : 2015-05-18

Abstract:
   Bluetooth Smart is the brand name for the Bluetooth low energy
   feature in the Bluetooth specification defined by the Bluetooth
   Special Interest Group.  The standard Bluetooth radio has been widely
   implemented and available in mobile phones, notebook computers, audio
   headsets and many other devices.  The low power version of Bluetooth
   is a specification that enables the use of this air interface with
   devices such as sensors, smart meters, appliances, etc.  The low
   power variant of Bluetooth is standardized since the revision 4.0 of
   the Bluetooth specifications, although version 4.1 or newer is
   required for IPv6.  This document describes how IPv6 is transported
   over Bluetooth low energy using 6LoWPAN techniques.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6lo-btle/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-6lo-btle-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-6lo-btle-12

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
6lo mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lo

---

From: Samita Chakrabarti <[email-masked]>
Date: Tue, 19 May 2015 07:36:33 +0000

Thanks Teemu for the headsup on the updates.

Question(without reading the latest draft yet): will the compression updates using multiple link-local addresses with random IIDs be applicable in generic  6lo (ipv6-over-foo) cases in your opinion ?

Regards,
-Samita
-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of Savolainen Teemu (Nokia-TECH/Tampere)
Sent: Monday, May 18, 2015 11:27 PM
To: [email-masked]
Subject: [6lo] About updates in draft-ietf-6lo-btle-12.txt

Hi all,

Best regards,

Teemu

-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of ext [email-masked]
Sent: 19. toukokuuta 2015 9:15
To: [email-masked]
Cc: [email-masked]
Subject: [6lo] I-D Action: draft-ietf-6lo-btle-12.txt

Abstract:

---

From: "Savolainen Teemu (Nokia-TECH/Tampere)" <[email-masked]>
Date: Tue, 19 May 2015 20:03:41 +0000

Hi Samita,

Even after the updates the draft only talks about link-local addresses mapped to the Bluetooth Device Addresses (which may be random addresses). 

The updates were about non-link-local addresses that are registered with ARO and that cannot be determined from link-layer headers. In the new text the nodes can fully elide address when referring to the latest registered address, and previously registered addresses can only be partially elided. Please see example in the updated draft.

Maybe the approach could apply to other foos, but I haven't checked them in detail enough to really tell.

Best regards,

	Teemu

-----Original Message-----
From: ext Samita Chakrabarti [mailto:[email-masked]] 
Sent: 19. toukokuuta 2015 10:37
To: Savolainen Teemu (Nokia-TECH/Tampere); [email-masked]
Subject: RE: [6lo] About updates in draft-ietf-6lo-btle-12.txt

Regards,
-Samita
-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of Savolainen Teemu (Nokia-TECH/Tampere)
Sent: Monday, May 18, 2015 11:27 PM
To: [email-masked]
Subject: [6lo] About updates in draft-ietf-6lo-btle-12.txt

Hi all,

Best regards,

Teemu

-----Original Message-----
From: 6lo [mailto:[email-masked]] On Behalf Of ext [email-masked]
Sent: 19. toukokuuta 2015 9:15
To: [email-masked]
Cc: [email-masked]
Subject: [6lo] I-D Action: draft-ietf-6lo-btle-12.txt

Abstract: