Subject: [6lo] mic comment about layers

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 20 Jul 2015 19:29:09 +0200

Hello,

I wanted to make a comment at the mic about layering, during the IANA 
registry discussion.

As I hear the discussion about liaison with ITU, it looks to me as a 
ping-pong of statements.

Who is responsible to allocate these codepoints - IANA or ITU?

Even if IANA makes a registry for it, are we sure that ITU will not 
allocate in the future other codepoints beyond what IANA allocates?  
And, should we care?

My oppinion on this is that IANA should not allocate numbers to whatever 
runs below IPv6 headers.

Let the underlying layers (below IP) offer IEEE-like interfaces, with 
EtherTypes.  That's what works.

Alex

---

From: Kerry Lynn <[email-masked]>
Date: Mon, 20 Jul 2015 13:34:32 -0400

On Mon, Jul 20, 2015 at 1:29 PM, Alexandru Petrescu <
[email-masked]> wrote:

> allocate in the future other codepoints beyond what IANA allocates?  And,
> should we care?
>
> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xhtml

> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 20 Jul 2015 19:38:47 +0200

Le 20/07/2015 19:34, Kerry Lynn a écrit :
> On Mon, Jul 20, 2015 at 1:29 PM, Alexandru Petrescu
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hello,
>
>     I wanted to make a comment at the mic about layering, during the
>     IANA registry discussion.
>
>     My oppinion on this is that IANA should not allocate numbers to
>     whatever runs below IPv6 headers.
>

That is a reflection of what IEEE controls.  It's IEEE who controls, and 
IANA 'mirrors' it.

I dont have the same feeling that the same happens between ITU and 6lo 
here.  It looks more like a competition between who allocates what.  The 
format of it is not agreed either.

And - worse - the 6lo WG does not seem to be queried oppinion, but 
imposed decisions.

This is not a way to move forward, I fully disagree.

Alex

>
>     Let the underlying layers (below IP) offer IEEE-like interfaces,
>     with EtherTypes.  That's what works.
>
>     Alex
>
>
>     [email-masked] <mailto:[email-masked]>

---

From: Kerry Lynn <[email-masked]>
Date: Mon, 20 Jul 2015 13:47:45 -0400

On Mon, Jul 20, 2015 at 1:38 PM, Alexandru Petrescu <
[email-masked]> wrote:

> <kel>
Yes, sorry - I should have provided more context.  It seems there's a well
defined process
[RFC 7042] for coordination between IEEE and IETF and expert review is
required.  Perhaps
something similar can be worked out in this case.
</kel>

> And - worse - the 6lo WG does not seem to be queried oppinion, but imposed
> decisions.
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 20 Jul 2015 21:03:49 +0200

Le 20/07/2015 19:47, Kerry Lynn a écrit :
> On Mon, Jul 20, 2015 at 1:38 PM, Alexandru Petrescu
> <[email-masked] <mailto:[email-masked]>
> <mailto:[email-masked]
> <mailto:[email-masked]>>> wrote:
>
> Hello,
>
> That is a reflection of what IEEE controls.  It's IEEE who controls,
> and IANA 'mirrors' it.
>
> <kel> Yes, sorry - I should have provided more context.  It seems
> there's a well defined process [RFC 7042] for coordination between
> IEEE and IETF and expert review is required.  Perhaps something
> similar can be worked out in this case. </kel>

I agree with that RFC mentioning, thanks.

But the advancement doesnt look promissing to me.  Let me say why.

Ralph (liaison, all due respect), expressed that ITU requested an answer
in 1week time. (IMHO and not only mine this is way too short to figure
out in a consensual way).  And proposed an answer saying (1) future IANA
allocations do not break G-9x specs and (2) to be figured out.

Somebody with ITU experience said G-990_5_ should be considered as well,
that _5_ seemed to be a surprise to the group.

At this point, it is not clear what is (2) in Ralph's thinking.  And it
is not clear - in case IANA creates registry - whether or not ITU agrees
that IANA takes control of this space.

I think we could try to agree whether or not we should state upfront
that this is not under the authority of IANA.  My personal oppinion is
to let ITU take control of it.  This is a matter below IP.

In that sense, ITU may make a requirement on IEEE to write a MAC layer,
over which, in the end, IP could run.

I really dont think it is an IETF's group's business (any other than
6man WG) to control and redefine IPv6 and all the layers below it.

Yours,

Alex

> I dont have the same feeling that the same happens between ITU and
> 6lo here.  It looks more like a competition between who allocates
> what.  The format of it is not agreed either.
>
> _______________________________________________ 6lo mailing list
> [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
> <mailto:[email-masked]>> https://www.ietf.org/mailman/listinfo/6lo
>
>
>
>