Subject: [6lo] Review Request for ipv6-over-nfc-07

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 5 Jun 2017 17:15:45 -0700

Hello Dave, Pascal, James and WG members:

ipv6-over-nfc-07 has just been published and the author mentions that he
had addressed the comments from Pascal and Dave.

 Pascal and Dave,  would you please have sometime to review version 07 to
check if your comments are addressed?

I have appended the excerpt from IETF98 meeting minutes for your reference.
This document is due for WG LC if  it looks okay.

James, you are shepherd for NFC draft -- please let us know if you are okay
with the document's next step.

Thanks,
-Samita

As per IETF98 meeting minutes:
================================================

2 IPv6 over NFC                                    Younghwan Choi

  https://tools.ietf.org/wg/6lo/draft-ietf-6lo-nfc-06 was presented by
Younghawn Choi on updates and
  discussed comments from WG and NFC forum. The draft was reviewed by NFC
forum, no more comments
  from NFC forum. The author likes to move to WGLC.

  Dave Thaler:IID generation changed as a result of previous meeting

  Pascal: Replacing 6 bit address with hashing function with fixed
parameters. Scanning is still
  easy. How is it different?
  YC: offset. Dave: offset should be random to add entropy, not predictable.
  Gabriel: offset may not be a right name. Nonce would be better.
  Samita: need reviewers before WGLC. Pascal, Dave, would you volunteer?
  Pascal will do the review and Dave agreed to review the final update.
=======================================================
---------- Forwarded message ----------
From: 최영환 <[email-masked]>
Date: Sun, Jun 4, 2017 at 5:02 PM
Subject: RE: [6lo] Request for IETF99@Prague 6lo Agenda items
To: Samita Chakrabarti <[email-masked]>
Cc: Gabriel Montenegro <[email-masked]>

Hello Samita,

I’ve submitted the new version of ipv6-over-nfc (-07). The document is
ready for review.

Thanks.

Best regards,

Younghwan Choi

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 5 Jun 2017 17:18:00 -0700

The diff file:

https://www.ietf.org/rfcdiff?url2=draft-ietf-6lo-nfc-07

-Samita

On Mon, Jun 5, 2017 at 5:15 PM, Samita Chakrabarti <[email-masked]>
wrote:

> James, you are shepherd for NFC draft -- please let us know if you are
> okay with the document's next step.
>
> Thanks,
> -Samita
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 15 Jun 2017 10:43:28 +0000

Dear authors ;

Thanks for incorporating a nonce in the computation of the privacy address. This addresses my concern. It would have been good to insist that you are doing it in the security section as well, but the text there confirms that the address is not repeated on the next connection so we should be all set. Also in the security section, I’m not sure what to do with this text:

“

   However, malicious tries for one connection of a long-lived link with
   NFC technology are not secure, so the method of deriving interface
   identifiers from 6-bit NFC Link layer addresses is intended to
   preserve global uniqueness when it is possible.  Therefore, it
   requires a way to protect from duplication through accident or
  forgery and to define a way to include sufficient bit of entropy in
   the IPv6 interface identifier, such as random EUI-64.

“
I fail to understand the first sentence and the paragraph reads as a problem statement, but for what?  Seems that section 4.3 does now provide the required entropy, correct?

About section 4.5, I think some more text could be useful to assign the role of 6LBR.
If 2 similar devices meet (say 2 handeheld), whether one is 6LR/LBR. How would that be decided?
When they are different, if there is a fixed device (a payment terminal, say) or provides connectivity as a router, then it makes sense that it is 6LBR.
This could be described so we would not end up with 2 devices that cannot talk because they only do 6LN.

Cheers,

Pascal

From: Samita Chakrabarti [mailto:[email-masked]]
Sent: mardi 6 juin 2017 02:16
To: Pascal Thubert (pthubert) <[email-masked]>; Dave Thaler <[email-masked]>; 최영환 <[email-masked]>; [email-masked]; lo <[email-masked]>
Cc: James Woodyatt <[email-masked]>
Subject: Review Request for ipv6-over-nfc-07

ipv6-over-nfc-07 has just been published and the author mentions that he had addressed the comments from Pascal and Dave.

 Pascal and Dave,  would you please have sometime to review version 07 to check if your comments are addressed?

James, you are shepherd for NFC draft -- please let us know if you are okay with the document's next step.

Thanks,
-Samita

2 IPv6 over NFC                                    Younghwan Choi
  https://tools.ietf.org/wg/6lo/draft-ietf-6lo-nfc-06 was presented by Younghawn Choi on updates and
  discussed comments from WG and NFC forum. The draft was reviewed by NFC forum, no more comments
  from NFC forum. The author likes to move to WGLC.

  Pascal: Replacing 6 bit address with hashing function with fixed parameters. Scanning is still
---------- Forwarded message ----------
From: 최영환 <[email-masked]<mailto:[email-masked]>>
Date: Sun, Jun 4, 2017 at 5:02 PM
Subject: RE: [6lo] Request for IETF99@Prague 6lo Agenda items
To: Samita Chakrabarti <[email-masked]<mailto:[email-masked]>>
Cc: Gabriel Montenegro <[email-masked]<mailto:[email-masked]>>

Hello Samita,

I’ve submitted the new version of ipv6-over-nfc (-07). The document is ready for review.
Thanks.

Best regards,
Younghwan Choi