Subject: [6lo] Thomas' review of draft-thubert-6lo-forwarding-fragments-05

From: Thomas Watteyne <[email-masked]>
Date: Tue, 18 Jul 2017 15:32:27 +0200

All,

I did a full review of draft-thubert-6lo-forwarding-fragments-05. PDF, with
many comments, attached.

I had reviewed -04 in March [1]. Overall, I believe the document is now
much clearer. The format it proposes and the way it works is clearly
understandable by an implementer such as myself. I very much like the fact
that "discussion items" (rationale, requirements, etc) are pushed to
appendices; they tend to confuse me if placed on top of the document.

To summarize, I believe fragment forwarding is important to have in any
6LoWPAN network, and that the mechanism described in this draft solves it.
Happy to discuss at the IETF99 6lo session this afternoon.

Thomas

[1] https://www.ietf.org/mail-archive/web/6lo/current/msg02340.html

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 19 Jul 2017 21:54:12 +0000

Thanks a bunch Thomas !

I acted and posted 06 https://tools.ietf.org/html/draft-thubert-6lo-forwarding-fragments-06
Note that the pdf format is not easy to work with. I cannot readily use it to reply on the list, and copy paste from your comment does not seem to work/

Take care;

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: mardi 18 juillet 2017 15:32
To: [email-masked]; [email-masked]
Subject: [6lo] Thomas' review of draft-thubert-6lo-forwarding-fragments-05

All,

I did a full review of draft-thubert-6lo-forwarding-fragments-05. PDF, with many comments, attached.

I had reviewed -04 in March [1]. Overall, I believe the document is now much clearer. The format it proposes and the way it works is clearly understandable by an implementer such as myself. I very much like the fact that "discussion items" (rationale, requirements, etc) are pushed to appendices; they tend to confuse me if placed on top of the document.

To summarize, I believe fragment forwarding is important to have in any 6LoWPAN network, and that the mechanism described in this draft solves it. Happy to discuss at the IETF99 6lo session this afternoon.

Thomas

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 20 Jul 2017 05:32:09 +0000

You're welcome! I agree that PDF is less than ideal, point taken.

On Wed, 19 Jul 2017 at 23:54 Pascal Thubert (pthubert) <[email-masked]>
wrote:

> Thanks a bunch Thomas !
>
>
>
> I acted and posted 06
> https://tools.ietf.org/html/draft-thubert-6lo-forwarding-fragments-06
>
> Note that the pdf format is not easy to work with. I cannot readily use it
> to reply on the list, and copy paste from your comment does not seem to
> work/
>
>
>
> Take care;
>
>
>
> Pascal
>
>
>
> *From:* 6lo [mailto:[email-masked]] *On Behalf Of *Thomas Watteyne
> *Sent:* mardi 18 juillet 2017 15:32
> *To:* [email-masked]; [email-masked]
> *Subject:* [6lo] Thomas' review of
> draft-thubert-6lo-forwarding-fragments-05
>
>
>
> All,
>
>
>

Thomas Watteyne, PhD

www.thomaswatteyne.com