Subject: [6lowapp] Fwd: New Version Notification for draft-shelby-6lowapp-encoding-00

From: Zach Shelby <[email-masked]>
Date: Fri, 16 Oct 2009 15:45:41 +0300

Hi,

We have submitted a draft looking at efficient XML encodings, their  
applicability to 6LowApp and what requirements there are for using  
them over an application protocol.

http://www.ietf.org/id/draft-shelby-6lowapp-encoding-00.txt

This is just an initial spin, we look forward to expanding the  
encodings and results still some more and adding input from others.  
However, what is important to note is that the summary is pretty  
universal for any encoding - provide a reasonable range of Internet  
media types and a couple transfer encoding types and we're good to go.

Cheers,
Zach

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: October 16, 2009 15:40:06  GMT+03:00
> To: [email-masked]
> Cc: [email-masked],[email-masked]
> Subject: New Version Notification for draft-shelby-6lowapp-encoding-00
>
>
> A new version of I-D, draft-shelby-6lowapp-encoding-00.txt has been  
> successfuly submitted by Zach Shelby and posted to the IETF  
> repository.
>
> Filename:	 draft-shelby-6lowapp-encoding
> Revision:	 00
> Title:		 Efficient XML Encoding and 6LowApp
> Creation_date:	 2009-10-16
> WG ID:		 Independent Submission
> Number_of_pages: 12
>
> Abstract:
> For the resource constrained devices and networks of 6LowApp it is
> essential that the payload of messages are compact.  The use of XML
> to represent data in web applications has become almost universal.
> The interoperability of 6LowApp with these applications will require
> that XML can also be carried over the embedded web.  This document
> introduces and compares techniques for encoding or compressing XML
> for use with 6LowApp including EXI, BXML and Fast Infoset.  The
> performance and requirements for using these encodings are analyzed
> in the scope of 6LowApp.  It is shown that these standard encodings
> can represent XML in a compact form, with reasonable overhead, and
> require only Internet media type and content transfer encoding
> indication from the application protocol.
>
>
>
> The IETF Secretariat.
>
>

-- 
http://www.sensinode.com
http://zachshelby.org - My blog “On the Internet of Things”
Mobile: +358 40 7796297

Zach Shelby
Head of Research
Sensinode Ltd.
Kidekuja 2
88610 Vuokatti, FINLAND

This e-mail and all attached material are confidential and may contain  
legally privileged information. If you are not the intended recipient,  
please contact the sender and delete the e-mail from your system  
without producing, distributing or retaining copies thereof.

---

From: Richard Kelsey <[email-masked]>
Date: Fri, 16 Oct 2009 11:16:38 -0400

From: Zach Shelby <[email-masked]>
   Date: Fri, 16 Oct 2009 15:45:41 +0300

This is great.  It should be a big help.

I do have a question about MIME types.  When using EXI in
schema-informed mode it seems you have two choices:
  - include the schema, either directly or by reference
  - use the application/octet-stream type
Is there much point in indicating that this is an EXI stream
if the schema is not also provided?  For messages as small as
these even sending a reference to the schema will signifcantly
increase the overhead.

The W3C EXI Best Practices document has only placeholders
for the sections on how to deal with schemas and out-of-band
encoding knowledge.
                                -Richard Kelsey