Subject: [6lowpan] something to ask

From: "孙燚" <[email-masked]>
Date: Sun, 9 Sep 2007 15:28:43 +0800

hello everyone!
i am a college student,and here i have a small question to ask ,which is
whether IPsec can be used into WSN,and is it necessary?
if you know something about it,please tell me !
thank you very much!
sunyi
_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

---

From: Shoichi Sakane <[email-masked]>
Date: Thu, 20 Sep 2007 16:52:03 +0900

Hi,

> if you know something about it,please tell me !

Basically, IPsec is based on IP.  If you don't think that WSN require IP
as its transport, IPsec is not needed.  In the view point of 6lowpan,
it is natural thought to use IPsec.  However, key establishment mechanism
should be considered.  because several protocol defined in the IETF are
not friendly with WSN.  They would bring significant impact to WSN when
you use them as is.