Subject: [6tisch] join priority in 802.15.4

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 8 Apr 2015 07:14:55 +0000

Hello Pat:

I have an open issue on the 6TiSCH architecture about the text below:

            A root is configured or obtains by some external means the knowledge of the RPLInstanceID
            for the TSGI. The root advertises its DagRank in the TSGI, that MUST be less than 0xFF,
            as its Join Priority (JP) in its IEEE802.15.4e Extended Beacons (EB). We'll note that the
            JP is now specified between 0 and 0x3F leaving 2 bits in the octet unused in the IEEE802.15.4e
            specification. After consultation with IEEE authors, it was asserted that 6TiSCH can make
            a full use of the octet to carry an integer value up to 0xFF.

I remember that you proposed changes to the join priority format. What will the final 802.15.4 2015 say about this?

Many thanks in advance!

Pascal

---

From: Pat Kinney <[email-masked]>
Date: Wed, 8 Apr 2015 08:25:41 -0500

We did talk about the join priority contained within the TSCH Synchronization IE.  The language of the text was changed to be clear and concise, however leaving the intent the same, with this note: "A lower value of join priority indicates that connection to the beaconing device is a shorter route distance to the PAN coordinator".  Also, indeed the current value of Join Priority is limited to 0x3f.

I can insert a comment in the upcoming Sponsor Ballot modifying the definition to also allow DagRank along with modifying the range to be 0 to 0xff.  Is this what 6tisch wants?

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked] <mailto:[email-masked]>

On 8, Apr2015, at 2:14, Pascal Thubert (pthubert) <[email-masked]> wrote:

Hello Pat:

 
 
Many thanks in advance!
 
Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 8 Apr 2015 13:30:49 +0000

Yes, Pat.

6TiSCH would like to be able to expose a Rank in the full byte. We'd really appreciate that you add that comment to the ballot.

Thanks for all !

Pascal

From: Pat Kinney [mailto:[email-masked]]
Sent: mercredi 8 avril 2015 15:26
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: join priority in 802.15.4

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked]<mailto:[email-masked]>

On 8, Apr2015, at 2:14, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:

Hello Pat:

Many thanks in advance!

Pascal

---

From: Jonathan Simon <[email-masked]>
Date: Wed, 8 Apr 2015 10:46:59 -0700

I think it was a mistake being 0x3f in the first place.  It was 0xff in an earlier draft but changed and I never noticed it to fix it.
-- 
Jonathan
On Apr 8, 2015, at 6:30 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:

> Yes, Pat.
>  
> 6TiSCH would like to be able to expose a Rank in the full byte. We’d really appreciate that you add that comment to the ballot.
>  
> Thanks for all !
>  
> Pascal
>  
> [email-masked]
>  
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> http://cp.mcafee.com/d/5fHCNAg6wUSyMCYMqejhOYUedTdEK3CkPqbwVBYSyUed7aar9EVdKfffecnKr4qilH057Ox-NVsSva7X7BPuCzB1dZdZ_HYOOyyMCqeuLsKDt5fDPhO-yqerKsJt6OaaJTA-l3PWApmU6CQjq9K_8I9LfzAm4PhOrKr9PCJhbcatbVKY01MjlS67OFek7qUVelb4PrAVkIjbAaJMJZ0lbVKY01dEzAQNNI5-Aq83iSVelb4PiWq816IE6y1qcGNBcIq89gd43RQ-hvVwSOYr9MZghcze