Subject: [6tisch] Attracting your attention on a charter text update

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 1 Feb 2016 14:58:47 +0000

Dear all:

I did not get any comment on the proposed change (below).
I’m willing to assume it’s good news. If you disagree please let it be known now.
Thomas and I will meet this week and conclude.

“Produce an Information Model containing the management requirements
of a 6TiSCH node. A data model mapping for an existing protocol (such as Concise
Binary Object Representation (CBOR) over the Constrained Application …”

Would become
“Produce a Data Model expressed in YANG and enabling the management
of the 6top sublayer. A mapping for an existing protocol (such as Concise
Binary Object Representation (CBOR) over the Constrained Application …
“

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: vendredi 29 janvier 2016 17:50
To: Qin Wang <[email-masked]>; Brian Haberman <[email-masked]>; [email-masked]
Subject: Re: [6tisch] information model or data model in the new charter

I agree Qin;

“Produce an Information Model containing the management requirements
of a 6TiSCH node. A data model mapping for an existing protocol (such as Concise
Binary Object Representation (CBOR) over the Constrained Application …”

Would become
“Produce a Data Model expressed in Yand and enabling the management
of the 6top sublayer. A mapping for an existing protocol (such as Concise
Binary Object Representation (CBOR) over the Constrained Application …
“

Note that I reduced the scope of the data model to the 6ttop piece.

Is that what we want ?

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: vendredi 29 janvier 2016 16:49
To: Brian Haberman <[email-masked]<mailto:[email-masked]>>; Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] information model or data model in the new charter

Hi Brain, Pascal and all,

I think both what we actually did in the current 6top-interface draft, and what we are going to redo as Thomas and Xavi suggested in the last Webex, are Yang date model of 6top, instead of information model. Thus, I think we need to re-word the Charter accordingly. Make sense?

In addition, the attached file presents clear definition on both interface model and Yang model.

Thanks
Qin

On Wednesday, January 27, 2016 2:48 PM, Brian Haberman <[email-masked]<mailto:[email-masked]>> wrote:

Hi Pascal,

On 1/27/16 2:38 PM, Pascal Thubert (pthubert) wrote:
> Hello Brian and Qin:
>
> We discussed that at the time of the first charter, using RFC 3444 as
> our reference; it is my understanding that we aimed the 6top
> interface document
> https://tools.ietf.org/html/draft-ietf-6tisch-6top-interface at
> providing a Yang Data model to manage the 6top layer in a device. It
> is my understanding that some form of information model in natural
> language would be present in the 6top draft, but my reading of the
> 6top interface is that there is some degree of information model
> there too, that explains the data model. If so, is that a problem?

I don't think the problem is in a *document*. Benoit is questioning the
wording of the proposed charter.  I would suggest reviewing his comments
in light of the current wording of the new charter text.

https://datatracker.ietf.org/doc/charter-ietf-6tisch/
https://datatracker.ietf.org/doc/charter-ietf-6tisch/ballot/#benoit-claise

Regards,

Brian

>
> Cheers,
>
> Pascal
>
>> -----Original Message----- From: 6tisch
>> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian Haberman Sent:
>> lundi 25 janvier 2016 14:11 To: [email-masked]<mailto:[email-masked]> Subject: Re:
>> [6tisch] information model or data model in the new charter
>>
>> Hi Qin,
>>
>> On 1/22/16 3:30 PM, Qin Wang wrote:
>>> Dear all, In today's Webex meeting, we were talking about the
>>> feedback from Bonoit about the new Charter, see [6tisch] Benoit
>>> Claise's No Objection on charter-ietf-6tisch-01-00: (with
>>> COMMENT), and want to continue the discussion in the ML. The
>>> question is what is exactly we want to do with Yang model, and
>>> how to make the paragraph about Yang model in the new Charter
>>> more accurate. Any comments and suggestion is welcome. ThanksQin
>>>
>>
>> This issue needs to get resolved before I will release the charter
>> for external review. Benoit's point illustrated an issue in the
>> charter where it is not clear as to whether the WG is interested in
>> an information model or a data model.
>>
>> Regards, Brian

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Tom Phinney <[email-masked]>
Date: Mon, 1 Feb 2016 08:03:16 -0700

+1

===

On 2016.02.01 07:58, Pascal Thubert
(pthubert) wrote:

Dear
all:

I
did not get any comment on the proposed change (below).

I’m
willing to assume it’s good news. If you disagree please let
it be known now.

Thomas
and I will meet this week and conclude.

“Produce
an Information Model containing the management requirements

of
a 6TiSCH node. A data model mapping for an existing protocol
(such as Concise

Binary
Object Representation (CBOR) over the Constrained
Application …”

Would
become

“Produce
a Data Model expressed in YANG and enabling the management

of
the 6top sublayer. A mapping for an existing protocol (such
as Concise

Binary
Object Representation (CBOR) over the Constrained
Application …

“

Cheers,

Pascal

From:
6tisch [mailto:[email-masked]]
On Behalf Of Pascal Thubert (pthubert)

To: Qin Wang <[email-masked]>;
Brian Haberman <[email-masked]>;
[email-masked]

Subject: Re: [6tisch] information model or data
model in the new charter

I
agree Qin;

“Produce
an Information Model containing the management
requirements

of
a 6TiSCH node. A data model mapping for an existing
protocol (such as Concise

Binary
Object Representation (CBOR) over the Constrained
Application …”

Would
become

“Produce
a Data Model expressed in Yand and enabling the management

of
the 6top sublayer. A mapping for an existing protocol
(such as Concise

Binary
Object Representation (CBOR) over the Constrained
Application …

“

Note
that I reduced the scope of the data model to the 6ttop
piece.

Is
that what we want ?

Pascal

From: Qin
Wang [mailto:[email-masked]]

To: Brian Haberman <[email-masked]>;
Pascal Thubert (pthubert) <[email-masked]>;
[email-masked]

Subject: Re: [6tisch] information model or
data model in the new charter

Hi
Brain, Pascal and all,

I
think both what we actually did in the current
6top-interface draft, and what we are going to redo
as Thomas and Xavi suggested in the last Webex, are
Yang date model of 6top, instead of information
model. Thus, I think we need to re-word the Charter
accordingly. Make sense?

In
addition, the attached file presents clear
definition on both interface model and Yang model.

Thanks

Qin

On
Wednesday, January 27, 2016 2:48 PM, Brian
Haberman <[email-masked]>
wrote:

Hi
Pascal,

On 1/27/16 2:38 PM, Pascal Thubert (pthubert)

https://tools.ietf.org/html/draft-ietf-6tisch-6top-interface
at

> there too, that explains the data model.
If so, is that a problem?

I don't think the problem is in a *document*.
Benoit is questioning the

wording of the proposed charter.  I would
suggest reviewing his comments

in light of the current wording of the new
charter text.

Regards,

Brian

>> [mailto:[email-masked]]
On Behalf Of Brian Haberman Sent:

>> lundi 25 janvier 2016 14:11 To: [email-masked]

6tisch mailing list

[email-masked]

[email-masked]

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 1 Feb 2016 16:27:18 -0300

+1
El feb 1, 2016 9:03 AM, "Tom Phinney" <[email-masked]> escribió:

> +1
> ===
> On 2016.02.01 07:58, Pascal Thubert (pthubert) wrote:
>
> Dear all:
>
>
>
> *From:* 6tisch [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Pascal Thubert (pthubert)
> *Sent:* vendredi 29 janvier 2016 17:50
> *To:* Qin Wang <[email-masked]> <[email-masked]>; Brian
> Haberman <[email-masked]> <[email-masked]>;
> [email-masked]
> *Subject:* Re: [6tisch] information model or data model in the new charter
>
>
>
> I agree Qin;
>
>
>
> *From:* Qin Wang [mailto:[email-masked] <[email-masked]>]
> *Sent:* vendredi 29 janvier 2016 16:49
> *To:* Brian Haberman <[email-masked]>; Pascal Thubert
> (pthubert) <[email-masked]>; [email-masked]
> *Subject:* Re: [6tisch] information model or data model in the new charter
>
>
>
> I think both what we actually did in the current 6top-interface draft, and
> what we are going to redo as Thomas and Xavi suggested in the last Webex,
> are Yang date model of 6top, instead of information model. Thus, I think we
> need to re-word the Charter accordingly. Make sense?
>
>
>
> On Wednesday, January 27, 2016 2:48 PM, Brian Haberman <
> [email-masked]> wrote:
>
>
>
> Hi Pascal,
>
> >> [mailto:[email-masked]] On Behalf Of Brian Haberman Sent:
> >> lundi 25 janvier 2016 14:11 To: [email-masked] Subject: Re:
> 6tisch mailing [email-masked]://www.ietf.org/mailman/listinfo/6tisch
>
>
>