Subject: [6tisch] Wireshark Dissector for draft-ietf-6tisch-6top-protocol-03

From: Yasuyuki Tanaka <[email-masked]>
Date: Tue, 22 Nov 2016 19:11:33 +0100

Hi all,

A patch to support 6P of draft-03 has been merged into the master
branch of Wireshark with the short commit hash of 0f36cf6. This patch
updates the code based on draft-02 that was already there.

The latest packages available at the following site, "automated build
section", should include the changes:

   https://www.wireshark.org/download/automated/

One thing to be noted is values of commands and return codes. Since I
had no idea what values should be used for them, I decided to keep the
values defined there, even though we can use separate code spaces for
command and return code now. Here is the list of the definitions:

   /* SIXTOP CMD and RC identifiers */
   #define IETF_6TOP_CMD_ADD              0x01
   #define IETF_6TOP_CMD_DELETE           0x02
   #define IETF_6TOP_CMD_STATUS           0x03
   #define IETF_6TOP_CMD_LIST             0x04
   #define IETF_6TOP_CMD_CLEAR            0x05
   #define IETF_6TOP_RC_SUCCESS           0x06
   #define IETF_6TOP_RC_ERR_VER           0x07
   #define IETF_6TOP_RC_ERR_SFID          0x08
   #define IETF_6TOP_RC_ERR_GEN           0x09
   #define IETF_6TOP_RC_ERR_BUSY          0x0A
   #define IETF_6TOP_RC_ERR_NORES         0x0B
   #define IETF_6TOP_RC_ERR_RESET         0x0C
   #define IETF_6TOP_RC_ERR               0x0D

In addition to support draft-03, I made some enhancements on UI. For
example, a string of "6top" is shown in the protocol column for a 6P
frame instead of "IEEE 802.15.4" so that you can find 6P frames
easily. Please take a look at the attached screen image if you're
interested in how they look.

I hope you would like them, and I hope I interpreted the draft
correctly, especially bit-fields...

Best,
Yatch

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 22 Nov 2016 19:48:04 +0100

Awesome, thanks Yatch!

We are going to work on 6P again, so I'm afraid a couple of more edits
might be needed :-\

On Tue, Nov 22, 2016 at 7:11 PM, Yasuyuki Tanaka <
[email-masked]> wrote:

> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Tue, 22 Nov 2016 20:01:08 +0100

Hi Thomas,

> We are going to work on 6P again, so I'm afraid a couple of more
> edits might be needed :-\

A new patch will come out if necessary ;-)

Best,
Yatch

On 2016/11/22 19:48, Thomas Watteyne wrote:
> Awesome, thanks Yatch!
>
> We are going to work on 6P again, so I'm afraid a couple of more edits might be needed :-\
>
> On Tue, Nov 22, 2016 at 7:11 PM, Yasuyuki Tanaka <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi all,
>
>       https://www.wireshark.org/download/automated/ <https://www.wireshark.org/download/automated/>
>
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/6tisch <https://www.ietf.org/mailman/listinfo/6tisch>
>
>
>
>
> --
> www.thomaswatteyne.com <http://www.thomaswatteyne.com>

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 24 Nov 2016 13:27:28 +0100

awesome

On Tue, Nov 22, 2016 at 8:01 PM, Yasuyuki Tanaka <
[email-masked]> wrote:

>> [email-masked] <mailto:[email-masked]>>
>> wrote:
>>
>>     Hi all,
>>
>>       https://www.wireshark.org/download/automated/ <
>> https://www.wireshark.org/download/automated/>
>>
>>
>>     https://www.ietf.org/mailman/listinfo/6tisch <
>> https://www.ietf.org/mailman/listinfo/6tisch>
>>
>>
>>
>>
>> --

Thomas Watteyne, PhD

www.thomaswatteyne.com