Subject: [6tisch] Minutes, 09 December 2016 interim, 6TiSCH WG

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 13 Dec 2016 12:14:08 +0000

Note: timestamps in PDT.

Connection details

  *   Date: 7-8am Pacific: http://www.worldtimebuddy.com/?qm=1&lid=100,12,5392171,1850147&h=100&date=2016-12-09&sln=15-16
  *   Webex link: https://cisco.webex.com/ciscosales/j.php?MTID=mcdbbe3a4e38d97d986b507ec12a1f9b1
     *   Meeting number (access code): 203 224 694
     *   Meeting password: sixtus (749887 from phones)
  *   Webex Recording: https://cisco.webex.com/ciscosales/lsr.php?RCID=fda7ad27975547408cc6bb03ed8b6943
  *   Slides: https://bitbucket.org/6tisch/meetings/src/master/161209_webex/slides_161209_webex.ppt

Taking notes (using Etherpad)

  1.  Pascal Thubert
  2.  Malisa Vucinic

Present (alphabetically)

  1.  Geraldine Texier
  2.  Jonathan Munoz
  3.  Malisa Vucinic
  4.  Maria Rita Palattella
  5.  Nicola Accettura
  6.  Pascal Thubert
  7.  Randy Turner
  8.  SVR Anad
  9.  Simon Duquennoy
  10. Tengfei Chang
  11. Thomas Watteyne
  12. Qin Wang
  13. Xavi Vilajosana
  14. Yasuyuki Tanaka

Action Items

  *   Michael and Malisa to resubmit both sec drafts with name to ietf- with NO change.
  *   Randy to start a discussion on the ML about TSCH over sub-GHz PHY layers.
  *   Thomas to organize a 6P DT meeting on 12/16 at the 6TiSCH interim time to progress on 6top.
  *   Diego to publish consensus about SF0
  *   Maria Rita to publish what consensus is obtained on the terminology and ask again in the terms for which consensus was not reached

Agenda

  *   Administrivia [2min]
     *   Approval agenda
     *   Approval minutes last call
  *   Status of drafts [Chairs] [5min]
  *   Update on security [Michael, chairs] [5min]
  *   Wrap up ML discussions on 6top [Thomas] [25min]
  *   Next steps for SF0 [Pascal] [15min]
  *   AOB [3min]

Minutes

  *   [07.04] meeting starts
     *   recording starts
     *   chairs remind Note Well
  *   [07.07] Administrivia [2min]
     *   Approval agenda

Tengfei asks to talk about relocation format Maria Rita asks to discuss on the terminology updated agenda proposed and approved, see slide

     *   Approval minutes last call

No issues rasied, minutes approved

  *   [07.10] Status of drafts (Pascal Thubert)
     *   minimal draft in IETF LC.
     *   both security draft adopted.

Action item: Michael and Malisa, please resubmit both sec drafts with name to ietf- with NO change.

     *   RFC8025 (paging dispatch) -> published
     *   routing dispatch, published in 3-4 months
     *   BBR draft update
     *   dao-projection, accepted at ROLL. Potential replacement of P2P RPL, based on AODV.
  *   [07.16] Update on draft-ietf-6tisch-minimal (Thomas Watteyne)
     *   presents on behalf of Xavi, who is connected through voice only
     *   AD review from Suresh triggered lots of reshuffling
     *   there should be no changes in technical content but should be verified
     *   Thomas goes through the changes -- exact same contents but presented differently.
     *   Organized by layers, e.g. setting 15.4, setting RPL, etc...
     *   Xavi: following Suresh's comments found some duplicates and reorganized
  *   [07.19] Misc discussion on the Mailing List (Thomas Watteyne)
     *   Timeslot template and slot duration
     *   Question: what happens if my packet is too long to finish before the end of the slot?
     *   Answer: looking upon the figure 3 about the timeslot template, if the packet is too long then the slot duration needs to be extend to fit the long packet.
     *   Randy: problem in sub-GHz band, slow bit rate, we overrun slot boundaries because some beacons have many IEs. 2015 spec does not preclude overrun.
     *   Pascal: do you use CCA?
     *   Randy we looked at fragmentation, but seems heavy. We tried CCA. I was not sure how to take slow bit rate into account. My interpretations that we are willing to trade fragmentation overhead to keep slots aligned.
     *   Pascal: WISA uses two timeslots that can be grouped as one. Can we use a similar technique?
     *   Jonathan: Alternative would be to use a bigger timeslot for sub-GHz. Lowest datarate would be 50 kbps.
     *   Randy: we advertise an MTU of 1280 although the 15.4g defines a 2047 bytes MTU.
     *   Thomas: multiple people working on that, potential for a draft explaining how to adapt a schedule for low speeds.
     *   Simon: solution for me was redefine 30ms time slots
     *   Jonathan: fitting to the worst case

Action item: Randy to start a discussion on the ML about TSCH over sub-GHz PHY layers.

  *   [07.32] Update on security (Malisa Vucinic)
     *   The DT met twice during past 2 weeks, to speed up work.
     *   presented the minimal-security draft again and we discussed address assignment.
     *   Tero indicatd that short addresses need a lease time, key identifier missing for link-layer.
     *   Good news: well-known URI for the JCE is feasible; but should be an URI in .arpa.
     *   Max indicated that we need a special attribute in the certificate for JCE.
     *   Discussions on certificate enrollment using EST as done in ANIMA and how to adapt it to 6TiSCH.
  *   Wrap up ML discussions on 6top (Thomas Watteyne)
     *   Lot of work in coming slides, not enough time.
     *   can everyone join next week, same time?

time works for all 6P key contributors

     *   proposal is to have a side meeting on 6top protocol.

Action item: Thomas to organize a 6P DT meeting on 12/16 at the 6TiSCH interim time to progress on 6top.

     *   The slides will be published and a meeting next week will wrap it up.
     *   Let's talk about 6P signaling traffic now. What cells is that traffic sent on. No doc says how traffic is segregated between minimal and dedicated slots. Which traffic goes where? Proposal to to use minimal as a last resort only.
     *   Simon: Contiki implementation uses shared slot iff there no dedicated slot.
     *   Tengfei: OpenWSN feedback: in 2-step transaction, if we miss the last ack, it's possible to have a single-sided schedule
     *   Pascal: better no create a transmit slot if there is no positive ack.
     *   Simon: that's better, it maybe that the receiver listens if the ack was sent and missed, but that is not as bad.
     *   Thomas: We'll eventually realize at the next sync. Should not be that often.
     *   Nicola: I found the same thing when implementing on OpenWSN. It is a problem that can happen, more frequently if using simulation motes.
  *   Next steps for SF0 (Thomas Watteyne)
     *   Diego not here, as editor, we need him to make consensus.
     *   Will ask Diego to propose a consensus

Action item: Diego to publish consensus about SF0

  *   Terminology (Maria Rita Palattella)
     *   Xavi asked to add CCA, Pascal asked to prepare for last call.
     *   I went through the draft and identified terms that are obsolete, or very generic, got feedback on ML agreeing to remove those terms.
     *   No consensus on removing CDU matrix, same for bundle.
     *   Pending the definition of deterministic networks.
     *   Pascal: recommends to publish new version of terminology with consensus.

Action item: Maria Rita to publish what consensus is obtained on the terminology and ask again in the terms for which consensus was not reached

  *   Rechartering
     *   no time.
  *   AOB
     *   Malisa:
        *   working on 6TiSCH simulator in Python.
        *   Simulates on a high level the behavior of the 6TiSCH stack.
        *   Just finished the implementation of shared slots.
        *   Contributions are welcome.
        *   https://bitbucket.org/6tisch/simulator/

---

From: Randy Turner <[email-masked]>
Date: Tue, 13 Dec 2016 11:45:17 -0500

Regarding my comment about a 1280 MTU for our sub-gig network, the 2047-byte 802.15.4g PHY max is trimmed for both potential IE expansion as well as tunnel headers (one or more IPv6-in-IPv6 encamps)

Randy

> On Dec 13, 2016, at 7:14 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> Note: timestamps in PDT.
> 
> Connection details
> 
> Date: 7-8am Pacific: http://www.worldtimebuddy.com/?qm=1&lid=100,12,5392171,1850147&h=100&date=2016-12-09&sln=15-16 <http://www.worldtimebuddy.com/?qm=1&lid=100,12,5392171,1850147&h=100&date=2016-12-09&sln=15-16>
> Webex link: https://cisco.webex.com/ciscosales/j.php?MTID=mcdbbe3a4e38d97d986b507ec12a1f9b1 <https://cisco.webex.com/ciscosales/j.php?MTID=mcdbbe3a4e38d97d986b507ec12a1f9b1>
> Meeting number (access code): 203 224 694
> Meeting password: sixtus (749887 from phones)
> Webex Recording: https://cisco.webex.com/ciscosales/lsr.php?RCID=fda7ad27975547408cc6bb03ed8b6943 <https://cisco.webex.com/ciscosales/lsr.php?RCID=fda7ad27975547408cc6bb03ed8b6943>
> Slides: https://bitbucket.org/6tisch/meetings/src/master/161209_webex/slides_161209_webex.ppt <https://bitbucket.org/6tisch/meetings/src/master/161209_webex/slides_161209_webex.ppt>
> Pascal Thubert
> Malisa Vucinic
> Geraldine Texier
> Jonathan Munoz
> Malisa Vucinic
> Maria Rita Palattella
> Nicola Accettura
> Pascal Thubert
> Randy Turner
> SVR Anad
> Simon Duquennoy
> Tengfei Chang
> Thomas Watteyne
> Qin Wang
> Xavi Vilajosana
> Yasuyuki Tanaka
> Michael and Malisa to resubmit both sec drafts with name to ietf- with NO change.
> Randy to start a discussion on the ML about TSCH over sub-GHz PHY layers.
> Thomas to organize a 6P DT meeting on 12/16 at the 6TiSCH interim time to progress on 6top.
> Diego to publish consensus about SF0
> Maria Rita to publish what consensus is obtained on the terminology and ask again in the terms for which consensus was not reached
> Agenda
> 
> Administrivia [2min]
> Approval agenda 
> Approval minutes last call
> Status of drafts [Chairs] [5min]
> Update on security [Michael, chairs] [5min]
> Wrap up ML discussions on 6top [Thomas] [25min]
> Next steps for SF0 [Pascal] [15min]
> AOB [3min]
> Minutes
> 
> [07.04] meeting starts
> recording starts
> chairs remind Note Well
> [07.07] Administrivia [2min]
> Approval agenda
> Approval minutes last call
> [07.10] Status of drafts (Pascal Thubert)
> minimal draft in IETF LC.
> both security draft adopted.
> RFC8025 (paging dispatch) -> published
> routing dispatch, published in 3-4 months
> BBR draft update
> dao-projection, accepted at ROLL. Potential replacement of P2P RPL, based on AODV.
> [07.16] Update on draft-ietf-6tisch-minimal (Thomas Watteyne)
> presents on behalf of Xavi, who is connected through voice only
> AD review from Suresh triggered lots of reshuffling
> there should be no changes in technical content but should be verified
> Thomas goes through the changes -- exact same contents but presented differently.
> Organized by layers, e.g. setting 15.4, setting RPL, etc...
> Xavi: following Suresh's comments found some duplicates and reorganized
> [07.19] Misc discussion on the Mailing List (Thomas Watteyne)
> Timeslot template and slot duration
> Question: what happens if my packet is too long to finish before the end of the slot?
> Answer: looking upon the figure 3 about the timeslot template, if the packet is too long then the slot duration needs to be extend to fit the long packet.
> Randy: problem in sub-GHz band, slow bit rate, we overrun slot boundaries because some beacons have many IEs. 2015 spec does not preclude overrun.
> Pascal: do you use CCA?
> Randy we looked at fragmentation, but seems heavy. We tried CCA. I was not sure how to take slow bit rate into account. My interpretations that we are willing to trade fragmentation overhead to keep slots aligned.
> Pascal: WISA uses two timeslots that can be grouped as one. Can we use a similar technique?
> Jonathan: Alternative would be to use a bigger timeslot for sub-GHz. Lowest datarate would be 50 kbps.
> Randy: we advertise an MTU of 1280 although the 15.4g defines a 2047 bytes MTU.
> Thomas: multiple people working on that, potential for a draft explaining how to adapt a schedule for low speeds.
> Simon: solution for me was redefine 30ms time slots
> Jonathan: fitting to the worst case
> [07.32] Update on security (Malisa Vucinic)
> The DT met twice during past 2 weeks, to speed up work.
> presented the minimal-security draft again and we discussed address assignment.
> Tero indicatd that short addresses need a lease time, key identifier missing for link-layer.
> Good news: well-known URI for the JCE is feasible; but should be an URI in .arpa.
> Max indicated that we need a special attribute in the certificate for JCE.
> Discussions on certificate enrollment using EST as done in ANIMA and how to adapt it to 6TiSCH.
> Wrap up ML discussions on 6top (Thomas Watteyne)
> Lot of work in coming slides, not enough time.
> can everyone join next week, same time?
> proposal is to have a side meeting on 6top protocol.
> The slides will be published and a meeting next week will wrap it up.
> Let's talk about 6P signaling traffic now. What cells is that traffic sent on. No doc says how traffic is segregated between minimal and dedicated slots. Which traffic goes where? Proposal to to use minimal as a last resort only.
> Simon: Contiki implementation uses shared slot iff there no dedicated slot.
> Tengfei: OpenWSN feedback: in 2-step transaction, if we miss the last ack, it's possible to have a single-sided schedule
> Pascal: better no create a transmit slot if there is no positive ack.
> Simon: that's better, it maybe that the receiver listens if the ack was sent and missed, but that is not as bad.
> Thomas: We'll eventually realize at the next sync. Should not be that often.
> Nicola: I found the same thing when implementing on OpenWSN. It is a problem that can happen, more frequently if using simulation motes.
> Next steps for SF0 (Thomas Watteyne)
> Diego not here, as editor, we need him to make consensus.
> Will ask Diego to propose a consensus
> Terminology (Maria Rita Palattella)
> Xavi asked to add CCA, Pascal asked to prepare for last call.
> I went through the draft and identified terms that are obsolete, or very generic, got feedback on ML agreeing to remove those terms.
> No consensus on removing CDU matrix, same for bundle.
> Pending the definition of deterministic networks.
> Pascal: recommends to publish new version of terminology with consensus.
> Rechartering
> no time.
> AOB
> Malisa:
> working on 6TiSCH simulator in Python.
> Simulates on a high level the behavior of the 6TiSCH stack.
> Just finished the implementation of shared slots.
> Contributions are welcome.
> https://bitbucket.org/6tisch/simulator/ <https://bitbucket.org/6tisch/simulator/>
>  
> _______________________________________________
> 6tisch mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/6tisch <https://www.ietf.org/mailman/listinfo/6tisch>