Subject: [6tisch] [6TiSCH] sixtop relocation command format/sixtop general message format?

From: Tengfei Chang <[email-masked]>
Date: Fri, 9 Dec 2016 16:53:25 +0100

Dear all,

As we are going to have RELOCATE command in sixtop draft, then we will need
add a specific format for RELOCATE. Though the format is not discussed yet,
but I think finally it will ends up something with two list of cell in the
packet and having (a) fields to indicate where the cell list to be added
and list to be removed are. Of course , with RELOCATE command byte in the
frame. I think this format can be a general format for ADD , DELETE  and
RELOCATE.

With such format,

   - if there is only list of cell to be added, then the frame can be
   represented as ADD command
   - if there is only list of cell to be removed, then DELETE  command
   - if there are both two list of cell, and they have the same number,
   then RELOCATE command..

The benefit of using this two cell list format is that:

If the node wants to relocate one cell and at the same time add some cells
OR delete some cells, with single sixtop transaction, which is

   - there are two list of cell, one for adding, one for deleting, but
   length of adding list is longer than deleting list (Add command+Relocation
   command)
   - there are two list of cell, one for adding, one for deleting, but
   length of adding list is shorter than deleting list (Delete
   command+Relocation command)

Let me know your thought.

Tengfei

-- 
Chang Tengfei,
Pre-Postdoctoral Research Engineer, Inria

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Fri, 9 Dec 2016 23:34:35 +0100

Hi Tengfei,

My first impression of your ideas is that it's a bit complicated,
especially the idea of generalizing Add, Delete, and Relocate
commands. I'd suggest discussing the Relocation command format alone
first.

I have another comment, which is more technical.

> it will ends up something with two list of cell in the packet and
> having (a) fields to indicate where the cell list to be added and
> list to be removed are. (snip)
>
>   * if there are both two list of cell, and they have the same
>     number, then RELOCATE command..

To my understanding, the Relocate command is something like an alias
command of the Add and Delete combination. In that sense, the cell
list to add and the cell list to delete could have different lengths.

The number cells in the cell list to add could be more than the number
of cells a requester wants to relocate. This is the same thing as the
Add command has a smaller value for NumCells than the length of
CellList. If a requester hesitates to specify which cells are
candidates to relocate to, it may put an empty cell list to add in a
Relocation request as the 3-step transaction of the add operation. The
same thing might happen with the cell list to delete in relocation,
although it's less likely than the case of the cell list to add.

We might define that the two cell lists MUST have the same length. In
this case, we would lose flexibility in choosing which cells to
relocate to...

That's my two cents. Thanks!

Best,
Yatch

On 2016/12/09 16:53, Tengfei Chang wrote:
> Dear all,
>
> As we are going to have RELOCATE command in sixtop draft, then we will need add a specific format for RELOCATE. Though the format is not discussed yet, but I think finally it will ends up something with two list of cell in the packet and having (a) fields to indicate where the cell list to be added and list to be removed are. Of course , with RELOCATE command byte in the frame. I think this format can be a general format for ADD , DELETE  and RELOCATE.
>
> With such format,
>
>   * if there is only list of cell to be added, then the frame can be represented as ADD command
>   * if there is only list of cell to be removed, then DELETE  command
>   * if there are both two list of cell, and they have the same number, then RELOCATE command..
>
> If the node wants to relocate one cell and at the same time add some cells OR delete some cells, with single sixtop transaction, which is
>
>   * there are two list of cell, one for adding, one for deleting, but length of adding list is longer than deleting list (Add command+Relocation command)
>   * there are two list of cell, one for adding, one for deleting, but length of adding list is shorter than deleting list (Delete command+Relocation command)
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

---

From: Qin Wang <[email-masked]>
Date: Mon, 12 Dec 2016 15:32:54 +0000 (UTC)

Hi Tengfei,
My impression on your proposal is that you are trying to use the combination of the length of ADD CellList and DELETE CellList as sort of operation code. Right? If 6P really needs so many operations, why do we just add more operation codes, which could cost just 1 more bit?
ThanksQin 

    On Friday, December 9, 2016 10:53 AM, Tengfei Chang <[email-masked]> wrote:

 Dear all, 

With such format,    
   - if there is only list of cell to be added, then the frame can be represented as ADD command   

   - if there is only list of cell to be removed, then DELETE  command
   - if there are both two list of cell, and they have the same number, then RELOCATE command..
The benefit of using this two cell list format is that:
If the node wants to relocate one cell and at the same time add some cells OR delete some cells, with single sixtop transaction, which is   
   - there are two list of cell, one for adding, one for deleting, but length of adding list is longer than deleting list (Add command+Relocation command)   

   - there are two list of cell, one for adding, one for deleting, but length of adding list is shorter than deleting list (Delete command+Relocation command)
Let me know your thought.
Tengfei
-- 
Chang Tengfei,Pre-Postdoctoral Research Engineer, Inria
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch