Subject: [6tisch] Brief update about the last week's 802.15.12 developments

From: Charlie Perkins <[email-masked]>
Date: Mon, 17 Jul 2017 08:46:18 -0700

Hello folks,

This afternoon, I managed to completely misunderstand what I was being 
asked about at the 6tisch meeting.  Please excuse...

I would indeed like to offer a very brief update about the recent 
802.15.12 progress last week at the IEEE 802 Wireless meeting. The 
minutes are available at the following URL:

https://mentor.ieee.org/802.15/dcn/17/15-17-0429-00-0012-tg-802-15-12-minutes-for-july-2017-plenary-meeting.doc

Here are some developments from the meeting:

  * Discussed the programming interface between 802.15.12 layer and
    higher-layer protocols
  * Will be looking towards CoAP for remote management interface
  * Discussed the role of the management module and use of profiles to
    simplify configuration
  * Discussed the processing of incoming frames and functional block
    interface imposed by the features of 802.15.10 (Layer-2 routing)
  * Discussed the value of using YANG as a preferred method for
    describing interface profiles and other necessary management data

I have attached the current version of the Functional Block 
Decomposition diagram for 802.15.12 (as drawn up by Pat Kinney). It's 
almost self-explanatory but not quite.  PDE may be compared to switching 
on Ethertype.  A "SAP" is a service-access point and is a general term 
which means "module interface".  A SAP is defined by a list of 
parameters, and what the recipient does with the parameters.  L2R is 
layer-2 routing.  KMP is Key Management Protocol (802.15.9).  I won't go 
into the MAC or PHY layer parameters, but you can see in the diagram 
where TSCH lives.

Regards,
Charlie P.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 17 Jul 2017 20:59:14 +0000

Thanks Charlie!

This is exceeding the expectations by far : )

Take care,

Pascal

Le 17 juil. 2017 ? 17:46, Charlie Perkins <[email-masked]<mailto:[email-masked]>> a ?crit :

Hello folks,

This afternoon, I managed to completely misunderstand what I was being asked about at the 6tisch meeting.  Please excuse...

I would indeed like to offer a very brief update about the recent 802.15.12 progress last week at the IEEE 802 Wireless meeting.  The minutes are available at the following URL:

  *   Discussed the programming interface between 802.15.12 layer and higher-layer protocols
  *   Will be looking towards CoAP for remote management interface
  *   Discussed the role of the management module and use of profiles to simplify configuration
  *   Discussed the processing of incoming frames and functional block interface imposed by the features of 802.15.10 (Layer-2 routing)
  *   Discussed the value of using YANG as a preferred method for describing interface profiles and other necessary management data

I have attached the current version of the Functional Block Decomposition diagram for 802.15.12 (as drawn up by Pat Kinney).  It's almost self-explanatory but not quite.  PDE may be compared to switching on Ethertype.  A "SAP" is a service-access point and is a general term which means "module interface".  A SAP is defined by a list of parameters, and what the recipient does with the parameters.  L2R is layer-2 routing.  KMP is Key Management Protocol (802.15.9).  I won't go into the MAC or PHY layer parameters, but you can see in the diagram where TSCH lives.

Regards,
Charlie P.

<For_6tisch.docx>
_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch