Subject: [6tisch] new command for 6P

From: Xavi Vilajosana Guillen <[email-masked]>
Date: Wed, 19 Jul 2017 19:22:36 +0200

Dear all,

I would like to propose a new command to be used to the 6P Protocol. The
command may be used to configure SF or exchange information between the SF
of the communicating nodes. The command can be named SIGNAL and 6P will not
define the content but only the operation and encapsulation. The content
will be defined by the different SFs as an IE.

I think that a message like this brings flexibility to SFs to implement
configuration operations.

what do you think?
regards,
Xavi

-- 
Dr. Xavier Vilajosana
Wireless Networks Lab

*Internet Interdisciplinary Institute (IN3)Professor*
(+34) 646 633 681
[email-masked] <[email-masked]>
http://xvilajosana.org
http://wine.rdi.uoc.edu
Parc Mediterrani de la Tecnologia
Av Carl Friedrich Gauss 5, B3 Building
08860 Castelldefels (Barcelona). Catalonia. Spain

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 19 Jul 2017 19:03:29 +0000

Makes sense to me ☺

From: 6tisch [mailto:[email-masked]] On Behalf Of Xavi Vilajosana Guillen
Sent: mercredi 19 juillet 2017 19:23
To: tisch <[email-masked]>
Subject: [6tisch] new command for 6P

Dear all,

I would like to propose a new command to be used to the 6P Protocol. The command may be used to configure SF or exchange information between the SF of the communicating nodes. The command can be named SIGNAL and 6P will not define the content but only the operation and encapsulation. The content will be defined by the different SFs as an IE.

I think that a message like this brings flexibility to SFs to implement configuration operations.

what do you think?
regards,
Xavi

--
Dr. Xavier Vilajosana
Wireless Networks Lab
Internet Interdisciplinary Institute (IN3)
Professor
(+34) 646 633 681
[email-masked]<mailto:[email-masked]>
http://xvilajosana.org
http://wine.rdi.uoc.edu

[Universitat Oberta de Catalunya]  [https://ferranadelantado.files.wordpress.com/2014/05/wine_logo_small2-e1453363995864.png?w=330&h=123]

---

From: Tengfei Chang <[email-masked]>
Date: Wed, 19 Jul 2017 21:06:45 +0200

I like the idea!

On Wed, Jul 19, 2017 at 9:03 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> Makes sense to me J
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Xavi
> Vilajosana Guillen
> *Sent:* mercredi 19 juillet 2017 19:23
> *To:* tisch <[email-masked]>
> *Subject:* [6tisch] new command for 6P
>
>
>
> Dear all,
>
>
>
> *Dr. Xavier Vilajosana*
> *Internet Interdisciplinary Institute (IN3) Professor*
> (+34) 646 633 681 <+34%20646%2063%2036%2081>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
Chang Tengfei,
Pre-Postdoctoral Research Engineer, Inria

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Wed, 19 Jul 2017 22:30:54 +0200

Xavi,

That sounds interesting.

Could you share any example what kind of configuration will be conveyed 
in a Signal Request and/or Response?

Best,
Yatch

On 2017/07/19 19:22, Xavi Vilajosana Guillen wrote:
> command may be used to configure SF or exchange information between the 
> SF of the communicating nodes. The command can be named SIGNAL and 6P 
> will not define the content but only the operation and encapsulation. 
> The content will be defined by the different SFs as an IE.
> 
> /Internet Interdisciplinary Institute (IN3)
> Professor/
> (+34) 646 633 681
> [email-masked] <mailto:[email-masked]>
> http://xvilajosana.org
> http://wine.rdi.uoc.edu
> Universitat Oberta de Catalunya
>

---

From: Xavi Vilajosana Guillen <[email-masked]>
Date: Thu, 20 Jul 2017 05:19:21 +0200

Hi Yatch,

here an example,

assume we have a fancy SF (named SFz) that requires to configure certain
timeouts in a certain manner. Consider that this configuration cannot be
deployed statically or pre-shared as it may depend on the app requirements,
node rank or can be varying in time.

When a node in that network starts, joins through minimal and
minimal-security and the SFz needs to start allocating cells, before
however, it needs to configure the timeouts to meet the application
requirements in that node.

Using the SIGNAL command with an IE that is defined by the SFz document,
two nodes will be able to install the configuration.

In detail, node A is time source of Node B. Assume Node B joins and the SFz
sends a SIGNAL command to Node A with the timeout configuration for the
link. Node B verifies the content of the received SFz IE in the SIGNAL
command and sends back a Response confirming the configuration. If all
worked both nodes install the configuration.

do you think makes sense?
regards,
Xavi

2017-07-19 22:30 GMT+02:00 Yasuyuki Tanaka <[email-masked]>:

> Xavi,
>
> That sounds interesting.
>
> Could you share any example what kind of configuration will be conveyed in
> a Signal Request and/or Response?
>
> Best,
> Yatch
>

-- 
Dr. Xavier Vilajosana
Wireless Networks Lab

---

From: "Lijo Thomas" <[email-masked]>
Date: Thu, 20 Jul 2017 11:42:22 +0530

Seems to be useful one , Xavi..

Thanks & Regards,

Lijo Thomas 

Sent: 19 July 2017 22:53
To: tisch

Dear all,

what do you think?

regards,

Xavi

-- 

Dr. Xavier Vilajosana
Wireless Networks Lab
Internet Interdisciplinary Institute (IN3)
Professor
(+34) 646 633 681
xvilajosana <mailto:[email-masked]> @uoc.edu
http://xvilajosana.org
http://wine.rdi.uoc.edu

-------------------------------------------------------------------------------------------------------------------------------
[ C-DAC is on Social-Media too. Kindly follow us at:
Facebook: https://www.facebook.com/CDACINDIA & Twitter: @cdacindia ]

This e-mail is for the sole use of the intended recipient(s) and may
contain confidential and privileged information. If you are not the
intended recipient, please contact the sender by reply e-mail and destroy
all copies and the original message. Any unauthorized review, use,
disclosure, dissemination, forwarding, printing or copying of this email
is strictly prohibited and appropriate legal action will be taken.
-------------------------------------------------------------------------------------------------------------------------------

---

From: Fabrice Théoleyre <[email-masked]>
Date: Thu, 20 Jul 2017 08:40:36 +0200

That sounds great to me, and it is sufficiently flexible to be useful in many situations.

Best regards,
Fabrice

> Le 20 juil. 2017 à 05:19, Xavi Vilajosana Guillen <[email-masked]> a écrit :
> 
> Hi Yatch,
> 
> here an example,
> 
> assume we have a fancy SF (named SFz) that requires to configure certain timeouts in a certain manner. Consider that this configuration cannot be deployed statically or pre-shared as it may depend on the app requirements, node rank or can be varying in time. 
> 
> When a node in that network starts, joins through minimal and minimal-security and the SFz needs to start allocating cells, before however, it needs to configure the timeouts to meet the application requirements in that node.  
> 
> Using the SIGNAL command with an IE that is defined by the SFz document, two nodes will be able to install the configuration.
> 
> In detail, node A is time source of Node B. Assume Node B joins and the SFz sends a SIGNAL command to Node A with the timeout configuration for the link. Node B verifies the content of the received SFz IE in the SIGNAL command and sends back a Response confirming the configuration. If all worked both nodes install the configuration.
> 
> 2017-07-19 22:30 GMT+02:00 Yasuyuki Tanaka <[email-masked] <mailto:[email-masked]>>:
> Xavi,
> 
> That sounds interesting.
> 
> Could you share any example what kind of configuration will be conveyed in a Signal Request and/or Response?
> 
> Best,
> Yatch
> 
> (+34) 646 633 681 <tel:%28%2B34%29%20646%20633%20681>
> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
> http://xvilajosana.org <http://xvilajosana.org/>
> http://wine.rdi.uoc.edu <http://wine.rdi.uoc.edu/>
> http://xvilajosana.org <http://xvilajosana.org/>
> http://wine.rdi.uoc.edu <http://wine.rdi.uoc.edu/>

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Thu, 20 Jul 2017 12:40:29 +0200

Xavi,

Thank you for the example!

xavi> do you think makes sense?
Yes, I do :-)

Best,
Yatch

On 2017/07/20 5:19, Xavi Vilajosana Guillen wrote:
> deployed statically or pre-shared as it may depend on the app 
> requirements, node rank or can be varying in time.
> 
> In detail, node A is time source of Node B. Assume Node B joins and the 
> SFz sends a SIGNAL command to Node A with the timeout configuration for 
> the link. Node B verifies the content of the received SFz IE in the 
> SIGNAL command and sends back a Response confirming the configuration. 
> If all worked both nodes install the configuration.
> 
>     Could you share any example what kind of configuration will be
>     conveyed in a Signal Request and/or Response?
> 
>     Best,
>     Yatch
> 
>         I would like to propose a new command to be used to the 6P
>         Protocol. The command may be used to configure SF or exchange
>         information between the SF of the communicating nodes. The
>         command can be named SIGNAL and 6P will not define the content
>         but only the operation and encapsulation. The content will be
>         defined by the different SFs as an IE.
> 
>         [email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>
>         http://xvilajosana.org
>         http://wine.rdi.uoc.edu

---

From: Michael Richardson <[email-masked]>
Date: Thu, 20 Jul 2017 23:52:26 +0200

Xavi> information between the SF of the communicating nodes. The command
    Xavi> can be named SIGNAL and 6P will not define the content but only the
    Xavi> operation and encapsulation. The content will be defined by the
    Xavi> different SFs as an IE.

    Xavi> I think that a message like this brings flexibility to SFs to
    Xavi> implement configuration operations.

I believe that I'm ignorant of how an SFx gets chosen for an LLN.
Can multiple co-exist in different parts of the LLN?
(I don't think so)
Can the chosen SFx change over time?

I ask because it seems like at least the content must include the SFx
type so that there is no confusion of SFx's IE with SFy's IE.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Xavi Vilajosana Guillen <[email-masked]>
Date: Fri, 21 Jul 2017 05:04:26 +0200

Hi Michael,

the SFID is part of the 6P IE header so it is checked at both sides during
a transaction.
There can be multiple SFs running on a node (at the same time). (e.g one
per slotframe with a different objective), hence the SFID is used to
identify what SF originated the command.

regards,
X

-- 
Dr. Xavier Vilajosana
Wireless Networks Lab