Subject: [6tisch] Next step for the scheduling function draft

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 19 Jul 2017 15:46:15 +0000

Dear authors :
 
Based on the discussion at the meeting yesterday, we propose you the following action plan
 
1)      Addressing Thomas' point on the '0' which cannot be experimental, suggestion is to rename SF0 to SFx or SFX
2)      Addressing Suresh's comment that an experimental draft should indicate which experimentations are expected, suggestion is to create a new section and propose research items
3)      Once this is done, publish as experimental
 
Does that sound right?

The chairs

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 25 Jul 2017 04:19:22 -0400

Pascal,
           I answer inline.
Regards,

                        Diego

2017-07-19 17:46 GMT+02:00 Pascal Thubert (pthubert) <[email-masked]>:

> 1)      Addressing Thomas' point on the '0' which cannot be experimental,
> suggestion is to rename SF0 to SFx or SFX
>

I will rename it SFX.

> 2)      Addressing Suresh's comment that an experimental draft should
> indicate which experimentations are expected, suggestion is to create a new
> section and propose research items
>

>From the three main tasks that any SF must do:
- Cell Scheduling algorithm
- Cell Relocation algorithm
- Timeout value definition

I propose the following experimental work on representative use cases:

1) Define values for OVERPROVISION, SF0THRESH and ranges to the number of
cells
to Add or Delete after the Allocation Policy is applied for typical use
cases.

2) Analyze the scheduling stability (in terms of oscillation) and the
hysteresis effect
on scheduling using SFX. A tradeoff shall be found between the reactivity
of the algorithm
facing new scheduling requirements and the number of overprovisioned cells.

3) Define the PDR value below the Average which is most effective for
blacklisting
cells and a method to whitelist cells. Analyze the stability and long-term
behavior
of this algorithm

4) Measure the distribution of cell scheduling delay (including the time
taken by
6P) to estimate timeouts for different type of transactions

> 3)      Once this is done, publish as experimental

I wait for your comments for the new proposed section to submit a new
version.

>
> Does that sound right?
>
> The chairs
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125