Subject: [6tisch] SF0 - lollipop

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Sep 2017 10:52:50 -0400

I wondered why it was called a Lollipop Sequence Number, so I asked Google,
and saw:
    https://en.wikipedia.org/wiki/Lollipop_sequence_numbering

which says:
      Lollipop sequence numbering was originally believed to resolve the
      ambiguity problem in cyclic sequence numbering schemes, and was used in
      OSPF version 1 for this reason. Later work showed that this was not the
      case, like in the ARPANET sequence bug, and OSPF version 2 replaced it
      with a linear numbering space, with special rules for what happens when
      the sequence numbers reach the end of the numbering space[1].

with a link to:
   http://www.ciscopress.com/articles/article.asp?p=24090&seqNum=4

are we sure that we are not being bitten in the same way?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Sep 2017 11:57:23 -0400

> We do not use sequence numbers in SF0. Why do you ask for lollipop
    > sequence scheme?

Sorry, I mispoke.  I'm poor ignorant guy who knows little about scheduling :-)
It's about 6P not SF0... which is used in SFx.
Xavi spoke about it in today's call.

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 8 Sep 2017 14:40:35 -0300

Michael,
             Well, I could not attend today to the webex call
and I may have not been aware that a sequence number
was proposed to be used in SF0 / SFX.
              Regards,

                                                Diego

2017-09-08 12:57 GMT-03:00 Michael Richardson <[email-masked]>:

> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Xavi Vilajosana Guillen <[email-masked]>
Date: Tue, 12 Sep 2017 14:56:45 +0200

Hi Michael,

I think that for us the problem won't appear as we do not need to
synchronize sequence numbers, just check that they are not duplicates ( the
last seen and the new one are different and the new one is not 0 while the
stored one is different than 0).

regards,
Xavi

-- 
Dr. Xavier Vilajosana
Wireless Networks Lab

*Internet Interdisciplinary Institute (IN3)Professor*
(+34) 646 633 681
[email-masked] <[email-masked]>
http://xvilajosana.org
http://wine.rdi.uoc.edu
Parc Mediterrani de la Tecnologia
Av Carl Friedrich Gauss 5, B3 Building
08860 Castelldefels (Barcelona). Catalonia. Spain