Subject: [71attendees] IPv6 on a Mac

From: Philip Matthews <[email-masked]>
Date: Mon, 10 Mar 2008 13:00:44 -0400

Does anyone have any pointers for what to do to get IPv6 set up on a  
Mac (10.4.11)?
When I connect to ietf-v6ONLY, I cannot reach any websites, including  
www.ietf.org and the wiki for the IPv6 experiment.
I checked the wiki page, but didn't see anything (perhaps I missed it?).

- Philip
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Robert Kisteleki <[email-masked]>
Date: Mon, 10 Mar 2008 13:18:41 -0400

I reported the same issue to the NOC, they are looking into it.

It does work in general, except for the reverse DNS (try with traceroute6 -n 
<any known v6 address>), therefore in practice you cannot really use it.

Robert

---

From: Alain Durand <[email-masked]>
Date: Mon, 10 Mar 2008 13:18:33 -0400

Try:
http://www.civil-tongue.net/6and4/wiki/Macintosh

  - Alain.

---

From: John Jason Brzozowski <[email-masked]>
Date: Mon, 10 Mar 2008 13:19:53 -0500

Are you able to query DNS over IPv6?  From a terminal window run the
following:

dig aaaa ietf71.comcast.net

What do you see?

> I checked the wiki page, but didn't see anything (perhaps I missed it?).

=========================================
John Jason Brzozowski (CISSP, RHCT)
Comcast Corporation
e) mailto:[email-masked]
m) 609-377-6594
p) 856-324-2671
=========================================

---

From: Leslie Daigle <[email-masked]>
Date: Mon, 10 Mar 2008 13:21:42 -0400

Hi,

FYI, see general information here:
http://wiki.tools.isoc.org/IETF71_IPv4_Outage

and material particular to Mac here:
http://www.civil-tongue.net/grandx/wiki/Macintosh

Note that you will have to manually enter the
v6 DNS address (provided on the first page) and
play with Firefox properties to get it to talk
to v6 (or use Safari).

Leslie.

> I checked the wiki page, but didn't see anything (perhaps I missed  

Leslie Daigle
Chief Internet Technology Officer
Internet Society
[email-masked]

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 10 Mar 2008 13:59:00 -0400

Hi,

This seems more fundamental.  The router address is coming up  
fe80:<something> instead of 2001:df8:<something>. Is this expected  
behavior?   I cannot ping the v6 nameserver addresses.  I am assuming  
that either Mac OS X isn't finding the correct router address, the  
router isn't advertising it, or the router address is ok but the  
router is not forwarding.  Does anyone have the IPv6 router address  
so we can try configuring and/or pinging the router's ipv6 address  
manually?

thanks,
-rohan

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 10 Mar 2008 14:03:48 -0400

On 10 mrt 2008, at 13:59, Rohan Mahy wrote:

> behavior?

Yes, this is normal.

> I cannot ping the v6 nameserver addresses.  I am assuming

Can you ping6 my machine at 2001:df8::16:21b:63ff:fe02:3c13 (not on  
v6only, on the regular WLAN)?
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Mon, 10 Mar 2008 20:05:32 +0200

> fe80:<something> instead of 2001:df8:<something>. Is this expected

Yes. Standard ICMPv6 autoconfiguration behavior.

> Does anyone have the IPv6 router address

ping6 -I <iface_name> address

works on Linux, should work on OSX & BSDs as well.

-- 
Rémi Denis-Courmont

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 10 Mar 2008 19:14:48 +0100

You can also try  2001:df8:0:80::2 on IETF-A SSID as traceroute6 indicates this address as the first hop (but a ping with link local with the right scope should also be working)

Or on Windows: ping6  fe80::20b:bfff:fea9:7054%6 (replace 6 by your wireless interface id)

-éric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rohan Mahy
Sent: lundi 10 mars 2008 18:59
To: Leslie Daigle
Cc: [email-masked]
Subject: Re: [71attendees] IPv6 on a Mac

Hi,

This seems more fundamental.  The router address is coming up fe80:<something> instead of 2001:df8:<something>. Is this expected  
behavior?   I cannot ping the v6 nameserver addresses.  I am assuming  
that either Mac OS X isn't finding the correct router address, the router isn't advertising it, or the router address is ok but the router is not forwarding.  Does anyone have the IPv6 router address so we can try configuring and/or pinging the router's ipv6 address manually?

thanks,
-rohan

On Mar 10, 2008, at 1:21 PM, Leslie Daigle wrote:
> v6 DNS address (provided on the first page) and play with Firefox 
> properties to get it to talk to v6 (or use Safari).
>
> Leslie.
>

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 10 Mar 2008 14:14:39 -0400

> v6only, on the regular WLAN)?

Yes, from "ietf-a"

> rohan% ping6 2001:df8::16:21b:63ff:fe02:3c13
> PING6(56=40+8+8 bytes) 2001:df8::80:214:51ff:feed:1b8c -->  
> 2001:df8::16:21b:63ff:fe02:3c13
> 16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=0 hlim=63  
> time=2.683 ms
> 16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=1 hlim=63  
> time=2.603 ms
> 16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=2 hlim=63  
> time=4.749 ms
> ^C

I can also ping the router from "ietf-a"

> ping6 2001:df8:0:5::6
> PING6(56=40+8+8 bytes) 2001:df8::80:214:51ff:feed:1b8c -->  
> 2001:df8:0:5::6
> 16 bytes from 2001:df8:0:5::6, icmp_seq=0 hlim=63 time=1.116 ms
> 16 bytes from 2001:df8:0:5::6, icmp_seq=1 hlim=63 time=1.174 ms
> ^C

I cannot ping the router from "ietf-v6ONLY" however:

> rohan% ifconfig en1
> en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>         inet6 fe80::214:51ff:feed:1b8c%en1 prefixlen 64 scopeid 0x5
>         inet6 2001:df8::80:214:51ff:feed:1b8c prefixlen 64 autoconf
>         inet6 2002:8281:54fa:a:214:51ff:feed:1b8c prefixlen 64  
> detached autoconf
>         inet6 fec0::a:214:51ff:feed:1b8c prefixlen 64 detached  
> autoconf
>         ether 00:14:51:ed:1b:8c
>         media: autoselect status: active
>         supported media: autoselect
> rohan% ping6 2001:df8:0:5::6
> ping6: UDP connect: No route to host

thanks,
-rohan

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 10 Mar 2008 14:19:03 -0400

> v6only, on the regular WLAN)?

I can (from my Mac) on either WLAN

 > From ietf-a
[68-247-78-229:~] tme% ping6 2001:df8::16:21b:63ff:fe02:3c13
PING6(56=40+8+8 bytes) 2001:df8::112:219:e3ff:fe02:56e2 -->  
2001:df8::16:21b:63ff:fe02:3c13
16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=0 hlim=63  
time=3.54 ms
16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=1 hlim=63  
time=1.834 ms
^C
--- 2001:df8::16:21b:63ff:fe02:3c13 ping6 statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 1.834/2.687/3.540 ms

 > From ietf-v6only
[68-247-78-229:~] tme% ping6 2001:df8::16:21b:63ff:fe02:3c13
PING6(56=40+8+8 bytes) 2001:df8::80:219:e3ff:fe02:56e2 -->  
2001:df8::16:21b:63ff:fe02:3c13
16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=0 hlim=63  
time=127.548 ms
16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=1 hlim=63  
time=1.65 ms
^C
--- 2001:df8::16:21b:63ff:fe02:3c13 ping6 statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 1.650/64.599/127.548 ms

[68-247-78-229:~] tme%

Note that the first v6only ping has a large RTT. That seems to be  
repeatable, at least
the first time I ping it on a session.

[68-247-78-229:~] tme% ping6 2001:df8::16:21b:63ff:fe02:3c13
PING6(56=40+8+8 bytes) 2001:df8::112:219:e3ff:fe02:56e2 -->  
2001:df8::16:21b:63ff:fe02:3c13
16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=0 hlim=63  
time=39.24 ms
16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=1 hlim=63  
time=7.687 ms
16 bytes from 2001:df8::16:21b:63ff:fe02:3c13, icmp_seq=2 hlim=63  
time=1.851 ms
^C

Regards
Marshall

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 10 Mar 2008 14:29:53 -0400

>>        inet6 2002:8281:54fa:a:214:51ff:feed:1b8c prefixlen 64  
                ^^^^^^^^^^^^^^^

The plot thickens. Apparently someone is advertising a 6to4 prefix  
somewhere, probably on another wlan, and your system retains that  
address which obviously won't work on an IPv6-only network.

Try turning off your wireless and then turning it on and making sure  
that you immediately go to the IPv6-only wlan.

ping6 fe80::20b:bfff:fea9:7054%en1

should work on the v6-only wlan regardless, though. (This is the link  
local address for the router there.)
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 10 Mar 2008 19:40:30 +0100

On IETF-A, 6to4 is also advertized... Let's the 'fun' begin...

Ethernet adapter Wireless Network Connection:
        IP Address. . . . . . . . . . . . : 130.129.83.207
        Subnet Mask . . . . . . . . . . . : 255.255.248.0
        IP Address. . . . . . . . . . . . : fec0::a:213:ceff:fecc:ca26%1
        IP Address. . . . . . . . . . . . :
2002:8281:54fa:a:9131:6b15:900b:fdaf
        IP Address. . . . . . . . . . . . :
2002:8281:54fa:a:213:ceff:fecc:ca26
        IP Address. . . . . . . . . . . . :
2001:df8:0:80:1d2b:e23b:1abc:a81
        IP Address. . . . . . . . . . . . :
2001:df8:0:80:213:ceff:fecc:ca26

2002:8281:54fa ==> 130.129.84.250 (off-line right now)

Are we running rafixd? Or another tool?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Iljitsch van Beijnum
Sent: lundi 10 mars 2008 19:30
To: Rohan Mahy
Cc: [email-masked]
Subject: Re: [71attendees] IPv6 on a Mac

                ^^^^^^^^^^^^^^^

---

From: Morgan Sackett <[email-masked]>
Date: Mon, 10 Mar 2008 15:35:51 -0400

>> ping6: UDP connect: No route to host

It looks like your address didn't change when you switched to v6ONLY.   
Your address should be 2001:df8::112:xxxx:xxxx:xxxx.

> -rohan

Morgan Sackett
VP of Engineering

VeriLAN Event Services, Inc.
215 SE Morrison Street
Portland, OR 97214

Tel: 503 907-1415
Fax: 503 224-8833

[email-masked]
www.verilan.com

This e-mail contains proprietary information and may be confidential.  
If you are not the intended recipient of this e-mail, you are hereby  
notified that any dissemination, distribution or copying of this  
message is strictly prohibited. If you received this message in error,  
please delete it immediately.

---

From: Tony Hansen <[email-masked]>
Date: Mon, 10 Mar 2008 15:41:54 -0400

Windows XP's IPv6 works fine as long as you are using IPv4 for DNS. From 
the IETF71_IPv4_Outage web page:

	Note that Windows XP will pass IPv6 traffic payload, but does
	not do DNS lookups over IPv6

Has anyone found a work around for this issue?

	Tony Hansen
	[email-masked]

---

From: Pekka Savola <[email-masked]>
Date: Mon, 10 Mar 2008 21:58:23 +0200 (EET)

> Has anyone found a work around for this issue?

Some Windows implementations automatically do DNS lookups to multicast 
addresses like fec0:0:0:ffff::[123].  You should see these as DNS servers 
in ipconfig/all output.

This is some form of Windows XP; not sure if this occurs on all service 
packs.

If this is true, configuring the localDNS resolvers to listen and respond 
on these multicast addresses might do the trick.

Maybe someone who actually have Win XP (I don't) can elaborate on this ?

Pekka

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 10 Mar 2008 20:57:49 +0100

C:\WINDOWS\SYSTEM32\DRIVERS\ETC\HOSTS for a short back in time trip?

:-)

AFAIK, NANOG was running a single IPv4 service during their IPv6 only
hours: DNS for Win XP. A work-around.

-eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Tony Hansen
Sent: lundi 10 mars 2008 20:42
To: [email-masked]
Subject: [71attendees] IPv6 on a Windows XP?

	Tony Hansen
	[email-masked]

---

From: Danny McPherson <[email-masked]>
Date: Mon, 10 Mar 2008 14:01:44 -0600

> Has anyone found a work around for this issue?

Was talking to Dave Thaler about this yesterday.  It came up at
NANOG and APNIC/APRICOT as well.  Official response is to
upgrade to Vista, as much other infrastructure (e.g., AD) in XP
don't work over IPv6 either.

-danny

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 10 Mar 2008 21:09:31 +0100

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Pekka Savola
> 
> Some Windows implementations automatically do DNS lookups to 
> multicast addresses like fec0:0:0:ffff::[123].  You should 
> see these as DNS servers in ipconfig/all output.
> 
> This is some form of Windows XP; not sure if this occurs on 
> all service packs.
> 
> If this is true, configuring the localDNS resolvers to listen 
> and respond on these multicast addresses might do the trick.

We also need to be sure that the DNS servers are layer 2 adjacent to the
Win XP machines; else, the DNS reply will never reach the Win XP machine
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Arifumi Matsumoto <[email-masked]>
Date: Tue, 11 Mar 2008 05:43:32 +0900

Tony,

why not install bind on Windows XP ? :)
http://www.isc.org/index.pl?/sw/bind/view/?release=9.3.2-P2

---

From: Danny McPherson <[email-masked]>
Date: Mon, 10 Mar 2008 14:46:16 -0600

> hours: DNS for Win XP. A work-around.

Yes, an 'XP' LAN was created that had Local v4 (for DNS) and
Global v6 that sat behind an IPv6-Only router off the general
NANOG IPv6 LAN with normal v6 folk.

-danny

---

From: Dave Thaler <[email-masked]>
Date: Mon, 10 Mar 2008 14:05:34 -0700

Forwarding, hoping it will go through this time...

> From: Dave Thaler
> Sent: Monday, March 10, 2008 4:06 PM
> To: 'Tony Hansen'
> Cc: [email-masked]
> Subject: RE: [71attendees] IPv6 on a Windows XP?
>
> DNS-over-IPv6 support wasn't added in Windows until Windows Vista
> (and Server 2003).  The only workaround for XP that I know of is to
> use the hosts file (%windir%\System32\drivers\etc\hosts) to manually
> enter the mappings.
>
> In theory, another workaround would be to install an NSP (name service
> provider) that supports DNS-over-IPv6, but I'm not aware of one.  If
> one
> existed, no changes to XP should be required other than installing it,
> as XP is extensible to having an arbitrary number of NSPs.
>
> -Dave
>
> > From: [email-masked] [mailto:71attendees-
> > [email-masked]] On Behalf Of Tony Hansen
> > Sent: Monday, March 10, 2008 3:42 PM
> > To: [email-masked]

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 10 Mar 2008 17:06:49 -0400

> http://www.isc.org/index.pl?/sw/bind/view/?release=9.3.2-P2

Can someone write up an explanation of how to do that?

I installed BIND and set up the interface with DNS address 127.0.0.1  
but I'm at a loss about how to control BIND under XP... I can't find  
any information about where the named.conf goes and how to tell the  
server to reload it.
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Dave Thaler <[email-masked]>
Date: Mon, 10 Mar 2008 14:12:03 -0700

BIND is (as far as I know) a DNS server, not a stub resolver that plugs
into the sockets apis.  Hence it cannot be used as a workaround in any
way I know of, unfortunately.

-Dave

> [email-masked]] On Behalf Of Iljitsch van Beijnum
> Sent: Monday, March 10, 2008 5:07 PM
> To: Arifumi Matsumoto
> Cc: [email-masked]
> Subject: Re: [71attendees] IPv6 on a Windows XP?
>

---

From: Dave Thaler <[email-masked]>
Date: Mon, 10 Mar 2008 14:15:04 -0700

Ah, I think I understand what Iljitsch is getting at... point
XP's client at the BIND server (recursive resolver) on the local machine.
Yeah, that does sound promising...

-Dave

> [email-masked]] On Behalf Of Dave Thaler
> Sent: Monday, March 10, 2008 5:12 PM
> To: Iljitsch van Beijnum; Arifumi Matsumoto
> Cc: [email-masked]

---

From: Alain Durand <[email-masked]>
Date: Mon, 10 Mar 2008 17:16:29 -0400

Could you configure you stub resolver with 127.0.0.1 and then run bind
listening on 127.0.0.1 and forwarding to the real DNS server listening for
v6 requests on the net?

  - Alain.

---

From: Arifumi Matsumoto <[email-masked]>
Date: Tue, 11 Mar 2008 06:16:53 +0900

Iljitsch van Beijnum wrote:
> I installed BIND and set up the interface with DNS address 127.0.0.1 but 
> I'm at a loss about how to control BIND under XP... I can't find any 
> information about where the named.conf goes and how to tell the server 
> to reload it.

Though I've never tried it myself,
the default directory is C:\WINDOWS\system32\dns.

"ISC BIND" is installed as a service. So you can
start/stop from the service control manager.
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Dave Thaler <[email-masked]>
Date: Mon, 10 Mar 2008 13:05:52 -0700

In theory, another workaround would be to install an NSP (name service
provider) that supports DNS-over-IPv6, but I'm not aware of one.  If one
existed, no changes to XP should be required other than installing it,
as XP is extensible to having an arbitrary number of NSPs.

-Dave

---

From: Dave Thaler <[email-masked]>
Date: Mon, 10 Mar 2008 13:51:25 -0700

Trying to resend as the first one apparently didn't go through...

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 10 Mar 2008 23:08:24 +0000

File locations are apparently in C:\windows\system32\dns\etc\

I found some info at 
http://www.linode.com/forums/archive/o_t/t_1676/bind_9_on_windows_xp_using_apache_server.html

We need a BIND expert for contents of files!

/Elwyn

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 10 Mar 2008 23:17:26 +0000

Also there is a readme.1st file in the distribution with more info.

/e

---

From: "George, Wes E IV [NTK]" <[email-masked]>
Date: Wed, 12 Mar 2008 09:59:52 -0500

The otherwise useful instructions on the wiki for installing bind as a workaround to reduce XP's currently end in "Result is a crash!  Bug reported... watch this space."
Given that plenary (and therefore outage) is tonight and there's no fix as of yet for BIND workaround, how about enabling JUST DNS in IPv4 like was done at NANOG IPv4 outage, perhaps just on the local DNS servers being reported on DHCP?

Or failing that, perhaps someone with a box running some superior version of software that understands that DNS is sorta critical to proper IPv6 function [*nix, Leopard, *cough* mumble..vista] could put a static 1918 address on their box to make their box available on the network for us unfortunate souls to use for DNS without actually needing IPv4 enabled on the wireless network itself?

It should be possible to configure DNS to listen/respond on IPv4 and but respond with IPv6 addresses (AAAA), right?

Even if BIND is fixed, we're not covering any new ground by proving that XP doesn't do IPv6 well, and those of us stuck with an XP box would still like to participate in the trial.

Thanks,
Wes

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Elwyn Davies
Sent: Monday, March 10, 2008 7:17 PM
To: Elwyn Davies
Cc: [email-masked]
Subject: Re: [71attendees] IPv6 on a Windows XP?

/e

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 12 Mar 2008 11:24:40 -0400

On 12 mrt 2008, at 10:59, George, Wes E IV [NTK] wrote:

> Or failing that, perhaps someone with a box running some superior  
> version of software that understands that DNS is sorta critical to  
> proper IPv6 function [*nix, Leopard, *cough* mumble..vista] could  
> put a static 1918 address on their box to make their box available  
> on the network for us unfortunate souls to use for DNS without  
> actually needing IPv4 enabled on the wireless network itself?

Ok. I've set up the address 172.31.71.71 on my laptop to respond to  
DNS queries. So if you set up your interface with a suitably randomly  
chosen address in 172.31.0.0/16 with no default gateway and DNS server  
172.31.71.71 you can resolve names as long as I have my laptop open.  
For the next hour or so I'll be on the ietf-v6ONLY wlan, please test  
and let me know if it works.
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Elwyn Davies <[email-masked]>
Date: Wed, 12 Mar 2008 15:44:47 +0000

I fear I am still waiting on a fast fix from ISC (no promises, and 
looking at the place where it hapened I am not surprised)..
However I have had an idea on a minor change (after detailed study of 
Bind manual) that might result in the broken code path being avoided.
Just about to go and try it out.
/Elwyn

---

From: Elwyn Davies <[email-masked]>
Date: Wed, 12 Mar 2008 16:25:50 +0000

Regrettably neither plan worked.

Adding an extra statement to force 'forwarding' on BIND did not prevent 
the crash.

I couldn't access Iljitsch's DNS server AFAICS.

Bummer.

/Elwyn

Iljitsch van Beijnum wrote:
>> proper IPv6 function [*nix, Leopard, *cough* mumble..vista] could put 
>> a static 1918 address on their box to make their box available on the 
>> network for us unfortunate souls to use for DNS without actually 
>> needing IPv4 enabled on the wireless network itself?
>

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 12 Mar 2008 14:39:42 -0400

On 12 mrt 2008, at 12:46, George, Wes E IV [NTK] wrote:

> missed your message time window. Ping me when you're back on and  
> I'll give it a try. Thanks!

Try again. I'll try to stay online for a while.  :-)

I'm in the [email-masked] jabber room.

Iljitsch

---

From: "George, Wes E IV [NTK]" <[email-masked]>
Date: Wed, 12 Mar 2008 14:04:46 -0500

So far no luck. I can reach v6 hosts by address, I can ping you via IPv4, but lookups are failing:
C:\Documents and Settings\weg0221>ping 172.31.71.71

Pinging 172.31.71.71 with 32 bytes of data:

Reply from 172.31.71.71: bytes=32 time=40ms TTL=64
Reply from 172.31.71.71: bytes=32 time=2ms TTL=64

Ping statistics for 172.31.71.71:
    Packets: Sent = 2, Received = 2, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 2ms, Maximum = 40ms, Average = 21ms

C:\Documents and Settings\weg0221>nslookup
*** Can't find server name for address 172.31.71.71: Non-existent domain
*** Default servers are not available
Default Server:  UnKnown
Address:  172.31.71.71

> set q=aaaa
> ipv6.google.com
Server:  UnKnown
Address:  172.31.71.71

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out
> exit

C:\Documents and Settings\weg0221>nslookup
*** Can't find server name for address 172.31.71.71: Non-existent domain
*** Default servers are not available
Default Server:  UnKnown
Address:  172.31.71.71

> ipv6.google.com
Server:  UnKnown
Address:  172.31.71.71

Non-authoritative answer:
Name:    ipv6.google.com

Thanks,
Wes

-----Original Message-----
From: Iljitsch van Beijnum [mailto:[email-masked]]
Sent: Wednesday, March 12, 2008 2:40 PM
To: George, Wes E IV [NTK]
Cc: [email-masked]
Subject: Re: [71attendees] IPv6 on a Windows XP?

On 12 mrt 2008, at 12:46, George, Wes E IV [NTK] wrote:

> missed your message time window. Ping me when you're back on and I'll
> give it a try. Thanks!

Iljitsch

---

From: Roque Gagliano <[email-masked]>
Date: Wed, 12 Mar 2008 12:42:49 -0400

so, if you use your own machine (127.0.0.1) as your dns server you  
could go arround the XP not resolving over IPv6 issue?

r.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 12 Mar 2008 15:49:08 -0400

> could go arround the XP not resolving over IPv6 issue?

Elwyn has been trying to do that but it's not simple and there seems  
to be a BIND bug. I'm on MacOS so I don't have that problem but I'm  
running a local nameserver that is reachable on 169.254.71.71 for  
people who are also on the v6-only network. Since there is no DHCP  
server you should be getting an address is 169.254.0.0/16 too so you  
only have to point at the DNS server (172.31.71.71 also still works).
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: "George, Wes E IV [NTK]" <[email-masked]>
Date: Wed, 12 Mar 2008 14:50:50 -0500

It works now! Thanks.

Thanks,
Wes

-----Original Message-----
From: Iljitsch van Beijnum [mailto:[email-masked]]
Sent: Wednesday, March 12, 2008 3:09 PM
To: George, Wes E IV [NTK]
Subject: Re: [71attendees] IPv6 on a Windows XP?

> *** Request to UnKnown timed-out

Hm, a quick

allow-recursion { any; };

should help against that... Sorry about that.

Iljitsch

---

From: "George, Wes E IV [NTK]" <[email-masked]>
Date: Wed, 12 Mar 2008 16:21:05 -0500

As requested....

To make this work (as a client running XP)-

associate with the ipv6-only SSID
open network properties for wireless and open TCPIP for IPv4, and set some static IPv4 address in either the 172.31/16 network or 169.254/16 network, with default mask and no default gateway.
set a static DNS entry pointing to either 169.254.71.71 or 172.31.71.71, whichever is on the same network as you defined your PC to be on.
issue ipconfig /flushdns in command prompt to clear your existing DNS cache entries

cross your fingers and hope it works...

Oh, and bug anyone you see at IETF with Microsoft on their badge to fix this in XP service pack 3! Dave, I'm glancing in your direction ;-)

Thanks,
Wes

_________________________________________
  Wesley George
        Sprint IP Engineering
  703-689-7505 (O)  703-864-4902 (PCS)
        http://www.sprint.net
_________________________________________

-----Original Message-----
From: Dave Thaler [mailto:[email-masked]]
Sent: Wednesday, March 12, 2008 5:03 PM
To: George, Wes E IV [NTK]
Subject: RE: [71attendees] IPv6 on a Windows XP?

Can you send out a list of steps of what you did to get it to work?
(I assume you're on XP?)

I think a bunch of people would appreciate it.

Thanks!
-Dave

> [email-masked]] On Behalf Of George, Wes E IV [NTK]
> Sent: Wednesday, March 12, 2008 3:51 PM
> To: Iljitsch van Beijnum
> Cc: [email-masked]

---

From: "George, Wes E IV [NTK]" <[email-masked]>
Date: Wed, 12 Mar 2008 16:25:18 -0500

Sorry for the spam. Occurred to me that I skipped a step if you don't have Ipv6 installed already.

You can either add a protocol in network properties or issue netsh interface ipv6 install from commandline to enable Ipv6 to start with.

Thanks,
Wes

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of George, Wes E IV [NTK]
Sent: Wednesday, March 12, 2008 5:21 PM
To: Dave Thaler
Cc: [email-masked]
Subject: Re: [71attendees] IPv6 on a Windows XP?

As requested....

Thanks,
Wes

-----Original Message-----
From: Dave Thaler [mailto:[email-masked]]
Sent: Wednesday, March 12, 2008 5:03 PM
To: George, Wes E IV [NTK]
Subject: RE: [71attendees] IPv6 on a Windows XP?

Thanks!
-Dave