Subject: [71attendees] ietf71 wireless problems

From: Michael Richardson <[email-masked]>
Date: Mon, 10 Mar 2008 10:56:00 -0400

I'm having layer-2 problems with the wireless.
(I will have to go plugin at the terminal room to send this)
I tried most of Sunday to get online, but I never succeeded.  It is
no better this morning.  
I am sending this in the hope that I am not alone. Many people can
online a bit, but get very poor performance, or are unable to stay on
very long.  My case seems pathological.

It looks like there are just too many APs to me.  My poor card doesn't
stay associated to any one of them long enough to get any data through.

I am using an external orinoco 802.11b card "Lucent Technologies GOLD",
but I have similar experiences with cisco Aironet cards. (Yes, this is a
card from an ietf 40-something meeting).  The driver/orinoco-firmware
combination does not let me get a list of APs (too old), while the cisco
one does, but the cisco one never sees any AP, even though it can get a
list of them.

I've never had problems with wireless, and I'm pretty kernel competent,
and the same cards were last used 2008-03-06.   I'm running debian
"GNU/Linux" etch with a custom 2.6.20.6 kernel.  I suspect that my cards
might need firmware upgrades to deal with some new-fangled mechanism, but I am
ignorant of what that might be. 

(I am in the market for an external 802.11a card that has a sufficiently
enlightened policy about releasing details such that quality open source
drivers can be written. No binary blobs please. The last one I ran
overheated the internal radio, and destroyed my motherboard)

Sitting at one end of the breakfast area I get:
(note link quality)

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:17:DF:AA:3F:42   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:2
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:17:DF:AA:38:82   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:4
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:17:DF:AA:30:52   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:4
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:17:DF:AA:30:52   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:13
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.412 GHz  Access Point: None   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:17
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:17:DF:AA:36:12   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:28
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:17:DF:AA:38:80   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:30
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:17:DF:AA:38:82   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:34
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:17:DF:A9:DA:52   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:36
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:17:DF:A9:DA:52   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:38
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1 essid 'ietf'
marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:"ietf"  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:17:DF:AA:38:80   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:164
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

...

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:"ietf"  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:17:DF:AA:38:80   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:165
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marajade:/home/mcr# iwconfig eth1
eth1      IEEE 802.11b  ESSID:"ietf"  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:17:DF:AA:30:50   
          Bit Rate:2 Mb/s   Sensitivity:1/3  
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:168
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Jim Reid <[email-masked]>
Date: Mon, 10 Mar 2008 16:25:53 +0000

> I'm having layer-2 problems with the wireless.

<AOL mode>Me too!</AOL Mode>

I spoke to one of the helpdesk guys in the terminal room. There's a  
problem with the APs in the meeting areas. Someone's working on it.  
The problem is that these APs don't seem to negotiate 802.11b  
properly. :-( The access points in the terminal room do. :-)

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 10 Mar 2008 12:55:25 -0400

> card from an ietf 40-something meeting).

It looks like the network is 802.11n (it tells me I'm connected at 130  
Mbps), and in my (granted, limited) experience with 802.11n gear is  
that unlike 802.11g, it has no compunction about about stepping on  
802.11b—hard.

Perhaps things would work better for last century's wifi cards if 2.4  
GHz stuff is set to 802.11g. Or maybe not...

Iljitsch

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 10 Mar 2008 13:21:54 -0400

I'm having the problem and I talked to the help desk.  They have some
newer APs, and they are having trouble with .11b.  Some devices are more
sensitive than others.  Older Thinkpads with older cards (mine is a T41
with a Cisco adapter that doesn't seem to do .11a) are troublesome.

They do have people working on it.  It does work for me in the terminal
room.  If you can connect to the .11a network, you won't have problems.

Brian

> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]]
> On Behalf Of Iljitsch van Beijnum
> Sent: Monday, March 10, 2008 12:55 PM
> To: Michael Richardson
> Cc: [email-masked]; [email-masked]
> Subject: Re: [71attendees] ietf71 wireless problems
> 
> 802.11b-hard.

---

From: Morgan Sackett <[email-masked]>
Date: Mon, 10 Mar 2008 13:22:12 -0400

Hi all,

It does in fact appear that the new APs we have are having issues with  
802.11b clients.  We are in the process of deploying a fix for this,  
so please hang tight.

We do in fact have N on the network, but only in the 5ghz range.   
802.11b/g clients should not be specifically affected by N.  If you  
are having issues with it, please let us know by stopping by the  
helpdesk in the Terminal Room, or by sending email to [email-masked] 
.

Morgan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 10 Mar 2008 18:28:03 +0100

I am having similar problems with a ThinkPad with a Intel(R)
PRO/Wireless LAN 2100 3B Mini PCI Adapter. 

Dan

> [mailto:[email-masked]] On Behalf Of Rosen, Brian
> Sent: Monday, March 10, 2008 7:22 PM
> To: Iljitsch van Beijnum; Michael Richardson
> I'm having the problem and I talked to the help desk.  They 
> have some newer APs, and they are having trouble with .11b.  
> Some devices are more sensitive than others.  Older Thinkpads 
> with older cards (mine is a T41 with a Cisco adapter that 
> doesn't seem to do .11a) are troublesome.
> 
> They do have people working on it.  It does work for me in 
> the terminal room.  If you can connect to the .11a network, 
> you won't have problems.
> 
> Brian
> 
> > > (I will have to go plugin at the terminal room to send 
> this) I tried 
> > > most of Sunday to get online, but I never succeeded.  It is no 
> > > better this morning.
> > > I am using an external orinoco 802.11b card "Lucent Technologies 
> > > GOLD", but I have similar experiences with cisco Aironet cards. 
> > > (Yes, this is a card from an ietf 40-something meeting).
> >

---

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 10 Mar 2008 20:15:47 +0200

I could not get my Thinkpad T.40 to connect anywhere except in the
terminal room.
I updated the drivers to a 2007 version, and there was no change.

I went down the block and bought a USB b/g adapter and am now
connecting,
but the connection seems to drop every few minutes.

Y(J)S

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 10 Mar 2008 17:09:56 -0400

On Mar 10 2008, at 13:22, Morgan Sackett wrote:

> We are in the process of deploying a fix

I just had my .11b phone connect for the first time (near "AP114") and  
had a decent RTP/SIP call.
Thanks!

Gruesse, Carsten

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 10 Mar 2008 16:22:07 -0400

On Mon, Mar 10, 2008 at 10:56:00AM -0400,
 Michael Richardson <[email-masked]> wrote 
 a message of 197 lines which said:

> I have similar experiences with cisco Aironet cards. (Yes, this is a

My very old Cisco Aironet card worked at every IETF meeting I went in,
works at my hotel, but does not work at IETF 71. I can get the list of
APs but never associates.

The NOC told me they forbid the associations with too low bitrates,
which may be the reason my old dinosaurian card is refused.

I use the terminal room in the mean time (there is a more modern Wifi
card inside my laptop but the current driver is too alpha - it freezes
the kernel). During the meetings, I'm forced to listen to talks
instead of watching YouTube.

So, IPv6 works but Wifi does not. How's that for a report :-)
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: "Gene Chang (genchang)" <[email-masked]>
Date: Mon, 10 Mar 2008 17:54:19 -0400

I think the comparison between your Wi-Fi card and IPv6 is unfair. I
wonder if your IPv6 from IETF 40-something works? :-)

Gene

------------------------------------------------------------------------
----
Eugene Chang (genchang)
Cisco Systems
Office:   603-559-2978
Mobile:  781-799-0233
Skype:  gene02421

> On Behalf Of Stephane Bortzmeyer
> Sent: Monday, March 10, 2008 4:22 PM
> To: Michael Richardson

---

From: Morgan Sackett <[email-masked]>
Date: Mon, 10 Mar 2008 17:57:57 -0400

We have deployed a few APs that are known to work with .11b clients.   
These APs are set to only associate at .11b rates, and the .11b rates  
are disabled on the units that are not compatible.  We are still  
interested if people are experiencing problems.

On Mar 10, 2008, at 5:09 PM, Carsten Bormann wrote:

> I just had my .11b phone connect for the first time (near "AP114")  
> and had a decent RTP/SIP call.
> Thanks!
>
> Gruesse, Carsten
>

Morgan Sackett
VP of Engineering

VeriLAN Event Services, Inc.
215 SE Morrison Street
Portland, OR 97214

Tel: 503 907-1415
Fax: 503 224-8833

[email-masked]
www.verilan.com

This e-mail contains proprietary information and may be confidential.  
If you are not the intended recipient of this e-mail, you are hereby  
notified that any dissemination, distribution or copying of this  
message is strictly prohibited. If you received this message in error,  
please delete it immediately.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 10 Mar 2008 23:11:45 +0100

I am one of the folks who could not connect yesterday and much of today.
Now the situation seems to have been fixed in Salon J where I could not
connect in the morning. The network seems to be a little unstable (a
couple of disconnects in 25 minutes) but I can connect, so thanks!

Dan

> [mailto:[email-masked]] On Behalf Of Morgan Sackett
> Sent: Monday, March 10, 2008 11:58 PM
> To: Carsten Bormann
> Cc: [email-masked]
> These APs are set to only associate at .11b rates, and the 
> .11b rates are disabled on the units that are not compatible. 
>  We are still interested if people are experiencing problems.
> 
> 
> If you are not the intended recipient of this e-mail, you are 
> hereby notified that any dissemination, distribution or 
> copying of this message is strictly prohibited. If you 
> received this message in error, please delete it immediately.
> 
> 
> 
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 10 Mar 2008 18:35:59 -0400

On Mon, Mar 10, 2008 at 05:57:57PM -0400,
 Morgan Sackett <[email-masked]> wrote 
 a message of 46 lines which said:

> These APs are set to only associate at .11b rates,

It seems to work. I am now able to use Wifi on the "ietf"
network. Many thanks!

"ietf-v6ONLY" still fails. And anyone knows what is ESSID
"ietf-v6help"?

---

From: Daniel Ellard <[email-masked]>
Date: Mon, 10 Mar 2008 18:51:50 -0400

> which may be the reason my old dinosaurian card is refused.

That stinks.

My "airport" might not be quite so ancient as your Aironet, but it's
certainly a bit long in the tooth.  Nevertheless, it has worked fine with
every wireless at every conference/hotel/campus/etc until today.

There's something ironic about having a card that clearly adheres faithfully
to the standard not work at a meeting of a standards organization...

-Dan

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Tue, 11 Mar 2008 10:47:38 -0400

--On Monday, March 10, 2008 10:56:00 AM -0400 Michael Richardson 
<[email-masked]> wrote:

> might need firmware upgrades to deal with some new-fangled mechanism, but
> I am ignorant of what that might be.

It is worth noting that the Linux wireless extensions provide for at most 
64K-1 bytes of data in scan results (the length field is a 16-bit integer). 
In the breakfast room around the time you were having this problem, the 
scan data for the number of AP's visible was larger than 32K.  So if you 
have an application which starts with a 4K buffer and then doubles it, as 
NetworkManager does, then it ends up discovering 32K is not big enough, and 
doubling it to.... zero!  A patched NM which instead jumps from 32K to 
64K-1 (the maximum size) is able to collect scan results and connect to the 
network.

Note that this is in addition to other issues which have been discussed on 
this thread, some of which have been resolved since Sunday.

-- Jeff

---

From: Derek Atkins <[email-masked]>
Date: Tue, 11 Mar 2008 11:00:33 -0400

> 64K-1 (the maximum size) is able to collect scan results and connect to the 

I've reported this to the networkmanager people.

> this thread, some of which have been resolved since Sunday.

-derek

-- 
Derek Atkins
Principal Software Engineer

PGP Corporation
4 Farragut Ave
Somerville, MA  02144

+1 617 623 3745 | [email-masked]

PGP Corporation -- Rest Secured.(TM)

PGP Fingerprint:
0FEE 5EA1 FF22 E0C9 4FFE
631A 9232 FF93 1C80 1DB7

This email and any attachments thereto may contain private,
confidential, and privileged material for the sole use of the intended
recipient. Any review, copying, or distribution of this email (or any
attachments thereto) by others is strictly prohibited. If you are not
the intended recipient, please contact the sender immediately and
permanently delete the original and any copies of this email and any
attachments thereto.