Subject: [71attendees] IPv6 Jabber Identity server anyone?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 11 Mar 2008 12:59:49 -0700

In an attempt to ensure the all important objective of connecting to the requisite chat room during the plenary I tried out ietf-v6ONLY today.

Issues discovered (OS/X Lepoard on a MacBook Air):

1) Firefox does not allow an IPv6 URL to be entered into the address bar, fe80::... was turned into http://www.fe80.com/...

2) iChat and Adium were both unable to connect to my gmail identity server so I was unable to connect to any chat room whatsoever.

Conclusion: Not only does it not work, the level of user intervention required is such that I am going to have to retreat to a small desert island (no Internet) during the transition phase or spend 110% of my time fixing the transition problems of all my relatives. Might as well be using IPv8...

This has to be completely transparent to the end user. The current scheme requires double ended adoption before IPv6 gives me the same level of usability as IPv4. 
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Michael Graff <[email-masked]>
Date: Tue, 11 Mar 2008 10:11:09 -0500

On Tuesday 11 March 2008 14:59:49 Hallam-Baker, Phillip wrote:
> Conclusion: Not only does it not work, the level of user intervention
> required is such that I am going to have to retreat to a small desert
> island (no Internet) during the transition phase or spend 110% of my time
> fixing the transition problems of all my relatives. Might as well be using
> IPv8...
>
> This has to be completely transparent to the end user. The current scheme
> requires double ended adoption before IPv6 gives me the same level of
> usability as IPv4.

This is one reason I don't think the no-v4 experiment is really of use right 
now.

The fact is that ipv4 is not going to go away on some magical day.  It's going 
to be here until we're all long dead.  The ability for V6 only hosts to 
contact V4 only hosts is where the magic is.  We all know we cannot reach our 
favorite search engines, mail servers, or whatnot over V6.  This does not 
require an hour to learn.

Most of the magic at this point seems to be in clients being able to not only 
understand IPv6 addresses and sockets, but to know how to reach IPv4 hosts 
when there is no local IPv4 address available.  NAT for the win.  And 
teaching applications to deal with the fact that IPv4 is not "the internet" 
anymore is critical before anyone will want to put an IPv6 only network on 
the air in more than an experiement.

--Michael

---

From: Jaap Akkerhuis <[email-masked]>
Date: Tue, 11 Mar 2008 21:18:37 +0100

1) Firefox does not allow an IPv6 URL to be entered into the address =
    bar, fe80::... was turned into http://www.fe80.com/...
    
You used the square brackets? http://[2001:7b8:206:1::1]/ worls for me

	jaap

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Tue, 11 Mar 2008 16:19:33 -0400

At Tue, 11 Mar 2008 12:59:49 -0700,

> 1) Firefox does not allow an IPv6 URL to be entered into the address bar, fe80::... was turned into http://www.fe80.com/...

I suspect you specified a link-local address with the "%link-ID"
suffix like:
http://[fe80::1%lo0]/

For simplicity, just forget link-local addresses (unless it's
absolutely necessary, which I don't believe is the case here).
Dealing with link-local addresses in normal applications is very
tricky, and doing so for the URL is particularly problematic because
the conflict meaning of the '%' character.

Global (or even the loopback) addresses that don't require the %
notation should work fine, for example,
http://[2001:1890:1112:1::20]/
has just led my firefox on Leopard to www.ietf.org.

---
JINMEI, Tatuya
Internet Systems Consortium, Inc.
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 11 Mar 2008 16:20:47 -0400

Le 08-03-11 à 15:59, Hallam-Baker, Phillip a écrit :
> 1) Firefox does not allow an IPv6 URL to be entered into the address  
have you tried http://[fe80::...] ?  i.e. enclosing into brackets?
RFC2732 for the specific info; RFC3986 for the merged URI
>
> 2) iChat and Adium were both unable to connect to my gmail identity  
> server so I was unable to connect to any chat room whatsoever.
>
> Conclusion: Not only does it not work,
>
well, if a server is only ipv4 (as the gmail identity server you are  
referring to), then obviously on an ipv6-only network, you won't be  
connected to it.

> the level of user intervention required is such that I am going to  
> have to retreat to a small desert island (no Internet) during the  
> transition phase or spend 110% of my time fixing the transition  
> problems of all my relatives. Might as well be using IPv8...
>
> This has to be completely transparent to the end user.
>
agree. in dual-stack scenarios, this is transparent. this experiment  
(v6only) pushes the envelop for v6-only deployments.

Marc.

> The current scheme requires double ended adoption before IPv6 gives  
> me the same level of usability as IPv4.
>

-----
IPv6 book: Migrating to IPv6, Wiley, 2006, http://www.ipv6book.ca

---

From: Patrik Fältström <[email-masked]>
Date: Tue, 11 Mar 2008 16:21:31 -0400

> This is one reason I don't think the no-v4 experiment is really of  

I think the experiment is very valuable. Not because things will work,  
but more because people (like myself) actually start to ensure that  
IPv6 exists and works. I have too many things to do, but the fact IPv4  
will be gone I actually ensured I have IPv6 image on my router at  
home, IPv6 connectivity etc. It would (still) have been too low  
priority if this test would not have happend.

    Patrik

---

From: "Larry J. Blunk" <[email-masked]>
Date: Tue, 11 Mar 2008 16:21:25 -0400

Hallam-Baker, Phillip wrote:
>
> In an attempt to ensure the all important objective of connecting to 
> the requisite chat room during the plenary I tried out ietf-v6ONLY today.
>

  You need to enclose the IPv6 address in square backets, i.e.
http://[2001:468:1400:5::32]   (http:// is optional).

---

From: "Pete St. Pierre" <[email-masked]>
Date: Tue, 11 Mar 2008 13:23:11 -0700

> bar, fe80::... was turned into http://www.fe80.com/...
I haven't tried this in a while, but you likely need brackets [ ]  
around the v6 address.  See RFC 3986 (originally defined in 2732) for  
details.
> Conclusion: Not only does it not work, the level of user  
> intervention required is such that I am going to have to retreat to  
> a small desert island (no Internet) during the transition phase or  
> spend 110% of my time fixing the transition problems of all my  
> relatives. Might as well be using IPv8...
>
> This has to be completely transparent to the end user. The current  
> scheme requires double ended adoption before IPv6 gives me the same  
> level of usability as IPv4.
>

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 11 Mar 2008 13:30:35 -0700

The objective here is to determine the functionality available to a user on an IPv6 only connection.

If the functionality is that I can only reach IPv6 hosts then I might as well use IPv8. The deployment strategy is going to fail. There is no incentive to deploy IPv6 hosts until there is a network of IPv6 clients and vice-versa.

So I would say that we have an important result, the current plan is unworkable. 

I am not giving up my IPv4 address until there is no Internet resource that I cannot reach via IPv6.

The dual stack scenario works for the end user but does nothing to solve the problem of depleting IPv4 space unless the IPv4 is behind a NAT.

-----Original Message-----
From: Marc Blanchet [mailto:[email-masked]]
Sent: Tue 11/03/2008 4:20 PM
To: Hallam-Baker, Phillip
Cc: [email-masked]
Subject: Re: [71attendees] IPv6 Jabber Identity server anyone?

	

	

well, if a server is only ipv4 (as the gmail identity server you are referring to), then obviously on an ipv6-only network, you won't be connected to it.

	the level of user intervention required is such that I am going to have to retreat to a small desert island (no Internet) during the transition phase or spend 110% of my time fixing the transition problems of all my relatives. Might as well be using IPv8...

agree. in dual-stack scenarios, this is transparent. this experiment (v6only) pushes the envelop for v6-only deployments.

Marc.

	The current scheme requires double ended adoption before IPv6 gives me the same level of usability as IPv4. 

-----

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 11 Mar 2008 16:32:58 -0400

> bar, fe80::... was turned into http://www.fe80.com/...

If it doesn't work with brackets either, you need to enable IPv6 in  
Firefox in about:config (for some unknown reason Firefox and  
Thunderbird do IPv6 out of the box on other platforms, but it's  
disabled on the Mac).

> server so I was unable to connect to any chat room whatsoever.

Which is not strange because Google doesn't do IPv6 at this time. But  
if you want you can work around this:

http://www.ietf.org/mail-archive/web/ietf/current/msg50560.html

Adium should work well, iChat will only work if there is still an IPv4  
address on the system somewhere, which will be the case if you have  
Parallels installed.

BTW, anyone want to come to the v6 WLAN and try iChat Bonjour?

> level of usability as IPv4.

Looks like you learned something from the experience already.  :-)

Iljitsch

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 11 Mar 2008 13:33:41 -0700

The demonstration has proved something that many people knew but few have been willing to accept.

The next challenge is going to be to get people to accept the fact that IPv6 deployment is not going to be viable unless it is zero-click administration for the end user.

I am not going to spend all my otherwise free time giving free network administration advice.

We now have Firefox loading the ietf.org page, but it does a reverse DNS lookup first for the loadbalancing so its actually on ipv4 by the time we are done.

Still no idea where there might be a jabber identity server that runs IPv6.

-----Original Message-----
From: [email-masked] on behalf of Patrik Fältström
Sent: Tue 11/03/2008 4:21 PM
To: Michael Graff
Cc: [email-masked]
Subject: Re: [71attendees] IPv6 Jabber Identity server anyone?

    Patrik

---

From: Michael Graff <[email-masked]>
Date: Tue, 11 Mar 2008 16:49:00 -0400

I still feel the experiment does not map into actual deployment  
practices. I doubt v4 is going to vanish and certainly just turning  
off routing in the hour long session only demonstrates one thing --  
that ipv4 routing breaks foe an hour.

Or are all dhcp v4 addresses going to expire then as well?  Otherwise  
the host has a v4 address and it can reasonably expect to he able to  
use it.

--Michael

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 11 Mar 2008 17:05:08 -0400

> address on the system somewhere, which will be the case if you have

Turns out that this works differently whether you have IPv4 turned off  
or you have it turned on but there just isn't any. In the latter case,  
iChat has no problems.

If you really want to cheat, use sequoia.muada.com port 80 as a proxy  
and you can reach the IPv4 web with only IPv6 connectivity.

However, that didn't work for me with the Parallels fake interfaces.  
You can easily remove those but you probably want to do that in a  
separate "location" so they're not really gone.
_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: John Jason Brzozowski <[email-masked]>
Date: Tue, 11 Mar 2008 17:08:49 -0400

Did you try this for the URL in Firefox:

http://[2001:558:ff0f:1000::2]/

John

On 3/11/08 3:59 PM, "Hallam-Baker, Phillip" <[email-masked]> wrote:

> 
> 
> In an attempt to ensure the all important objective of connecting to the
> requisite chat room during the plenary I tried out ietf-v6ONLY today.
> 
> 1) Firefox does not allow an IPv6 URL to be entered into the address bar,
> fe80::... was turned into http://www.fe80.com/...
> 
> 2) iChat and Adium were both unable to connect to my gmail identity server so
> I was unable to connect to any chat room whatsoever.
> 
> 
> Conclusion: Not only does it not work, the level of user intervention required
> is such that I am going to have to retreat to a small desert island (no
> Internet) during the transition phase or spend 110% of my time fixing the
> transition problems of all my relatives. Might as well be using IPv8...
> 

=========================================
John Jason Brzozowski (CISSP, RHCT)
Comcast Corporation
e) mailto:[email-masked]
m) 609-377-6594
p) 856-324-2671
=========================================

---

From: Ronald van der Pol <[email-masked]>
Date: Wed, 12 Mar 2008 04:57:57 +0100

> if you want you can work around this:

But they are setting up their first(?) IPv6 peerings at the AMS-IX in the
Netherlands:

https://www.ams-ix.net/connected/show_member.html?id=c822c1b63853ed273b89687ac505f9fa

Look for 2001:4860::/32 in your router table.

Any ietf google folks want to comment? A dual stack www.google.* would
be nice.

	rvdp

---

From: Bill Fenner <[email-masked]>
Date: Wed, 12 Mar 2008 10:10:12 -0400

> the conflict meaning of the '%' character.

Argh.  http://tools.ietf.org/html/draft-fenner-literal-zone ,  
anyone? ;-)

   Bill

---

From: Kurt Erik Lindqvist <[email-masked]>
Date: Wed, 12 Mar 2008 16:22:40 +0100

On 11 mar 2008, at 21.30, Hallam-Baker, Phillip wrote:

> If the functionality is that I can only reach IPv6 hosts then I  
> might as well use IPv8. The deployment strategy is going to fail.  
> There is no incentive to deploy IPv6 hosts until there is a network  
> of IPv6 clients and vice-versa.
>
> The dual stack scenario works for the end user but does nothing to  
> solve the problem of depleting IPv4 space unless the IPv4 is behind  
> a NAT.
>

Which is why we had NAT-PT and why work is going on in v6ops to create  
requirements for a "better" translation mechanism to allow co- 
existance in a transition.

- kurtis -

---

From: Ronald van der Pol <[email-masked]>
Date: Wed, 12 Mar 2008 16:45:19 +0100

> Any ietf google folks want to comment? A dual stack www.google.* would

I was pointed to ipv6.google.com with google's version of the dancing
kame :-)

	rvdp