Subject: Re: [80attendees] I-Ds for Kindle

From: "Hugo Salgado" <[email-masked]>
Date: Mon, 21 Feb 2011 23:12:39 +0000

What format are they? Can you post some samples to try it in a sony ebook reader?
Thanks a lot,

Hugo

------Original Message------
From: Marc Petit-Huguenin
Sender: [email-masked]
To: 80attendees
Subject: [80attendees] I-Ds for Kindle
Sent: Feb 21, 2011 20:01

Like for IETF 77th, I will be preparing bundles of I-Ds converted for the Kindle
to read in the flight to the meeting.  I will be preparing them for the WG
sessions I will attend (mostly RAI), but if there is enough people interested, I
can generate a bundle for each sessions and put them on a public server.

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
_______________________________________________
80attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/80attendees

Sent from my BlackBerry® wireless device

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 21 Feb 2011 15:20:03 -0800

> What format are they? Can you post some samples to try it in a sony ebook reader?

Not sure it will work for something else than Kindle.

Anyway I-Ds available in XML format are converted to the MOBI format, others to
a series of pictures.

The files from IETF 77 are still available here:

http://ietf.implementers.org/77/kindle2/

E.g. avp.zip contains file in mobi and pic format.

- -- 
Marc Petit-Huguenin

---

From: Hugo Salgado <[email-masked]>
Date: Mon, 21 Feb 2011 21:02:54 -0300

I can confirm that the .mobi documents works perfect in a
sony prs-700 ereader, using "calibre" software for upload,
which convert it to .epub on the fly. However the gifs doesn't
work :(

I'm mainly interested in dnsext, dnsop, and dane drafts!

Thanks a lot.

Hugo

---

From: Brian Smith <[email-masked]>
Date: Mon, 21 Feb 2011 19:08:53 -0500

Not trying to promote my own food here, but it might help someone. Here 
is a python script that I wrote to use create an HTML format output to 
be thrown directly into Amazon's KindleGen application. There are some 
bugs with diagram and title detection, but it does seem to do a pretty 
good job none-the-less.

As always YMMV.

https://github.com/pingwin/RFC-2-Kindle

Any contributions will be welcomed.

--
Brian Smith
CTO at DNS.com
https://www.dns.com/
http://twitter.com/dnsdotcom/

On 02/21/2011 06:12 PM, Hugo Salgado wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
>
> iEYEARECAAYFAk1i7uMACgkQ9RoMZyVa61cPMQCfZqJGv87d0Go0lbbbC3Ft+ce5
> YJEAn3XjRVNr0JyK0RbnC6umLQ66dU9l
> =X9Fs
> -----END PGP SIGNATURE-----

---

From: Tero Kivinen <[email-masked]>
Date: Tue, 22 Feb 2011 16:03:07 +0200

> What format are they? Can you post some samples to try it in a sony

Should have remembered to include urls to my files in my previous
format:

The urls are:

        http://www.fenron.net/~fenner/ietf/rfc.mobi

and

        http://www.fenron.net/~fenner/ietf/rfc.epub

The mobi format (http://en.wikipedia.org/wiki/Mobipocket) works in
Kindle 3, and any mobipocket reader software, along with lots of other
readers). ePub (http://en.wikipedia.org/wiki/EPUB) should then work in
rest of the devices...

You might need to download them to your PC first and then transfer
them to your device separately. Kindle should be able to download them
directly from that url over WiFi.

Those are still old versions updated 2010-11-06, but I will update
them before the next IETF.
-- 
[email-masked]