Subject: [81attendees] Android app for IETF 81

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 27 Jun 2011 12:48:55 -0700

I was complaining to my friend Isabelle Dalmasso that there was no easy tool to
manage a customized agenda during the IETF meeting so she wrote an Android app
doing exactly this.  You can install it from the Android Market, by using this
URL or the attached QR code:

http://market.android.com/details?id=org.dalmasso.ietfsched

The app itself was built upon the app Google released for their own Google I/O
conference.  That app was subsequently released as open source. The app is using
the data available on the IETF web site, but because there is no API available
for this kind of application, there is some restrictions on what can be done.

Please try it and send us your feedback, either on the Market or directly.

Enjoy!

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: Arturo Servin <[email-masked]>
Date: Mon, 27 Jun 2011 17:49:36 -0300

It is not what you are looking for, but I used:

http://tools.ietf.org/agenda/81/calendar

	Quite simple, download as ical and done. No details about the session but for me is ok for now.

Regards,
-as

On 27 Jun 2011, at 16:48, Marc Petit-Huguenin wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> 
> iEYEARECAAYFAk4I3qQACgkQ9RoMZyVa61e1XACfTEbyyCfaOzClhRe7q6jsl4p/
> FskAnAiqvC1+SUNROoRB4WkThOjdroib
> =as1T
> -----END PGP SIGNATURE-----
> _______________________________________________
> 81attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/81attendees

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 27 Jun 2011 14:07:20 -0700

> Quite simple, download as ical and done. No details about the session but for me

The Android app is IMO easier to use, especially if like me you do not want the
distraction of a laptop during the sessions.

- -- 
Marc Petit-Huguenin

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Tue, 28 Jun 2011 08:10:50 +0200

One quick question - is this a throw-away application, i.e. only good for Quebec, or something that could automatically be updated, e.g. for Taiwan?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Marc Petit-Huguenin
Sent: Monday, June 27, 2011 10:49 PM
To: [email-masked]
Cc: Isabelle Dalmasso
Subject: [81attendees] Android app for IETF 81

Enjoy!

- -- 
Marc Petit-Huguenin

---

From: Ole Jacobsen <[email-masked]>
Date: Mon, 27 Jun 2011 23:36:53 -0700 (PDT)

And ported to the iPhone?  :-)

Ole J. Jacobsen
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj
Skype: organdemo

On Tue, 28 Jun 2011, Weingarten, Yaacov (NSN - IL/Hod HaSharon) wrote:

> One quick question - is this a throw-away application, i.e. only 
> good for Quebec, or something that could automatically be updated, 
> e.g. for Taiwan?
>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 28 Jun 2011 11:16:11 -0400

>>>>> "Marc" == Marc Petit-Huguenin <[email-masked]> writes:
    Marc> I was complaining to my friend Isabelle Dalmasso that there
    Marc> was no easy tool to manage a customized agenda during the IETF
    Marc> meeting so she wrote an Android app doing exactly this.  You
    Marc> can install it from the Android Market, by using this URL or
    Marc> the attached QR code:

Thanks for this, I'm installing it.

As for the API, the tools folks were making ICS files available
with the schedule before.  I wonder if that isn't more than enough API
to solve the problem?  
Given the restrictions on what you can get, will you get updates on room
or time changes? 

I noticed for 80, that the generation of the ical feed was either gone
or not obvious.  

As a frequent remote participant,  I also wouldn't mind if this app
could find the appropriate audio channel for me, and... well... play
it... and also... join the jabber room :-)

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 28 Jun 2011 11:18:34 -0400

> I noticed for 80, that the generation of the ical feed was either gone

Well, it's at: http://trac.tools.ietf.org/agenda/81/calendar

I think that the link on the left eluded me, because there was a link
from http://trac.tools.ietf.org/agenda/81/ before to it.

---

From: Paul Wouters <[email-masked]>
Date: Tue, 28 Jun 2011 11:39:57 -0400 (EDT)

> it... and also... join the jabber room :-)

A mobile website would be even better then a specific platform app.

and don't forget the stream of inline #ietfXX :)

Paul

---

From: Tim Chown <[email-masked]>
Date: Tue, 28 Jun 2011 16:43:49 +0100

> and don't forget the stream of inline #ietfXX :)

Providing the meeting data as open data (RDF) would be ideal... or is that the case already?

Tim

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 28 Jun 2011 09:31:21 -0700

> it... and also... join the jabber room :-)

Yes, and it is not just for remote participants.  On the last meeting I wanted
to see one specific presentation in one session but had to be in another session
at the same time.  By listening to the stream I could have switched rooms for
just the duration of this presentation.

- -- 
Marc Petit-Huguenin

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 28 Jun 2011 17:32:47 +0000

Hi Everyone,
 
I'm Sheng Jiang and I didn't attend the Android App meeting or ietf org,
 
Could you  please remove me: [email-masked] from your email list?
 
Thanks,
Sheng

> Date: Tue, 28 Jun 2011 09:31:21 -0700
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]; [email-masked]
> Subject: Re: [81attendees] Android app for IETF 81
> 
> iEYEARECAAYFAk4KAdcACgkQ9RoMZyVa61cAeACfaHDZqfMRixSymNZiskb3gWPW
> 3V4An2OX7EwpwyIWyBYe3AsJvVA2AsWG
> =AlwV