Subject: [86attendees] Missing the Caribe Royale?

From: Brian Campbell <[email-masked]>
Date: Sat, 16 Mar 2013 19:33:50 -0600

Here's a little photo to help remember it
http://www.flickr.com/photos/brian-d-campbell/8561519461/in/pool-1281104@N21/lightbox/

---

From: Don Blumenthal <[email-masked]>
Date: Sun, 17 Mar 2013 09:37:07 -0400

FWIW, my birder wife, who still rolls her eyes when I use the word "seagull," said that the bird is a Scarlet Macaw.

Don

From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Campbell
Sent: Saturday, March 16, 2013 9:34 PM
To: [email-masked]
Subject: [86attendees] Missing the Caribe Royale?

Here's a little photo to help remember it http://www.flickr.com/photos/brian-d-campbell/8561519461/in/pool-1281104@N21/lightbox/

---

From: Ray Bellis <[email-masked]>
Date: Fri, 22 Mar 2013 11:20:09 +0000

On 17 Mar 2013, at 13:37, Don Blumenthal <[email-masked]<mailto:[email-masked]>> wrote:

FWIW, my birder wife, who still rolls her eyes when I use the word “seagull,” said that the bird is a Scarlet Macaw.

The birding was much better at Merritt Island Wildlife Refuge (near Kennedy Space Center)

<http://www.flickr.com/photos/raybellis/sets/72157633016877246/>

Ray

---

From: Scott Brim <[email-masked]>
Date: Fri, 22 Mar 2013 19:26:52 +0000

The painted buntings are excellent.

On 03/22/13 07:20, "Ray Bellis" <[email-masked]<mailto:[email-masked]>> allegedly wrote:

Ray