Subject: [86attendees] Edge Analysis of Wireless & Wired Networks

From: Eric Burger <[email-masked]>
Date: Sun, 10 Mar 2013 08:20:14 -0400

WiFi, Tower 2: http://n3.netalyzr.icsi.berkeley.edu/restore/id=ae81b058-26334-6832a3e6-4773-49e2-b416
Of note:
RTT of 640ms to California
4.5% packet loss
Uplink: 660 Kbps
Downlink: too slow to measure
Uplink buffer: 5.9 SECONDS (!!!!)
No IPv6

Wired, Tower 2: http://n3.netalyzr.icsi.berkeley.edu/restore/id=ae81b058-26331-eac12fcf-bc38-4b23-80b0
Of note:
RTT of 49ms to California
0.0% packet loss
Uplink & Downlink: >20Mbps
Buffering too small to measure, if any at all
IPv6? Well, this is interesting for an IETF network:
	Your system can not send or receive fragmented traffic over IPv6. 
	The path between your network and our system supports an MTU of at least 1496 bytes. The path between our system and your network has an MTU of 1500 bytes. The path between our system and your network does not appear to handle fragmented IPv6 traffic properly.
Other than that, my baseboard broadband connection looks pretty good!

---

From: Dave Taht <[email-masked]>
Date: Sun, 10 Mar 2013 08:31:03 -0400

600+ ms huh?

If anyone wants to plug in some rather thoroughly de-bufferbloated cerowrt
boxes in I brought 6 extras running the 3.7.5-2 firmware....
On Mar 10, 2013 8:20 AM, "Eric Burger" <[email-masked]> wrote:

> WiFi, Tower 2:
> http://n3.netalyzr.icsi.berkeley.edu/restore/id=ae81b058-26334-6832a3e6-4773-49e2-b416
> Of note:
> Wired, Tower 2:
> http://n3.netalyzr.icsi.berkeley.edu/restore/id=ae81b058-26331-eac12fcf-bc38-4b23-80b0
> Of note:
>         The path between your network and our system supports an MTU of at
> least 1496 bytes. The path between our system and your network has an MTU
> of 1500 bytes. The path between our system and your network does not appear
> to handle fragmented IPv6 traffic properly.
> _______________________________________________
> 86attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/86attendees
>
>

---

From: Simon Perreault <[email-masked]>
Date: Sun, 10 Mar 2013 08:41:21 -0400

> 	The path between your network and our system supports an MTU of at least 1496 bytes. The path between our system and your network has an MTU of 1500 bytes. The path between our system and your net…

Same here.

I would really like to know what kind of box drops our dear IPv6 
fragments. :)

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Bill Fenner <[email-masked]>
Date: Sun, 10 Mar 2013 11:24:44 -0400

On Sun, Mar 10, 2013 at 8:41 AM, Simon Perreault <
[email-masked]> wrote:

>>         The path between your network and our system supports an MTU of
>> at least 1496 bytes. The path between our system and your network has an
>> MTU of 1500 bytes. The path between our system and your network does not
>> appear to handle fragmented IPv6 traffic properly.
>>
>
> Same here.
>

Can you try to find out?  "traceroute6 <destination> 1600", and compare
that with "traceroute6 <destination>"?

This does not test receiving IPv6 fragments, only sending, but one step at
a time.

  Bill

---

From: Simon Perreault <[email-masked]>
Date: Sun, 10 Mar 2013 11:27:23 -0400

Le 2013-03-10 08:41, Simon Perreault a écrit :
>> least 1496 bytes. The path between our system and your network has an
>> MTU of 1500 bytes. The path between our system and your network does
>> not appear to handle fragmented IPv6 traffic properly.
>
> Same here.

After more investigation, prompted by an incredulous NOC person 
(thanks!), I could not reproduce this with my own remote servers. So our 
fine NOC folks are not to blame. So there must be something else between 
here and Netalyzr's servers that is dropping IPv6 fragments. More 
investigation needed.

Simon

---

From: Jim Martin <[email-masked]>
Date: Mon, 11 Mar 2013 10:48:29 -0400

Starting at Noon today, Brighthouse will be making some changes to our connection to eliminate the dropped v6 packets mentioned yesterday. Each outage should just be a few seconds, and we'll do one external link, wait for things to stabilize, and then do the second. All in all, we expect very limited disruption, but wanted to warn everyone. 

	Take this opportunity to enjoy lunch and get back to your mail once you get back :-)

	- Jim

On Mar 10, 2013, at 8:41 AM, Simon Perreault <[email-masked]> wrote:

> I would really like to know what kind of box drops our dear IPv6 fragments. :)
> 
> Simon
> --

---

From: Michael Richardson <[email-masked]>
Date: Mon, 11 Mar 2013 18:18:22 -0400

>>>>> "Jim" == Jim Martin <[email-masked]> writes:
    Jim> 	Starting at Noon today, Brighthouse will be making some
    Jim> changes to our connection to eliminate the dropped v6 packets
    Jim> mentioned yesterday. Each outage should just be a few seconds,
    Jim> and we'll do one external link, wait for things to stabilize,
    Jim> and then do the second. All in all, we expect very limited
    Jim> disruption, but wanted to warn everyone.

    Jim> 	Take this opportunity to enjoy lunch and get back to
    Jim> your mail once you get back :-)

Can you tell us more about what they are fixing?
What was the root cause?

I think it is important for everyone to know why the "option" to drop
fragments even existed.

-- 
Michael Richardson
-on the road-

---

From: Yoav Nir <[email-masked]>
Date: Mon, 11 Mar 2013 22:32:11 +0000

> I think it is important for everyone to know why the "option" to drop

NAT-PT, whether 4 to 4, 4 to 6, or 6 to 4, requires state on the router, which limits the capacity of the router based on memory. So many routers that are capable of address translation have a configuration switch to drop packets. This exists regardless of whether NAT is or is not configured (it's also needed for firewalls)

This is, after all, the reason we're working on IKE-over-TCP in IPsecME.

Yoav

---

From: Nalini Elkins <[email-masked]>
Date: Wed, 13 Mar 2013 05:39:46 -0700 (PDT)

IETFers,

The Snack BoF to discuss issues of large, medium, and small data center operators will be at 17:10 today (Wed.)  in the Caribbean Foyer.  The table will be set up in front of where the lunch service is.    It will be in between the Caribbean rooms and the IETF lounge.  (To provide adequate routing information!)

This is an informal session & we look forward to a lively discussion!
 
Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

---

From: Eric Burger <[email-masked]>
Date: Wed, 13 Mar 2013 15:42:30 -0400

8.5 hours is a bit short notice. Regrets.

Good luck selling your consulting services, though!

---

From: Nalini Elkins <[email-masked]>
Date: Thu, 14 Mar 2013 04:41:23 -0700 (PDT)

Eric,

Sorry you couldn't  make it to the BoF.

As far as your comment:

"Good luck selling your consulting services, though!"

I hope I am not misunderstanding but you seem to be implying that I am doing this as a marketing activity for my company.   To be blunt, we don't need to.   We make plenty of money and have almost more business than we can handle.

So, we are in a position to try to do something for the common good.  I think it is in the long term best interests of both data center operators and the IETF to have more engagement.   I have also found that conversations in an informal setting often lead to more productive outcomes.  People are more relaxed and open to exchanging ideas.  That is one of the advantages of face to face conferences. That was the reason for the Snack BoF.

I am actually getting behind on my paid work while being here at IETF.  (As I am sure are many others.)  But, I will say that the idea of working for the common good, and trying to do it over and above your "day" job,  resonates with many people at IETF that I have talked to.  Because many IETFers have been doing just this for many years.  For this, I commend them and I thank them.  

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

________________________________
From: Eric Burger <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Wednesday, March 13, 2013 12:42 PM
Subject: Re: [86attendees] Snack BoF: Data Center Issues: Location

IETFers,