Subject: [86attendees] iPhone-ish power adapter found

From: "John G. Scudder" <[email-masked]>
Date: Wed, 13 Mar 2013 14:08:20 -0400

Knockoff iPhone power adapter, marked "Just Charge It!", found in Caribbean III at 13:00. Given to Secretariat.

--John

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 13 Mar 2013 18:23:08 +0000

Anybody know why?

My iPhone 5 (And many iPhone 4) don't get wifi associated after selecting the v6 only SSID.

Cheers,
Rajiv

Sent from my Phone

On Mar 13, 2013, at 2:10 PM, "John G. Scudder" <[email-masked]> wrote:

> _______________________________________________
> 86attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/86attendees

---

From: Andrew Mcgregor <[email-masked]>
Date: Wed, 13 Mar 2013 14:23:57 -0400

They don't consider themselves to have an internet connection with no IPv4.

On 13 March 2013 14:23, Rajiv Asati (rajiva) <[email-masked]> wrote:

> > Knockoff iPhone power adapter, marked "Just Charge It!", found in
> Caribbean III at 13:00. Given to Secretariat.
> >
> > --John

-- 
Andrew McGregor | SRE | [email-masked] | +61 4 8143 7128

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 13 Mar 2013 18:40:03 +0000

IPv6 only SSID should work. It worked fine for me elsewhere.

Btw, Samsung focus S (win7) has the same problem.

Cheers,
Rajiv

Sent from my Phone

On Mar 13, 2013, at 2:24 PM, "Andrew Mcgregor" <[email-masked]<mailto:[email-masked]>> wrote:

On 13 March 2013 14:23, Rajiv Asati (rajiva) <[email-masked]<mailto:[email-masked]>> wrote:
Anybody know why?

Cheers,
Rajiv

Sent from my Phone

On Mar 13, 2013, at 2:10 PM, "John G. Scudder" <[email-masked]<mailto:[email-masked]>> wrote:

> [email-masked]<mailto:[email-masked]>
_______________________________________________
86attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/86attendees

--
Andrew McGregor | SRE | [email-masked]<mailto:[email-masked]> | +61 4 8143 7128
_______________________________________________
86attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/86attendees

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Wed, 13 Mar 2013 14:41:16 -0400

Developers, developers....

while (true) {
    if ( !brain_dead_internet_check()) {
         stupidly_refuse_to_use_stack_i_have();
    } else {
        blindy_try_to_connect_even_if_nothing_works();
    }
}

:D

On 3/13/13 2:23 PM, Andrew Mcgregor wrote:
>     > Knockoff iPhone power adapter, marked "Just Charge It!", found
>     in Caribbean III at 13:00. Given to Secretariat.
>     >
>     > --John
>     > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
> Andrew McGregor | SRE | [email-masked]
> <mailto:[email-masked]> | +61 4 8143 7128
>
>

---

From: <[email-masked]>
Date: Wed, 13 Mar 2013 18:44:13 +0000

As a data point, Nokia Lumia 820 (Windows Phone 8) associates and works fine (well, as fine as things work in IPv6-only land).

Best regards,

                Teemu

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Rajiv Asati (rajiva)
Sent: 13. maaliskuuta 2013 14.40
To: Andrew Mcgregor
Cc: [email-masked]
Subject: Re: [86attendees] IPv6 only SSID not working on iPhone

Cheers,
Rajiv

Sent from my Phone

Cheers,
Rajiv

Sent from my Phone

---

From: joel jaeggli <[email-masked]>
Date: Wed, 13 Mar 2013 15:23:37 -0400

> My iPhone 5 (And many iPhone 4) don't get wifi associated after selecting the v6 only SSID.
they assume any network they can't dhcp on is an undesirable network.

---

From: Dan York <[email-masked]>
Date: Wed, 13 Mar 2013 15:35:14 -0400

Rajiv,

> they assume any network they can't dhcp on is an undesirable network.

As it happens, I just spent some time with Stuart Cheshire of Apple trying to diagnose this after Sunset4 ended.  We found that the issue seems to be that both iOS and Mac OS X are not getting a DNS resolver address on the ietf-v6ONLY network.  They *are* getting IPv6 addresses, but not getting the DNS resolver info.  On Mac OS X if you manually enter a DNS server address of "2001:df8:0:5::6" it will work.
 
Someone else was able to bring up Windows 8 in a vmware window on a Mac (in bridge mode) and it did get both an IPv6 address and a DNS resolver and worked fine.

I raised a ticket with [email-masked] who then raised a ticket with the NOC.

Dan

--
Dan York
Senior Content Strategist, Internet Society
[email-masked]   +1-802-735-1624 
Jabber: [email-masked] 
Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/deploy360/

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 13 Mar 2013 19:49:26 +0000

Rajiv

In some conferences, a trick is used to provide a fake and useless IPv4 address to alleviate this problem (e.g. Cisco Live) with a trick very similar to the WIDE project one presented this afternoon in SUNSET4

-éric

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rajiv Asati (rajiva)
Sent: mercredi 13 mars 2013 14:40
To: Andrew Mcgregor
Cc: [email-masked]
Subject: Re: [86attendees] IPv6 only SSID not working on iPhone

Cheers,
Rajiv

Sent from my Phone

Cheers,
Rajiv

Sent from my Phone

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 13 Mar 2013 20:26:09 +0000

Dan,

Thanks. That worked.

I suspect that the usage of SLAAC is to be blamed here. RDNS option is still missing, I suppose. :(

Cheers,
Rajiv

Sent from my Phone

On Mar 13, 2013, at 3:35 PM, "Dan York" <[email-masked]<mailto:[email-masked]>> wrote:

Rajiv,

On Mar 13, 2013, at 3:23 PM, joel jaeggli <[email-masked]<mailto:[email-masked]>> wrote:

I raised a ticket with [email-masked]<mailto:[email-masked]> who then raised a ticket with the NOC.

Dan

--
Dan York
Senior Content Strategist, Internet Society
[email-masked]<mailto:[email-masked]>   +1-802-735-1624
Jabber: [email-masked]<mailto:[email-masked]>
Skype: danyork   http://twitter.com/danyork

---

From: Arturo Servin <[email-masked]>
Date: Thu, 14 Mar 2013 04:35:46 -0700

I have a Chromebook that refuses to connect to the IPv6 only network.

I didn't have time to troubleshoot (in fact I do not know how to get in the
insides of the machine). But if someone wants to have fun inspecting what
is going on I will be available. Just look for the Chromebook and the
orange.

regards
as

On Wed, Mar 13, 2013 at 1:26 PM, Rajiv Asati (rajiva) <[email-masked]>wrote:

> On Mar 13, 2013, at 3:35 PM, "Dan York" <[email-masked]> wrote:
>
>  Rajiv,
>
>  As it happens, I just spent some time with Stuart Cheshire of Apple
> trying to diagnose this after Sunset4 ended.  We found that the issue seems
> to be that both iOS and Mac OS X are not getting a DNS resolver address on
> the ietf-v6ONLY network.  They *are* getting IPv6 addresses, but not
> getting the DNS resolver info.  On Mac OS X if you manually enter a DNS
> server address of "2001:df8:0:5::6" it will work.
>
> Someone else was able to bring up Windows 8 in a vmware window on a Mac
> (in bridge mode) and it did get both an IPv6 address and a DNS resolver and
> worked fine.
>

---

From: Stuart Cheshire <[email-masked]>
Date: Fri, 15 Mar 2013 07:51:10 -0700

> They don't consider themselves to have an internet connection with no IPv4.

Or... perhaps we could try some actual facts.

The IETF DHCPv6 server was temporarily unreachable. It is now fixed,
and my iPhone is again working on the "ietf-v6ONLY" SSID.

So it was a simple network issue, which has been fixed.

Stuart Cheshire

---

From: joel jaeggli <[email-masked]>
Date: Fri, 15 Mar 2013 11:00:28 -0400

> and my iPhone is again working on the "ietf-v6ONLY" SSID.
yes, we set the O bit but the stateless dhcpv6 server was out of 
commision for a while.

---

From: Andrew Mcgregor <[email-masked]>
Date: Fri, 15 Mar 2013 12:33:52 -0400

Ah... that's changed.  Thanks for the clue.

---

From: Adam Roach <[email-masked]>
Date: Fri, 15 Mar 2013 12:50:12 -0400

So, I can confirm that I observed (with more than a cursory analysis, 
albeit only with the tools I could install on a non-jailbroken iPad) the 
behavior that Andrew describes on my iPad in Vancouver. I opened a bug 
on it, but it didn't go anywhere (I got a response a week or so later 
asking for logging information that I couldn't provide because I don't 
have a v6-only network at home, and wasn't going to set up something 
quite that complicated for this particular issue).

But, in any case, what Andrew says below isn't without basis in facts; 
it's just (apparently) out of date.

/a

On 3/15/13 12:33, Andrew Mcgregor wrote:
> On 15 March 2013 10:51, Stuart Cheshire <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     On Wed, Mar 13, 2013 at 11:23 AM, Andrew Mcgregor
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
> Andrew McGregor | SRE [email-masked]