Subject: [86attendees] The net thinks I'm in china

From: Michael Graff <[email-masked]>
Date: Mon, 11 Mar 2013 12:43:24 +0000

Thanks to geocoding based on IP address, I am apparently in China, Brazil, or any of several other places outside the US.

This is causing no end of fun.  Google initially finds my location in China, and later fixes this once the GPS kicks in.  Wikipedia asks me to donate in Kč, and HBO Go tells me a message in Spanish and that Brazil is not an area I can watch movies in.

We are truly an international group!  :)

---

From: Derek Atkins <[email-masked]>
Date: Mon, 11 Mar 2013 06:12:04 -0700

At least for me it was San Antonio, so the only issue was my phone showing the wrong time and weather..

-derek

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Michael Graff [[email-masked]]
Sent: Monday, March 11, 2013 8:43 AM
To: <[email-masked]>
Subject: [86attendees] The net thinks I'm in china

---

From: Ben Campbell <[email-masked]>
Date: Mon, 11 Mar 2013 08:18:45 -0500

I appear to be in Prague

On Mar 11, 2013, at 8:12 AM, Derek Atkins <[email-masked]> wrote:

> _______________________________________________
> 86attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/86attendees

---

From: Chris Morrow <[email-masked]>
Date: Mon, 11 Mar 2013 09:24:41 -0400

How are you all testing this?
(So the right parts can get fixed)
On Mar 11, 2013 9:19 AM, "Ben Campbell" <[email-masked]> wrote:

> > From: [email-masked] [[email-masked]] On
> Behalf Of Michael Graff [[email-masked]]
> > Thanks to geocoding based on IP address, I am apparently in China,
> Brazil, or any of several other places outside the US.
> >
> > This is causing no end of fun.  Google initially finds my location in
> China, and later fixes this once the GPS kicks in.  Wikipedia asks me to
> donate in Kč, and HBO Go tells me a message in Spanish and that Brazil is
> not an area I can watch movies in.
> >

---

From: joel jaeggli <[email-masked]>
Date: Mon, 11 Mar 2013 09:26:45 -0400

We endeavor in general to get the geoip providers understand what our 
region is each time that we move the address blocks associated with the 
meeting.

Site using obsolete data or (e.g. maxminds free geolite is updated once 
a month) or providers that have bad or obsolete data to begin with are 
clearly a limitation.

---

From: Michael Graff <[email-masked]>
Date: Mon, 11 Mar 2013 13:35:11 +0000

I used the hbo go app to attempt to watch a movie this morning.
I popped up maps.google.com<http://maps.google.com>, and it defaulted to China.
I went to Wikipedia English side and was asked to donate in a non-US currency.

On Mar 11, 2013, at 9:24, "Chris Morrow" <[email-masked]<mailto:[email-masked]>> wrote:

On Mar 11, 2013 9:19 AM, "Ben Campbell" <[email-masked]<mailto:[email-masked]>> wrote:
I appear to be in Prague

On Mar 11, 2013, at 8:12 AM, Derek Atkins <[email-masked]<mailto:[email-masked]>> wrote:

> From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] On Behalf Of Michael Graff [[email-masked]<mailto:[email-masked]>]
> To: <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
86attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/86attendees

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 11 Mar 2013 09:40:14 -0400

As I type this both Bing Maps and Google Maps place us at the Renaissance
Orlando at SeaWorld, which is about 6 miles away from the Caribe. That's a
lot closer than China. :-)

On the other hand, speedtest.net seems to think that we're in Wichita KS
this morning. When I used it yesterday, it showed us in Prague, so that's
progress of a sort.

Cheers,
Andy

On Mon, Mar 11, 2013 at 9:26 AM, joel jaeggli <[email-masked]> wrote:

> Site using obsolete data or (e.g. maxminds free geolite is updated once a
> month) or providers that have bad or obsolete data to begin with are
> clearly a limitation.
>
>
>
>>> ______________________________**__________
>>> ______________________________**_________________
>>> 86attendees mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/**listinfo/86attendees<https://www.ietf.org/mailman/listinfo/86attendees>
>>>
>> ______________________________**_________________
>> 86attendees mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/86attendees<https://www.ietf.org/mailman/listinfo/86attendees>
>>
>>
> ______________________________**_________________
> 86attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/86attendees<https://www.ietf.org/mailman/listinfo/86attendees>
>

---

From: Chris Morrow <[email-masked]>
Date: Mon, 11 Mar 2013 09:51:35 -0400

Your soul is catching up.

---

From: Stig Venaas <[email-masked]>
Date: Mon, 11 Mar 2013 07:01:53 -0700

I also got San Antonio. Except Google for some reason figured I should 
see the Australian Google page.

Stig

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 11 Mar 2013 14:12:30 +0000

While connected to IETF.1X Google maps places me at the Caribe Royal.
But an IP address locator app is returning San Francisco.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: 11 March, 2013 15:40
To: joel jaeggli
Cc: Ben Campbell; Derek Atkins; Michael Graff; <[email-masked]>
Subject: Re: [86attendees] The net thinks I'm in china

As I type this both Bing Maps and Google Maps place us at the Renaissance Orlando at SeaWorld, which is about 6 miles away from the Caribe. That's a lot closer than China. :-)
On the other hand, speedtest.net<http://speedtest.net> seems to think that we're in Wichita KS this morning. When I used it yesterday, it showed us in Prague, so that's progress of a sort.
Cheers,
Andy

On Mon, Mar 11, 2013 at 9:26 AM, joel jaeggli <[email-masked]<mailto:[email-masked]>> wrote:
We endeavor in general to get the geoip providers understand what our region is each time that we move the address blocks associated with the meeting.

Site using obsolete data or (e.g. maxminds free geolite is updated once a month) or providers that have bad or obsolete data to begin with are clearly a limitation.

-derek

---

From: Phil Hunt <[email-masked]>
Date: Mon, 11 Mar 2013 07:45:38 -0700

I am in the lounge. My Apple system preferences panel thinks I am in Vancouver -- When I have "Set time zone automatically using current location" turned on.

Given people are picking up past IETF locations, I might want to turn automatic off for the week to avoid network jet-lag.  :-)

Phil

@independentid
www.independentid.com
[email-masked]

On 2013-03-11, at 7:12 AM, Yaakov Stein wrote:

> From: [email-masked] [mailto:[email-masked]] On Behalf OfAndrew G. Malis
> On the other hand, speedtest.net seems to think that we're in Wichita KS this morning. When I used it yesterday, it showed us in Prague, so that's progress of a sort.
> 
> Cheers,
> Andy
>  
>

---

From: Michael Graff <[email-masked]>
Date: Mon, 11 Mar 2013 14:48:25 +0000

I think perhaps it depends on exactly what your device gets for an address, perhaps at some arbitrary subnet boundary.  In any case, I'm still in China in IETF meeting space on IETF-a.

On Mar 11, 2013, at 10:45, "Phil Hunt" <[email-masked]<mailto:[email-masked]>> wrote:

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

Y(J)S

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf OfAndrew G. Malis
Sent: 11 March, 2013 15:40
To: joel jaeggli
Cc: Ben Campbell; Derek Atkins; Michael Graff; <[email-masked]<mailto:[email-masked]>>
Subject: Re: [86attendees] The net thinks I'm in china

As I type this both Bing Maps and Google Maps place us at the Renaissance Orlando at SeaWorld, which is about 6 miles away from the Caribe. That's a lot closer than China. :-)
On the other hand, speedtest.net<http://speedtest.net/> seems to think that we're in Wichita KS this morning. When I used it yesterday, it showed us in Prague, so that's progress of a sort.
Cheers,
Andy

-derek

---

From: Scott Brim <[email-masked]>
Date: Mon, 11 Mar 2013 10:57:02 -0400

I'm on meeting room wifi, ssid eduroam.  I just got on wikipedia and was
asked for a donation in units of 100 Kč  :-D

---

From: Hermin Anggawijaya <[email-masked]>
Date: Tue, 12 Mar 2013 04:07:27 +1300

I wonder if that (incorrect geoIP) is what causes Google Play Store app to
say that the application I wanted to download/install is unavailable in the
country I'm in...this issue only started happening when I got connected to
the hotel's and/or IETF's network, since Saturday.

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 11 Mar 2013 15:12:33 +0000

Interesting.

I also tried eduroam and IETF as well as IETF.1X, and consistently got the correct location.

Y(J)S

---

From: Shishio Tsuchiya <[email-masked]>
Date: Mon, 11 Mar 2013 11:23:15 -0400

I hope IETF and conference network tests Erik draft.:-)
http://tools.ietf.org/html/draft-google-self-published-geofeeds-00

Regards,
-Shihio

---

From: Ben Campbell <[email-masked]>
Date: Tue, 12 Mar 2013 14:24:32 -0400

I'm seeing a new interesting side effect to this whole location issue

I've had more than one online service accounts locked, apparently because they decided my access from an unexpected location smelled suspicious. It had me worried for a bit, but as far as I can tell from the only one that gives me enough information to actually tell anything, the attempts were all legitimate.

I suppose accessing from several different and scattered countries within a few hours of each other would seem suspicious to anyone that thinks that geocoding by IP address actually works.

On Mar 11, 2013, at 10:48 AM, Michael Graff <[email-masked]> wrote:

> On Mar 11, 2013, at 10:45, "Phil Hunt" <[email-masked]> wrote:
>

---

From: Olafur Gudmundsson <[email-masked]>
Date: Tue, 12 Mar 2013 14:47:38 -0400

Wikipedia just asked me for donation in Kč Czech koruna, so the "net" does not agree where we are 
just that we are not in Orlando  
For the record my language preferences are Icelandic and English, the laptop is brand new thus there is nothing on my system to indicate that I have been there or have some koruna's sitting around. 

	Olafur

---

From: Randall Gellens <[email-masked]>
Date: Tue, 12 Mar 2013 12:34:19 -0700

At 2:24 PM -0400 3/12/13, Ben Campbell wrote:

>  I've had more than one online service accounts locked, apparently 
> because they decided my access from an unexpected location smelled 
> suspicious. It had me worried for a bit, but as far as I can tell 
> from the only one that gives me enough information to actually tell 
> anything, the attempts were all legitimate.
>
>  I suppose accessing from several different and scattered countries 
> within a few hours of each other would seem suspicious to anyone 
> that thinks that geocoding by IP address actually works.

Why not just tunnel all web access (at least to sites where you have 
accounts) through an ssh tunnel to your own server back home, and 
avoid the whole issue?

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
There are things that are so serious that you can only joke about them
                                                          --Heisenberg

---

From: Bob Hinden <[email-masked]>
Date: Tue, 12 Mar 2013 15:40:19 -0400

I am being shown as being in Prague as well.  This should be a reminder that using IP addresses for geo-locaton is a bad idea.  It may be a time for someone in the IETF to write a document explaining why this is a bad idea.  We have lots of operational experience in this area :-(

Bob

---

From: Dave Crocker <[email-masked]>
Date: Tue, 12 Mar 2013 15:46:48 -0400

> I am being shown as being in Prague as well.  This should be a reminder that using IP addresses for geo-locaton is a bad idea.  It may be a time for someone in the IETF to write a document explaini…

the system is probably applying a heuristic and (possibly correctly) 
guessing you'd /rather/ be in Prague.

d/

-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Derek Atkins <[email-masked]>
Date: Tue, 12 Mar 2013 12:47:27 -0700

> accounts) through an ssh tunnel to your own server back home, and 

It's harder to tunnel on my phone...

-derek

---

From: Bob Hinden <[email-masked]>
Date: Tue, 12 Mar 2013 15:51:34 -0400

Dave,

> the system is probably applying a heuristic and (possibly correctly) guessing you'd /rather/ be in Prague.

That would be true if it put me in Hawaii :-)

Bob

---

From: Mary Barnes <[email-masked]>
Date: Tue, 12 Mar 2013 15:04:49 -0500

On Tue, Mar 12, 2013 at 2:46 PM, Dave Crocker <[email-masked]> wrote:

>> I am being shown as being in Prague as well.  This should be a reminder
>> that using IP addresses for geo-locaton is a bad idea.  It may be a time
>> for someone in the IETF to write a document explaining why this is a bad
>> idea.  We have lots of operational experience in this area :-(
>>
>
>

[MB] Certainly not so in my case - it thinks I'm in Atlanta. [/MB]

---

From: Ole Jacobsen <[email-masked]>
Date: Tue, 12 Mar 2013 13:10:31 -0700 (PDT)

The NOC folks have, on numerous occasions, explained what causes this 
problem and what is being done (long term) to fix it.

Can we stop talking about it now?

Ole

Ole J. Jacobsen
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj
Skype: organdemo

---

From: Marcos Sanz <[email-masked]>
Date: Tue, 12 Mar 2013 21:15:08 +0100

> problem and what is being done (long term) to fix it.

Is that documented somewhere? I'd love to read it.

Best,
Marcos

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Mar 2013 16:27:35 -0400

On Mar 12, 2013, at 3:40 PM, Bob Hinden <[email-masked]> wrote:
> This should be a reminder that using IP addresses for geo-locaton is a bad idea.  It may be a time for someone in the IETF to write a document explaining why this is a bad idea.  We have lots of operational experience in this area :-(

While I certainly don't disagree with your point in principle, I would argue that the IETF is actually a very poor illustrative example, because we are special.   :)

---

From: Randall Gellens <[email-masked]>
Date: Tue, 12 Mar 2013 18:47:18 -0700

At 3:46 PM -0400 3/12/13, Dave Crocker wrote:

>>  I am being shown as being in Prague as well.  This should be a 
>> reminder that using IP addresses for geo-locaton is a bad idea. 
>> It may be a time for someone in the IETF to write a document 
>> explaining why this is a bad idea.  We have lots of operational 
>> experience in this area :-(
>
>
>  the system is probably applying a heuristic and (possibly 
> correctly) guessing you'd /rather/ be in Prague.

Very cool.

I need to try it and see what it says.  (Probably Brisbane.)

-------------- Randomly selected tag: ---------------
The whole problem with the world is that fools and fanatics are always
so certain of themselves, but wiser people so full of doubts.
                                                    --Bertrand Russell

---

From: Michael Richardson <[email-masked]>
Date: Wed, 13 Mar 2013 14:04:51 -0400

On Mar 12, 2013, at 3:40 PM, Bob Hinden <[email-masked]> wrote:
> This should be a reminder that using IP addresses for geo-locaton is a
> bad idea.  It may be a time for someone in the IETF to write a
> document explaining why this is a bad idea.  We have lots of
> operational experience in this area :-( 

BTW: Neal Stephenson's REAMDE novel uses geo-location of IP addresses as
     a minor McGuffin.  It seems to also ignore that, from what I
     understand many parts of China are multiply NAT'ed.

-- 
Michael Richardson
-on the road-