Subject: [86attendees] Recommended: Habibi USA

From: Dean Willis <[email-masked]>
Date: Mon, 11 Mar 2013 19:54:36 -0500

Totally not-chain authentic Lebanese with excellent service. From $20.
About 3 miles north.

Very tasty so far.

---

From: Dan Weber <[email-masked]>
Date: Mon, 11 Mar 2013 19:29:58 -0600

Confirmed delicious.
On Mar 11, 2013 8:54 PM, "Dean Willis" <[email-masked]> wrote:

> _______________________________________________
> 86attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/86attendees
>
>

---

From: Steve Donovan <[email-masked]>
Date: Tue, 12 Mar 2013 16:31:04 -0400

+1

Here's the address: 8607 Palm Pkwy, Orlando, FL 32836

On Mar 11, 2013, at 9:29 PM, Dan Weber wrote:

> Totally not-chain authentic Lebanese with excellent service. From $20. About 3 miles north.
> 
> Very tasty so far.
> 
>