Subject: [87attendees] ief-nat64 network experiences?

From: Ted Lemon <[email-masked]>
Date: Thu, 1 Aug 2013 13:50:37 +0000

I'm curious to know if anyone tried the ietf-nat64 network, and what they thought of it.

My goal in asking the rest of the IESG and the NOC to agree to set up this network was essentially to make it possible for us to eat our own dogfood.   Some IETFers are able to do everything they need to do on the v6only network, but for most of us there are too many services we routinely use that are not available that way.

By setting up a (hopefully) production-quality nat64 network with a carrier-grade switch and a carrier-grade DNS64 server, I was hoping that we could provide a way to close that gap a bit, without forcing people to use a dual-stack environment (the main IETF network).

So I'm curious to hear how that went.  Did you try the nat64 network?   How did it work for you?   Were you able to remain on it for the whole IETF, or did you find that there were services you had to have that did not work?

I'm not sure whether to encourage you to reply privately rather than to the attendees list, just in case there are lots of responses, so I will leave it to your judgment.   If you see a dozen responses on the list, that's probably enough, but I think a dozen would be nice so that people can see that other people tried it and what their experiences were.   I will try to summarize the responses I get that didn't go to the list, as well as the ones that did.

Oh, my results?   I was on the nat64 network the whole week, whenever I was not in my hotel room, where that ssid is not available.   I almost never noticed that I was on the network; here are the issues I ran into:

- ssh doesn't do happy eyeballs, and it tries IPv4 first,
  so that didn't go so well.
- OpenVPN requires you to specify a transport, and it took
  me a while to figure this out, so I didn't have my VPN
  running until today.
- The VoIP client I use on the Mac, Blink, got back a AAAA
  record and used the first four bytes of it as an IP
  address, which was interesting.

As far as I can remember, that's it.   So for me at least it was a success—this is the first IETF where I've gone IPv6 native for the majority of the week.

Thank you for your participation!

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 1 Aug 2013 17:51:54 -0500

Hi, Ted,

I am now using a personal netbook running Win7 starter for almost all of my
IETF work, so this was the first time I dorked around with some flavor of
ipv6 at IETF week.

The only site I had problems with on IETF-nat64 was Google drive. I didn't
use hundreds of applications, but everything else I did worked.
Unfortunately, I was flat-out all week, using Google Docs for all my
note-taking, and had to switch back to keep going, so I don't know what
caused the problem I had - but I'll check more closely in Vancouver.

Thank you for putting this in place.

Spencer

On Thursday, August 1, 2013, Ted Lemon wrote:

> My goal in asking the rest of the IESG and the NOC to agree to set up this
> network was essentially to make it possible for us to eat our own dogfood.
>   Some IETFers are able to do everything they need to do on the v6only
> network, but for most of us there are too many services we routinely use
> that are not available that way.
>
> By setting up a (hopefully) production-quality nat64 network with a
> carrier-grade switch and a carrier-grade DNS64 server, I was hoping that we
> could provide a way to close that gap a bit, without forcing people to use
> a dual-stack environment (the main IETF network).
>
> So I'm curious to hear how that went.  Did you try the nat64 network?
> How did it work for you?   Were you able to remain on it for the whole
> IETF, or did you find that there were services you had to have that did not
> work?
>
> I'm not sure whether to encourage you to reply privately rather than to
> the attendees list, just in case there are lots of responses, so I will
> leave it to your judgment.   If you see a dozen responses on the list,
> that's probably enough, but I think a dozen would be nice so that people
> can see that other people tried it and what their experiences were.   I
> will try to summarize the responses I get that didn't go to the list, as
> well as the ones that did.
>
> Oh, my results?   I was on the nat64 network the whole week, whenever I
> was not in my hotel room, where that ssid is not available.   I almost
> never noticed that I was on the network; here are the issues I ran into:
>
> As far as I can remember, that's it.   So for me at least it was a
> success—this is the first IETF where I've gone IPv6 native for the majority
> of the week.
>
> _______________________________________________
> 87attendees mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/87attendees
>

---

From: Ralph Droms <[email-masked]>
Date: Fri, 2 Aug 2013 10:08:13 +0200

Trying it yesterday and today on an iPhone 5, iOS 6.1.4...

Most everything seems to work ok, with good performance.

As we discussed yesterday, ietf-nat64 seems to break iMessage.

I think it's breaking my secure access to e-mail (both Cisco remote security access and gmail access).  I'll continue to investigate.

Thanks for running this test and I encourage others to join; the results, I think, will be important.

- Ralph

---

From: Philip Matthews <[email-masked]>
Date: Fri, 2 Aug 2013 10:27:49 +0200

I used this briefly on Monday.  However, I discovered that it seemed to break my access to my corp email, so I had to switch back.

However, I used the NAT64 network at previous IETFs (which was provided by Viagenie) and it worked well.

- Philip

---

From: "Olle E. Johansson" <[email-masked]>
Date: Fri, 2 Aug 2013 10:44:30 +0200

> However, I used the NAT64 network at previous IETFs (which was provided by Viagenie) and it worked well.

Using it on my laptop with os/x doesn't generate any issues.

On my iphone the mail app claims I'm not connected to the internet, whatsapp is repeatedly trying to connect, but many apps just works.

/O

---

From: "Olle E. Johansson" <[email-masked]>
Date: Fri, 2 Aug 2013 10:51:07 +0200

> On my iphone the mail app claims I'm not connected to the internet, whatsapp is repeatedly trying to connect, but many apps just works.

The App Store app claims I'm not connected to Wifi or a mobile network, even though I'm having a full WiFi icon in the top of the screen. Tss tss.

/O

---

From: Arturo Servin <[email-masked]>
Date: Fri, 02 Aug 2013 10:51:27 +0200

My office services (email, jabber) worked without problem, except VPN
(it is only v4).

	Dropbox dead
	Skype dead
	Viber dead

	Evernote worked without problem
	iTunes store worked
	Netflix told me that it was not supported here (not sure where they
think I am)
	
	In another conference they used 464xlat and the user experience was
much better.

Regards,
as

On 8/2/13 10:27 AM, Philip Matthews wrote:
> [email-masked]

---

From: Arturo Servin <[email-masked]>
Date: Fri, 02 Aug 2013 11:02:48 +0200

Sorry I didn't mentioned. OSX 10.8.4

Regards,
as

---

From: Dominik Bay <[email-masked]>
Date: Fri, 2 Aug 2013 11:12:52 +0200

> The App Store app claims I'm not connected to Wifi or a mobile network, even though I'm having a full WiFi icon in the top of the screen. Tss tss.

My iOS7 device works fully with the NAT64 WiFi except Facebook App.
Messenger works though.

-dominik

---

From: Simon Perreault <[email-masked]>
Date: Fri, 02 Aug 2013 11:24:33 +0200

> However, I used the NAT64 network at previous IETFs (which was provided by Viagenie) and it worked well.

I'm pretty sure they forgot to say the magic words... ;)

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Ted Lemon <[email-masked]>
Date: Fri, 2 Aug 2013 09:41:17 +0000

> The App Store app claims I'm not connected to Wifi or a mobile network, even though I'm having a full WiFi icon in the top of the screen. Tss tss.

Interesting.   This is working for me on Mountain Lion.   Is it when you browse the store, or when you download something from it?   Both work for me.

---

From: Chris Elliott <[email-masked]>
Date: Fri, 2 Aug 2013 11:55:40 +0200

On Fri, Aug 2, 2013 at 11:41 AM, Ted Lemon <[email-masked]> wrote:

> > The App Store app claims I'm not connected to Wifi or a mobile network,
> even though I'm having a full WiFi icon in the top of the screen. Tss tss.
>
> Interesting.   This is working for me on Mountain Lion.   Is it when you
> browse the store, or when you download something from it?   Both work for
> me.
>

I'm on 10.8.4 and browsing the store worked, as did finding updates. I only
had app updates, but when I tried to download, the download paused itself
right a way, and the retry button was greyed out. Changing networks and
killing (force quit) and restarting the App Store application didn't help.
A reboot did.

Chris.

-- 
Chris Elliott
[email-masked]

---

From: "Olle E. Johansson" <[email-masked]>
Date: Fri, 2 Aug 2013 12:25:58 +0200

> Interesting.   This is working for me on Mountain Lion.   Is it when you browse the store, or when you download something from it?   Both work for me.

App Store on the Iphone, not on the laptop. Sorry for the confusion.

/O

---

From: Dan York <[email-masked]>
Date: Fri, 2 Aug 2013 11:00:45 +0000

Ted,

On 8/1/13 3:50 PM, "Ted Lemon" <[email-masked]> wrote:

>My goal in asking the rest of the IESG and the NOC to agree to set up
>this network was essentially to make it possible for us to eat our own
>dogfood.   Some IETFers are able to do everything they need to do on the
>v6only network, but for most of us there are too many services we
>routinely use that are not available that way.

And thank you all for having the NAT64 network set up. It was very useful
to see what worked and didn't work in a NAT64 environment.  I hope that we
will continue the experiment in Vancouver and future IETF events.

>Oh, my results?  

My results weren't as good as yours.  I had no problem whatsoever
accessing any websites - that all seemed to work fine. Evernote worked.
However:

- My connection to my work email server didn't work.
- DropBox was unable to connect (I noticed Arturo had this problem, too)
- Skype didn't connect
- Jabber was mixed:
    * my Gmail worked fine
    * my jabber.org account did NOT work
    * my jabber.isoc.org account did NOT work

Given these challenges I had to flip back to the other networks, although
admittedly it did provide some nice time free of interruptions... (but I
couldn't join WG Jabber chats via my normal jabber account).

I'd be curious to try it again next time.

Thanks again for the experiment,
Dan

---

From: "GangChen" <[email-masked]>
Date: Fri, 2 Aug 2013 19:37:57 +0800

I used the ietf-nat64 both on my laptop and iphone.
I would like to say I got better user experience on the laptop, because most
office tools work well.
Some apps on iphone works. But some instant message apps are broken.
Facetime is broken as well.
That may be inconvenience for "communication". I also agree 464xlat would
bring better experiences.

gang

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ralph Droms
Sent: Friday, August 02, 2013 4:08 PM
To: Ted Lemon
Cc: <[email-masked]> attendees
Subject: Re: [87attendees] ief-nat64 network experiences?

I think it's breaking my secure access to e-mail (both Cisco remote security
access and gmail access).  I'll continue to investigate.

Thanks for running this test and I encourage others to join; the results, I
think, will be important.

- Ralph

---

From: Michael Richardson <[email-masked]>
Date: Fri, 02 Aug 2013 09:58:22 -0400

> so that didn't go so well.

While ssh could certainly make two DNS requests and two connect(2)s, it can
not cache the result anywhere.  The same would be true for nearly every
single cmd-line tool... so this begs a system-wide (but per-user!)
happy-eyeballs cache.

Such a daemon would also be a good repository for lots of MIF-like things.

    > address, which was interesting.

Humourous.
So you connected to 0.96.x.y a lot?  (assuming you were getting 0064: back)

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Ted Lemon <[email-masked]>
Date: Fri, 2 Aug 2013 14:20:20 +0000

> 	In another conference they used 464xlat and the user experience was

This is not surprising, but wasn't really the goal.   We have an IPv4 network, and a 464xlat network would look pretty much like it, except with non-global addresses and no IPv6.   It's certainly true that setting up a nat64 network at an IETF, where we have a big block of IPv4 addresses to use, is completely artificial, but the goal is threefold:

- Reveal bugs in commonly-used applications as they operate
  on IPv6 rather than dual-stack
- Reveal protocols that can't work over a NAT64 of which we
  weren't previously aware
- Give people a taste of life on the native IPv6 network
  that we might see in our homes next year, or sometime
  thereafter.

So while I really like the things that 464xlat allows to work, and think it's a useful migration tool, I greatly appreciate that you tried out the nat64 network, and hope you will continue to do so if we decide to continue providing it in the future.   My hope is that more people at future IETFs will have the experience I had: that I didn't have to give up and switch back in order to get work done.

BTW, the difference between this nat64 network and previous networks is that we used a translator with sufficient capacity to handle the entire traffic of the IETF.   The load that we had this time probably would have been small enough that a small linux box would have done just fine, but I'm really hoping we can make this a standard service and lure more and more people away from the IPv4 network and get them to eat the dogfood we are making here.