Subject: Re: [88attendees] Get your bitcoins with your coffee

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 4 Nov 2013 16:08:06 -0800

On Tue, Oct 29, 2013 at 01:16:55PM -0400,
 John R Levine <[email-masked]> wrote 
 a message of 16 lines which said:

> I see in the paper that the Waves coffee shop in Vancouver will be
> installing a bitcoin ATM this week, claimed to be the first in the
> world.
> 
> It's at 900 Howe, corner of Smithe street, a short walk from the Hyatt.

Did any IETFer test it yet? What about a bitcoin BoF? :-)

---

From: "Wiley, Glen" <[email-masked]>
Date: Tue, 5 Nov 2013 00:41:16 +0000

I am planning on buying some BTC if I can make it there this week.  I'D
also enjoy a BTC BoF if someone wants to pull one together.
-- 
Glen Wiley
KK4SFV

Sr. Engineer
The Hive, Verisign, Inc.

On 11/4/13 7:08 PM, "Stephane Bortzmeyer" <[email-masked]> wrote:

>_______________________________________________
>88attendees mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/88attendees

---

From: Adam Roach <[email-masked]>
Date: Mon, 04 Nov 2013 16:49:16 -0800

> also enjoy a BTC BoF if someone wants to pull one together.

Yep; maybe you could talk about this recently described exploit:

http://hackingdistributed.com/2013/11/04/bitcoin-is-broken/

/a

---

From: "Wiley, Glen" <[email-masked]>
Date: Tue, 5 Nov 2013 00:53:11 +0000

It would be a fun chatŠthere is much silliness in that article (mixed in
with some sensible material).  Too bad the "research paper" renders a
permission denied.
-- 
Glen Wiley
KK4SFV

Sr. Engineer
The Hive, Verisign, Inc.

---

From: John R Levine <[email-masked]>
Date: Mon, 4 Nov 2013 17:52:20 -0800 (PST)

> Did any IETFer test it yet? What about a bitcoin BoF? :-)

I got some bitcoins and coffee this afternoon.  Now I just have to figure
out what to do with the little piece of paper with a QR code it gave me.

If you have a facebook account, I posted some pictures.

R's,
John

---

From: Jon Hudson <[email-masked]>
Date: Mon, 4 Nov 2013 18:00:31 -0800

And then there is the DNS connection....
What is namecoin / Dot-BIT ?

Namecoin is a distributed domain registration system based on the bitcoin concept.
It is part of the Dot-BIT project.

It allows you to :
* register domains (.bit currently)
* be the only person to be able to modify it (no possible external control)

It is inspired by the bitdns discussion and recent failures of the DNS.
* This is a new blockchain, separate from the main Bitcoin chain
* Name/value pairs are stored in the blockchain attached to coins
* Names are acquired through new transaction types - new, first-update and update
* Names expire after 12000 blocks unless renewed with an update
* No two unexpired names can be identical
* Block validation is extended to reject transactions that do not follow the above rules
* The code is here: https://github.com/vinced/namecoin

---

From: Keith Mitchell <[email-masked]>
Date: Mon, 04 Nov 2013 22:46:44 -0500

> And then there is the DNS connection....

Hmm, you could probably come up with a scheme for doing IP address
allocation based on this kind of stuff, too...

Keith

> Namecoin <http://dot-bit.org/Namecoin> is a distributed domain
> registration system based on the bitcoin concept.
> It is part of the Dot-BIT project <http://dot-bit.org/>.
> 
> *It allows you to :*

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 4 Nov 2013 22:51:15 -0800

On Mon, Nov 04, 2013 at 04:49:16PM -0800,
 Adam Roach <[email-masked]> wrote 

> http://hackingdistributed.com/2013/11/04/bitcoin-is-broken/

Like many (most?) papers in computer and network security, a real
attack and an overinflated title (no, Bitcoin is not broken, the title
does not match the content of the article).

See <https://bitcointalk.org/index.php?topic=324413.0> for a balanced
view.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 4 Nov 2013 22:48:31 -0800

On Mon, Nov 04, 2013 at 05:52:20PM -0800,
 John R Levine <[email-masked]> wrote 

> out what to do with the little piece of paper with a QR code it gave me.

Here is what I did. I do not claim to be a Bitcoin expert so it is
probably not the best procedure and it may even have some flaw, but it
apparently worked for me:

0) Authentify myself to the Robocoin (the ATM), with fingerprints
1) Create a wallet on the Robocoin. KEEP THE PAPER but do
not allow anyone to see it (it carries the private key of the wallet).
2) Buy bitcoins by feeding the machine with a 20 $ note. You get a
recipt (no need to keep it)
3) Install Electrum <http://electrum.org/> on your computer
4) Import the wallet by typing the private key (menu Import -> Private
keys)
5) Your money arrives in the wallet
6) Spend it. I gave it to EFF <https://supporters.eff.org/donate> by
clicking on Send then typing the bitcoin address that EFF indicates

---

From: Ross Finlayson <[email-masked]>
Date: Thu, 7 Nov 2013 12:18:05 -0800

> I see in the paper that the Waves coffee shop in Vancouver will be installing a bitcoin ATM this week, claimed to be the first in the world.
> 

Holy Moly!  I just saw someone feed $7000 (Canadian) into this ATM (to buy bitcoin).

(In a way, this makes sense.  Because the supply of Bitcoin is limited, it tends to be a deflationary currency.  A 'buy and hold' strategy may make sense, if you're a speculator with enough money to risk...)

	Ross.

---

From: "Wiley, Glen" <[email-masked]>
Date: Thu, 7 Nov 2013 20:20:40 +0000

A few of us just used the ATM - well designed, nifty experience.  If you
have any interest in BTC at all you really need to stop by and give it a
shot.

A little painful not that BTC has spiked to $300 USD
-- 
Glen Wiley
KK4SFV

Sr. Engineer
The Hive, Verisign, Inc.

On 11/7/13 3:18 PM, "Ross Finlayson" <[email-masked]> wrote:

>>installing a bitcoin ATM this week, claimed to be the first in the world.
>> 
>(In a way, this makes sense.  Because the supply of Bitcoin is limited,
>it tends to be a deflationary currency.  A 'buy and hold' strategy may
>make sense, if you're a speculator with enough money to risk...)
>
>	Ross.
>

---

From: Ondřej Surý <[email-masked]>
Date: Thu, 7 Nov 2013 13:15:34 -0800

Does it?

http://arxiv.org/pdf/1311.0243.pdf

O.

--
 Ondřej Surý -- Chief Science Officer
 -------------------------------------------
 CZ.NIC, z.s.p.o.    --    Laboratoře CZ.NIC
 Americka 23, 120 00 Praha 2, Czech Republic
 mailto:[email-masked]    http://nic.cz/
 tel:+420.222745110       fax:+420.222745112
 -------------------------------------------

---

From: Ondřej Surý <[email-masked]>
Date: Thu, 7 Nov 2013 13:17:53 -0800

And use this for v3 version:

http://arxiv.org/pdf/1311.0243v3.pdf

It works for me at this moment from IETF network just fine.

O.

---

From: "Wiley, Glen" <[email-masked]>
Date: Thu, 7 Nov 2013 21:17:33 +0000

Thanks for the repost - looks like it works now.

-- 
Glen Wiley
KK4SFV

Sr. Engineer
The Hive, Verisign, Inc.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 7 Nov 2013 13:33:33 -0800

On Thu, Nov 07, 2013 at 01:17:53PM -0800,
 Ondřej Surý <[email-masked]> wrote 

> http://arxiv.org/pdf/1311.0243v3.pdf

Also read the rebuttal:

https://freedom-to-tinker.com/blog/felten/bitcoin-isnt-so-broken-after-all/

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 7 Nov 2013 14:15:11 -0800

> installing a bitcoin ATM this week, claimed to be the first in the

Big success, probably in good part because of the many IETFers :

http://gigaom.com/2013/11/07/first-bitcoin-atm-gets-348-transactions-in-first-8-days-now-comes-the-hard-part/

---

From: John R Levine <[email-masked]>
Date: Thu, 7 Nov 2013 18:09:29 -0800 (PST)

> (In a way, this makes sense.

Not really.  He paid a commission in the range of $400.  For that much,
I'd set up an account at MtGox unless I really really REALLY didn't want
people to know where the cash went.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail.

---

From: "Wiley, Glen" <[email-masked]>
Date: Fri, 8 Nov 2013 02:52:57 +0000

Buying BTC in that volume right now (at $371 USD/BTC) sounds a little
loopy to me.
-- 
Glen Wiley
KK4SFV

Sr. Engineer
The Hive, Verisign, Inc.

---

From: joel jaeggli <[email-masked]>
Date: Thu, 7 Nov 2013 20:03:35 -0800

> people to know where the cash went.

 ~3-4kg of one of BC’s more popular cash crops.

---

From: Franck Martin <[email-masked]>
Date: Sun, 10 Nov 2013 20:20:33 +0000

http://www.vancouversun.com/100K+traded+through+Vancouver+Bitcoin+week+with+video/9145774/story.html

Printed on recycled paper!

> On Nov 7, 2013, at 20:04, "joel jaeggli" <[email-masked]> wrote:
> 
>

---

From: "Cao Zhen \(CZ\)" <[email-masked]>
Date: Mon, 11 Nov 2013 14:25:14 +0800

Will IETF consider supporting pay registration fee via bitcoin :) 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Franck Martin
> Sent: Monday, November 11, 2013 4:21 AM
> To: joel jaeggli
> Cc: Ross Finlayson; John R Levine; [email-masked]
> Subject: Re: [88attendees] Get your bitcoins with your coffee
> 
> >> Not really.  He paid a commission in the range of $400.  For that
> >> much, I'd set up an account at MtGox unless I really really REALLY
> >> didn't want people to know where the cash went.
> >