Subject: Re: [89attendees] [89all] Navigating the Hilton Metropole: An Instructional Video

From: Ted Lemon <[email-masked]>
Date: Sun, 2 Mar 2014 14:50:55 +0000

On Mar 2, 2014, at 2:03 PM, Alexa Morris <[email-masked]> wrote:
> Welcome to IETF 89! The Secretariat has prepared a short (2 minute) instructional video that we hope will help you navigate the Hilton Metropole this week. 

You guys must have had a lot of fun producing this.   :)

---

From: Tim Chown <[email-masked]>
Date: Sun, 2 Mar 2014 14:56:52 +0000

> You guys must have had a lot of fun producing this.   :)

Indeed - it’s excellent!

tim