Subject: [89attendees] so which SIM card to get? and from where?

From: =JeffH <[email-masked]>
Date: Mon, 03 Mar 2014 23:29:13 -0800

Is an EE sim card preferable to a 3 coverage-wise?

I'd like to be able to call the US and recieve calls from US at not 
ridiculous rates, and have data.

thoughts?

thanks,

=JeffH

---

From: John Bradley <[email-masked]>
Date: Tue, 4 Mar 2014 08:36:33 +0000

I have been using the same 3 sim when I come to the UK for several years now.  

The nice thing is that the minutes don't expire, and you can get per day data at 50p if you are only in town for a couple of days. 
There is a 3 iphone app that is helpful though you need to make a UK apple account to get it.   There is likely a similar android app.

I pay about 5GBP per trip for voice and data on average.

The coverage is not great but OK.    I feel that I should use a customer as a carrier in the UK but they were all much more expensive when I checked so ...  

EE has a better network with LTE but the bands are different from the US so likely significant research into the specific phone would be required to determine if there is any benefit in a specific case.

John B.

John Bradley  |  Sr. Technical Architect
Ping Identity  |   www.pingidentity.com

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
O: +1 720.306.6055   M: +1 (303) 396-9546
Email: [email-masked]

Twitter: @ve7jtb
LinkedIn.com/in/v7jtb

On Mar 4, 2014, at 7:29 AM, =JeffH <[email-masked]> wrote:

> I'd like to be able to call the US and recieve calls from US at not ridiculous rates, and have data.
> 
> thoughts?
> 
> thanks,
> 
> =JeffH
> 
> _______________________________________________
> 89attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/89attendees

---

From: [email-masked]
Date: 4 Mar 2014 23:25:23 -0000

>Is an EE sim card preferable to a 3 coverage-wise?

Generally yes.  It combines the former Orange and T-Mobile networks.  I
have great coverage with my 900/1800 phone.

>ridiculous rates, and have data.

Their Camel plan offers 30 mins of free calls to the US (good for a
month) with a £10 topup, 10p/min thereafter, 25p/min for calls to the
UK.  Calls from the US cost whatever your US carrier charges for calls
to UK mobiles, on the order of 20c/min for a cheap carrier,
considerably more for the expensive ones.

My phone doesn't do mobile data (I have wifi for that) but I see they
have 100MB for £3 or 500MB for £7.50 or 1GB for £12.

R's,
John