Subject: [89attendees] laundry service

From: Ralph Droms <[email-masked]>
Date: Mon, 3 Mar 2014 10:38:42 +0000

Can anyone recommend a launder-sort-fold "by-the-kg" laundry service nearby?

- Ralph

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 3 Mar 2014 10:40:18 +0000

> Can anyone recommend a launder-sort-fold "by-the-kg" laundry service nearby?

Don’t know about “nearby”, but if a 10-minute bus ride isn’t out of the question:

http://porchesterlaunderette.moonfruit.com

Grüße, Carsten

---

From: David Misell <[email-masked]>
Date: Mon, 03 Mar 2014 10:45:11 +0000

bell st next to the brazen head, self service, turn right of the edgware rd at the green man pub walk up on the right

Kind Regards,
Dave

David S. Misell MSc CISSP MBCS
+44 (0)7710 380044
misell.dave (Skype)

> On 3 Mar 2014, at 10:38, Ralph Droms <[email-masked]> wrote:
> 
> _______________________________________________
> 89attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/89attendees

---

From: David Misell <[email-masked]>
Date: Mon, 03 Mar 2014 10:46:55 +0000

there is a dry cleaners on the corner of edgware road and old marylebone rd, look for the halifax it's next door, most will at least wash shrirts there are others

Kind Regards,
Dave

---

From: David Misell <[email-masked]>
Date: Mon, 03 Mar 2014 10:59:10 +0000

Mummum

Kind Regards,
Dave

> On 3 Mar 2014, at 10:46, David Misell <[email-masked]> wrote:
>

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 03 Mar 2014 11:02:09 +0000

I noticed that there is a 'back street' laundry/dry cleaners even closer 
at the junction of Sale Place (1st left off Praed St) and Star St.  
Didn't inspect exact capabilities or quality but it's probably about 
100m from back door of Hilton.

/Elwyn

---

From: Michael Richardson <[email-masked]>
Date: Mon, 03 Mar 2014 06:11:20 -0500

David Misell <[email-masked]> wrote:
    > bell st next to the brazen head, self service, turn right of the
    > edgware rd at the green man pub walk up on the right

I need it tomorrow too.
I think it is here:

http://goo.gl/maps/4GcUW

did I get it right?

---

From: David Misell <[email-masked]>
Date: Mon, 03 Mar 2014 11:14:50 +0000

looks good
there are many others, but a pub that does excellent thia make self service bearable
Kind Regards,
Dave

> On 3 Mar 2014, at 11:11, Michael Richardson <[email-masked]> wrote:
> 
>

---

From: Ralph Droms <[email-masked]>
Date: Mon, 3 Mar 2014 16:12:21 +0000

I dropped my laundry off at Edgware Road Dry Cleaner.  They have the launder-sort-fold service I was looking for.  £20 for 5 days of clothes.

It's right across Edgware Road from the hotel, on Chapel St. across from the M&S store entrance.

I'll let you know what the clothes look like when I get them back tomorrow...

- Ralph

---

From: Michael Richardson <[email-masked]>
Date: Mon, 03 Mar 2014 11:24:51 -0500

> I'll let you know what the clothes look like when I get them back

Was same-day service available?

---

From: Ralph Droms <[email-masked]>
Date: Mon, 3 Mar 2014 16:40:55 +0000

> Was same-day service available?

I'm pretty sure, but I couldn't use it.  I dropped off this afternoon about 3, and I have other commitments until after the shop closes today.  

Limited info and phone number: http://www.edgwareroad-drycleaner.co.uk

- Ralph

---

From: Randall Gellens <[email-masked]>
Date: Tue, 4 Mar 2014 02:06:32 -0800

The web page says 10% off when order exceeds 15 pounds, so does the 
20 pounds you were quoted include the discount?

About how many clothes was the "5 days" for 20 pounds?

The web At 4:40 PM +0000 3/3/14, Ralph Droms wrote:

>  I'm pretty sure, but I couldn't use it.  I dropped off this 
> afternoon about 3, and I have other commitments until after the 
> shop closes today. 
>

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
I have made it a rule, whenever in my power, to avoid becoming the
draughtsman of papers to be reviewed by a public body.
              --Benjamin Franklin

---

From: David Misell <[email-masked]>
Date: Tue, 04 Mar 2014 10:21:05 +0000

The best service wash in the area, carry on past the windsor castle in crawford st on the rhs, weekdays til 8pm

Kind Regards,

Dave

David S. Misell MBCS CISSP
Skype misell.dave
+44(0)7710380044
0207 7239135

> On 4 Mar 2014, at 10:06, Randall Gellens <[email-masked]> wrote:
> 
> The web page says 10% off when order exceeds 15 pounds, so does the 20 pounds you were quoted include the discount?
>

---

From: Ralph Droms <[email-masked]>
Date: Tue, 4 Mar 2014 10:25:52 +0000

> The web page says 10% off when order exceeds 15 pounds, so does the 20 pounds you were quoted include the discount?

I didn't notice the discount offer until after I prepaid for the laundry, so I can't say.

> About how many clothes was the "5 days" for 20 pounds?

A big gym bag stuffed full, maybe 1/2-2/3 of a standard carryon.  The clothes weren't formally weighed - the person I talked to picked up the bag, looked thoughtful for a second and said "£20".  Had I been so inclined, I might have been able to haggle the price...

- Ralph

---

From: Kaoru Maeda <[email-masked]>
Date: Tue, 4 Mar 2014 23:52:15 +0000

Today I tried that laundry service http://www.edgwareroad-drycleaner.co.uk

It costed me 15 pounds for my 4-days clothes:
- 4 t-shirts
- 4 underpants
- 4 cotton shirts
- 4 pairs of socks
- 3 handkerchieves

I dropped my laundry at 7:30am (as soon as the shop opens).
They said I could pick up my laundry in the afternoon.  I did at 18:45.
No credit cards accepted.  Cash only.

I think the quality is not bad.  
Note: the shirts were not ironed.  (I did myself)

Regards,

-- 
Kaoru Maeda <[email-masked]>
Lepidum Co., Ltd.