Subject: [89attendees] laundry

From: [email-masked]
Date: 3 Mar 2014 10:56:45 -0000

Walk out of the hotel onto Praed St, walk 1/2 block west to the Post
Office, cross and walk two short blocks down Sale Pl, and you'll
find Central Laundry on the left at the corner of  Star Street.

It has coin washers, appears to have staff who'll do your laundry for
you at extra cost.

R's,
John

---

From: Randall Gellens <[email-masked]>
Date: Tue, 4 Mar 2014 02:19:59 -0800

It appears to be called "Central Wash" per Google Maps:

https://www.google.com/maps/@51.517966,-0.169497,3a,75y,287.01h,97.08t/data=!3m4!1e1!3m2!1shRSUVNKWknjOr9n7dfwKPA!2e0

I was hoping to find a web page that might confirm laundry service 
and have prices, but I can't find one.

At 10:56 AM +0000 3/3/14, <[email-masked]> wrote:

>  _______________________________________________
>  89attendees mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/89attendees

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
The attention span of a computer is only as long as its electrical cord
or battery life.