Subject: [89attendees] found a great dinner at the Great Queen Street

From: Bill Mills <[email-masked]>
Date: Tue, 4 Mar 2014 16:35:19 -0800 (PST)

I had a great late dinner (after passing out in the afternoon with jet-lag-itis) at the Great Queen street.   It's a short walk form the Tottenham Court station, and the 98 bus goes from right near the hotel to Tottenham.

Amazing lamb shanks with barley.  Mostly a wine rather than beer type place.

-bill

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 5 Mar 2014 12:52:18 +0000

The nearest underground is actually Holborn..

Note also that Tottenham and Tottenham Court Road are two completely different places.

Keith

________________________________
From: 89attendees [mailto:[email-masked]] On Behalf Of Bill Mills
Sent: 05 March 2014 00:35
To: Attendees
Subject: [89attendees] found a great dinner at the Great Queen Street

-bill