Subject: [90attendees] Canada specific info from US State Dept.

From: Sandra Murphy <[email-masked]>
Date: Tue, 15 Jul 2014 15:14:23 -0400

At IETF89 in London, I related an incident on the 89attendees list involving confiscation of a penknife at the London Eye.  Someone very helpfully posted a pointer to the US State Dept web site for the UK, something they do for all nations to list special considerations that US citizens should know.

I thought that sounded like a great idea, so I looked it up for this trip as well.  Yes, Canada is awfully close to US in things besides geography, but that's not the same as exactly the same.

Here's the URL: http://travel.state.gov/content/passports/english/country/canada.html.

As teasers, here are a few things I spotted that I did not know:

You can be fined in Toronto for leaving your car unlocked or having items in view. (A reaction to the prevalence of smash-and-grab thefts.)

You must declare ANY firearms you bring into the country and can get into trouble (confiscation, arrest) if they find any that you forgot to declare.  There are also forms to fill out if you want to borrow a firearm while in the country.  Not that I would do either, but a mark of how seriously they consider this.  (For all I know, US laws are similar.) 

There are three categories of firearms and "some knives" are included in the "restricted firearms" category.  (You can believe that caught my eye!  No word on that page on what "some" means.)

Under "pornography", it says computers and cell phones are subject to search at the border.

DUI is a criminal offense.  Any prior conviction "no matter how old or how minor the infraction" means you are excluded from entry, with a long latency exception process (called "approval for rehabilitation", to give you an idea of how they regard this).

This is info specifically intended for US citizens and their cultural expectations.  It should be useful for all attendees but may not mention something that other nation's citizens would not expect.  Other nations may provide similar info for their citizens.

--Sandy

---

From: Paul Wouters <[email-masked]>
Date: Tue, 15 Jul 2014 15:18:42 -0400

> This is info specifically intended for US citizens and their cultural expectations.  It should be useful for all attendees but may not mention something
> that other nation's citizens would not expect.  Other nations may provide similar info for their citizens.

And don't take back things into the US that are legal in Canada, but illegal in the US. Such as some chocolate:

http://www.cbc.ca/thisisthat/blog/2014/06/02/canadian-kinder-surprise-smuggling-ring-broken-up-by-us-officials/

Paul

---

From: JF Tremblay <[email-masked]>
Date: Tue, 15 Jul 2014 15:33:58 -0400

The same is true for cuban cigars, cuban rum and absinthe. Enjoy them in Canada, but it’s illegal to bring them back to the US. 

In the same line, you can’t bring a baby walker or a second-hand mattress in Canada… (if that fits in your luggage). 
http://correresmidestino.com/5-things-banned-in-canada/

/JF

On Jul 15, 2014, at 3:18 PM, Paul Wouters <[email-masked]> wrote:

> _______________________________________________
> 90attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/90attendees
>

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Tue, 15 Jul 2014 16:37:57 -0300

I always pack a small(ish) swiss army knife in my checked bag... I hope
it won't land me in jail :-)

On 7/15/14, 4:33 PM, JF Tremblay wrote:
> The same is true for cuban cigars, cuban rum and absinthe. Enjoy them
> in Canada, but it's illegal to bring them back to the US. 
>
> In the same line, you can't bring a baby walker or a second-hand
> mattress in Canada... (if that fits in your luggage). 
> On Jul 15, 2014, at 3:18 PM, Paul Wouters <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>>> Here's the URL:
>>> http://travel.state.gov/content/passports/english/country/canada.html.
>>
>>> This is info specifically intended for US citizens and their
>>> cultural expectations.  It should be useful for all attendees but
>>> may not mention something
>> And don't take back things into the US that are legal in Canada, but
>> illegal in the US. Such as some chocolate:
>>

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 15 Jul 2014 15:54:01 -0400

On Jul 15, 2014, at 3:37 PM, "Carlos M. Martinez" <[email-masked]> wrote:

> I always pack a small(ish) swiss army knife in my checked bag... I hope it won't land me in jail :-)

It could have in the UK.  Or it could just have been confiscated at the London Eye.

--Sandy

---

From: [email-masked]
Date: 15 Jul 2014 20:03:31 -0000

>it won't land me in jail :-)

They don't care.  I can't say the same about poorly trained TSA
officers at US checkpoints.  The TSA clearly says they're OK, but some
of the officers don't know that.  Or maybe they do, and they want a
free jackknife for their kid.

---

From: "D. Hugh Redelmeier" <[email-masked]>
Date: Tue, 15 Jul 2014 16:08:10 -0400 (EDT)

| From: Carlos M. Martinez <[email-masked]>

| I always pack a small(ish) swiss army knife in my checked bag... I hope
| it won't land me in jail :-)

No.

<http://www.cbsa-asfc.gc.ca/publications/pub/bsf5044-eng.html>

But beware: my Swiss army knife tries to sneak onto planes in my
pocket.  One time I had to mail it home from an IETF meeting because I
caught it after I had checked my bags.

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Tue, 15 Jul 2014 17:17:21 -0300

I pack it on an external pocket of my checked bag, which I then wrap at
the airport. When I arrive at destination, I scratch the wrap a little
bit, get the sak out, and then I proceed to cut the rest of the wrap.

Silly, but the first time I did it I almost felt like Houdini.

:D

-Carlos

---

From: Linus Nordberg <[email-masked]>
Date: Wed, 16 Jul 2014 15:58:32 +0200

Sandra Murphy <[email-masked]> wrote
Tue, 15 Jul 2014 15:14:23 -0400:

| Under "pornography", it says computers and cell phones are subject to search at the border.

Do you have any more details on that one?

I'm assuming Canada doesn't have anything like the UK law on giving up
your pass phrases ("S.53").

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Jul 2014 10:08:10 -0400

> Do you have any more details on that one?

This is true in general.   The U.S. has successfully claimed the right to search your laptop at the border as well, and it's not realistic to think that you are safe at any border crossing where the government hasn't explicitly said you are (and maybe not even then--sounds fishy!).   So put your sensitive data in an encrypted box online, download it when you get there, and memorize the passphrase that encrypts it so that it's not on your computer when you travel.   Problem solved.

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 16 Jul 2014 10:09:40 -0400

> your pass phrases ("S.53").

I would not assume anything of the sort.  During the period when you
are entering Canada, you don't actually have many protections.  The
status of such passwords is at best unknown.  Canada has certain laws
about pornographic material that are quite strong, and a border agent
might insist that you provide a password or have your laptop impounded
if you are under suspicion.

In general, when crossing an international border, you should assume
that any contents of your laptop are open to scrutiny.  That said,
I've never had my laptop looked at by the Canadian border people, and
for about a year I crossed every other week.  

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 16 Jul 2014 15:37:52 +0000

For UK attendees see https://www.gov.uk/foreign-travel-advice/canada I did not notice anything very unusual.

IETF'ers should note "Take all rubbish with you, and treat any food items with great care to avoid attracting animals to your site" so be careful with the cookie crumbs.

Andy

> -----Original Message-----
> From: 90attendees [mailto:[email-masked]] On Behalf Of
> Sandra Murphy
> Sent: 15 July 2014 20:14
> To: attendees
> Cc: Sandra Murphy
> Subject: [90attendees] Canada specific info from US State Dept.
> 
> At IETF89 in London, I related an incident on the 89attendees list
> involving confiscation of a penknife at the London Eye.  Someone very
> helpfully posted a pointer to the US State Dept web site for the UK,
> something they do for all nations to list special considerations that
> US citizens should know.
> 
> I thought that sounded like a great idea, so I looked it up for this
> trip as well.  Yes, Canada is awfully close to US in things besides
> geography, but that's not the same as exactly the same.
> 
> Here's the URL:
> You can be fined in Toronto for leaving your car unlocked or having
> items in view. (A reaction to the prevalence of smash-and-grab thefts.)
> 
> You must declare ANY firearms you bring into the country and can get
> into trouble (confiscation, arrest) if they find any that you forgot to
> declare.  There are also forms to fill out if you want to borrow a
> firearm while in the country.  Not that I would do either, but a mark
> of how seriously they consider this.  (For all I know, US laws are
> similar.)
> 
> There are three categories of firearms and "some knives" are included
> in the "restricted firearms" category.  (You can believe that caught my
> eye!  No word on that page on what "some" means.)
> 
> DUI is a criminal offense.  Any prior conviction "no matter how old or
> how minor the infraction" means you are excluded from entry, with a
> long latency exception process (called "approval for rehabilitation",
> to give you an idea of how they regard this).
> 
> This is info specifically intended for US citizens and their cultural
> expectations.  It should be useful for all attendees but may not
> mention something that other nation's citizens would not expect.  Other
> nations may provide similar info for their citizens.
> 
> --Sandy
> 
>

---

From: Colin Doyle <[email-masked]>
Date: Wed, 16 Jul 2014 11:53:50 -0400

http://goo.gl/oNBkZl

:)

-- 
*Colin Doyle*
Networking Fellow
Verilan, Inc.
7327 SW Barnes Rd. #215
Portland, OR 97225

+1 503.810.2129 [mobile]
[email-masked] <mailto:[email-masked]> [email]
cdoyle.verilan [skype]
www.verilan.com <http://www.verilan.com/> [website]

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 16 Jul 2014 09:34:07 -0700

> This is true in general.   The U.S. has successfully claimed the right to search your laptop at the border as well, and it's not realistic to think that you are safe at any border crossing where th…

And remember lying is a felony.  Check with Marha Stewart on that one...

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 16 Jul 2014 09:39:25 -0700

> for about a year I crossed every other week.

Back in '84 when American Motors was building the plant outside of 
Toronto, I was supporting the controller on the project management. We 
had a plasma screen notebook (one of the 1st decent carriables) and he 
got held up in customs for 3 hours as they figured out what to do with 
such equipment.  It was almost laughable.

'What is that thing, a portable TV? Those cannot be carried in.'

:)

Oh, and if you were carrying a 9" tape with anything on it to the plant, 
you always claimed it was a report that would be printed in the plant on 
Canadian paper...

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Jul 2014 12:56:22 -0400

> And remember lying is a felony.  Check with Marha Stewart on that one...

The point of the protocol I just described is that you don't _have_ to lie.   You can legitimately let them search the laptop, and they won't find anything, so they won't have a reason to ask you for any keys.   If it's out of your possession during the process, you might want to make sure they didn't add a bug of some kind, but that's pretty heavy paranoia.   If that scenario worries you, the nail polish trick is probably worth doing.

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 16 Jul 2014 10:26:47 -0700

> IETF'ers should note "Take all rubbish with you, and treat any food items with great care to avoid attracting animals to your site" so be careful with the cookie crumbs.

This might be a wise consideration for November.  IEEE 802 wireless 
meets over in Waikoloa and the birds were always attacking the crumbs.  
And watch out about honey for your tea.  One gal got visited by a couple 
bees at breakfast that were interested in her little container of honey.

-- 
Standard Robert Moskowitz
Senior Technical Advisor
Security & Standards
Verizon Business Systems
C:248-928-6233
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 16 Jul 2014 13:43:34 -0400

Even longer ago, I was on a car trip from Detroit to Waterloo. We had a 
box of punched cards containing software. Customs was hassling us about 
them - wanted to charge us duty or something. We got them off our back 
by telling them that the cards were "used". That seemed to satisfy them. :-)

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 16 Jul 2014 13:45:27 -0400

> IETF'ers should note "Take all rubbish with you, and treat any food items with great care to avoid attracting animals to your site" so be careful with the cookie crumbs.

This is a concern. If you leave extra cookies lying around in the 
conference rooms they will definitely attract animals. :-)

	Thanks,
	Paul

---

From: "Mishra, Sanjay" <[email-masked]>
Date: Wed, 16 Jul 2014 13:49:16 -0400

Yeah, IETF has a lot of wild life.

-----Original Message-----
From: 90attendees [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Wednesday, July 16, 2014 1:45 PM
To: [email-masked]
Subject: Re: [90attendees] UK Specific info from FCO

> IETF'ers should note "Take all rubbish with you, and treat any food items with great care to avoid attracting animals to your site" so be careful with the cookie crumbs.

This is a concern. If you leave extra cookies lying around in the conference rooms they will definitely attract animals. :-)

	Thanks,
	Paul

>> into trouble (confiscation, arrest) if they find any that you forgot 
>> to declare.  There are also forms to fill out if you want to borrow a 
>> in the "restricted firearms" category.  (You can believe that caught 
>> my eye!  No word on that page on what "some" means.)
>>
>> DUI is a criminal offense.  Any prior conviction "no matter how old 
>> or how minor the infraction" means you are excluded from entry, with 
>> a long latency exception process (called "approval for 
>> rehabilitation", to give you an idea of how they regard this).
>>
>> mention something that other nation's citizens would not expect.  
>> Other nations may provide similar info for their citizens.
>>
>> --Sandy
>>
>>
>

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 16 Jul 2014 10:50:17 -0700

On 07/16/2014 10:43 AM, Paul Kyzivat wrote:
> Even longer ago, I was on a car trip from Detroit to Waterloo. We had 
> a box of punched cards containing software. Customs was hassling us 
> about them - wanted to charge us duty or something. We got them off 
> our back by telling them that the cards were "used". That seemed to 
> satisfy them. :-)

Yeah, it would be hard to misdirect them on what was on the cards unless 
you did not print the characters on the top.  Tapes it was easy.  Had 
one fellow that did not know the secret handshake said he was bringing 
the new operating system for the plant's mainframe.  He was held up in 
customs for 6 hours as the plant had to work on import papers for the 
software that they had already paid for including taxes.  He missed out 
on the beer that evening; a real punishment for him.

---

From: William Atwood <[email-masked]>
Date: Wed, 16 Jul 2014 13:51:27 -0400

Reminds me of the time my family and I were visiting the Zoo in San
Diego.  At one point there was a sign saying "Primate Education Center"...

It was pointing to the high school, which was adjacent to the zoo.

  Bill

-- 
Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8