Subject: [90attendees] iPhone wifi weirdness during the conference

From: Jeff Haas <[email-masked]>
Date: Sat, 26 Jul 2014 12:05:51 -0400

This is mostly a post-IETF poll to see if others saw similar issues.  Wifi on my laptop (Mac) worked fine throughout the conference.  My iphone on the other hand, seemed to have all sorts of issues with the wifi:
- "ietf" would connect most of the time, but not always give me an address.  Occasionally I'd get ipv6 dns address.
- "ietf-hotel" would connect most regularly, especially in my room but connectivity to the outside world was flakey at best.
- The ietf-a, and all .1x networks simply gave up immediately and fell back to the other config.

Mostly I solved my issues by disabling the wifi and falling back to Rogers.

Did anyone else see similar issues?  

In the future, what sort of troubleshooting is good for diagnosing the root cause of such problems?

-- Jeff

---

From: Reinaldo Penno <[email-masked]>
Date: Sat, 26 Jul 2014 09:18:46 -0700

Jeff,

same here. I noticed not only on iPhone but my Android phone was well.

And in general "ietf-hotel" was very flaky across all devices I tried, 
including a Mac and a Lenovo Windows laptop.

thanks,

On 7/26/14, 9:05 AM, Jeff Haas wrote:
> _______________________________________________
> 90attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/90attendees

---

From: Randy Bush <[email-masked]>
Date: Sat, 26 Jul 2014 14:53:35 -0400

> root cause of such problems?

the noc should have a help desk in the terminal room.  oh wait.  they
do.

randy

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sat, 26 Jul 2014 15:00:26 -0400

On my iPhone5s, "ietf" worked very well in the meeting floors. In my room,
"ietf-hotel" was useless, and I used Rogers for the iPhone; I used the
wired connection for my Mac, and I would have used Internet sharing on the
laptop if I had needed it, but Rogers worked fine.

Cheers,
Andy

On Sat, Jul 26, 2014 at 12:18 PM, Reinaldo Penno <[email-masked]> wrote:

>> This is mostly a post-IETF poll to see if others saw similar issues.
>>  Wifi on my laptop (Mac) worked fine throughout the conference.  My iphone
>> on the other hand, seemed to have all sorts of issues with the wifi:
>> - "ietf" would connect most of the time, but not always give me an
>> address.  Occasionally I'd get ipv6 dns address.
>> - "ietf-hotel" would connect most regularly, especially in my room but
>> connectivity to the outside world was flakey at best.

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 26 Jul 2014 16:23:23 -0400

> On 26.07.2014, at 12:05, Jeff Haas <[email-masked]> wrote:
> 

As usual, eduroam just worked on my 5s.
I never knew I wasn't at my university.
Only when stepping out of the meeting rooms did the ietf-hotel weirdness begin.

Grüße, Carsten

---

From: Chris Elliott <[email-masked]>
Date: Sat, 26 Jul 2014 16:27:18 -0400

We can't fix what we don't know about.

My iPhone5 worked reliably across all networks, except for ietf-hotel in my
room, but I was in a corner room at the very end of the hall. My laptop
even had issues there, despite the much better antenna. My Airport Express
solved that problem and gave me much better wifi performance in my room
using the room wired connection. Other folks I know had Androids of various
types and they also worked well on our networks.

Please report such issues when it happens--this meeting (and many others)
Verilan is contracted to support the network and staff the help desk.
Please make use of them, either in person or by submitting a report to
[email-masked], as noted in the Network Information page. It is
obviously too late now, unfortunately.

The information that would help us debug these issues include:

 - The model of device, the version of OS it is running, and the MAC
addresses you used on it's wifi interfaces
 - The SSID you are connecting to
 - The BSSID of the AP you attach to (MAC address of the AP)
 - Where this happened
 - Description of what didn't work, and, if other networks work, what did.
Include the v4 or v6 addresses and router and/or DNS addresses you got, or
which you didn't get.
 - If you are using the 802.1X encrypted networks (ietf.1x, ietf-a.1x, and
eduroam), exactly where it failed. Did you get authenticated? How do you
have your 802.1X supplicant (client) configured? Do you have our
certificate in your certificate store or are you asked to accept it? Are
you using ietf/ietf as username and password for the ietf*.1x nets? Are you
using TTLS or PEAP with MS-CHAPv2 or GTC inner EAP methods?
 - If you did get addresses, could you ping the router, DNS server? If so,
where couldn't you reach, and what does a traceroute show?

Don't worry if you can't supply all of the above. It's great if you can,
and we can help you find what we need if you can't. If you can only supply
some information, the MAC addresses you used on device's wifi interfaces is
the most important for us to start tracking down where things didn't work.
Often we can determine the issue and help you re-configure your devices in
minutes. It might take longer if it is a network issue, but we were only
affected by a single bug, and it did not affect any attendees, that we
configured a workaround for this time. We had no other problems that we
knew about.

Safe travels, and hope to see you in Hawaii!
Chris.

-- 
Chris Elliott
[email-masked]

---

From: Jeff Haas <[email-masked]>
Date: Sat, 26 Jul 2014 17:43:38 -0400

Chris,

On Jul 26, 2014, at 4:27 PM, Chris Elliott <[email-masked]> wrote:
> Please report such issues when it happens--this meeting (and many others) Verilan is contracted to support the network and staff the help desk. Please make use of them, either in person or by submitting a report to [email-masked], as noted in the Network Information page. It is obviously too late now, unfortunately.

If I had zero connectivity, I would have.  It was only the iphone that was behaving oddly, which suggested issues with my equipment.

>  - The model of device, the version of OS it is running, and the MAC addresses you used on it's wifi interfaces

Is there a way to retrieve the bssid from the iphone?  The diagnostic information provided in the control panel is very sparse.

>  - Where this happened
>  - Description of what didn't work, and, if other networks work, what did. Include the v4 or v6 addresses and router and/or DNS addresses you got, or which you didn't get.
>  - If you are using the 802.1X encrypted networks (ietf.1x, ietf-a.1x, and eduroam), exactly where it failed. Did you get authenticated? How do you have your 802.1X supplicant (client) configured? Do you have our certificate in your certificate store or are you asked to accept it? Are you using ietf/ietf as username and password for the ietf*.1x nets? Are you using TTLS or PEAP with MS-CHAPv2 or GTC inner EAP methods?
>  - If you did get addresses, could you ping the router, DNS server? If so, where couldn't you reach, and what does a traceroute show?

For the bulk of the cases, it simply would try to associate for a few seconds, then give up and move along.  In a few of the weird cases, association appeared to complete, but dhcp looked like it hung and eventually a 169.254 address might be assigned.  In the oddest cases I'd get a 2001:: dns server.

And thanks for the additional information.  Unlike Randy's suggestion, I'd rather show up with more than "rectangular internet box broken. please fix."

-- Jeff

---

From: Randy Bush <[email-masked]>
Date: Sun, 27 Jul 2014 09:22:31 +0200

> I'd rather show up with more than "rectangular internet box
> broken. please fix."

help desk should know how to get info, such as bssid, off the phone.  or
boot to someone in the noc.  but with the net down, everybody home, ...
there is little hope.

i report bugs as soon as i sense them.  i may not have sufficient info
to debug, but perhaps my issues correlate with those of others.  and,
yes, i whine even when all i can say is "the intertubes are broken."

randy

---

From: Mikael Abrahamsson <[email-masked]>
Date: Sun, 27 Jul 2014 11:58:17 +0200 (CEST)

> Please report such issues when it happens--this meeting (and many others)

I would just like to chime in that I have several times reported things 
during IETF meetings and received excellent responses in a very timely 
fashion. So people, report if you have problems so they can be fixed, the 
crew behind the ticket system seems to work very efficiently and know what 
they're doing, so there is no reason not to report issues.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Michael StJohns <[email-masked]>
Date: Sun, 27 Jul 2014 12:51:25 -0400

> We can't fix what we don't know about.

Hi Chris -

I, like the others, encountered problems with my iPhone and iPad. But 
not with my laptop.  That to me said that it was probably something I'd 
done to myself rather than an issue with the network. That, coupled with 
no other reports on the mailing list, led to me not filing a report.

I also encountered the issues with connecting to ietf-a through those 
devices similar to what was mentioned elsewhere, primarily in the 
lobby.  I didn't use any of the encrypted wireless SSIDs.

Unfortunately, all the nice tools I have on my laptop to figure out 
things don't exists on my iP* devices.

My issues manifested with problems reaching certain sites, notably 
Google.  I kept getting shunted off to Google UK from time to time. That 
was particularly problematic in that the furshlinger Safari version that 
is current no longer has separate bars for search vs urls and that led 
to some interesting  cursing on my part.  I ended up using Bing a number 
of times as it was reasonably responsive.

I've got an iPhone 5s and an iPad mini - both running ios 7.1.2. I'm 
suspicious of ipv6 routing related to this issue.

In any event, I'll know to report these at the next IETF.

Thanks for the good work you and the NOC did during this last IETF.

Mike

>
> My iPhone5 worked reliably across all networks, except for ietf-hotel 
> in my room, but I was in a corner room at the very end of the hall. My 
> laptop even had issues there, despite the much better antenna. My 
> Airport Express solved that problem and gave me much better wifi 
> performance in my room using the room wired connection. Other folks I 
> know had Androids of various types and they also worked well on our 
> networks.
>
> Please report such issues when it happens--this meeting (and many 
> others) Verilan is contracted to support the network and staff the 
> help desk. Please make use of them, either in person or by submitting 
> a report to [email-masked] 
> <mailto:[email-masked]>, as noted in the Network Information 
> page. It is obviously too late now, unfortunately.
>
>  - Description of what didn't work, and, if other networks work, what 
> did. Include the v4 or v6 addresses and router and/or DNS addresses 
> you got, or which you didn't get.
>  - If you are using the 802.1X encrypted networks (ietf.1x, ietf-a.1x, 
> and eduroam), exactly where it failed. Did you get authenticated? How 
> do you have your 802.1X supplicant (client) configured? Do you have 
> our certificate in your certificate store or are you asked to accept 
> it? Are you using ietf/ietf as username and password for the ietf*.1x 
> nets? Are you using TTLS or PEAP with MS-CHAPv2 or GTC inner EAP methods?
>  - If you did get addresses, could you ping the router, DNS server? If 
> so, where couldn't you reach, and what does a traceroute show?
>
> Don't worry if you can't supply all of the above. It's great if you 
> can, and we can help you find what we need if you can't. If you can 
> only supply some information, the MAC addresses you used on device's 
> wifi interfaces is the most important for us to start tracking down 
> where things didn't work. Often we can determine the issue and help 
> you re-configure your devices in minutes. It might take longer if it 
> is a network issue, but we were only affected by a single bug, and it 
> did not affect any attendees, that we configured a workaround for this 
> time. We had no other problems that we knew about.
>
> On Sat, Jul 26, 2014 at 3:00 PM, Andrew G. Malis <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     On my iPhone5s, "ietf" worked very well in the meeting floors. In
>     my room, "ietf-hotel" was useless, and I used Rogers for the
>     iPhone; I used the wired connection for my Mac, and I would have
>     used Internet sharing on the laptop if I had needed it, but Rogers
>     worked fine.
>
>     Cheers,
>     Andy
>
>
>
>     On Sat, Jul 26, 2014 at 12:18 PM, Reinaldo Penno
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Jeff,
>
>         And in general "ietf-hotel" was very flaky across all devices
>         I tried, including a Mac and a Lenovo Windows laptop.
>
>         thanks,
>
>
>
>             This is mostly a post-IETF poll to see if others saw
>             similar issues.  Wifi on my laptop (Mac) worked fine
>             throughout the conference.  My iphone on the other hand,
>             seemed to have all sorts of issues with the wifi:
>             - "ietf" would connect most of the time, but not always
>             give me an address.  Occasionally I'd get ipv6 dns address.
>             - "ietf-hotel" would connect most regularly, especially in
>             my room but connectivity to the outside world was flakey
>             at best.
>             - The ietf-a, and all .1x networks simply gave up
>             immediately and fell back to the other config.
>
>             In the future, what sort of troubleshooting is good for
>             diagnosing the root cause of such problems?
>
>             -- Jeff
>
>
>             [email-masked] <mailto:[email-masked]>
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
>
>

---

From: Jeff Haas <[email-masked]>
Date: Sun, 27 Jul 2014 13:10:42 -0400

On Jul 27, 2014, at 12:51 PM, Michael StJohns <[email-masked]> wrote:

> My issues manifested with problems reaching certain sites, notably Google.  I kept getting shunted off to Google UK from time to time. 

I had this issue.  Attempting to connect to http://yahoo.com (my defacto bookmark to trigger walled garden login auth) also dumped me out at the UK site.

-- Jeff

---

From: Andrew Sullivan <[email-masked]>
Date: Sun, 27 Jul 2014 13:19:54 -0400

On Sun, Jul 27, 2014 at 12:51:25PM -0400, Michael StJohns wrote:
> Google.  I kept getting shunted off to Google UK from time to time.

Well, it's not hard to figure out what's going on there.  Our IP range
was located in London because that's where we were last time.
Geolocation of IP addresses is your friend except, of course, when it
isn't.  When we get to Hawaiʻi, I imagine you can expect ads for
Toronto.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: William Atwood <[email-masked]>
Date: Sun, 27 Jul 2014 13:31:43 -0400

Michael,

The issue of being shunted off to Google UK was probably due to Google's
"location" service, which still thought that the IETF was in London
(which is the last place where 31.133.x.y was seen).  I live in Montreal
(Canada), and even if I enter google.com, I end up on google.ca.  The
first morning, I had occasion to open google maps, and when the screen
came up, it was centered on London.

Chris,

Given the rather strong connection between the senior management at the
IETF and the senior management at Google, I am wondering if a way could
be found to "advise" Google (and some of the other location services) as
to where 31.133.x.y is going to be next.  Google's location service
thought that I was in London; another IP lookup service that I accessed
thought that we were in Atlanta.

  Bill

On 27/07/2014 12:51 PM, Michael StJohns wrote:
> done to myself rather than an issue with the network.  That, coupled
> with no other reports on the mailing list, led to me not filing a report. 
> 

-- 
Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: Warren Kumari <[email-masked]>
Date: Sun, 27 Jul 2014 13:45:18 -0400

> thought that we were in Atlanta.

There is actually a protocol for this --
http://tools.ietf.org/html/draft-google-self-published-geofeeds-02 --
and we even publish a feed: http://noc.ietf.org/geo/google.csv

This file lets Google (and other folk who geolocate) know ahead of
time where the prefixes live. We did all the right bits - we started
announcing the space a few weeks early, we announced it from the right
AS, etc -- unfortunately I forgot the critical step of actually
updating the file... Erik Kline pointed this out to me on the 22nd,
but by then it was too late to make a difference...

So, the Google part at least was my fault. We had tried to progress
this document, but it died because of privacy concerns, and the
authors got tired of pushing it uphill...

W

---

From: Michal Krsek <[email-masked]>
Date: Sun, 27 Jul 2014 13:52:21 -0400

Hi Bill,

> On 27. 7. 2014, at 13:31, William Atwood <[email-masked]> wrote:
> Chris,
> 

this problem isn't new. I remember it at least back to forst IETF meeting in Prague. NOC team and other folks were trying to find any way how to tell GeoIP providers where is the prefix located. 

No success by now I think. They simply aren't interested as their users are not complaining to them.

I do not want to raise one of GeoIP providers, they acted more less same way. Any good advice is welcome.

Michal

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 28 Jul 2014 13:45:11 +0000

I didn't have a room at the Fairmont, so I never tried the hotel SSID.
My iPhone 3GS had no issues with the ietf SSID. I had data roaming turned off, so I never attached to Rogers for data.
Google Maps got me to "hockey hall of fame" perfectly, when connected to ietf SSID (and Rogers for voice but not data).
Barbara