Subject: [95attendees] ISOC briefing panel, Tuesday lunchtime

From: Tim Chown <[email-masked]>
Date: Tue, 29 Mar 2016 14:20:21 +0000

Hi,

I don’t think I’ve seen it advertised here, but I picked it up via other channels. Apologies if it’s a repeat.

https://www.internetsociety.org/blog/tech-matters/2016/03/registration-open-ietf-95-briefing-panel-public-policy-and-internet

Registration still seems to have spaces.

Tim

---

From: Megan Kruse <[email-masked]>
Date: Tue, 29 Mar 2016 15:26:34 +0000

Tim,

Thanks for highlighting this. We’re opening registration in two time blocks - 0900UTC and 2100UTC. There are currently 7 spaces remaining in the first block, but if you don’t make it, try again at 2100!

It’ll also be webcast and open to the public.

Thanks,
Megan
-------------
Megan Kruse
Manager, Technology Outreach & Strategic Planning
Internet Society
@MeganRKruse
@Deploy360 / @ISOCtech