Subject: [95attendees] IETFers app update

From: Tom Pusateri <[email-masked]>
Date: Thu, 24 Mar 2016 09:28:05 -0400

The new update of the IETFers app is ready to download. As you will see in the release notes, this one has been rewritten to synchronize with the IETF database. The first time you run it, it will take some time so be patient. Also, it will not automatically switch meetings, you have to do that in Settings. The first time you switch to a new meeting, it also will have a noticeable delay. We will work to make these delays shorter.

On the bright side, this app will work for future meetings. As soon as the new meetings and sessions are published, it will discover them.

There are certain features that I wasn’t able to replicate using the database including audio streaming and playback, jabber log synchronization, and maps. If you would like to see missing features brought back, let me know and I will work with the tools team to make it possible.

The import favorites from previous meeting also got left out due to time pressure to get this version released. It will be back in the next release.

Thanks,
Tom

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 24 Mar 2016 15:04:16 +0100

The one thing that I have been missing in the (in my case android) app is
a capability to inset private appointments/meetings that I plan during IETF.
Do you think it would be doable to add such a feature?

Keep up the good work.

Thanks, Bert

On 24/03/16 14:28, Tom Pusateri wrote:
> _______________________________________________
> 95attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/95attendees
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 24 Mar 2016 10:33:01 -0400

Bert, I just put those in my regular calendar, and export the IETFers
favorites to my calendar as well, thus my regular calendar becomes a master
calendar showing all appointments and meetings.

Tom, I miss the maps, those were really helpful. With the maps, you don’t
need the paper agenda at all. As a workaround, I opened the online map page
in Safari and I’ll keep that as an open page.

Cheers,
Andy

On Thu, Mar 24, 2016 at 10:04 AM, Bert Wijnen (IETF) <[email-masked]>
wrote:

>> The new update of the IETFers app is ready to download. As you will see
>> in the release notes, this one has been rewritten to synchronize with the
>> IETF database. The first time you run it, it will take some time so be
>> patient. Also, it will not automatically switch meetings, you have to do
>> that in Settings. The first time you switch to a new meeting, it also will
>> have a noticeable delay. We will work to make these delays shorter.
>>
>> On the bright side, this app will work for future meetings. As soon as
>> the new meetings and sessions are published, it will discover them.
>>
>> There are certain features that I wasn’t able to replicate using the
>> database including audio streaming and playback, jabber log
>> synchronization, and maps. If you would like to see missing features
>> brought back, let me know and I will work with the tools team to make it
>> possible.
>>
>> The import favorites from previous meeting also got left out due to time
>> pressure to get this version released. It will be back in the next release.
>>
>> Thanks,
>> Tom
>>
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 24 Mar 2016 16:05:44 +0100

> There are certain features that I wasn’t able to replicate using the database including audio streaming and playback, jabber log synchronization, and maps. If you would like to see missing features…

Apart from the maps already mentions, the audio streaming is really
useful on site when you need to be in two meetings at the same time so
you can decide when to run over to the other meeting.

Grüße, Carsten

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Thu, 24 Mar 2016 11:50:29 -0400

Thank you muy mucho for the IETFers app.

I was using it (iOS 9.3, iPhone 6S) this morning in a manner that
perhaps you didn't intend that exposed some clunkiness in the new
syncing behavior. It did take a while to download on first launch
after updating the new app... but it hung and didn't seem to finish
(and the heading said IETF 94). I forced closed the app, restarted,
still syncing. I had to delete and reinstall the app to get past this
and then it seemed to recognize it should try to synch IETF 95 and did
so pretty quickly 20-30s.

However, here is the real usability nit: Like Andrew Malis I favorite
sessions in IETFers and use the auto add-to-calendar facility within
the app. I had favorited a bunch of sessions and then started checking
out agendas and popping out of the IETFers app and into my calendar
app. This fast switching between IETFers and another app caused
IETFers to attempt to re-synch the IETF 95 data it had *every time I
switched back to the app.* Occassionally, this was unobtrusive but
more often than not the app would hang or take a long while to see if
it needed to sync.

While I still love the app (who couldn't?!) it would be great if it
checked if it needed to sync less often (not every time the app is
switched to). Maybe once an hour with a settings toggle to resync? Or
maybe a "skip sync" button on the sync interaction to say to the app
"syncing is all well and good, but you're my master and I want to see
a potentially stale IETF schedule!!!"

::)

Thanks a ton, Joe

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

CDT's annual dinner, Tech Prom, is April 6, 2016! https://cdt.org/annual-dinner

---

From: prz <[email-masked]>
Date: Thu, 24 Mar 2016 09:57:11 -0700

> Thank you muy mucho for the IETFers app.

 Hail to Tom. This is one of the greatest services to IETF practically 
 speaking
 I ever saw anyone perform ...

 --- tony

---

From: prz <[email-masked]>
Date: Thu, 24 Mar 2016 10:00:41 -0700

On Thu, 24 Mar 2016 09:28:05 -0400, Tom Pusateri <[email-masked]> 
 wrote:
> The new update of the IETFers app is ready to download. As you will

 Sign of someone having a clue here. 5 updates on my iphone choking WiFi 
 going on now:

 LI 106MB
 FB Messenger 83MB
 G Maps 55MB

 Tom's IETFs 2.2 MB

 It does tell you something I think ...

 --- tony

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 24 Mar 2016 17:05:29 +0000

Question, Tom - I updated the app on my iPhone, and opened it. As expected, it spent some time fondling the network. Now it sits and stares at me; the only words on the screen are "IETF 94", and looking at settings, I don't see a means to select "IETF 95".

What am I missing?

---

From: Ray Bellis <[email-masked]>
Date: Thu, 24 Mar 2016 17:07:06 +0000

On 24/03/2016 17:05, Fred Baker (fred) wrote:
> Question, Tom - I updated the app on my iPhone, and opened it. As
> expected, it spent some time fondling the network. Now it sits and
> stares at me; the only words on the screen are "IETF 94", and looking
> at settings, I don't see a means to select "IETF 95".
> 
> What am I missing?

Mine did that too - I "force closed" the app and restarted it and then
the expected screen appeared.

Ray

---

From: Michael StJohns <[email-masked]>
Date: Thu, 24 Mar 2016 13:51:19 -0400

On 3/24/2016 9:28 AM, Tom Pusateri wrote:

Hi Tom -

Thanks as always for the update, but I really wish you'd have provided 
this as a new app/separate beta given how much has changed.  I've 
already found one issue that's very problematic - if you have no network 
access, the app blocks trying to load - even if it has a reasonably 
current database.   That means no access in airplane mode.  It also 
means that if you disable the app's access to cellular data (e.g. to 
avoid roaming charges), and you're not on Wifi - again, no access.

As far as I can tell, there's no timeout set for the network check either.

Or am I missing some settings somewhere?

Later, Mike

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 24 Mar 2016 14:24:45 -0400

Without seeing a screen shot, I can offer a few options:

1. click the bottom right hand tab that says settings and then Meeting Location select IETF 95.

2. If that isn’t possible, kill the app by double clicking and side scrolling until it is selected and flick it up to terminate and and then restart.

3. If that still doesn’t do it, then deleting and re-downloading.

There are some IETF server issues that aren’t totally resolved that cause aborts when syncing but it should retry after suspending and resuming and eventually sync.

Tom

> On Mar 24, 2016, at 1:05 PM, Fred Baker (fred) <[email-masked]> wrote:
>

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 24 Mar 2016 14:27:19 -0400

Mike,
	That was not intentional. There should be a timeout (although it might be too long). I will test it and get an update out.

Thanks,
Tom

> On Mar 24, 2016, at 1:51 PM, Michael StJohns <[email-masked]> wrote:
> 
> Thanks as always for the update, but I really wish you'd have provided this as a new app/separate beta given how much has changed.  I've already found one issue that's very problematic - if you have no network access, the app blocks trying to load - even if it has a reasonably current database.   That means no access in airplane mode.  It also means that if you disable the app's access to cellular data (e.g. to avoid roaming charges),  and you're not on Wifi - again, no access.
> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/95attendees <https://www.ietf.org/mailman/listinfo/95attendees>
>

---

From: Robert Edmonds <[email-masked]>
Date: Thu, 24 Mar 2016 15:31:30 -0400

> The new update of the IETFers app is ready to download. As you will see in the release notes, this one has been rewritten to synchronize with the IETF database. The first time you run it, it will t…

Hi,

There is a graphical glitch in the Android version. When scrolling the
list of sessions slowly the text labels are smeared, making it difficult
to read when the list is in motion. It's hard to take a screenshot of
the behavior, because it disappears when scrolling stops.

This is on a Nexus 5X running Android 6.0.1.

-- 
Robert Edmonds