Subject: [99attendees] REG: Visa Invitation Letter

From: Sudhin Jacob <[email-masked]>
Date: Mon, 5 Jun 2017 11:21:28 +0000

Hi All,

Could you please let me know whom to contact to get Local LOI for processing the Visa. The computer generated local LOI is not in proper format. Appreciate your help.

Regards,
Sudhin

---

From: Fred Baker <[email-masked]>
Date: Mon, 5 Jun 2017 06:27:58 -0700

I should think you would contact the IAD at [email-masked].

> On Jun 5, 2017, at 4:21 AM, Sudhin Jacob <[email-masked]> wrote:
> 
> Hi All,
>  
> _______________________________________________
> 99attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/99attendees