Subject: Re: [AAA-DOCTORS] New version of draft-ietf-dime-mip6-integrated

From: <[email-masked]>
Date: Fri, 9 Jan 2009 09:45:53 +0200

Jouni,

Compared to version -11, this moves the MIP6-Feature-Vector and
MIP6-Home-Link-Prefix attributes back to the >255 space.  
I think they should be as they were in version -11.

Otherwise, this looks good.

Best regards,
Pasi

> -----Original Message-----
> From: ext jouni korhonen [mailto:[email-masked]] 
> Sent: 30 December, 2008 12:25
> To: Eronen Pasi (Nokia-NRC/Helsinki)
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [AAA-DOCTORS] New version of 
> draft-ietf-dime-mip6-integrated
> 
> Hi Pasi, all,
> 
> According to my notes we have now converged to a common 
> understanding  
> on this I-D. I have prepared an update of the I-D that includes all  
> comments. See the following link for the diff (PDF) that summarizes  
> changes since the -10 that was submitted to the IESG: 
> http://www.tschofenig.priv.at/svn/draft-ietf-dime-mip6-integrated/dime-mip6-integrated-10-to-12-diff.pdf> 

> Does this revision match others' idea of the agreed on changes?
> 
> Cheers,
> 	Jouni
> 
> 
> On Dec 18, 2008, at 7:41 PM, <[email-masked]> 
> <[email-masked] 
>  > wrote:
> 
> > Jouni Korhonen wrote:
> >
> >>> Looking back at the emails, the following things (not related to
> >>> this RADIUS/Diameter topic) were still not handled in the
> >>> -11 version:
> >>>
> >>> - Describing the semantics of the MIP6-Home-Link-Prefix in request
> >>> messages.
> >>
> >> Would the following text in Section 4.2.4 work for you?
> >>
> >> Old:
> >>
> >>    The HAAA MAY act as a central entity managing prefixes for MNs.
> >>    In this case, the HAAA returns the prefix allocated for the MN
> >>    and returns it the NAS.  The NAS/ASP uses then, for example,
> >>    mechanisms described in
> >>    [I-D.ietf-mip6-bootstrapping-integrated-dhc] to deliver the home
> >>    link prefix to the MN.
> >>
> >> New:
> >>
> >>    The HAAA MAY act as a central entity managing prefixes for MNs.
> >>    In this case, the HAAA returns the prefix allocated for the MN
> >>    and returns it the NAS.  The NAS/ASP uses then, for example,
> >>    mechanisms described in
> >>    [I-D.ietf-mip6-bootstrapping-integrated-dhc] to deliver the home
> >>    link prefix to the MN. The NAS/ASP MAY propose a specific prefix
> >>    allocation to the HAAA by including the MIP6-Home-Link-Prefix
> >>    AVP in the request message. However, the HAAA is MAY override
> >>    the prefix allocation hint proposed by the NAS/AAA and return a
> >>    different prefix in the response message.
> >
> > Both this and Lionel's slightly edited version look OK to me.
> >
> >>> - If the message contains information about multiple HAs, 
> which home
> >>> agent(s) the prefix(es) in MIP6-Home-Link-Prefix AVP(s) belong to.
> >>> (One way to solve this would be to move it inside the Grouped AVP;
> >>> another way would be to prohibit its use if the message contains
> >>> multiple HAs; other solutions may be possible)
> >>
> >> Actually, I have a vague recollection that independent of number of
> >> the HAs, there would be only one prefix. I cannot find anything to
> >> back up this now, though.
> >>
> >> Thus, we could move the MIP6-Home-Link-Prefix AVP inside the MIP6-
> >> Agent-Info AVP (in that case, we could actually consider using the
> >> Framed-IPv6- Prefix AVP instead of the MIP6-Home-Link-Prefix
> >> AVP). Or we could add text that says using the 
> MIP6-Home-Link-Prefix
> >> AVP when there are multiple HAs does not make much sense.
> >
> > I slightly prefer moving it inside the grouped AVP.
> >
> > Best regards,
> > Pasi
> > _______________________________________________
> > AAA-DOCTORS mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/aaa-doctors
> 
> 
_______________________________________________
AAA-DOCTORS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/aaa-doctors

---

From: "jouni korhonen" <[email-masked]>
Date: Fri, 9 Jan 2009 11:08:20 +0200

Hi Pasi,

Right, I'll move the two AVPs back to <256 space. Will submit a revision
soon.

Cheers,
    Jouni

On Fri, Jan 9, 2009 at 9:45 AM, <[email-masked]> wrote:

> http://www.tschofenig.priv.at/svn/draft-ietf-dime-mip6-integrated/dime-mip6-integrated-10-to-12-diff.pdf
> >
>