Subject: [AAA-DOCTORS] Fwd: [Technical Errata Reported] RFC5090 (5115)

From: Benoit Claise <[email-masked]>
Date: Fri, 15 Sep 2017 09:22:14 +0200

Dear AAA doctors,

Let me know what you think.

Regards, Benoit

-------- Forwarded Message --------
Subject: 	[Technical Errata Reported] RFC5090 (5115)
Date: 	Thu, 14 Sep 2017 13:07:40 -0700
From: 	RFC Errata System <[email-masked]>
To: 	[email-masked], [email-masked], [email-masked], 
[email-masked], [email-masked], [email-masked], 
[email-masked], [email-masked], [email-masked]
CC: 	[email-masked], [email-masked], [email-masked]

The following errata report has been submitted for RFC5090,
"RADIUS Extension for Digest Authentication".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5115

--------------------------------------
Type: Technical
Reported by: Denis Ovsienko <[email-masked]>

Section: 3

Original Text
-------------
3.17.  Digest-Domain Attribute
[...]
    Length
          3
[...]

3.18.  Digest-Stale Attribute
[...]
    Length
          3

Corrected Text
--------------
3.17.  Digest-Domain Attribute
[...]
    Length
          >= 3
[...]

3.18.  Digest-Stale Attribute
[...]
    Length
          >= 3

Notes
-----
Those two attributes contain string values. All other such attributes in Section 3 uniformly define Length >= 3.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party
can log in to change the status and edit the report, if necessary.

--------------------------------------
RFC5090 (draft-ietf-radext-rfc4590bis-02)
--------------------------------------
Title               : RADIUS Extension for Digest Authentication
Publication Date    : February 2008
Author(s)           : B. Sterman, D. Sadolevsky, D. Schwartz, D. Williams, W. Beck
Category            : PROPOSED STANDARD
Source              : RADIUS EXTensions
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG
.

---

From: Alan DeKok <[email-masked]>
Date: Fri, 15 Sep 2017 07:13:23 -0400

Looks good to me.  An attribute carrying a string 'true' can't be 3 octets in length.

	<= 7

  Because it can only contain the strings 'true' and 'false'.

  But we don't make that distinction for other attributes.  e.g. Digest-HA1 which is the output of a hash, and should be fixed length.

  I think it's fine to just use ">= 3" here.

> On Sep 15, 2017, at 3:22 AM, Benoit Claise <[email-masked]> wrote:
> 
> Dear AAA doctors,
> 
> To:	[email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
> _______________________________________________
> AAA-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aaa-doctors

---

From: Benoit Claise <[email-masked]>
Date: Fri, 15 Sep 2017 21:35:15 +0200

Thanks Alan.
Errata Verified.

Regards, B.