Subject: [AAA-WG]: [Issue] AVP data type mismatch in Section 4.6 of base -07

From: "Mark Jones" <[email-masked]>
Date: Wed, 26 Sep 2001 14:58:39 -0400

Submitter name: Mark Jones
Submitter email address: [email-masked]
Date first submitted: 2001-09-26
Reference:
Document: base -07
Comment type: E
Priority: 'S'
Section: 4.6

Rationale/Explanation of issue:

Some of the data types listed in the AVP table in section 4.6 do not match
those in the AVP description elsewhere in the draft.

Request change:

The AVP data types in section 4.6 should be corrected as follows:

Accounting-Multi-Session-Id 	OctetString	-> UTF8String
Accounting-Session-Id 		OctetString	-> UTF8String
Acct-Application-Id		Integer32	-> Unsigned32
Alternate-Peer			OctetString	-> DiameterIdentity
Acct-Application-Id		Integer32	-> Unsigned32
Destination-Host 			OctetString	-> DiameterIdentity
Destination-Realm			OctetString	-> UTF8String
Error-Message			OctetString	-> UTF8String
Error-Reporting-Host		OctetString	-> DiameterIdentity
Origin-Host				OctetString	-> DiameterIdentity
Origin-Realm			OctetString	-> UTF8String
Product-Name			OctetString	-> UTF8String
Proxy-Host				IPAddress	-> DiameterIdentity
Redirect-Host			OctetString	-> DiameterIdentity
Route-Record			OctetString	-> DiameterIdentity
Session-Id				OctetString	-> UTF8String
Source-Route			OctetString	-> DiameterIdentity

Regards,
       Mark

---

From: "Mark Jones" <[email-masked]>
Date: Wed, 26 Sep 2001 15:22:04 -0400

Apologies, please ignore this issue. It is a duplicate of issue 103 by Dave
Frascone.

Regards,
       Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Mark Jones
> Sent: September 26, 2001 2:59 PM
> To: [email-masked]
> Subject: [AAA-WG]: [Issue] AVP data type mismatch in Section 4.6 of base
> -07
>
>