Subject: [AAA-WG]: [issue] DIAMETER_NO_COMMON_TRUST error

From: Miguel Ángel Monjas Llorente <[email-masked]>
Date: Thu, 06 Sep 2001 19:16:39 +0200

Submitter name: Miguel A. Monjas
Submitter email address: [email-masked] 
Date first submitted: 2001-09-06
Reference:
http://www.merit.edu/mail.archives/aaa-wg/2001-08/msg00300.html
Document: CMS-02
Comment type: T
Priority: 2
Section: 1.2
Rationale/Explanation of issue:

DIAMETER_NO_COMMON_TRUST error is introduced in section 7.2 of
CMS-Sec. However, no explicit mention to it is done in the text. The
definition is as follows:

  This error code is returned when a receiver receives a PDSR for
  which it has no common trust with the sender, which is required
  to establish the DSA.

What seems to suggest that when a proxy receives a PDSAR from a client
when there no exist "common trust" between them.

In which situations is considered that there's common trust?

Requested change: 

Add clarifying text

Regards

  // M.A.

-- 
  Miguel Angel Monjas Llorente
  Systems Engineer, GSM/UMTS Systems Management
  Ericsson España, S.A. (EEM) UMTS/GSM Databases
  Tel: +34 91 3393605                 Mob: +34 629 570196
  <mailto:[email-masked]>  Fax: +34 91 3392538
  Retama 1, 4th. 28045 Madrid - SPAIN -

---

From: Jari Arkko <[email-masked]>
Date: Fri, 07 Sep 2001 16:30:41 +0300

I have trouble understanding issue #168. Section
7.2 of cms-sec-02 does not include such an error.
Also, the provided reference doesn't seem to
be related to this issue. Perhaps this error
was agreed in the context of some other issue?
But searching 'issues.html' with 'trust' didn't
reveal anything either.

... clarification would be appreciated (or maybe
my web cache is just out of sync of the drafts?)

Jari

---

From: Miguel Ángel Monjas Llorente <[email-masked]>
Date: Fri, 07 Sep 2001 15:40:42 +0200

> 7.2 of cms-sec-02 does not include such an error.

Right. It isn't still in the draft. I didn't checked that it wasn't
actually in the CMS-02 but in the resolution of one of the issues (I
don't remember which one).

I'd better have talket to Pat off-line.

Pat, please, could you drop this issue? (although I still need some
clafirication on this point before adding it to the draft)

Regards

  // M.A.