Subject: [AAA-WG]: Issue 164: problems with Watch Dog

From: Pat Calhoun <[email-masked]>
Date: Sat, 15 Sep 2001 08:01:24 -0700

The authors of the issue are correct that the pseudo-code doesn't reflect
the text in 5.1. So, I propose adding the following field to the PCB
in 5.5.3:

wdRecoveryCount - This field contains the number of DWAs received
                  from a peer once the PCB's state is in the SUSPECT state.

Then changes are made to the pseudo-code to handle this case:

/*
 * OnReceiveDWA() is called whenever a DWA is received
 * from the peer.
 */
OnReceiveDWA(pcb)
{
     if pcb->Status == SUSPECT
          if pcb->wdRecoveryCount == 3
               pcb->wdRecoveryCount = 0
               pcb->Status = OKAY
          else pcb->wdRecoveryCount++
     else if pcb->Status != INACTIVE
          if pcb->Pending
               T = Tr
          else
               T = Ti
}

/*
 * OnTimerElapsed() is called by some timer services
 * whenever T reaches zero (0).
 */
OnTimerElapsed(pcb)
{
     if pcb->Status = OKAY
          SendWatchdog(pcb)
          pcb->Status = WAIT_DWA
          T = Tw
     else if pcb->Status = WAIT_DWA
          pcb->Status = SUSPECT
          T = Td
     else if pcb->Status = SUSPECT
          if pcb->wdRecoveryCount == 3
               StopConnection(pcb)
               FailoverProcedures(pcb)
          else SendWatchdog(pcb)
}

I believe this resolves the issue. Comments?

PatC

---

From: "Fredrik Johansson" <[email-masked]>
Date: Mon, 17 Sep 2001 12:30:32 +0200

Probably just a small miss when setting the counters in the pseudo code

According to section 5.1 the status should be set to OKAY when 3 watchdog
messages are exchanged withing accepted round trip times. However, I believe
that the pseudo code below require 4 DWAs to be received before Status is
set to OKAY? Considering the wdRecoveryCount starts at 0 and OKAY is not set
when wdRecoveryCount reaches 3 but the next time a DWA is received. i.e. the
4th DWA.

/Fredrik

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>Pat Calhoun
>Sent: den 15 september 2001 17:01
>To: [email-masked]
>Subject: [AAA-WG]: Issue 164: problems with Watch Dog
>
>

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 17 Sep 2001 08:03:51 -0700

ooops... you are correct. Will change 3 to 2, since 0 is the starting point.

Thanks,

PatC