Subject: [AAA-WG]: [issue] NAS-Session-Key and Session Master Keys

From: [email-masked]
Date: Thu, 27 Sep 2001 15:51:07 +0300

Submitter name: Henry Haverinen
Submitter email address: [email-masked]
Date first submitted: 2001-09-27
Reference: 
Document: nasreq
Comment type: S
Priority: 1
Section: 2.1.2 - 2.1.6
Rationale/Explanation of issue:

The NAS-Session-Key AVP, as currently specified, can only 
be used to transport encryption and integrity keys.
However, a IEEE 802.11 access point may need session 
master keys from which it derives the actual encryption
and authentication keys. (This is not certain yet.)

Requested change: 

Perhaps the NASREQ document could simply say that the 
CIPHER_KEY (or INTEGRITY_KEY) can alternatively be used as 
a session master key from which the NAS derives the actual 
cipher keys (integrity keys).

---

From: "Glen Zorn" <[email-masked]>
Date: Sat, 29 Sep 2001 09:16:13 -0700

> be used to transport encryption and integrity keys.

What makes you think that?

> cipher keys (integrity keys). 

I think that that goes w/o out saying.