Subject: [AAA-WG]: Question about Capabilities-Exchange

From: "Yolanda Garcia-Serrano (ECE)" <[email-masked]>
Date: Thu, 13 Sep 2001 09:45:52 +0200

Hi,

I have a question about the contents of Capabilities-Exchange messages:

In chapter 5.3.1, 5.3.2 as well as in 10.1 (AVP Table), Auth-Application-Id and
Acct-Application-Id AVPs do not appear as mandatory for CER and CEA messages.
MUST Auth-Application-Id or Acct-Application-Id (at least one of both) be
mandatory in CER/CEA messages? 
Otherwise, I found confusing following statements in the draft:

	* Section 2.5
	... all other Diameter nodes MUST advertise locally supported applications. 

Does not the "MUST" imply the sending of Auth-Application-Id or Acct-Application-Id in
the CER, CEA messages=

	* Section 5.3  (Capabilities Exchange)
	..  A receiver of a Capabilities-Exchange-Req (CER) message which does
	   not have any applications in common with the sender MUST return a
	   Capabilities-Exchange-Answer (CEA) with the Result-Code AVP set to
	   DIAMETER_NO_COMMON_APPLICATION, and SHOULD disconnect the transport
	   layer connection. 

How can a receiver of a CER message detect whether it has any application in common with the sender
if the message does not contain either Auth-Application-Id or Acct-Application-Id ?

	*6.9  Auth-Application-Id AVP
	   The Auth-Application-Id AVP (AVP Code 258) is of type Unsigned32 and
	   is used in order to advertise support of the Authentication and
	   Authorization portion of an application (see Section 2.5). The Auth-
	   Application-Id MUST also be present in all Authentication and/or
	   Authorization messages that are defined in a separate Diameter
	   specification and have an Application ID assigned.

Advertising support of the authen & autho portion of an application means include this
AVP in the CER/CEA messages, isn't it?

Sumarizing, I think the ABNR of CER and CEA messages, as well as the AVP table has to be updated
to include at least 1 Auth-Application-Id and 1 Acct-Application-Id. If so, could this be
clarified in the draft ?

Thanks, and best regards
	/Yolanda Garcia

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 13 Sep 2001 07:37:23 -0700

The ABNF doesn't have a way to state that either one or another AVP MUST be
present. So, the supporting text is the best we can do, and so far it hasn't
hampered any of the interopoerability tests we've had.

PatC