Subject: [AAA-WG]: [issue] the use of Disconnect-Peer-Request

From: [email-masked]
Date: Thu, 6 Sep 2001 05:50:52 +0300

Submitter name: Yanqun Le
Submitter email address: [email-masked] 
Date first submitted: 2001-09-06
Reference: 
Document: Base-07
Comment type: T
Priority: 2
Section: 5.4 and 5.6
Rationale/Explanation of issue:

1) We are puzzled of the use of Disconnect-Peer-Request. It doesn't appear
in Peer FSM. Does the event of R-Peer-Disc appeared in Peer FSM have the
same meaning to it? 

2) If a peer sends out DPR, which peer state should it change to? If it
can't receive DPA, what shall it do?

3) I infer from draft 07, a receiver of DPR should not periodically attempt
to reconnect to the sender of DPR. Then only if the sender of DPR will
reconnect to another peer after it is going to do so?
 
Best regards
Yanqun Le

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 6 Sep 2001 07:57:26 -0700

Yanqun,

I had received your request on the mailing list, but seem to be having some
issues in keeping up with work :(

Here's a snapshot of a portion of the state machine that will appear in -08. If
you believe that it is still incorrect, please let me know:

R-Open           Send-Message     R-Snd-Message    R-Open
                 R-Rcv-Message    Process          R-Open
                 WatchDog-Timer   R-Snd-DWR        R-Open
                 R-Rcv-DWR        Process-DWR,     R-Open
                                  R-Snd-DWA
                 R-Rcv-DWA        Process-DWA      R-Open
                 R-Conn-CER       R-Snd-CEA        R-Open
                                  R-Reject
                 Stop             R-Snd-DPR        Closing
                 R-Rcv-DPR        R-Snd-DPA,       Closed
                                  R-Disc
                 R-Peer-Disc      R-Disc           Closed
                 R-Rcv-CER        Error            Closed
                 R-Rcv-CEA        Error            Closed

I-Open           Send-Message     I-Snd-Message    I-Open
                 I-Rcv-Message    Process          I-Open
                 WatchDog-Timer   I-Snd-DWR        I-Open
                 I-Rcv-DWR        Process-DWR,     I-Open
                                  I-Snd-DWA
                 I-Rcv-DWA        Process-DWA      I-Open
                 R-Conn-CER       R-Reject         I-Open
                 Stop             I-Disc           Closed
                 I-Rcv-DPR        I-Snd-DPA,       Closed
                                  I-Disc
                 I-Peer-Disc      I-Snd-DPR        Closing
                 I-Rcv-CER        Error            Closed
                 I-Rcv-CEA        Error            Closed

Thanks,

PatC