Subject: [AAA-WG]: [Issue]: Diameter -07 introduction needs improvement

From: Randy Bush <[email-masked]>
Date: Wed, 05 Sep 2001 09:19:11 -0700

Description of issue: Diameter -07 introduction needs improvement

Submitter name: Randy Bush
Submitter email address: [email-masked] 
Date first submitted: 2001.09.03
Reference: 
Document: base
Comment type: E 
Priority: S 
Section: 1.0, 1.1
Rationale/Explanation of issue: 

The Introduction (section 1.0) talks about the history and motivation for
the development of Diameter. Section 1.1 talks about the basic building
blocks of Diameter. Section 2 provides an overview of protocol
concepts. What would be helpful is if a high-level introduction could
be provided within section 1. The material currently in section 1.1 might
be better moved to section 2.

Requested change: 

To provide context, the following topics would be useful in the
Introduction:
     
     a. An overview of the Diameter approach
            1. Relationship of NASes, Servers and Intermediaries
            2. Message routing concepts
            3. Requests, Responses, Unsolicited messages

     b. Important ways that Diameter differs from RADIUS
        (Idea is to introduce the concepts, not go into
         depth, but make clear what the feature is attempting
         to achieve. Reference where details are provided.)
            1. Peer-to-peer nature
            2. Explicit support for intermediaries
            3. Connection-oriented versus connectionless
            4. Concept of extensions
            5. Built-in failover support
            6. Larger attribute space 
            7. Integrated accounting
            8. Mandatory bit
            9. Application-layer ACKs and error messages
           10. Unsolicited server messages
           11. Peer discovery
           12. Capabilities negotiation (worth explaining why
               this isn't e2e here)

     c. Description of the Diameter document set and relationship
        between the documents.
 
     d. Approach to extensibility (this is in section 2.3, but might
        be better consolidated into the Introduction)

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 5 Sep 2001 09:13:35 -0700

Thanks for opening the issue. We'll take care of that.

What I find interesting, though, is that most of this was in the framework document,
which the WG decides to abandon some time ago. Now we need to pull some of the
text from the framework into the base protocol.

I do agree, though, that this is a good idea.

PatC

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 5 Sep 2001 10:56:09 -0700 (PDT)

> text from the framework into the base protocol.

We abandoned it with the understanding that the appropriate material would
find its way into base.

---

From: "Glen Zorn" <[email-masked]>
Date: Wed, 5 Sep 2001 11:16:38 -0700

> We abandoned it with the understanding that the appropriate material would

The good news is that only one more author (Ping Pan) needs to be added to
the base ;-)

---

From: Randy Bush <[email-masked]>
Date: Wed, 05 Sep 2001 11:24:48 -0700

> The good news is that only one more author (Ping Pan) needs to be added to

imiho, it is time to have an editor on the front page and a section in the
body for contributor credits.  the iesg is starting to push back on the
massive author list, which is especially prevalent in some sub-ip wgs.

randy

---

From: "Glen Zorn" <[email-masked]>
Date: Wed, 5 Sep 2001 11:34:04 -0700

> massive author list, which is especially prevalent in some sub-ip wgs.

Well, this author list isn't all that massive.  Just out of curiosity,
though, doesn't the IESG have better things to do (say, reviewing technical
content ;-) than worrying about the size of author lists?  I'm not, by the
way, referring to either of _our_ esteemed ADs; however, I personally know
of at least one I-D which passed WG Last Call and languished for at least 4
months before the relevant AD even _looked_ at it...

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 5 Sep 2001 11:42:22 -0700

> We abandoned it with the understanding that the appropriate material would

So perhaps the issue was the "appropriate material" was never really defined.

In any case, onto work...

PatC