Subject: [Ace] Purpose of this list

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 10 Dec 2013 22:10:45 -0000

Hi,

I like the name, and I think security is a good thing.

There is clearly some overlap between this proposal and what the DICE working
group is doing.

I would also like to understand whether the intention is to provide security at
a particular layer in constrained networks or across all layers of the
constrained network.

Since the description of the mailing list is both very specific and very vague,
can I call on the proponents of this work to post more explanation as soon as
possible.

Thanks,
Adrian

---

From: Stefanie Gerdes <[email-masked]>
Date: Wed, 11 Dec 2013 00:39:18 +0100

Hi Adrian,

I am glad that people are already interested in this discussion group.
The reason for creating this mailing list was a discussion about
authorization in the CoRE WG in Berlin and Vancouver. The feeling in
Vancouver was that only some of this work can be done in CoRE while some
other topics might fit better into the security area.

> There is clearly some overlap between this proposal and what the DICE working

You are correct that some topics are close to the work of the DICE
working group and the DICE chairs were involved in some of the
discussions in Vancouver. DICE is focused on DTLS improvements, though,
and the topics we want to discuss in ACE don't really fit in there.

> can I call on the proponents of this work to post more explanation as soon as

We are currently working on a more meaningful proposal which will
hopefully answer a lot of questions.

Best regards,
Steffi

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 11 Dec 2013 00:53:07 +0100

Adrian,

On 11 Dec 2013, at 00:39, Stefanie Gerdes <[email-masked]> wrote:

>  The feeling in

One view of how that might be worked is on slide 105 of 
	http://www.ietf.org/proceedings/88/slides/slides-88-core-0.pdf

Now this slide takes the view that the work that is closely intertwined with the base standard should happen in CoRE and that work with a high level of security content should happen in a new SEC area WG (called WGX there), with DICE certainly being part of the overall picture where the DTLS and related certificate issues dominate.  But, of course, in the end we have to make sure we assemble the right constituency in the right WGs.  How the division of work should look like in detail will be the subject of the discussion now and leading up to IETF89.

Re your question on whether this work might be useful on other layers than the application protocol:  Much of what we are trying to to (get devices to be verifiably authorized to do something wich each other) is often somewhat misleadingly subsumed under “key management”.  We will try to use CoAP and DTLS to perform operations on authorizations and related keying materials, but the authorizations we operate might very well cover more than application layer (CoRE) resources.  We need to find out how far the technical approaches here can carry us.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Wed, 11 Dec 2013 08:42:39 -0500

I second Adrian's question/confusion.
What about SOLACE?   Michael Behring has a lot of content that he is trying
to get into his behring-homenet-bootstrap document, but really it does not
fit into homenet, dice, roll, 6tisch, 6lo.

I think that we need a workshop, one to follow on from the pre-Paris IETF83
workshop, but this time, with less PPT and more focus on addressing
enrollment and authorization.

I think that we are all in violent agreement about what needds to happen, but
I think that many are scared to admit it, and we need a tygerteam to do a
prototype/spike implementation in order to bring the issues more clearly into
focus.  That is, this is a case running code followed by some rough consensus.

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Michael Richardson <[email-masked]>
Date: Wed, 11 Dec 2013 08:46:06 -0500

Carsten Bormann <[email-masked]> wrote:
    > Re your question on whether this work might be useful on other layers
    > than the application protocol:  Much of what we are trying to to (get
    > devices to be verifiably authorized to do something wich each other) is
    > often somewhat misleadingly subsumed under “key management”.  We will
    > try to use CoAP and DTLS to perform operations on authorizations and
    > related keying materials, but the authorizations we operate might very
    > well cover more than application layer (CoRE) resources.  We need to
    > find out how far the technical approaches here can carry us.

I concur completely, and want to +1 that this is not a key managemenet
problem.

Let's solve the problem for light switches acting on light bulbs, and given
that infrastructure/architecture,  extend it later towards motes acting as
router nodes, or joining layer-2 PANs.

---

From: Likepeng <[email-masked]>
Date: Thu, 12 Dec 2013 07:14:55 +0000

Hi Michael,

>What about SOLACE?

There is a mailing list for this. The last email in this mailing list is this one:
http://www.ietf.org/mail-archive/web/solace/current/msg00046.html

If I understand correctly from the discussion, the group is not satisfied to create a IRTF group for that. I think ace activity is partially based on the previous discussion, but with a focus on the authentication/authorization part.

>I think that we need a workshop, one to follow on from the pre-Paris IETF83 workshop, but this time, with less PPT and more focus on addressing enrollment and authorization.

I don’t think workshop helps. We had workshop before in Paris, and we had group discussion in Berlin, Bar BoF and several group discussions in Vancouver, several drafts on the table. So I believe now it is the time to try to set up a new WG. 

>I think that we are all in violent agreement about what needs to happen, but I think that many are scared to admit it, and we need a tygerteam to do a prototype/spike implementation in order to bring the issues more clearly into focus.  That is, this is a case running code followed by some rough consensus.

Yes, it will be good to have implementations.

Thanks,
Kind Regards
Kepeng

-----邮件原件-----
发件人: Ace [mailto:[email-masked]] 代表 Michael Richardson
发送时间: 2013年12月11日 21:43
收件人: [email-masked]
主题: Re: [Ace] Purpose of this list

I second Adrian's question/confusion.
What about SOLACE?   Michael Behring has a lot of content that he is trying
to get into his behring-homenet-bootstrap document, but really it does not fit into homenet, dice, roll, 6tisch, 6lo.

I think that we need a workshop, one to follow on from the pre-Paris IETF83 workshop, but this time, with less PPT and more focus on addressing enrollment and authorization.

I think that we are all in violent agreement about what needs to happen, but I think that many are scared to admit it, and we need a tygerteam to do a prototype/spike implementation in order to bring the issues more clearly into focus.  That is, this is a case running code followed by some rough consensus.