Subject: [Ace] Pete Resnick's No Objection on charter-ietf-ace-00-01: (with COMMENT)

From: "Pete Resnick" <[email-masked]>
Date: Tue, 13 May 2014 21:02:55 -0700

Pete Resnick has entered the following ballot position for
charter-ietf-ace-00-01: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/charter-ietf-ace/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I would generally ask whether the requirements and use cases (r&uc)
document needs to be output from the WG or can (at the WG's and AD's
discretion) simply be an internal document that never gets published as
an RFC (I don't think it needs to be), but the suggested milestones make
me even more convinced that there is no need to publish the document:
It's clear that the development of the protocol will be in parallel with
the development of the r&uc. Given that, it's clear that the charter is
not saying that the r&uc need to be nailed down before work can commence.
So I say make the submission to the IESG and publication of the r&uc
optional. No need for make-work if it turns out not to be interesting in
the long run.

---

From: Likepeng <[email-masked]>
Date: Mon, 19 May 2014 21:17:56 +0000

Hi Pete,

>No need for make-work if it turns out not to be interesting in the long run.

The group discussed this issue before, and the group prefers to publish the use cases & requirements as informative RFC:
https://www6.ietf.org/mail-archive/web/ace/current/msg00456.html

At the beginning of next month, there will be an informal interim meeting to discuss the problem description.

Also there was proposal to have pre-meeting in Toronto to discuss various topics.

Hannes and I believe that these activities can accelerate the progress on use case & requirements topic, and it should be finished much earlier.

So we propose to cut down the milestones for the use cases & requirements:

OLD:
Jul 2015 Submit “Use cases and Requirements” document to IESG for publication as informational RFC. 

NEW: 
Dec 2014 Submit "Use cases and Requirements" document to the IESG for publication as an Informational RFC.
END

Hope this helps.

Thanks,

Kind Regards
Kepeng & Hannes

-----邮件原件-----
发件人: Ace [mailto:[email-masked]] 代表 Pete Resnick
发送时间: 2014年5月14日 12:03
收件人: The IESG
抄送: [email-masked]
主题: [Ace] Pete Resnick's No Objection on charter-ietf-ace-00-01: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I would generally ask whether the requirements and use cases (r&uc) document needs to be output from the WG or can (at the WG's and AD's
discretion) simply be an internal document that never gets published as an RFC (I don't think it needs to be), but the suggested milestones make me even more convinced that there is no need to publish the document:
It's clear that the development of the protocol will be in parallel with the development of the r&uc. Given that, it's clear that the charter is not saying that the r&uc need to be nailed down before work can commence.
So I say make the submission to the IESG and publication of the r&uc optional. No need for make-work if it turns out not to be interesting in the long run.

_______________________________________________
Ace mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ace

---

From: Jari Arkko <[email-masked]>
Date: Tue, 20 May 2014 13:55:13 +0300

FWIW, in my opinion we at the IETF often focus too much on waterfall-type spec development, and extensive development of requirements and use cases is a part of that. I'd rather see us move more towards an incremental development model. 

Developing requirements and solutions in parallel works better for that, IMO, and it while it is of course OK for the WG to deliver an RFC, maybe it would be good to not require it. Particularly when with the current milestone dates, the project plan is starting to look like developing all requirements first and then when it is done, develop the solution.

> Dec 2014 Optionally, submit "Use cases and Requirements" document to the IESG for publication as an Informational RFC.

Jari