Subject: [Ace] Input for pre-WG meeting - paper on a delegation architecture

From: Rene Hummen <[email-masked]>
Date: Thu, 29 May 2014 09:04:04 +0000

Hello everyone,

I briefly showed a simple idea on how to delegate the DTLS session establishment to a dedicated server and to subsequently transfer the established session state to a constrained device in a session ticket during our meeting in Vancouver. Such delegation also affords authorization of secure communication involving constrained devices. We now have an accepted paper that presents this idea in more detail. You can find the paper here:
	http://www.comsys.rwth-aachen.de/fileadmin/papers/2014/2014-hummen-secon-delegation.pdf

Some of the presented aspects may be of interest within the scope of ACE. Specifically:
1) The session ticket can be store at the more powerful end-point, potentially relieving constrained devices from additional memory burden. The session ticket may also contain fine-granular authorizations based on RESTful resources. This is not described in the paper, but could be added, e.g., based on Appendix A in [1].
2) We consider revocation of authorized connections in the design of our delegation architecture. In doing so, we aim at preventing the need for time synchronization inside the constrained node network.
3) Constrained devices are only required to perform symmetric-key-based DTLS handshakes, thus especially reducing the computation and memory burden on constrained devices when compared to the use of public-key cryptography.
4) The delegation server may use any type of DTLS handshake (as long as it includes a session ticket exchange) for the session establishment and is not required to be online after the handshake delegation.

Unfortunately, I won’t be able to join your meeting in Stockholm. Still, my hope is that the information provided here is valuable input for your pre-WG meeting.

BR
René

[1] http://tools.ietf.org/html/draft-selander-core-access-control-02

--
Dipl.-Inform. Rene Hummen, Ph.D. Student
Chair of Communication and Distributed Systems
RWTH Aachen University, Germany
tel: +49 241 80 21426
web: http://www.comsys.rwth-aachen.de/team/rene-hummen/

---

From: Göran Selander <[email-masked]>
Date: Fri, 30 May 2014 06:43:09 +0000

Hi René

Thanks for your input. 

As people may not have the time to read it before the meeting I would like to summarize the content in the context of the meeting. I'll make a try, please correct me if I misunderstood. 

The topic for the meeting is problem description and solution components. Your main contribution to the problem description is issues with DTLS handshake in constrained devices, specifically with precise RAM requirements for a certain library. 

The main solution component presented is based on references such as [13] and [14] in the context of a Trusted Third Party, plus some additional authorization/revocation functionality of the TTP. 

I think this is useful input and 
encourage people who have the time to take a look at your paper. 

Thanks,
Göran

> On 29 maj 2014, at 11:04, "Rene Hummen" <[email-masked]> wrote:
> 
> Hello everyone,
> 
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: Rene Hummen <[email-masked]>
Date: Fri, 30 May 2014 09:12:27 +0000

Hi Göran,

thanks for the summary. Inline you find a few additional comments.

> The topic for the meeting is problem description and solution components. Your main contribution to the problem description is issues with DTLS handshake in constrained devices, specifically with p…

RAM requirements are only one aspect tackled in the paper. Specifically, we provide evaluation results regarding the RAM/ROM, computation, and transmission overheads for the certificate, symmetric-key, and session resumption handshakes of DTLS. This should provide a good overview of the overheads to be expected in constrained node networks.

In my opinion, especially the overheads incurred by the symmetric-key-based DTLS handshake could denote a baseline of comparison for solutions considered in the scope of ACE.

> The main solution component presented is based on references such as [13] and [14] in the context of a Trusted Third Party, plus some additional authorization/revocation functionality of the TTP.

Exactly, we use session tickets from the session resumption mechanism as a DTLS-native means to carry (implicit) authorization information from a TTP to a constrained device. These session tickets could also contain more fine-granular authorization information (see my previous email). As I understand from our pre-ACE discussions, these are two critical solution components.

Moreover, the topic of revocation came up a couple of times during our pre-ACE meetings. Hence, our ideas how to revoke authorizations may also be of interest for a solution in the context of ACE.

Thanks,
René