Subject: [Ace] Minor typos in draft-ietf-ace-cbor-web-token-01

From: Ludwig Seitz <[email-masked]>
Date: Thu, 18 Aug 2016 09:23:40 +0200

Hello,

I've noticed some minor things while trying to write code for CWTs:

1.) In section 5.1. it says:

"Create a CWT Claims Set containing the desired claims."

I'm pretty sure you meant a CBOR map of claims, because that is what you 
are showing in your examples.

2.) Also in section 5.1 it says:

"3.  Create a COSE Header containing the desired set of Header
      Parameters.  The CWT Header MUST be a valid according to the
      [I-D.ietf-cose-msg] specification."

Is it a COSE Header or a CWT Header you are referring to?

Also giving an example of what this header could look like would be nice.

3.) In section 5.2. it says:

"5.  If the JOSE Header contains a "content type""

That should be COSE Header or CWT Header.

Regards,

Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Samuel Erdtman <[email-masked]>
Date: Wed, 31 Aug 2016 17:50:14 +0200

See inline

> are showing in your examples.

I would say that the CWT Claims Set is a CBOR map of claims. Is that
unclear? I would prefer not to change.

> Is it a COSE Header or a CWT Header you are referring to?

One could argue either but I think we get less confusion by changing
according to your suggestion.
The COSE header is the header of the CWT i.e. a CWT header. in JOSE this
relation is closer then here

> That should be COSE Header or CWT Header.

You are right

>
>
> Regards,
>
> Ludwig
>
>
>
>
>
> --
> Ludwig Seitz, PhD
> SICS Swedish ICT AB
> Ideon Science Park
> Building Beta 2
> Scheelevägen 17
> SE-223 70 Lund
>
> Phone +46(0)70-349 92 51
> http://www.sics.se
>
>
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace
>
>