Subject: Re: [Ace] Reminder -- WGLC on draft-ietf-ace-cwt-proof-of-possession-02

From: Jim Schaad <[email-masked]>
Date: Sat, 16 Jun 2018 16:02:59 -0700

We have seen a number of messages on this document, but we have not yet seen
an updated draft that addresses all of these issues.  When should we expect
a new version.  It would have been nice to have had two published before
Montreal but that does not seem likely at this point.

Jim

> -----Original Message-----
> From: Ace <[email-masked]> On Behalf Of Roman Danyliw
> Sent: Wednesday, May 16, 2018 6:18 AM
> To: [email-masked]
> Subject: [Ace] Reminder -- WGLC on draft-ietf-ace-cwt-proof-of-possession-
> 02
> 
> Hello!
> 
> A reminder to the WG, draft-ietf-ace-cwt-proof-of-possession is in WGLC.
> Please send feedback to the mailing list by Wednesday, May 23.
> 
> Thanks,
> Roman and Jim
> 
> > -----Original Message-----
> > From: Ace [mailto:[email-masked]] On Behalf Of Roman Danyliw
> > Sent: Tuesday, May 08, 2018 6:19 PM
> > To: [email-masked]
> > Subject: [Ace] WGLC on draft-ietf-ace-cwt-proof-of-possession-02
> >
> > Hello!
> >
> > Consistent with the feedback from the editor team at the London
> > meeting, we are starting a working group last call (WGLC) for the
> > "Proof-of-Possession Key Semantics for CBOR Web Tokens (CWTs)" draft:
> >
> > ** draft-ietf-ace-cwt-proof-of-possession-02
> > **
> > https://tools.ietf.org/html/draft-ietf-ace-cwt-proof-of-possession-02
> >
> > Please send comments to the mailing list -- feedback on issues or
> > needed changes; as well as endorsements that this draft is ready.
> >
> > This WGLC will end on Wednesday, May 23, 2018.
> >
> > Thanks,
> > Roman and Jim
> >
> > _______________________________________________
> > Ace mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ace
> 
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 18 Jun 2018 12:02:32 +0000

Hi Jim,

I have made changes to the draft based on your review and the updated version of the document can be found at https://github.com/cwt-cnf/i-d/pull/13
However, I am not sure we have consensus on the changes.

Ciao
Hannes

-----Original Message-----
From: Jim Schaad [mailto:[email-masked]]
Sent: 17 June 2018 01:03
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Ace] Reminder -- WGLC on draft-ietf-ace-cwt-proof-of-possession-02

Jim

> > This WGLC will end on Wednesday, May 23, 2018.

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Mike Jones <[email-masked]>
Date: Mon, 18 Jun 2018 16:01:53 +0000

The proposed change to allow multiple PoP keys in a single "cnf" element introduces unnecessary syntactic and semantic ambiguity. It also breaks the semantic equivalence with RFC 7800. Hannes, you're right that there's not consensus to do this.

Please see my review of your pull request at

https://github.com/cwt-cnf/i-d/pull/13/files/b81205b292acb393592f2e803a47670e46928c73.

Thanks,

-- Mike

________________________________
From: Hannes Tschofenig <[email-masked]>
Sent: Monday, June 18, 2018 5:02:32 AM
To: Jim Schaad; [email-masked]
Cc: [email-masked]
Subject: RE: [Ace] Reminder -- WGLC on draft-ietf-ace-cwt-proof-of-possession-02

Hi Jim,

Ciao
Hannes

-----Original Message-----
From: Jim Schaad [mailto:[email-masked]]
Sent: 17 June 2018 01:03
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Ace] Reminder -- WGLC on draft-ietf-ace-cwt-proof-of-possession-02

Jim