Subject: [Ace] CWT-PoP & Multiple PoP keys

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 20 Jun 2018 06:57:02 +0000

Hi Jim,

I had a chat with Mike about relaxing the CWT-PoP spec to allow multiple PoP keys in a single CWT token.

He is concerned about the departure from RFC 7800 and, after giving it a bit more thoughts, I believe there is an issue. Initially, when we started the work our promise was that this is really just an alternative encoding of RFC 7800. With changes like those we are obviously breaking that concept. Having multiple keys within a single CWT is a corner case and I am not sure anymore whether I indeed want to go into that direction. In our implementation we are also not using multiple keys in a single CWT either.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Ludwig Seitz <[email-masked]>
Date: Wed, 20 Jun 2018 09:14:13 +0200

On 2018-06-20 08:57, Hannes Tschofenig wrote:
> He is concerned about the departure from RFC 7800 and, after giving it a 
> bit more thoughts, I believe there is an issue. Initially, when we 
> started the work our promise was that this is really just an alternative 
> encoding of RFC 7800. With changes like those we are obviously breaking 
> that concept. Having multiple keys within a single CWT is a corner case 
> and I am not sure anymore whether I indeed want to go into that 
> direction. In our implementation we are also not using multiple keys in 
> a single CWT either.
> 
> Ciao
> 
> Hannes
>

I agree that having multiple PoP keys in cnf for CWT-PoP seem like 
overkill. After all this is a draft aimed at constrained environments.
I also sympathize with Mike's suggestion to keep CWT-PoP aligned with 
RFC 7800.

/Ludwig

> IMPORTANT NOTICE: The contents of this email and any attachments are 
> confidential and may also be privileged. If you are not the intended 

Sending confidential email to a public mailing list again Hannes? You 
are a rebel ;-)

-- 
Ludwig Seitz, PhD
Security Lab, RISE SICS
Phone +46(0)70-349 92 51

---

From: Mike Jones <[email-masked]>
Date: Wed, 20 Jun 2018 15:48:07 +0000

Good.  Having resolved this, I believe we should be in position to do a release addressing the WGLC comments this week.

				-- Mike

-----Original Message-----
From: Ace <[email-masked]> On Behalf Of Ludwig Seitz
Sent: Wednesday, June 20, 2018 12:14 AM
To: [email-masked]
Subject: Re: [Ace] CWT-PoP & Multiple PoP keys

On 2018-06-20 08:57, Hannes Tschofenig wrote:
> He is concerned about the departure from RFC 7800 and, after giving it 
> a bit more thoughts, I believe there is an issue. Initially, when we 
> started the work our promise was that this is really just an 
> alternative encoding of RFC 7800. With changes like those we are 
> obviously breaking that concept. Having multiple keys within a single 
> CWT is a corner case and I am not sure anymore whether I indeed want 
> to go into that direction. In our implementation we are also not using 
> multiple keys in a single CWT either.
> 
> Ciao
> 
> Hannes
>

I agree that having multiple PoP keys in cnf for CWT-PoP seem like overkill. After all this is a draft aimed at constrained environments.
I also sympathize with Mike's suggestion to keep CWT-PoP aligned with RFC 7800.

/Ludwig

> confidential and may also be privileged. If you are not the intended

Sending confidential email to a public mailing list again Hannes? You are a rebel ;-)

-- 
Ludwig Seitz, PhD
Security Lab, RISE SICS
Phone +46(0)70-349 92 51

_______________________________________________
Ace mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ace