Subject: [Ace] Zaheduzzaman Sarker's No Objection on draft-ietf-ace-oauth-params-13: (with COMMENT)

From: Zaheduzzaman Sarker via Datatracker <[email-masked]>
Date: Wed, 24 Mar 2021 02:30:36 -0700

Zaheduzzaman Sarker has entered the following ballot position for
draft-ietf-ace-oauth-params-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ace-oauth-params/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

* Section 1:
   Nit : s/Respresentation/Representation

* Section 3.1:
  I have similar observation as Martin Duke, and the resolution suggested by
  author looks fine with me as long as the cases are distinguishable.

* Section 12:
   Refers to draft-ietf-ace-oauth-authz-33, -38 version is available now.

---

From: Seitz Ludwig <[email-masked]>
Date: Fri, 26 Mar 2021 07:16:53 +0000

Hello Zaheduzzaman,

Thank you for your review. The issues you found are now fixed in version -14.

Note that there seems to be an problem with xml2rfc, since the outdated reference to draft-ietf-ace-oauth-authz-33 should have been taken care of by the tooling.
I have notified the maintainer of xml2rfc and fixed the draft manually.

/Ludwig

> -----Original Message-----
> From: Zaheduzzaman Sarker via Datatracker <[email-masked]>
> Sent: den 24 mars 2021 10:31
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [EXTERNAL] Zaheduzzaman Sarker's No Objection on draft-ietf-ace-
> oauth-params-13: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
>

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Fri, 26 Mar 2021 14:03:38 +0000

Thanks for the update. My comments are addressed now.

Found a nit : It is RECOMMENDED that an AS reject a request
      containing a symmetric key value in the 'req_cnf' field
      (kty=Symmetric), since the AS is expected to be able to generate
      better symmetric keys than a constrained client. client (Note: this does
      not apply to key identifiers referencing a symmetric key).

s/reject/rejects

BR
Zahed

On 2021-03-26, 08:17, "iesg on behalf of Seitz Ludwig" <[email-masked] on behalf of [email-masked]> wrote:

    Hello Zaheduzzaman,

    /Ludwig

---

From: Seitz Ludwig <[email-masked]>
Date: Fri, 26 Mar 2021 14:07:52 +0000

Hello Zahed,

If it's ok with you I'll fix that in conjunction with the IETF-editor review (they will probably find a few more like this).

/Ludwig

> From: Zaheduzzaman Sarker <[email-masked]>
> Sent: den 26 mars 2021 15:04
> To: Seitz Ludwig <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [EXTERNAL] Zaheduzzaman Sarker's No Objection on draft-ietf-
> ace-oauth-params-13: (with COMMENT)
> 
> On 2021-03-26, 08:17, "iesg on behalf of Seitz Ludwig" <iesg-
> [email-masked] on behalf of [email-masked]> wrote:
> 
>     Hello Zaheduzzaman,
> 
>     Note that there seems to be an problem with xml2rfc, since the outdated
> reference to draft-ietf-ace-oauth-authz-33 should have been taken care of
> by the tooling.
> email

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Fri, 26 Mar 2021 14:09:19 +0000

Sure. Thanks.

BR
Zahed

On 2021-03-26, 15:08, "Seitz Ludwig" <[email-masked]> wrote:

    Hello Zahed,

    /Ludwig