Subject: [Acme] Adopt two email-related drafts

From: "Salz, Rich" <[email-masked]>
Date: Thu, 8 Jun 2017 15:35:47 +0000

At the interim, we had strong consensus to adopt Alexsey's draft (was one, is now two) on ACME challenges and certs for email services and users:

  https://datatracker.ietf.org/doc/draft-melnikov-acme-email-smime/

  https://datatracker.ietf.org/doc/draft-melnikov-acme-email-tls/

If you are opposed to adoption, please post to the list by the end of next week.

--
Senior Architect, Akamai Technologies
Member, OpenSSL Dev Team
IM: [email-masked] Twitter: RichSalz

---

From: Russ Housley <[email-masked]>
Date: Thu, 8 Jun 2017 15:50:16 -0400

> At the interim, we had strong consensus to adopt Alexsey’s draft (was one, is now two) on ACME challenges and certs for email services and users:
>  
>   https://datatracker.ietf.org/doc/draft-melnikov-acme-email-smime/ <https://datatracker.ietf.org/doc/draft-melnikov-acme-email-smime/>
Why is the email address limited to all ASCII?  The LAMPS WG is almost done with the document for a certificate to include internationalized email addresses in certificates, so I would like to see them included here too.
  
>   https://datatracker.ietf.org/doc/draft-melnikov-acme-email-tls/ <https://datatracker.ietf.org/doc/draft-melnikov-acme-email-tls/>
I hope we are not depended in any way on AUTH=SCRAM-SHA-1.

Russ

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 9 Jun 2017 10:10:10 +0100

Russ,

On 08/06/2017 20:50, Russ Housley wrote:

>> At the interim, we had strong consensus to adopt Alexsey’s draft (was 
>> one, is now two) on ACME challenges and certs for email services and 
>> users:
>> _https://datatracker.ietf.org/doc/draft-melnikov-acme-email-smime/_
>
> Why is the email address limited to all ASCII?  The LAMPS WG is almost 
> done with the document for a certificate to include internationalized 
> email addresses in certificates, so I would like to see them included 
> here too.

I've done the quickest job I could do to get something published before 
the ACME Interim. As email addresses require new ACME identity type 
anyway, supporting Internationalized Emails should be relatively 
straightforward.
So yes, I am happy to do that.
>
>> _https://datatracker.ietf.org/doc/draft-melnikov-acme-email-tls/_
>

There is no obvious dependency on SCRAM at this point. If you are 
talking about example EHLO response, it includes all sort of other 
capabilities that are not relevant. I am happy to clarify this in the 
document.

Best Regards,
Alexey

---

From: Russ Housley <[email-masked]>
Date: Fri, 9 Jun 2017 12:27:26 -0400

> I've done the quickest job I could do to get something published before the ACME Interim. As email addresses require new ACME identity type anyway, supporting Internationalized Emails should be relatively straightforward.
> There is no obvious dependency on SCRAM at this point. If you are talking about example EHLO response, it includes all sort of other capabilities that are not relevant. I am happy to clarify this in the document.

Good.  I’m pleased to see these documents become the starting point for the WG.

Russ