Subject: [Acme] Mail regarding draft-ietf-acme-tls-alpn

From: Ben Sykes <[email-masked]>
Date: Fri, 25 May 2018 08:09:01 -0700

Hi there,

Having read through the draft spec, I have a concern over certificate
renewals.
As I read it, the server would have to temporarily use a customized
self-signed certificate while the check is pending. Won't this mean any
regular user connecting to that server over TLS at the time be presented
with the self-signed certificate? This would manifest as downtime for the
service.
Is there a provision for renewal using this method?

Thanks,
Ben

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 25 May 2018 15:38:10 +0000

*   As I read it, the server would have to temporarily use a customized self-signed certificate while the check is pending.

If you renew before the current cert expires, that’s not an issue, right?

---

From: Ilari Liusvaara <[email-masked]>
Date: Fri, 25 May 2018 19:42:59 +0300

> Is there a provision for renewal using this method?

AFAIK, there is no way to construct a validation method that is all of:

- Can be used by "public" CAs.
- TLS-level.
- Operates on port 443.
- No downtime.
- No special application or TLS library support required.

TLS-ALPN fails the last line (if you do not have special application or
TLS library support, you take downtime).

I have cooked an experimental version of TLS library I have written,
with the needed support to answer the validation queries with no
downtime (also internally generating the needed certificate from name
-> key authorization mapping). 

-Ilari

---

From: Roland Shoemaker <[email-masked]>
Date: Fri, 25 May 2018 11:07:48 -0700

The validation certificate should only ever be served for requests that negotiate the amce-tls/1 application protocol, which browsers or equivalent user software should never do. This allows the server (or load balancer) to continue serving normal traffic to users while also serving validation traffic to the ACME server.

> On May 25, 2018, at 8:09 AM, Ben Sykes <ben=[email-masked]> wrote:
> 
> Hi there,
> 
> Having read through the draft spec, I have a concern over certificate renewals.
> As I read it, the server would have to temporarily use a customized self-signed certificate while the check is pending.. Won't this mean any regular user connecting to that server over TLS at the time be presented with the self-signed certificate? This would manifest as downtime for the service.
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme

---

From: Ben Sykes <[email-masked]>
Date: Fri, 25 May 2018 13:23:12 -0700

Ah ok. Got it.
That's good.
On Fri, May 25, 2018 at 11:07 AM Roland Shoemaker <[email-masked]>
wrote:

> The validation certificate should only ever be served for requests that
> negotiate the amce-tls/1 application protocol, which browsers or equivalent
> user software should never do. This allows the server (or load balancer) to
> continue serving normal traffic to users while also serving validation
> traffic to the ACME server.
>
> self-signed certificate while the check is pending.. Won't this mean any