Subject: [Acme] I-D Action: draft-ietf-acme-acme-16.txt

From: [email-masked]
Date: Fri, 12 Oct 2018 11:57:51 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Automated Certificate Management Environment WG of the IETF.

        Title           : Automatic Certificate Management Environment (ACME)
        Authors         : Richard Barnes
                          Jacob Hoffman-Andrews
                          Daniel McCarney
                          James Kasten
	Filename        : draft-ietf-acme-acme-16.txt
	Pages           : 90
	Date            : 2018-10-12

Abstract:
   Public Key Infrastructure X.509 (PKIX) certificates are used for a
   number of purposes, the most significant of which is the
   authentication of domain names.  Thus, certification authorities
   (CAs) in the Web PKI are trusted to verify that an applicant for a
   certificate legitimately represents the domain name(s) in the
   certificate.  Today, this verification is done through a collection
   of ad hoc mechanisms.  This document describes a protocol that a CA
   and an applicant can use to automate the process of verification and
   certificate issuance.  The protocol also provides facilities for
   other certificate management functions, such as certificate
   revocation.

   RFC EDITOR: PLEASE REMOVE THE FOLLOWING PARAGRAPH: The source for
   this draft is maintained in GitHub.  Suggested changes should be
   submitted as pull requests at https://github.com/ietf-wg-acme/acme
   [1].  Instructions are on that page as well.  Editorial changes can
   be managed in GitHub, but any substantive change should be discussed
   on the ACME mailing list ([email-masked]).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-acme-acme/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-acme-acme-16
https://datatracker.ietf.org/doc/html/draft-ietf-acme-acme-16

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-acme-16

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Richard Barnes <[email-masked]>
Date: Fri, 12 Oct 2018 15:03:31 -0400

This draft contains the latest (final?) round of changes:

Minor fixes related to POST-as-GET (#454)
Fixed typo: 'appear' instead of 'apper'. (#456)
Fix cross-reference in IANA considerations (#461)
Remove exception for certificate GET. (#459)
Tweak security concerns for URL correlations. (#463)
Forbid the use of 'nonce' in account roll-over (#464)
Revert "Revert "Randomize URLs in examples (#455)" (#458)" (#460)

Chairs, ADs: I believe this addresses all known issues and is ready to
proceed to the RFC Editor.

--Richard

On Fri, Oct 12, 2018 at 2:58 PM <[email-masked]> wrote:

> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 12 Oct 2018 19:12:04 +0000

*   Chairs, ADs: I believe this addresses all known issues and is ready to proceed to the RFC Editor.

I believe so, too.  Can the AD’s work with the IESG to move this forward?
--Richard

On Fri, Oct 12, 2018 at 2:58 PM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

   RFC EDITOR: PLEASE REMOVE THE FOLLOWING PARAGRAPH: The source for
   this draft is maintained in GitHub.  Suggested changes should be
   submitted as pull requests at https://github.com/ietf-wg-acme/acme<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_ietf-2Dwg-2Dacme_acme&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=RKDb7tlPT6sMZ6l8vPU9RQ4DKnrr9zKmlepKuk1LWiM&s=B1Q263xwiXR9Kt0Q_PKzgh3GcJEOUU3-KtoyMvc1Kv4&e=>
   [1].  Instructions are on that page as well.  Editorial changes can
   be managed in GitHub, but any substantive change should be discussed
   on the ACME mailing list ([email-masked]<mailto:[email-masked]>).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-acme-acme/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dacme-2Dacme_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=RKDb7tlPT6sMZ6l8vPU9RQ4DKnrr9zKmlepKuk1LWiM&s=wYFmFjbN-84L6gNwvegzScWfcdUbq6AzMObFH1pTVJk&e=>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-acme-acme-16<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dacme-2Dacme-2D16&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=RKDb7tlPT6sMZ6l8vPU9RQ4DKnrr9zKmlepKuk1LWiM&s=5hCsfagZ9xS2Xb2AVRlfH2dyQSXtaVchBcQ2Qub6tc4&e=>
https://datatracker.ietf.org/doc/html/draft-ietf-acme-acme-16<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dacme-2Dacme-2D16&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=RKDb7tlPT6sMZ6l8vPU9RQ4DKnrr9zKmlepKuk1LWiM&s=-k613Vf1dn7fXp6MnwZpjC-9aDPIAgcB7a4z3ibKS9Q&e=>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-acme-16<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dacme-2Dacme-2D16&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=RKDb7tlPT6sMZ6l8vPU9RQ4DKnrr9zKmlepKuk1LWiM&s=FSeB7kbqjckMUMkgXZ-5FD9_FJmcjTuL3ZOOShSOu7w&e=>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=RKDb7tlPT6sMZ6l8vPU9RQ4DKnrr9zKmlepKuk1LWiM&s=XpYJMvz1Ok-7J94YP8E7B-TaTnd_dtZeufKn7BOg61o&e=>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=RKDb7tlPT6sMZ6l8vPU9RQ4DKnrr9zKmlepKuk1LWiM&s=_ePbPORnaOf7hHQea-nDerrKCf7CLcoSIY6uJEX2GoE&e=>

_______________________________________________
Acme mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/acme<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_acme&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=RKDb7tlPT6sMZ6l8vPU9RQ4DKnrr9zKmlepKuk1LWiM&s=e8RemmII_hSJamvfKE9jgQqCJJMLkncQnF9RmqT0pAM&e=>