Subject: Re: [Actn] Charter - An Early Proposal

From: Dhruv Dhody <[email-masked]>
Date: Wed, 5 Mar 2014 14:33:10 +0000

Hi Dan,

Here are some suggestions  on the charter text.

OLD:
Transport networks have a variety of mechanisms to facilitate separation of
data plane and control plane, distributed signaling for path setup and
protection, and centralized path computation and traffic engineering. These
represent key technologies for enabling flexible and dynamic networking and
efficient control and protection of resources.
NEW:
Transport networks have a variety of mechanisms to -
* Facilitate separation of data plane and control plane
* Distributed signaling for path setup and protection
* Support for centralized path computation and traffic engineering.
These represent key technologies for enabling flexible & dynamic networking
along with efficient control & protection of resources.
Rationale:
There are multiple 'and' in the original sentence which was confusing.

OLD:
Coordination of underlying transport layers and presentation as an
abstracted topology to the customer.
NEW:
Coordination of underlying transport layers/domains and presentation as a
consolidated abstract topology to the customer.

Some text may be needed to specify
- The recursive nature of ACTN
- Dynamic nature via programability

I was also wondering should have some text on trust model (security),
policy etc.

Also do you see a need to better define the scope - what would we be
working on if chartered and what would be out of scope? What interfaces may
be standardized? Or is it too early to think of that?

Regards,
Dhruv

On Fri, Feb 28, 2014 at 5:51 PM, King, Daniel <[email-masked]>wrote:

>  Hi ACTN list,
>
>
>
> To help discussions at IETF89 (London), we put together a very early
> charter proposal to help scope the problem and solution space:
>
>
>
> https://sites.google.com/site/actnbof/
>
>
>
> Please review the text and comment. It would be great to move the ACTN
> offline discussions online, so please do not be shy to engage on the list.
>
>
>
> Br, Dan.
>
> _______________________________________________
> ACTN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/actn
>
>

---

From: Leeyoung <[email-masked]>
Date: Thu, 6 Mar 2014 10:18:24 +0000

Hi Dhruv,

Thanks for your suggestion on the charter text. Please see inline for my comment.

Regards,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Wednesday, March 05, 2014 8:33 AM
To: King, Daniel
Cc: [email-masked]
Subject: Re: [Actn] Charter - An Early Proposal

Hi Dan,

OLD:
Transport networks have a variety of mechanisms to facilitate separation of data plane and control plane, distributed signaling for path setup and protection, and centralized path computation and traffic engineering. These represent key technologies for enabling flexible and dynamic networking and efficient control and protection of resources.
NEW:
Transport networks have a variety of mechanisms to -
* Facilitate separation of data plane and control plane
* Distributed signaling for path setup and protection
* Support for centralized path computation and traffic engineering.
These represent key technologies for enabling flexible & dynamic networking along with efficient control & protection of resources.
Rationale:
There are multiple 'and' in the original sentence which was confusing.

YOUNG>> Agreed.

OLD:
Coordination of underlying transport layers and presentation as an abstracted topology to the customer.
NEW:
Coordination of underlying transport layers/domains and presentation as a consolidated abstract topology to the customer.

YOUNG>> Good point. Consolidated abstract topology encompassing layers/domains is one of the unique characteristics of ACTN. Thanks for point this out clearly.

Some text may be needed to specify
- The recursive nature of ACTN
- Dynamic nature via programmability

YOUNG>> We have this explanation in the framework and problem statement documents. Do you think we need to give detail explanation here?

I was also wondering should have some text on trust model (security), policy etc.

YOUNG>> We will add some security/policy text in the revision after today's meeting.

Also do you see a need to better define the scope - what would we be working on if chartered and what would be out of scope? What interfaces may be standardized? Or is it too early to think of that?

YOUNG>> I think this is a bit too early to put at this point, but certainly we need to be specific down the road.

Regards,
Dhruv

On Fri, Feb 28, 2014 at 5:51 PM, King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:
Hi ACTN list,

To help discussions at IETF89 (London), we put together a very early charter proposal to help scope the problem and solution space:

Please review the text and comment. It would be great to move the ACTN offline discussions online, so please do not be shy to engage on the list.

Br, Dan.

_______________________________________________
ACTN mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/actn