Subject: [Actn] comments on ACTN framework

From: "WRIGHT, STEVEN A" <[email-masked]>
Date: Fri, 7 Mar 2014 10:41:09 +0000

The SDN references in the framework are not particularly helpful and I would suggest to remove them or move to an appendix as they imply some specific implementation...

The abstracted topology is a data structure.  It might be useful to have the framework discuss the basic CRUD operations that can be performed on this data structure. This would help to separate the issues association with the creation of an abstracted topology from those associated with reading its current state. In combination with the roles identified, you would then have a basis for some discussion of the associated security issues, for example.

Best regards

Steven Wright, MBA, PhD, JD.
NFV & SDN Industry Engagement
Standards & Industry Alliances
AT&T Services Inc.
1057 Lenox Park Blvd NE, STE 4D28
Atlanta, GA 30319
P: 404.499.7030

[email-masked]<mailto:[email-masked]>

---

From: Leeyoung <[email-masked]>
Date: Mon, 10 Mar 2014 18:33:10 +0000

Hi Steven,

Thanks for your comment on the ACTN framework. Please see inline for my comment.

Best Regards,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of WRIGHT, STEVEN A
Sent: Friday, March 07, 2014 4:41 AM
To: [email-masked]
Subject: [Actn] comments on ACTN framework

YOUNG>> The SDN reference is used to bring up the reality of control plane and data plane separation in transport networks, namely, GMPLS/PCE. I am not sure if the reference does imply some specific implementation. It just gives some context for ACTN, as ACTN is building in top of physical control/management planes.

But as Nico brought up and Daniele's slides during a bar BoF, we are not precluding building network abstraction control over management plane based system. Is this your concern?

YOUNG>>  What is CRUD? Is this Create/Read/Update/Delete? If so, yes, I agree we need to elaborate CRUD operations on specific data structures we have in mind. Do you want to provide some text on the framework? We have not got into this data model details in the framework.
Best regards