Subject: Re: [Add] meeting hum: should the IETF take up this work?

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 31 Jul 2019 17:29:08 +0000

From: Eric Rescorla <[email-masked]>
> This seems to be assuming a number of facts about how ISPs behave that are not in evidence.

ISPs, like browsers and search portals, do not all have the same business models, practices, and cultures. Just as the Firefox browser is very different from Google Chrome, then so too is ISP-1 from ISP-2.

---

From: Tommy Jensen <[email-masked]>
Date: Wed, 31 Jul 2019 17:41:23 +0000

Maybe a good way to empower UXs, app or platform, to inform the user about their different DNS options would be to build user-centric information into a feature discovery protocol for RRs. This would allow RRs committed to user value to advertise the features they want the user to know about.

For example, RRs could provide answers to stub questions such as:

  *   Maximum length of time (in seconds) personal data is retained
  *   Maximum length of time (in seconds) anonymized data is retained
  *   URL where RRs privacy or other legal policies can be discovered
  *   Does or does not (boolean) filter or block results from authoritative sources
     *   Might be expected to be true for "clean filter" DNS services
  *   ...

This would allow stubs to build UXs that provide red/green checkmarks and recommendations such as "Your current DNS server keeps your data longer than this other server we recommend configuring instead". This would help separate privacy friendly ISPs from the rogue airport/coffee shop Wi-Fi ISPs that couldn't care less at run time.

Thanks,
Tommy
________________________________
From: Add <[email-masked]> on behalf of Livingood, Jason <[email-masked]>
Sent: Wednesday, July 31, 2019 10:29 AM
To: [email-masked] <[email-masked]>
Subject: Re: [Add] meeting hum: should the IETF take up this work?

--
Add mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fadd&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7C913ab902f70043663d5608d715dca716%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637001909757322923&amp;sdata=QASynB6%2BqiWTpU%2FE9WipAaBLRxnB3Lxmvo%2FTAPFCg2U%3D&amp;reserved=0