Subject: [Add] A guide to set up your own round-robin DNS-over-HTTPS proxy for privacy

From: Rob Sayre <[email-masked]>
Date: Mon, 23 Sep 2019 19:08:25 -0700

Hi,

This seems like a pretty simple guide to setting up your own DoH proxy:
https://dohproxy.com/

There are some comments here:
https://news.ycombinator.com/item?id=21054436

thanks,
Rob

---

From: Petr Špaček <[email-masked]>
Date: Tue, 24 Sep 2019 17:41:55 +0200

For reference: Very similar behavior can be achieved with DNS-over-TLS with Knot Resolver >= 4.2.0:

https://knot-resolver.readthedocs.io/en/stable/modules.html#forwarding-to-multiple-targets

The difference is that Knot Resolver distributes domains using Public Suffix List instead of round robin, which should make statistical analysis somewhat harder (we hope).

Petr Špaček  @  CZ.NIC