Subject: Re: [Add] DoH/DoT subject of antitrust inquiry

From: Christian Huitema <[email-masked]>
Date: Mon, 30 Sep 2019 09:37:03 -0700

> On Sep 30, 2019, at 8:55 AM, Michael Sinatra <[email-masked]> wrote:
> 
> The original article is in the WSJ, so it's probably paywalled.  Here's
> a free one, but it's just based on the WSJ article:
> 
> https://gizmodo.com/house-antitrust-investigators-now-scrutinizing-googles-1838601830
> 
> I am not sure where to start in terms of all the ways in which I
> disagree with the antitrust approach...

The article mentions one real issue behind the lawsuit: the ISP want to continue being able to sell consumer data to advertisers. So much for the other arguments.

-- Christian Huitema

---

From: S Moonesamy <[email-masked]>
Date: Tue, 01 Oct 2019 00:55:30 -0700

Hi Michael,
>disagree with the antitrust approach...

Please see the letter at 
https://www.ncta.com/sites/default/files/2019-09/Final%20DOH%20LETTER%209-19-19.pdf 
I'll skip the antitrust angle.  The specification was standardized in 
the IETF.  It can be implemented in application.  In this case, it is 
implemented and deployed in at least two web browsers.  One of the 
points in the letter is about centralization of DNS.  One of the web 
browser vendors stated that it does not want to encourage that.  Now, 
that is viewed as an issue.

Regards,
S. Moonesamy

---

From: Vittorio Bertola <[email-masked]>
Date: Tue, 1 Oct 2019 15:24:49 +0200 (CEST)

> Il 30 settembre 2019 17:55 Michael Sinatra <[email-masked]> ha scritto:
> 
>  

IMHO, if Do* deployment is used to push DNS resolution away from ISPs and into the hands of browsers and their business partners, it alters market dynamics on DNS-based services where browsers/public resolvers and ISPs compete for the same customers, i.e. DNS resolution itself and any value-added services on top of it. However, the anticompetitive effect only appears if the browser changes the resolver that the user would otherwise connect to.

In the end, a dominant browser pushing users to use a specific DNS resolver is not different from a dominant operating system pushing users to use a specific browser - something that was recognized anticompetitive 20 years ago.

-- 
 
Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Kenji Baheux <[email-masked]>
Date: Tue, 1 Oct 2019 18:00:33 +0200

We have said several times in multiple places that we have no plans to
change the user's DNS provider (email sent to DNS related IETF ML, replies
to press articles, blog post, etc).

Color me puzzled.

On Tue, Oct 1, 2019 at 5:53 PM Vittorio Bertola <vittorio.bertola=
[email-masked]> wrote:

> IMHO, if Do* deployment is used to push DNS resolution away from ISPs and
> into the hands of browsers and their business partners, it alters market
> dynamics on DNS-based services where browsers/public resolvers and ISPs
> compete for the same customers, i.e. DNS resolution itself and any
> value-added services on top of it. However, the anticompetitive effect only
> appears if the browser changes the resolver that the user would otherwise
> connect to.
>
> In the end, a dominant browser pushing users to use a specific DNS
> resolver is not different from a dominant operating system pushing users to
> use a specific browser - something that was recognized anticompetitive 20
> years ago.
>
> --
>
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

-- 
Kenji BAHEUX
Product Manager - Chrome
Google Japan

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 1 Oct 2019 16:30:16 +0000

>    The article mentions one real issue behind the lawsuit: the ISP want to continue being able to sell consumer data to advertisers. So much for the other arguments.

IMO the article is inaccurate on that point.

---

From: Michael Sinatra <[email-masked]>
Date: Tue, 1 Oct 2019 10:11:38 -0700

> The article mentions one real issue behind the lawsuit: the ISP want to continue being able to sell consumer data to advertisers. So much for the other arguments.

The best anti-competitive angle that I can come up with (from the
perspective of the authors of the letter is, "if Google can monetize
this data, we should be able to do so as well."  But the letter seems to
mis-characterize what Google is actually doing: "When a consumer or
enterprise uses Google’s Android phones or Chrome web browser, Android
or Chrome would make Google the encrypted DNS lookup provider by default
and most consumers would have limited practical knowledge or ability to
detect or reject that choice."

This seems to conflate Mozilla's Cloudflare-by-default policy with what
Google Chrome is doing, which I read as something more along the lines
of opportunistic encryption (if the user's configured DNS resolver
supports DoH, use that).

The letter leads with encryption as the major change, which appears to
have encouraged the media to pick this up as somehow an "anticompetitive
protocol," which I would also say is a mischaracterization.  As has been
pointed out on this and other lists, the protocol isn't the issue for
the most part, it's the application defaults.  *If* someone with a large
browser market share were to use the browser to direct encrypted data
toward a service they own, that could be seen as anticompetitive.  But
nobody is doing that--not yet.

So the letter is either wrong or it's a pre-emptive strike, akin to
saying "if Google, or anyone else, is thinking about doing this, don't."

michael

---

From: Vittorio Bertola <[email-masked]>
Date: Tue, 1 Oct 2019 20:25:10 +0200 (CEST)

Il 1 ottobre 2019 18:00 Kenji Baheux <[email-masked]> ha scritto:

We have said several times in multiple places that we have no plans to change the user's DNS provider (email sent to DNS related IETF ML, replies to press articles, blog post, etc).

Color me puzzled.

Yes, I also don't understand why those people are aiming at Google on this. One could argue that the matter needs to be discussed in general anyway, since at any time in the future any browser could change the policy and adopt one that affects competition. But presently, I think that the only approach which raises this kind of concerns is Mozilla's.

--