Subject: Re: [Add] Not looking at DNS privacy in isolation

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 29 Nov 2019 13:56:07 +0000

I’m not arguing that the local network not be considered a potential threat. Rather, that any network along the E2E path be considered a potential threat since the last hop network is not the only one able to surveil/block/modify DNS traffic.

JL

From: Patrick McManus <[email-masked]>
Date: Tuesday, November 26, 2019 at 2:02 PM
To: "Livingood, Jason" <[email-masked]>
Cc: Christian Huitema <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] Re: [Add] Not looking at DNS privacy in isolation

otoh the local network is probably responsible for the IP assignment and, especially when known to the end user, is capable of mapping that directly to real-life identity and other bits of profile linked to that identity. This gives them a somewhat unique threat attribute to be considered.

-P

On Tue, Nov 26, 2019 at 11:45 AM Livingood, Jason <[email-masked]<mailto:[email-masked]>> wrote:
On 11/24/19, 9:03 PM, "Add on behalf of Christian Huitema" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:
>    We can consider three actors: the local network provider, the DNS
    resolver, and the web hoster.and that the Each of them will receive some
    information about the transaction:

> * The local network will see the IP addresses of server and client, and
    the name of the fronting server in the "public" SNI. (The same
    information is available to all on path observers.)

[JL] As you note parenthetically this is true of any network along the end to end path between the client and the server. From a threat assessment standpoint those non-local network providers may be a greater risk (bumps in the wire), particularly as they are likely unknown to end users (such as transit networks or submarine link providers). So I would recommend you not focus on just a local network but more broadly to any network on the E2E path.

--
Add mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/add<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/add__;!rx_L75ITgOQ!QK8gEwNdYFlIrHhsbZESPysn2yQ0o-UmacFC_hFfcFN8Uk9jTHbH6oUMbHbaS9zJR6q-1Q$>

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 29 Nov 2019 10:18:51 -0800

That's definitely true! A local network is only one of the many places along a path that can perform surveillance, etc.

To Patrick's point, however, any entity that has a special relationship with the client, either by knowing more identity information or seeing a broader scope of traffic, can perform such a role more effectively. That can be a local network, a VPN resolver, or even a public resolver that can strongly correlate a connection from a client with a connection that has signed into some account, etc.

Once the contents of queries and SNI values are encrypted, the number of entities along a path that can easily correlate cleartext names with client identifiers is reduced. Someone can look at the traffic that is generated by a recursive resolver, but that is generally a large enough anonymity set to be less useful for surveillance.

Best,
Tommy

> On Nov 29, 2019, at 5:56 AM, Livingood, Jason <[email-masked]> wrote:
> 
> From: Patrick McManus <[email-masked] <mailto:[email-masked]>>
> To: "Livingood, Jason" <[email-masked] <mailto:[email-masked]>>
> Cc: Christian Huitema <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> On Tue, Nov 26, 2019 at 11:45 AM Livingood, Jason <[email-masked] <mailto:[email-masked]>> wrote:
>> On 11/24/19, 9:03 PM, "Add on behalf of Christian Huitema" <[email-masked] <mailto:[email-masked]> on behalf [email-masked] <mailto:[email-masked]>> wrote:
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/add <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/add__;!rx_L75ITgOQ!QK8gEwNdYFlIrHhsbZESPysn2yQ0o-UmacFC_hFfcFN8Uk9jTHbH6oUMbHbaS9zJR6q-1Q$>-- 
> Add mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/add <https://www.ietf.org/mailman/listinfo/add>