Subject: Re: [Add] Practical Observations from Encrypted DNS Deployments by Network Operators

From: Lanlan Pan <[email-masked]>
Date: Sun, 2 Aug 2020 01:42:59 +0800

Agree, CPE is not a terminal equipment.

For example，default CPE is customed by ISP, forwards the dns queries to ISP
DNS.
CPE can act as a DoT/DoH client.
If CPE offers DoT/DoH service at local network (not consider about the
certificate verification problem), it is hard to say the "end to end"
security for the terminal equipment.

Stephane Bortzmeyer <[email-masked]> 于2020年7月27日周一 下午10:30写道：

> On Thu, Jul 23, 2020 at 05:50:15PM +0100,
>  Chris Box (BT) <[email-masked]> wrote
>  a message of 87 lines which said:
>
> > These have been in force for some years. If Orange don't let you
> > change, they are most likely in breach of the French law which
> > adopts these regulations.
>
> IANAL (and I don't know if you are) but I guess the problem is in the
> definition of "terminal equipment of their choice". Some people may
> claim it is the PC (or smartphone), and that the CPE is actually part
> of the network, not a terminal equipment.
>
> --
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: Vittorio Bertola <[email-masked]>
Date: Mon, 3 Aug 2020 10:10:27 +0200 (CEST)

>     Il 01/08/2020 19:42 Lanlan Pan <[email-masked]> ha scritto:
>      
>      
Just for reference, "terminal equipment" in Europe is defined by directive 2008/63/EC:

'terminal equipment’ means:

(a) equipment directly or indirectly connected to the interface of a public telecommunications network to send, process or receive information; in either case (direct or indirect), the connection may be made by wire, optical fibre or electromagnetically; a connection is indirect if equipment is placed between the terminal and the interface of the network;

(b) satellite earth station equipment;

Of course, this then changes the question into: where is the "interface of a public telecommunications network" located? This is a definition that falls under the competence of each individual member State, so one could read this useful 94-page BEREC report that has information on each country:

https://berec.europa.eu/eng/document_register/subject_matter/berec/reports/8252-berec-report-on-the-location-of-the-network-termination-point

Bottom line: understanding regulation in Europe is not always immediate :-) But according to the report, almost all the countries that took a decision located the interface between the modem and the Internet, making the CPE "terminal equipment"; in one country this depends on who owns it.

--

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] mailto:[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Lanlan Pan <[email-masked]>
Date: Tue, 4 Aug 2020 20:46:59 +0800

Vittorio Bertola <[email-masked]> 于2020年8月3日周一 下午4:10写道：

> (a) equipment directly or indirectly connected to the interface of a
> public telecommunications network to send, process or receive information;
> in either case (direct or indirect), the connection may be made by wire,
> optical fibre or electromagnetically; a connection is indirect if equipment
> is placed between the terminal and the interface of the network;
>

On my personal option,  for home network environment (  PC/Mobile Phone
<--->  CPE <---> Internet  ),  CPE is not a teminal equipment, but  a
intermediate equipment on PC/Mobile Phone  <--->  Internet  connection.

Of course, this then changes the question into: where is the "interface of
> a public telecommunications network" located? This is a definition that
> falls under the competence of each individual member State, so one could
> read this useful 94-page BEREC report that has information on each country:
>
>
> Bottom line: understanding regulation in Europe is not always immediate
> :-) But according to the report, almost all the countries that took a
> decision located the interface between the modem and the Internet, making
> the CPE "terminal equipment"; in one country this depends on who owns it.
>

Of course,   for NTP scenario ( CPE <--> NTP Server ),  CPE is a terminal
equipment.
Personal technology discussion, nothing to do with BEREC.
Thanks, :-)

> [email-masked]