Subject: [Add] Draft-pp-add-resinfo

From: "Deen, Glenn" <[email-masked]>
Date: Mon, 17 Aug 2020 16:39:59 +0000

Hi ADD,

The responsible ADs and co-chairs for the various DNS WGs met recently to talk through where various drafts may fit better than where they were originally being discussed, and we wanted to suggest that the draft Draft-pp-add-resinfo which originally was being discussed on the DSNOPS list be discussed here on ADD as it’s a closer fit.       This has already been happening somewhat already, so this is mostly an attempt at clarification.

This is not a WG adoption of the draft, just recognizing that the ADD list would be the best fit for the material in the draft.

If anyone objects feel free to share your concerns.

Draft link:  https://datatracker.ietf.org/doc/html/draft-pp-add-resinfo

regards
ADD WG Chairs, Glenn Deen & David Lawrence

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 17 Aug 2020 19:12:54 +0000

> If anyone objects feel free to share your concerns.

Not an objection, but two questions:

- Is there a time plan for the call for adoption of draft-pp-add-resinfo?

- What about draft-pp-add-stub-upgrade? Was that omitted from the message by accident, or did you assume that we would roll that text into draft-pp-add-resinfo, or ... ?

--Paul Hoffman

---

From: "Deen, Glenn" <[email-masked]>
Date: Mon, 17 Aug 2020 20:15:20 +0000

Hi Paul,

Since draft-pp-add-stub-upgrade deals specifically with ADD's discovery work,  I think the assumption was that it would already be using the ADD list for discussion.     So more of a matter of assuming it was already in.

So to be clear - both drafts:   draft-pp-add-resinfo and draft-pp-add-stub-upgrade should be using the ADD list.

Regards
glenn

On 8/17/20, 12:13 PM, "Paul Hoffman" <[email-masked]> wrote:

    --Paul Hoffman

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 17 Aug 2020 19:14:46 -0400

The Resolver Info draft was originally adopted by DNSOP, so DNS people are
good with this work.
The registry it creates allows for more expressive information to be
extracted.  My only wish
is the authors could create several initial entries based on some of the
work they've done
implementing it.

tim

On Mon, Aug 17, 2020 at 12:40 PM Deen, Glenn <[email-masked]> wrote:

> Hi ADD,
>
>
>
> The responsible ADs and co-chairs for the various DNS WGs met recently to
> talk through where various drafts may fit better than where they were
> originally being discussed, and we wanted to suggest that the draft
> Draft-pp-add-resinfo which originally was being discussed on the DSNOPS
> list be discussed here on ADD as it’s a closer fit.       This has already
> been happening somewhat already, so this is mostly an attempt at
> clarification.
>
>
>
> This is not a WG adoption of the draft, just recognizing that the ADD list
> would be the best fit for the material in the draft.
>
>
>
> --
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 17 Aug 2020 19:20:33 -0400

Also, since I'm not a chair here, I can say that I think this work should
be adopted and worked in within ADD.

tim

On Mon, Aug 17, 2020 at 7:14 PM Tim Wicinski <[email-masked]> wrote:

>> This is not a WG adoption of the draft, just recognizing that the ADD
>> list would be the best fit for the material in the draft.
>>
>>
>>

---

From: Paul Wouters <[email-masked]>
Date: Tue, 18 Aug 2020 22:13:43 -0400 (EDT)

On Mon, 17 Aug 2020, Tim Wicinski wrote:

> The Resolver Info draft was originally adopted by DNSOP, so DNS people are good with this work.  
> The registry it creates allows for more expressive information to be extracted.  My only wish 
> is the authors could create several initial entries based on some of the work they've done
> implementing it.

Yes indeed. If we don't have any entries, why are we starting this work.

Personally I think "private-" is a better prefix than "temp-".

It would also be nice if the server had a standarized way of relaying
its public name, so that any TLSA records associated with it could
be found in the public DNS.

Paul

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 19 Aug 2020 13:23:26 +1000

> Personally I think "private-" is a better prefix than "temp-".

"X-", definitely "X-".  See RFC 6648.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 19 Aug 2020 14:49:40 +0000

> Yes indeed. If we don't have any entries, why are we starting this work.

We do have proposed entries: please see draft-pp-add-stub-upgrade. People asked us to split the entries into the document that would use them.

> be found in the public DNS.

Fully agree.

--Paul Hoffman