Subject: [Add] Adoption call for "Discovery of Equivalent Encrypted Resolvers"

From: "Deen, Glenn" <[email-masked]>
Date: Thu, 14 Jan 2021 19:28:50 +0000

Based on discussion during IETF109 and on list discussion the ADD chairs are asking for input on the ADD WG adoption of draft-pauly-add-deer.

The datatracker instance of the document can be found at:
             https://datatracker.ietf.org/doc/draft-pauly-add-deer/

The document source is at:
            https://github.com/tfpauly/draft-pauly-adaptive-dns-privacy/blob/master/draft-pauly-add-deer.md

This input call will last until January 26th, the day before the ADD January Interim.

Thanks,
Glenn Deen & David Lawrence.- ADD Co-chairs

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 14 Jan 2021 17:10:28 -0800

So, the datatracker announcement says:

The ADD WG has placed draft-box-add-requirements in state
Call For Adoption By WG Issued (entered by Glenn Deen)

Which one is it?
-Ekr

On Thu, Jan 14, 2021 at 11:29 AM Deen, Glenn <Glenn_Deen=
[email-masked]> wrote:

> Based on discussion during IETF109 and on list discussion the ADD chairs
> are asking for input on the ADD WG adoption of draft-pauly-add-deer.
>
>
>
> --
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: "Deen, Glenn" <[email-masked]>
Date: Fri, 15 Jan 2021 01:41:40 +0000

Ekr- Thanks for catching my clicking on the wrong document in datatracker.

We are asking for WG Adoption of:  Draft-pauly-add-deer

The chairs are expecting in the near future to also call for draft-box-add-requirements, but are waiting on an update that is being worked on before opening that documents adoption call.

Regards,
Glenn

On 1/14/21, 5:11 PM, "Eric Rescorla" <[email-masked]<mailto:[email-masked]>> wrote:

Which one is it?
-Ekr

On Thu, Jan 14, 2021 at 11:29 AM Deen, Glenn <Glenn_Deen=[email-masked]<mailto:[email-masked]>> wrote:
Based on discussion during IETF109 and on list discussion the ADD chairs are asking for input on the ADD WG adoption of draft-pauly-add-deer.

The datatracker instance of the document can be found at:
             https://datatracker.ietf.org/doc/draft-pauly-add-deer/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-pauly-add-deer/__;!!CQl3mcHX2A!VPGSXrxyBFSQ7j9ZQ4n2FI_i2wDqToxolU-js3dpiFuFaurQrEb-8bWXZInwClzJiQ$>

The document source is at:
            https://github.com/tfpauly/draft-pauly-adaptive-dns-privacy/blob/master/draft-pauly-add-deer.md<https://urldefense.com/v3/__https:/github.com/tfpauly/draft-pauly-adaptive-dns-privacy/blob/master/draft-pauly-add-deer.md__;!!CQl3mcHX2A!VPGSXrxyBFSQ7j9ZQ4n2FI_i2wDqToxolU-js3dpiFuFaurQrEb-8bWXZIk6jNt3Yw$>

Thanks,

--
Add mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/add<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/add__;!!CQl3mcHX2A!VPGSXrxyBFSQ7j9ZQ4n2FI_i2wDqToxolU-js3dpiFuFaurQrEb-8bWXZIkWs7Ucqw$>

---

From: Eric Orth <[email-masked]>
Date: Fri, 15 Jan 2021 17:40:11 -0500

I support adoption of DEER, and I intend to review and contribute, etc, etc.

I think there's some needed modifications to this, but I think the overall
idea and mechanisms (Do53/DoH resolvers designating other encrypted
resolvers through SVCB and the (maybe should-be optional) mechanisms for
authenticating it) is pretty non-controversial.  Let's get it adopted and
work through those smaller details.

On Thu, Jan 14, 2021 at 8:42 PM Deen, Glenn <Glenn_Deen=
[email-masked]> wrote:

> The chairs are expecting in the near future to also call for
> draft-box-add-requirements, but are waiting on an update that is being
> worked on before opening that documents adoption call.
>
>
>
> Regards,
>
> Glenn
>
>
>
> On 1/14/21, 5:11 PM, "Eric Rescorla" <[email-masked]> wrote:
>
>
>
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-pauly-add-deer/__;!!CQl3mcHX2A!VPGSXrxyBFSQ7j9ZQ4n2FI_i2wDqToxolU-js3dpiFuFaurQrEb-8bWXZInwClzJiQ$>
>
>
>
> <https://urldefense.com/v3/__https:/github.com/tfpauly/draft-pauly-adaptive-dns-privacy/blob/master/draft-pauly-add-deer.md__;!!CQl3mcHX2A!VPGSXrxyBFSQ7j9ZQ4n2FI_i2wDqToxolU-js3dpiFuFaurQrEb-8bWXZIk6jNt3Yw$>
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/add__;!!CQl3mcHX2A!VPGSXrxyBFSQ7j9ZQ4n2FI_i2wDqToxolU-js3dpiFuFaurQrEb-8bWXZIkWs7Ucqw$>
>
> --
> Add mailing list
> [email-masked]

---

From: "Vinny Parla (vparla)" <[email-masked]>
Date: Fri, 15 Jan 2021 23:11:54 +0000

I too am supportive of adoption of DEER and view the approach as reasonable.

From: Add <[email-masked]> On Behalf Of Eric Orth
Sent: Friday, January 15, 2021 5:40 PM
To: ADD Mailing list <[email-masked]>; Deen, Glenn 
<Glenn_Deen=[email-masked]>
Subject: Re: [Add] Adoption call for "Discovery of Equivalent Encrypted 
Resolvers"

I think there's some needed modifications to this, but I think the overall 
idea and mechanisms (Do53/DoH resolvers designating other encrypted resolvers 
through SVCB and the (maybe should-be optional) mechanisms for authenticating 
it) is pretty non-controversial.  Let's get it adopted and work through those 
smaller details.

On Thu, Jan 14, 2021 at 8:42 PM Deen, Glenn 
<Glenn_Deen=[email-masked] <mailto:[email-masked]> 
 > wrote:

The chairs are expecting in the near future to also call for 
draft-box-add-requirements, but are waiting on an update that is being worked 
on before opening that documents adoption call.

Regards,

Glenn

On 1/14/21, 5:11 PM, "Eric Rescorla" <[email-masked] <mailto:[email-masked]> > 
wrote:

Which one is it?

-Ekr

On Thu, Jan 14, 2021 at 11:29 AM Deen, Glenn 
<Glenn_Deen=[email-masked] <mailto:[email-masked]> 
 > wrote:

Based on discussion during IETF109 and on list discussion the ADD chairs are 
asking for input on the ADD WG adoption of draft-pauly-add-deer.

This input call will last until January 26th, the day before the ADD January 
Interim.

Thanks,

-- 
Add mailing list
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/add 
<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/add__;!!CQl3mcHX2A!VPGSXrxyBFSQ7j9ZQ4n2FI_i2wDqToxolU-js3dpiFuFaurQrEb-8bWXZIkWs7Ucqw$>

-- 
Add mailing list
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/add

---

From: David Schinazi <[email-masked]>
Date: Fri, 15 Jan 2021 15:48:30 -0800

I support adoption of draft-pauly-add-deer.

David

On Fri, Jan 15, 2021 at 3:12 PM Vinny Parla (vparla) <vparla=
[email-masked]> wrote:

> *From:* Add <[email-masked]> *On Behalf Of *Eric Orth
> *Sent:* Friday, January 15, 2021 5:40 PM
> *To:* ADD Mailing list <[email-masked]>; Deen, Glenn <Glenn_Deen=
> [email-masked]>
> *Subject:* Re: [Add] Adoption call for "Discovery of Equivalent Encrypted
> Resolvers"
>
>
>

---

From: Ben Schwartz <[email-masked]>
Date: Tue, 19 Jan 2021 10:01:27 -0500

I support adoption and will review and contribute text.

On Fri, Jan 15, 2021 at 6:48 PM David Schinazi <[email-masked]>
wrote:

>> *Subject:* Re: [Add] Adoption call for "Discovery of Equivalent
>> Encrypted Resolvers"
>>
>>
>>
>> I think there's some needed modifications to this, but I think the
>> overall idea and mechanisms (Do53/DoH resolvers designating other encrypted

---

From: tirumal reddy <[email-masked]>
Date: Wed, 20 Jan 2021 18:54:46 +0530

I support adoption of draft-pauly-add-deer. I will review and contribute
text.

-Tiru

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 20 Jan 2021 14:17:11 +0000

Thx,
Barbara

Regards,
Glenn

---

From: Chris Box <[email-masked]>
Date: Tue, 26 Jan 2021 22:48:53 +0000

Just before the deadline, I’ll also say I’m happy for DEER to be adopted.
It feels like a good design, and although it will benefit from some
changes, these can happen post-adoption.

Chris

---

From: "Deen, Glenn" <[email-masked]>
Date: Wed, 27 Jan 2021 23:32:35 +0000

Draft-pauly-add-deer has passed WG adoption call and is now an ADD WG document.

We’re finalizing its new name and will post to the list when the renamed WG document is available and the associated GitHub repository link

.

Thanks
Glenn Deen

On 1/14/21, 5:42 PM, "Add on behalf of Deen, Glenn" <[email-masked]<mailto:[email-masked]> on behalf of Glenn_Deen=[email-masked]<mailto:Glenn_Deen=[email-masked]>> wrote:

Thanks,