Subject: [Add] Designated Resolver Terminology

From: Jim Mozley <[email-masked]>
Date: Fri, 5 Mar 2021 13:35:11 +0000

Hi ADD,

A question on Designated Resolver terminology.

The draft Adaptive DNS Resolver Discovery https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01#section-2 has the following definition:

“Designated Resolver:  A DNS resolver that is designated as a responsible resolver for a given domain or zone.  Designated resolvers use encrypted transports.”

I do realise that this draft has expired on 14th January.

Whereas https://www.ietf.org/archive/id/draft-ietf-add-ddr-00.txt terminology has this definition:

“Designated Resolver:  A resolver, presumably an Encrypted Resolver, designated by another resolver for use in its own place. This designation can be authenticated with TLS certificates.”

Does this mean that the earlier definition is no longer in use, perhaps because the draft has expired? Hence does the term Designated Resolver now only apply to a Recursive Resolver?

I believe Apple is using some of the concepts detailed in https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01. If there is an implementation of the earlier (expired) draft will this be updated to reflect the change in usage of the term Designated Resolver?

Jim
--
Jim Mozley, Threat Researcher, Infoblox
[email-masked]<mailto:[email-masked]>

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 05 Mar 2021 09:53:54 -0800

Hi Jim,

Yes, there is a different use of the term between the documents. The adopted draft is trying to have the right terminology to describe the intent of the mechanism for discovering capabilities via SVCB records as described.

Fundamentally, the mechanism in draft-pauly-add-resolver-discovery is also discovering resolvers based off of SVCB records. The difference lies in which party is designating: a resolver designating another resolver, and a domain owner designating a resolver. I think we could start calling the latter case (in the document not adopted) "Domain-Designated Resolver” or something similar. We can update that some time.

Best,
Tommy

> On Mar 5, 2021, at 5:35 AM, Jim Mozley <[email-masked]> wrote:
> 
> Hi ADD,
>  
> The draft Adaptive DNS Resolver Discovery https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01#section-2 <https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01#section-2> has the following definition:
>  
> Whereas https://www.ietf.org/archive/id/draft-ietf-add-ddr-00.txt <https://www.ietf.org/archive/id/draft-ietf-add-ddr-00.txt> terminology has this definition:
>  
> I believe Apple is using some of the concepts detailed in https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01 <https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01>. If there is an implementation of the earlier (expired) draft will this be updated to reflect the change in usage of the term Designated Resolver?
>  
> Jim
> --
> [email-masked] <mailto:[email-masked]>-- 
> Add mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/add <https://www.ietf.org/mailman/listinfo/add>

---

From: Jim Mozley <[email-masked]>
Date: Sun, 7 Mar 2021 10:54:35 +0000

On 05/03/2021, 17:54, "Tommy Pauly" <[email-masked]> wrote:

Hi Jim,

Hi Tommy and ADD, I like “Domain-Designated Resolver” or similar for the authoritative server use case. I think it could be less ambiguous to establish a name for the resolver designating another resolver. I realise “Resolver-Designated Resolver” could be a mouthful. For consistency how about “Designated Domain Resolver” and “Designated Caching Resolver” as being consistent naming and dis-ambiguating?

Cheers, Jim

---

From: Jim Mozley <[email-masked]>
Date: Thu, 25 Mar 2021 11:20:09 +0000

Hi ADD,

Following up on my own post below. Given that changes are being made to draft-ietf-add-ddr would it be appropriate to consider the following terminology, or something similar, to disambiguate designated authoritative from caching resolvers:

“Designated Authoritative Resolver” – for designated authoritative resolvers
“Designated Caching Resolver” – for caching resolvers

There had also previously been a definition of “companion resolver” as well. I do realise a system could be both authoritative and caching (even if this is inadvisable), but I think two distinct names could help here in disambiguating the role being discussed in this case.

Over the history of DNS there has sometimes been terminology introduced that can be confusing, so it would be good to avoid confusion when introducing designated resolvers. What’s in a name? 😊

Jim

On 07/03/2021, 10:54, "Jim Mozley" <[email-masked]> wrote:

Hi Jim,

Cheers, Jim

---

From: Tommy Jensen <[email-masked]>
Date: Fri, 26 Mar 2021 22:37:59 +0000

Hey Jim,

If I am following your proposal correctly, you are saying change “designated resolver” within DDR to be “designated caching resolver” so that if/when Adaptive or any similar draft defines the concept of a resolver designated for a set of names, it can be called “designated authoritative resolver” without needing at that time to refine names with DDR.

Is that correct? Or do you see the different cases within DDR as needing two distinct names?

Thanks,
Tommy

From: Add <[email-masked]> On Behalf Of Jim Mozley
Sent: Thursday, March 25, 2021 4:20 AM
To: [email-masked]; Tommy Pauly <[email-masked]>
Subject: [EXTERNAL] Re: [Add] Designated Resolver Terminology

Hi ADD,

Jim

On 07/03/2021, 10:54, "Jim Mozley" <[email-masked]<mailto:[email-masked]>> wrote:

On 05/03/2021, 17:54, "Tommy Pauly" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jim,

Cheers, Jim

---

From: Eliot Lear <[email-masked]>
Date: Sat, 27 Mar 2021 13:25:46 +0100

> On 25 Mar 2021, at 12:20, Jim Mozley <jmozley=[email-masked]> wrote:
> 
> Hi ADD,
> 

In what sense is a resolver authoritative?

> “Designated Caching Resolver” – for caching resolvers

Which resolvers do not cache?

Eliot

---

From: Bill Woodcock <[email-masked]>
Date: Sat, 27 Mar 2021 13:49:17 +0100

> On Mar 27, 2021, at 1:25 PM, Eliot Lear <lear=[email-masked]> wrote:

Yeah, while I’m fully supportive of the goal of working out harmonized terminology and using it ubiquitously and uniformly, Eliot has an excellent point that the way to get there is not to recombine terms which have specific meanings in novel and unintuitive ways.

Sometimes a neologism is what’s needed, since it can be defined, and nobody assumes that they know what it means, because they know what the words mean, or how it’s used in other contexts.

                                -Bill

---

From: Jim Mozley <[email-masked]>
Date: Sat, 27 Mar 2021 14:52:06 +0000

Hi Tommy, comments in-line below…

On 26/03/2021, 22:38, "Add" <[email-masked]> wrote:

That is correct.

A previous, now expired draft https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01, had the concept of a designated resolver for a specific zone (section 2 – terminology) and the current draft draft-ietf-add-ddr has a designated resolver concept for a resolver “designated by another resolver for use in its own place”

I am suggested making clear in the name whether the designated resolver is authoritative or caching.

Cheers, Jim

---

From: Jim Mozley <[email-masked]>
Date: Sat, 27 Mar 2021 14:55:39 +0000

On 27/03/2021, 12:26, "Eliot Lear" <lear=[email-masked]> wrote:

On 25 Mar 2021, at 12:20, Jim Mozley <jmozley=[email-masked]<mailto:jmozley=[email-masked]>> wrote:

Hi ADD,

In the sense described by the draft https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01 in section 2<https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01%20in%20section%202>, terminology. I do realise this has now expired.

In the case described in https://tools.ietf.org/html/draft-pauly-add-resolver-discovery-01 where is could be authoritative.

My thinking is that making the terms unambiguous now would mean avoid confusion or changing names later.

Hope that clarifies it. Cheers, Jim

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 27 Mar 2021 18:36:16 +0000

On 27/03/2021 12:49, Bill Woodcock wrote:
> Yeah, while I’m fully supportive of the goal of working out 
> harmonized terminology and using it ubiquitously and uniformly,
> Eliot has an excellent point that the way to get there is not to
> recombine terms which have specific meanings in novel and unintuitive
> ways.

+1

And further, I'm not sure terminology is where this WG
faces a challenge, nor that new terms will help solve
what I think really comes down to a challenge due to a
change in who controls what.

S

> Sometimes a neologism is what’s needed, since it can be defined, and 
> nobody assumes that they know what it means, because they know what 
> the words mean, or how it’s used in other contexts.
> 
> -Bill
> 
>

---

From: Jim Mozley <[email-masked]>
Date: Mon, 29 Mar 2021 17:49:51 +0000

Hi Stephen, ADD,

On 27/03/2021, 18:36, "Add" <[email-masked]> wrote:

+1

This came about when I was working on a presentation to update colleagues, where I was including some information about designated authoritative resolvers (from the admittedly expired draft) and designated caching resolvers.  It helped to disambiguate to refer to them as such.

I realise naming does sometimes create a lot of debate, the motivation here is purely practical.

Jim