Subject: [Add] https://tools.ietf.org/html/draft-schwartz-svcb-dns-02

From: "A. Schulze" <[email-masked]>
Date: Sat, 17 Apr 2021 18:14:07 +0200

Hello,

I read the draft and like to point out the example section [1] is unclear to me.
Text start with a DoT resolver and two ports, followed by a DoH server.
But the example dns-data start with the DoH case followed by the DoT resolver on the non default port.

It would be helpful if "DNS over TLS on "resolver.example", port 853" is mentioned, too.
Also the auth example don't provide example for ns.example. itself.

The port section [2] say "This key is automatically mandatory if present."
I still cannot say if "port=" is mandatory or not.

Andreas

[1] https://tools.ietf.org/html/draft-schwartz-svcb-dns-02#section-8
[2] https://tools.ietf.org/html/draft-schwartz-svcb-dns-02#section-4.2

---

From: Peter van Dijk <[email-masked]>
Date: Mon, 19 Apr 2021 20:43:19 +0200

Hello Andreas,

> Also the auth example don't provide example for ns.example. itself.

You are not the only one who got confused!

After discussion about this in an earlier thread (
https://mailarchive.ietf.org/arch/msg/add/lkohz03rWbEDx36hDkaax5PKg34/)
, we came to the conclusion that having a default protocol of 'dot'
appended to the alpn list would be confusing for DNS server discovery.
Ben changed this in https://github.com/bemasc/svcb-dns/pull/2/files

Earlier commits to the same repo also clarify the examples somewhat.

> I still cannot say if "port=" is mandatory or not.

'automatically mandatory' means that if it is present, somebody who is parsing the record must reject the record if they do not understand what port means. More words at https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-svcb-https-04#section-7

Incidentally I just noted another commit to the draft at https://github.com/bemasc/svcb-dns/commit/d1caaebacdb21f042d949e46a86d6c11ac7b68f5 - which is so recent that I suspect your message may have triggered it.

Kind regards,
-- 
Peter van Dijk
PowerDNS.COM BV - https://www.powerdns.com/

---

From: Ben Schwartz <[email-masked]>
Date: Mon, 19 Apr 2021 14:47:32 -0400

Yep, it's clear that making DNS over TLS the implicit default did not match
most people's expectations here, so I've removed that default and just
published a new revision.  The new text also includes some improved
examples.  Thanks for the feedback!

New text: https://www.ietf.org/archive/id/draft-schwartz-svcb-dns-03.html
Diff:
https://www.ietf.org/rfcdiff?url1=draft-schwartz-svcb-dns-02&url2=draft-schwartz-svcb-dns-03

On Mon, Apr 19, 2021 at 2:43 PM Peter van Dijk <[email-masked]>
wrote:

> 'automatically mandatory' means that if it is present, somebody who is
> parsing the record must reject the record if they do not understand what
> port means. More words at
> https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-svcb-https-04#section-7
>
> Incidentally I just noted another commit to the draft at
> https://github.com/bemasc/svcb-dns/commit/d1caaebacdb21f042d949e46a86d6c11ac7b68f5
> - which is so recent that I suspect your message may have triggered it.
>
> Kind regards,
> --
> Peter van Dijk
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: "A. Schulze" <[email-masked]>
Date: Tue, 20 Apr 2021 20:24:45 +0200

Am 19.04.21 um 20:47 scrunchie Ben Schwartz:
> Yep, it's clear that making DNS over TLS the implicit default did not match most people's expectations here, so I've removed that default and just published a new revision.  The new text also includes some improved examples.  Thanks for the feedback!
> 
> New text: https://www.ietf.org/archive/id/draft-schwartz-svcb-dns-03.html <https://www.ietf.org/archive/id/draft-schwartz-svcb-dns-03.html>
> Diff: https://www.ietf.org/rfcdiff?url1=draft-schwartz-svcb-dns-02&url2=draft-schwartz-svcb-dns-03 <https://www.ietf.org/rfcdiff?url1=draft-schwartz-svcb-dns-02&url2=draft-schwartz-svcb-dns-03>

Hi Ben,

this version is much clearer to me.

Andreas