Subject: [Add] DNS-over-QUIC draft-schwartz-svcb-dns-03?

From: Paul Hoffman <[email-masked]>
Date: Wed, 28 Apr 2021 17:34:34 +0000

Greetings again. draft-schwartz-svcb-dns-03 points to draft-ietf-dnsop-svcb-https for the definition of what goes in the "alpn" parameter. However, I don't see a way in draft-ietf-dnsop-svcb-https to indicate DNS-over-QUIC (draft-ietf-dprive-dnsoquic). "h3" indicates DNS-over-HTTPS-over-QUIC, which is a very different protocol. 

Am I missing something? Or are the SVCB drafts missing this possibility?

--Paul Hoffman

---

From: Ben Schwartz <[email-masked]>
Date: Wed, 28 Apr 2021 10:41:02 -0700

It is signalled via the ALPN value "doq":
https://tools.ietf.org/html/draft-ietf-dprive-dnsoquic-02#section-5.1

On Wed, Apr 28, 2021 at 10:34 AM Paul Hoffman <[email-masked]>
wrote:

> Greetings again. draft-schwartz-svcb-dns-03 points to
> draft-ietf-dnsop-svcb-https for the definition of what goes in the "alpn"
> parameter. However, I don't see a way in draft-ietf-dnsop-svcb-https to
> indicate DNS-over-QUIC (draft-ietf-dprive-dnsoquic). "h3" indicates
> DNS-over-HTTPS-over-QUIC, which is a very different protocol.
>
> --
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 28 Apr 2021 18:14:38 +0000

On Apr 28, 2021, at 10:41 AM, Ben Schwartz <[email-masked]> wrote:
> 
> It is signalled via the ALPN value "doq": https://tools.ietf.org/html/draft-ietf-dprive-dnsoquic-02#section-5.1
> 

Yipes! Of course. Thanks!

--Paul Hoffman