Subject: Re: [Add] https://tools.ietf.org/html/draft-schwartz-svcb-dns-02

From: "A. Schulze" <[email-masked]>
Date: Mon, 3 May 2021 23:03:49 +0200

Am 20.04.21 um 20:24 schrieb A. Schulze:
> 
> 
> Am 19.04.21 um 20:47 scrunchie Ben Schwartz:
>> Yep, it's clear that making DNS over TLS the implicit default did not match most people's expectations here, so I've removed that default and just published a new revision.  The new text also includes some improved examples.  Thanks for the feedback!
>>
>> New text: https://www.ietf.org/archive/id/draft-schwartz-svcb-dns-03.html <https://www.ietf.org/archive/id/draft-schwartz-svcb-dns-03.html>
>> Diff: https://www.ietf.org/rfcdiff?url1=draft-schwartz-svcb-dns-02&url2=draft-schwartz-svcb-dns-03 <https://www.ietf.org/rfcdiff?url1=draft-schwartz-svcb-dns-02&url2=draft-schwartz-svcb-dns-03>
> 
> Hi Ben,
> 
> this version is much clearer to me.
> 
> Andreas
> 

Hello,

reading draft-schwartz-svcb-dns-03 again, I don't understand the first example.

> _dns.simple.example. 7200 IN SVCB 1 alpn=dot simple.example.

https://tools.ietf.org/html/draft-ietf-dnsop-svcb-https-05#section-1.2 say
> The SVCB RR has two mandatory fields and one optional.
>   1.  SvcPriority
>   2.  TargetName
>   3.  SvcParams (optional)

Then I would expect the example is written as "_dns.simple.example. 7200 IN SVCB 1 simple.example. alpn=dot"
My miss-understanding or wrong example?

Andreas

---

From: Ben Schwartz <[email-masked]>
Date: Mon, 3 May 2021 14:09:10 -0700

> My miss-understanding or wrong example?

Wrong example, first reported by Matt Nordhoff (
https://github.com/bemasc/svcb-dns/pull/3).

>
> Andreas
>
> --
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>