Subject: Re: [Add] [EXTERNAL] I-D Action: draft-ietf-add-ddr-01.txt

From: [email-masked]
Date: Mon, 14 Jun 2021 23:30:55 +0000

Hi Tommy - A quick clarification in enumeration 1 in section 1 (Introduction). The enumeration 1 says:

When only an IP address of an Unencrypted Resolver is known, the client queries a special use domain name to discover DNS SVCB records associated with the Unencrypted Resolver

Above did you mean "encrypted" instead of "Unencrypted" Resolver....?

Thanks
Sanjay

-----Original Message-----
From: Add [mailto:[email-masked]] On Behalf Of Tommy Jensen
Sent: Monday, June 14, 2021 7:04 PM
To: [email-masked]
Subject: [E] Re: [Add] [EXTERNAL] I-D Action: draft-ietf-add-ddr-01.txt

Hey everyone,

We have posted an update to DDR and welcome additional review. Many thanks to everyone who has reviewed so far. We are hoping to get additional feedback as we rev a -02 ahead of the deadline for IETF 111.

This version addresses some feedback regarding the use of IPv4/IPv6 examples, the use of IP hints, and some clarity of language regarding terminology ("equivalence" versus "designation") and scope.

I would like to highlight for the benefit of some feedback regarding scope that the scope of this draft remains limited in nature. For example, DDR has not and still does not attempt to solve the "85%" problem. You will see commentary on the GitHub bugs following that scoping.

Thanks,
Tommy

> -----Original Message-----
> From: Add <[email-masked]> On Behalf Of [email-masked]
> Sent: Monday, June 14, 2021 3:59 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [EXTERNAL] [Add] I-D Action: draft-ietf-add-ddr-01.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Adaptive DNS Discovery WG of the IETF.
> 
>         Title           : Discovery of Designated Resolvers
>         Authors         : Tommy Pauly
>                           Eric Kinnear
>                           Christopher A. Wood
>                           Patrick McManus
>                           Tommy Jensen
> 	Filename        : draft-ietf-add-ddr-01.txt
> 	Pages           : 12
> 	Date            : 2021-06-14
> 
> Abstract:
>    This document defines Discovery of Designated Resolvers (DDR), a
>    mechanism for DNS clients to use DNS records to discover a resolver's
>    encrypted DNS configuration.  This mechanism can be used to move from
>    unencrypted DNS to encrypted DNS when only the IP address of an
>    encrypted resolver is known.  It can also be used to discover support
>    for encrypted DNS protocols when the name of an encrypted resolver is
>    known.  This mechanism is designed to be limited to cases where
>    unencrypted resolvers and their designated resolvers are operated by
>    the same entity or cooperating entities.
> 
> 
> The IETF datatracker status page for this draft is:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fdatatra&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=PMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa6A&s=BwUZuC0-Qy6hNuwN-qsdSSXKsgRkZwQBlPYdZzGe7BI&e= 
> cker.ietf.org%2Fdoc%2Fdraft-ietf-add-
> ddr%2F&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7C4efbe3
> 5963a949fea69f08d92f8810a7%7C72f988bf86f141af91ab2d7cd011db47%7C1
> %7C0%7C637593083738862826%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC
> 4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&a
> mp;sdata=aSaQVCpy5v%2B%2BrQY%2FO%2B58%2FpsuYInrrSFnFOSnIQQPeRw
> %3D&amp;reserved=0
> 
> There is also an HTML version available at:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fwww.ie&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=PMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa6A&s=f2dCd2HMbA4RHMOMky9O0j7050vsbt7Ch5vMT9afE4k&e= 
> tf.org%2Farchive%2Fid%2Fdraft-ietf-add-ddr-
> 01.html&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7C4efbe3
> 5963a949fea69f08d92f8810a7%7C72f988bf86f141af91ab2d7cd011db47%7C1
> %7C0%7C637593083738862826%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC
> 4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&a
> mp;sdata=zv0FOkEWCo9PbEcvzc%2FcjuZTWAi53Td6dsOuY5hKyEs%3D&amp;re
> served=0
> 
> A diff from the previous version is available at:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fwww.ie&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=PMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa6A&s=f2dCd2HMbA4RHMOMky9O0j7050vsbt7Ch5vMT9afE4k&e= 
> tf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-add-ddr-
> 01&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7C4efbe35963
> a949fea69f08d92f8810a7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C
> 0%7C637593083738862826%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLj
> AwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;s
> data=QgeVUjM%2F5bSTseBkg0tytJ3RT0ztD56xoYmK4pKfJ%2Fs%3D&amp;reser
> ved=0
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dftp-253A-252F-252Fftp.ietf.or&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=PMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa6A&s=PrEk5FouIltJ9SIZSRZEHTnqL3gI5m8-eaVa6kzuYiA&e= 
> g%2Finternet-
> drafts%2F&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7C4efb
> e35963a949fea69f08d92f8810a7%7C72f988bf86f141af91ab2d7cd011db47%7
> C1%7C0%7C637593083738862826%7CUnknown%7CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000
> &amp;sdata=%2Fc8xtaTsW%2BmcWpqCR6oHJkY6hyN%2B3K02Ae6%2BRpCfLN
> w%3D&amp;reserved=0
> 
> 
> --
> Add mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fwww.ie&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=PMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa6A&s=f2dCd2HMbA4RHMOMky9O0j7050vsbt7Ch5vMT9afE4k&e= 
> tf.org%2Fmailman%2Flistinfo%2Fadd&amp;data=04%7C01%7CJensen.Thomas
> %40microsoft.com%7C4efbe35963a949fea69f08d92f8810a7%7C72f988bf86f1
> 41af91ab2d7cd011db47%7C1%7C0%7C637593083738862826%7CUnknown%
> 7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiL
> CJXVCI6Mn0%3D%7C1000&amp;sdata=Z71SomUyHBgCR8RoMIfGzH7bcURYM
> 7CNUr2JfSvG%2BM0%3D&amp;reserved=0

-- 
Add mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_add&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=PMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa6A&s=aKY2BAJrgsEC3-RzYsVsUpnp4F_SM7CJP1jiM8QBu9k&e=

---

From: Tommy Jensen <[email-masked]>
Date: Mon, 14 Jun 2021 23:35:29 +0000

Hey Sanjay,

"Unencrypted" was the intended term. That resolver itself may support encryption or it may not. At first, all the client has (in the scenario covered by DDR) is the knowledge of an IP address which supports unencrypted DNS. 

Thanks,
Tommy

> From: sanjay.mishra=[email-masked]
> <sanjay.mishra=[email-masked]>
> Sent: Monday, June 14, 2021 4:31 PM
> To: Tommy Jensen <[email-masked]>; [email-masked]
> Subject: RE: Re: [Add] [EXTERNAL] I-D Action: draft-ietf-add-ddr-01.txt
> 
> When only an IP address of an Unencrypted Resolver is known, the client
> queries a special use domain name to discover DNS SVCB records associated
> with the Unencrypted Resolver
> 
> We have posted an update to DDR and welcome additional review. Many
> thanks to everyone who has reviewed so far. We are hoping to get additional
> feedback as we rev a -02 ahead of the deadline for IETF 111.
> 
> This version addresses some feedback regarding the use of IPv4/IPv6 examples,
> the use of IP hints, and some clarity of language regarding terminology
> ("equivalence" versus "designation") and scope.
> 
> I would like to highlight for the benefit of some feedback regarding scope that
> the scope of this draft remains limited in nature. For example, DDR has not and
> still does not attempt to solve the "85%" problem. You will see commentary on
> the GitHub bugs following that scoping.
> 
> Thanks,
> Tommy
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefe
> nse.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-
> 3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-
> 252Fdatatra%26d%3DDwICAg%26c%3DudBTRvFvXC5Dhqg7UHpJlPps3mZ3LRx
> pb6__0PomBTQ%26r%3DXniVbishGiO2Ao9hKqSc-hTVIWCi3T-
> x6GdHR4ZTgoM%26m%3DPMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa
> 6A%26s%3DBwUZuC0-Qy6hNuwN-
> qsdSSXKsgRkZwQBlPYdZzGe7BI%26e%3D&amp;data=04%7C01%7CJensen.Tho
> mas%40microsoft.com%7Ca186ad050cb54f22547f08d92f8c7a96%7C72f988bf
> 86f141af91ab2d7cd011db47%7C1%7C0%7C637593103283347967%7CUnkno
> wn%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1ha
> WwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=pAM2y4pf6fbqfx3g95qlX2dcQgnx
> pg1bHeoh6YnGsVM%3D&amp;reserved=0
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefe
> nse.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-
> 3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-
> 252Fwww.ie%26d%3DDwICAg%26c%3DudBTRvFvXC5Dhqg7UHpJlPps3mZ3LRx
> pb6__0PomBTQ%26r%3DXniVbishGiO2Ao9hKqSc-hTVIWCi3T-
> x6GdHR4ZTgoM%26m%3DPMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa
> 6A%26s%3Df2dCd2HMbA4RHMOMky9O0j7050vsbt7Ch5vMT9afE4k%26e%3D
> &amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7Ca186ad050cb5
> 4f22547f08d92f8c7a96%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%
> 7C637593103283357961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAw
> MDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdat
> a=GUdgLoBl9Bcuak2N%2FgOMTimnm2%2Bvhfhm8kFJWHAOrk4%3D&amp;res
> erved=0
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefe
> nse.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-
> 3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-
> 252Fwww.ie%26d%3DDwICAg%26c%3DudBTRvFvXC5Dhqg7UHpJlPps3mZ3LRx
> pb6__0PomBTQ%26r%3DXniVbishGiO2Ao9hKqSc-hTVIWCi3T-
> x6GdHR4ZTgoM%26m%3DPMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa
> 6A%26s%3Df2dCd2HMbA4RHMOMky9O0j7050vsbt7Ch5vMT9afE4k%26e%3D
> &amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7Ca186ad050cb5
> 4f22547f08d92f8c7a96%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%
> 7C637593103283357961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAw
> MDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdat
> a=GUdgLoBl9Bcuak2N%2FgOMTimnm2%2Bvhfhm8kFJWHAOrk4%3D&amp;res
> erved=0
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefe
> nse.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-
> 3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dftp-253A-252F-
> 252Fftp.ietf.or%26d%3DDwICAg%26c%3DudBTRvFvXC5Dhqg7UHpJlPps3mZ3L
> Rxpb6__0PomBTQ%26r%3DXniVbishGiO2Ao9hKqSc-hTVIWCi3T-
> x6GdHR4ZTgoM%26m%3DPMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa
> 6A%26s%3DPrEk5FouIltJ9SIZSRZEHTnqL3gI5m8-
> eaVa6kzuYiA%26e%3D&amp;data=04%7C01%7CJensen.Thomas%40microsoft.c
> om%7Ca186ad050cb54f22547f08d92f8c7a96%7C72f988bf86f141af91ab2d7c
> d011db47%7C1%7C0%7C637593103283357961%7CUnknown%7CTWFpbGZsb
> 3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%
> 3D%7C2000&amp;sdata=RouCrNJ%2FtwhX6dRY6B%2BBB0BiWJaa%2BjIgEvUc
> RPk3eHI%3D&amp;reserved=0
> > g%2Finternet-
> >
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefe
> nse.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-
> 3A__nam06.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-
> 252Fwww.ie%26d%3DDwICAg%26c%3DudBTRvFvXC5Dhqg7UHpJlPps3mZ3LRx
> pb6__0PomBTQ%26r%3DXniVbishGiO2Ao9hKqSc-hTVIWCi3T-
> x6GdHR4ZTgoM%26m%3DPMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa
> 6A%26s%3Df2dCd2HMbA4RHMOMky9O0j7050vsbt7Ch5vMT9afE4k%26e%3D
> &amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7Ca186ad050cb5
> 4f22547f08d92f8c7a96%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%
> 7C637593103283357961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAw
> MDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdat
> a=GUdgLoBl9Bcuak2N%2FgOMTimnm2%2Bvhfhm8kFJWHAOrk4%3D&amp;res
> erved=0
> >
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefe
> nse.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-
> 3A__www.ietf.org_mailman_listinfo_add%26d%3DDwICAg%26c%3DudBTRvFv
> XC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ%26r%3DXniVbishGiO2Ao9hKqSc-
> hTVIWCi3T-
> x6GdHR4ZTgoM%26m%3DPMD8_L17Gwx7CAw4VbHltUh36_7a7lvo8oS_kQcSa
> 6A%26s%3DaKY2BAJrgsEC3-
> RzYsVsUpnp4F_SM7CJP1jiM8QBu9k%26e%3D&amp;data=04%7C01%7CJensen
> .Thomas%40microsoft.com%7Ca186ad050cb54f22547f08d92f8c7a96%7C72f9
> 88bf86f141af91ab2d7cd011db47%7C1%7C0%7C637593103283357961%7CUn
> known%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik
> 1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=ImzndRt6puCpYqureUWlSN4I
> AdBY%2Bl6%2BmHvkaT7f28I%3D&amp;reserved=0

---

From: [email-masked]
Date: Mon, 14 Jun 2021 23:50:35 +0000

Ah, Thank you. 

-Sanjay

-----Original Message-----
From: Tommy Jensen [mailto:Jensen.Thomas=[email-masked]] 
Sent: Monday, June 14, 2021 7:35 PM
To: Mishra, Sanjay <[email-masked]>; [email-masked]
Subject: [E] RE: Re: [Add] [EXTERNAL] I-D Action: draft-ietf-add-ddr-01.txt

Hey Sanjay,

Thanks,
Tommy

> When only an IP address of an Unencrypted Resolver is known, the 
> client queries a special use domain name to discover DNS SVCB records 
> associated with the Unencrypted Resolver
> 
> thanks to everyone who has reviewed so far. We are hoping to get 
> additional feedback as we rev a -02 ahead of the deadline for IETF 111.
> 
> This version addresses some feedback regarding the use of IPv4/IPv6 
> examples, the use of IP hints, and some clarity of language regarding 
> terminology ("equivalence" versus "designation") and scope.
> 
> I would like to highlight for the benefit of some feedback regarding 
> scope that the scope of this draft remains limited in nature. For 
> example, DDR has not and still does not attempt to solve the "85%" 
> problem. You will see commentary on the GitHub bugs following that scoping.
> 
> Thanks,
> Tommy
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.p
> rotection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefe&d=DwIFAg&c=
> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTV
> IWCi3T-x6GdHR4ZTgoM&m=zb3zSV8SJO62kWDTqnyjO0krjy2ukGSbV9a4vFbBqas&s=PT
> ghu3ktY_CmMNWuZbYlSu3G9cip81ASNIMjmHf8Wv4&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.p
> rotection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefe&d=DwIFAg&c=
> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTV
> IWCi3T-x6GdHR4ZTgoM&m=zb3zSV8SJO62kWDTqnyjO0krjy2ukGSbV9a4vFbBqas&s=PT
> ghu3ktY_CmMNWuZbYlSu3G9cip81ASNIMjmHf8Wv4&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.p
> rotection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefe&d=DwIFAg&c=
> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTV
> IWCi3T-x6GdHR4ZTgoM&m=zb3zSV8SJO62kWDTqnyjO0krjy2ukGSbV9a4vFbBqas&s=PT
> ghu3ktY_CmMNWuZbYlSu3G9cip81ASNIMjmHf8Wv4&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.p
> rotection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefe&d=DwIFAg&c=
> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTV
> IWCi3T-x6GdHR4ZTgoM&m=zb3zSV8SJO62kWDTqnyjO0krjy2ukGSbV9a4vFbBqas&s=PT
> ghu3ktY_CmMNWuZbYlSu3G9cip81ASNIMjmHf8Wv4&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.p
> rotection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefe&d=DwIFAg&c=
> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTV
> IWCi3T-x6GdHR4ZTgoM&m=zb3zSV8SJO62kWDTqnyjO0krjy2ukGSbV9a4vFbBqas&s=PT
> ghu3ktY_CmMNWuZbYlSu3G9cip81ASNIMjmHf8Wv4&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__nam06.safelinks.p
> rotection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefe&d=DwIFAg&c=
> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTV
> IWCi3T-x6GdHR4ZTgoM&m=zb3zSV8SJO62kWDTqnyjO0krjy2ukGSbV9a4vFbBqas&s=PT
> ghu3ktY_CmMNWuZbYlSu3G9cip81ASNIMjmHf8Wv4&e=