Subject: [Add] Fwd: New Version Notification for draft-boucadair-opsawg-add-encrypted-dns-02.txt

From: tirumal reddy <[email-masked]>
Date: Fri, 18 Jun 2021 15:51:37 +0530

Hi all,

This draft
https://datatracker.ietf.org/doc/html/draft-boucadair-opsawg-add-encrypted-dns
specifies
new RADIUS attributes that carry an ADN, a list of IP addresses and a set
of service parameters of encrypted DNS resolvers encoded following the
rules in ietf-dnsop-svcb-https.

Typical deployment scenarios are discussed in
https://datatracker.ietf.org/doc/html/rfc6911#section-2. For instance, it
is useful in residential broadband network deployments where the new RADIUS
attributes can be used to provision home routers with the ISP's Encrypted
DNS server via DHCP.  The RADIUS part of the draft was reviewed by a RADIUS
expert in OPSAWG WG.

Comments, suggestions and proposals of use cases for the RADIUS attributes
are welcome.

Cheers,
-Tiru

---------- Forwarded message ---------
From: <[email-masked]>
Date: Thu, 17 Jun 2021 at 16:42
Subject: New Version Notification for
draft-boucadair-opsawg-add-encrypted-dns-02.txt
To: Tirumaleswar Reddy.K <[email-masked]>, Mohamed Boucadair <
[email-masked]>

A new version of I-D, draft-boucadair-opsawg-add-encrypted-dns-02.txt
has been successfully submitted by Mohamed Boucadair and posted to the
IETF repository.

Name:           draft-boucadair-opsawg-add-encrypted-dns
Revision:       02
Title:          RADIUS Extensions for Encrypted DNS
Document date:  2021-06-17
Group:          Individual Submission
Pages:          15
URL:
https://www.ietf.org/archive/id/draft-boucadair-opsawg-add-encrypted-dns-02.txt
Status:
https://datatracker.ietf.org/doc/draft-boucadair-opsawg-add-encrypted-dns/
Htmlized:
https://datatracker.ietf.org/doc/html/draft-boucadair-opsawg-add-encrypted-dns
Diff:
https://www.ietf.org/rfcdiff?url2=draft-boucadair-opsawg-add-encrypted-dns-02

Abstract:
   This document specifies new Remote Authentication Dial-In User
   Service (RADIUS) attributes that carry an authentication domain name,
   a list of IP addresses, and a set of service parameters of encrypted
   DNS resolvers.

The IETF Secretariat

---

From: Ben Schwartz <[email-masked]>
Date: Fri, 18 Jun 2021 15:03:22 -0400

I'm not familiar with RADIUS, but I noticed an interesting divergence from
DNR here.  DNR carries the SvcParams as binary data in wire format, whereas
this draft proposes to deliver them as UTF-8 text, in zone-file format.
This shifts the burden of text parsing from the server (sender) to the
client (recipient).

I would have expected a design similar to DNR instead, using the RADIUS
"string" type instead of "text".

On Fri, Jun 18, 2021 at 6:22 AM tirumal reddy <[email-masked]> wrote:

> Hi all,
>
> This draft
> https://datatracker.ietf.org/doc/html/draft-boucadair-opsawg-add-encrypted-dns specifies
> --
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: <[email-masked]>
Date: Mon, 21 Jun 2021 08:46:55 +0000

Hi Ben, all,

We don’t want to deviate from DNR. Will be fixed. Thanks.

Cheers,
Med

De : Add [mailto:[email-masked]] De la part de Ben Schwartz
Envoyé : vendredi 18 juin 2021 21:03
À : tirumal reddy <[email-masked]>
Cc : ADD Mailing list <[email-masked]>
Objet : Re: [Add] Fwd: New Version Notification for draft-boucadair-opsawg-add-encrypted-dns-02.txt

I'm not familiar with RADIUS, but I noticed an interesting divergence from DNR here.  DNR carries the SvcParams as binary data in wire format, whereas this draft proposes to deliver them as UTF-8 text, in zone-file format.  This shifts the burden of text parsing from the server (sender) to the client (recipient).

I would have expected a design similar to DNR instead, using the RADIUS "string" type instead of "text".

On Fri, Jun 18, 2021 at 6:22 AM tirumal reddy <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

This draft https://datatracker.ietf.org/doc/html/draft-boucadair-opsawg-add-encrypted-dns specifies new RADIUS attributes that carry an ADN, a list of IP addresses and a set of service parameters of encrypted DNS resolvers encoded following the rules in ietf-dnsop-svcb-https.

Typical deployment scenarios are discussed in https://datatracker.ietf.org/doc/html/rfc6911#section-2. For instance, it is useful in residential broadband network deployments where the new RADIUS attributes can be used to provision home routers with the ISP's Encrypted DNS server via DHCP.  The RADIUS part of the draft was reviewed by a RADIUS expert in OPSAWG WG.

Comments, suggestions and proposals of use cases for the RADIUS attributes are welcome.

Cheers,
-Tiru
---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Thu, 17 Jun 2021 at 16:42
Subject: New Version Notification for draft-boucadair-opsawg-add-encrypted-dns-02.txt
To: Tirumaleswar Reddy.K <[email-masked]<mailto:[email-masked]>>, Mohamed Boucadair <[email-masked]<mailto:[email-masked]>>

Name:           draft-boucadair-opsawg-add-encrypted-dns
Revision:       02
Title:          RADIUS Extensions for Encrypted DNS
Document date:  2021-06-17
Group:          Individual Submission
Pages:          15
URL:            https://www.ietf.org/archive/id/draft-boucadair-opsawg-add-encrypted-dns-02.txt
Status:         https://datatracker.ietf.org/doc/draft-boucadair-opsawg-add-encrypted-dns/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-boucadair-opsawg-add-encrypted-dns
Diff:           https://www.ietf.org/rfcdiff?url2=draft-boucadair-opsawg-add-encrypted-dns-02

Abstract:

The IETF Secretariat

--
Add mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/add

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.