Subject: [admin-discuss] Attempt to diagram the structure of the IETF

From: Jay Daley <[email-masked]>
Date: Mon, 21 Feb 2022 12:24:52 +1300

I’ve had a go at diagramming the structure of the IETF and inter-related organisations to assist new staff and contractors:

	https://www.ietf.org/media/documents/IETF_Structure_-_February_2022.png

While the RSWG/RSAB are not officially approved, they are included.

Any feedback most welcome.

cheers
Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 20 Feb 2022 18:35:17 -0500

I think the IAB box is misleading.  I would label the inner second box 
"IAB members", and have the arrow to IAB chair go from there, as the IAB 
members, not the nomcom procedurally select the chair.

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 20 Feb 2022 18:36:37 -0500

I am pretty sure that the IAB appoints the IRTF Chair, and he appoints 
the Research Group chairs and other IRSG members.  So the arrow from IAB 
to IRSG should point directly to the IRTF Chair.

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 20 Feb 2022 18:38:31 -0500

If you are going to point out that multiple parties appoint members of 
the LLC Board, then you should note that the ISOC board appoints one 
Trustee, and the IESG appoints one Trustee.

Yours,
Joel

---

From: Jay Daley <[email-masked]>
Date: Mon, 21 Feb 2022 12:43:11 +1300

Thanks for this and the other fixes. I will change this and the IAB one, but the IRSG one was not spotted by Colin when I gave him and the IESG a preview so I’ll check with him.

Jay

> On 21/02/2022, at 12:38 PM, Joel M. Halpern <[email-masked]> wrote:
> 
> If you are going to point out that multiple parties appoint members of the LLC Board, then you should note that the ISOC board appoints one Trustee, and the IESG appoints one Trustee.
> 
> Yours,
> Joel
> 
> admin-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/admin-discuss

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Mon, 21 Feb 2022 00:00:39 +0000

The IAB appoints IRTF chair, so I agree that arrow should point to the IRTF Chair.

If I read RFC 2014 correctly, the IRTF chair appoints the IRSG members subject to approval of the IAB. I’m not convinced that it’s useful to include that level of detail on the chart, but happy for Jay to update if he believes it is.

Colin

> On 20 Feb 2022, at 23:43, Jay Daley <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 Feb 2022 13:58:35 +1300

I need to buy a bigger screen ;-). Maybe an outsider needs a very simplified version first, followed by this for the details.

One missing component (I think) is the tools team itself, even if technically "inside" the LLC. For a potential contractor, that would be the first question: where do I fit in?

Is there a way to show that the NomCom is populated from the community?

Off topic: should there also be an IETF workflow diagram? I'm not aware of one on the web site. There have been personal efforts in the past, but perhaps an agreed version would be helpful both to contractors and participants.

Regards
    Brian Carpenter

---

From: Jay Daley <[email-masked]>
Date: Mon, 21 Feb 2022 14:24:48 +1300

> On 21/02/2022, at 1:58 PM, Brian E Carpenter <[email-masked]> wrote:
> 

I’m sure they do - I’ll leave that to others though.

> One missing component (I think) is the tools team itself, even if technically "inside" the LLC. For a potential contractor, that would be the first question: where do I fit in?

I have added teams and the IRSG changes from a previous message

> Is there a way to show that the NomCom is populated from the community?

Just looking at options.

> Off topic: should there also be an IETF workflow diagram? I'm not aware of one on the web site. There have been personal efforts in the past, but perhaps an agreed version would be helpful both to…

I think these would be very helpful. 

cheers
Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Mon, 21 Feb 2022 08:11:15 -0800

Jay,

Quite an undertaking!   No good deed shall go unpunished :-)

A few comments:

Looking at this, it would appear that ISOC is part of the IETF.   The ISOC community might be surprised to learn this.

Having the NOMCOM on top, might cause some to conclude it’s the main leadership body for all below it.

I think it would be good to distinguish between appointing volunteers, vs. hiring employees/contractors.   For example, the ISOC board hires (selects, contracts, pays) a CEO, vs. the IAB appointing the IRTF chair.

“owns” is used in different ways.   ISOC “owns” the IETF LLC is quite different from the IESG “owns” Working Groups.  I am not sure that “owns” is quite right for relationship between the IESG and Working Groups.  “Charters” might be better.

Lastly, the use of black and white to distinguish different kinds of roles in the KEY is very subtle.  You might consider also using colors or shading.

Bob

> On Feb 20, 2022, at 3:24 PM, Jay Daley <[email-masked]> wrote:
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Feb 2022 12:16:58 -0500

Jay:

IANA is missing.  The IAB provides oversign, but it does not "own" ot "appoint" any of the resources.  The IETF Trust does "own" the IANA IPR (i.e., trademark and domain name).

Russ

> On Feb 20, 2022, at 6:24 PM, Jay Daley <[email-masked]> wrote:
>

---

From: "John Levine" <[email-masked]>
Date: 21 Feb 2022 14:58:24 -0500

>(i.e., trademark and domain name).

The IAB provides oversight to 1/3 of IANA, the parameters part. The
Trust does legally own the IPR but has contracts with PTI to do all of
the actual work. I don't think either of these are worth putting in
the picture unless we all get much larger screens.

R's,
John

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Feb 2022 15:01:39 -0500

> On Feb 21, 2022, at 2:58 PM, John Levine <[email-masked]> wrote:
> 

I think that IANA Protocol Parameters should me on the picture, but I do not know how to label the arrows.

Russ

---

From: Jay Daley <[email-masked]>
Date: Tue, 22 Feb 2022 09:17:49 +1300

> On 22/02/2022, at 5:11 AM, Bob Hinden <[email-masked]> wrote:
> 
> Jay,
> 

The title includes "and inter-related organisations" partly to cover ISOC and partly because some people insist that "IETF" cannot be used as an umbrella term to include the IAB/IRTF while others insist that it has been used as such for many years.

> Having the NOMCOM on top, might cause some to conclude it’s the main leadership body for all below it.

I put it at the top because of the appointment authority but I agree that this needs some form of adjustment, as Brian suggested, to explain how it is constructed.  If we were instead to have the IESG/IAB etc as the top layer then the arrows would likely become unmanageable.
> I think it would be good to distinguish between appointing volunteers, vs. hiring employees/contractors.   For example, the ISOC board hires (selects, contracts, pays) a CEO, vs. the IAB appointing…

That is captured by the box style - thick lines for community appointed bodies and double lines for contracted roles.

> “owns” is used in different ways.   ISOC “owns” the IETF LLC is quite different from the IESG “owns” Working Groups.  I am not sure that “owns” is quite right for relationship between the IESG and…

Agree and 'charters' is a better word.

> Lastly, the use of black and white to distinguish different kinds of roles in the KEY is very subtle.  You might consider also using colors or shading.

I was trying to avoid colour because of the problems with that - I will look at shading.

Jay

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Tue, 22 Feb 2022 10:01:11 +1300

> On 22/02/2022, at 9:01 AM, Russ Housley <[email-masked]> wrote:
> 
> 
> 

I agree that IANA should be there but the intent of this diagram is structure (bodies and roles) not assets or processes (for other diagrams) and so it should be IANA the org not the protocol parameters.  As IANA has a liaison role on the iESG and IAB I can add at least those arrows.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Tue, 22 Feb 2022 10:07:39 +1300

New version now posted, which addresses all of this (except the position of NomCom) and adds IANA.  Also includes some lines tweaks to improve readability.

Jay

> On 22/02/2022, at 9:17 AM, Jay Daley <[email-masked]> wrote:
> 
> Signed PGP part
> 
> 
>> On 22/02/2022, at 5:11 AM, Bob Hinden <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Jay,
>> 
> [email-masked] <mailto:[email-masked]>
> 
> 
> 

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 22 Feb 2022 11:23:39 +1300

Thanks, this is getting better and better.

IANA is not just a liaison relationship. It's actually a service provider 
to the IETF, but under organisational agreements rather than a contract held by the LLC. Also, should it be inside a box labelled ICANN?

Regards
    Brian

On 22-Feb-22 10:07, Jay Daley wrote:
>> On 22/02/2022, at 9:17 AM, Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> Signed PGP part
>>
>>
>> I put it at the top because of the appointment authority but I agree that this needs some form of adjustment, as Brian suggested, to explain how it is constructed.  If we were instead to have the IESG/IAB etc as 
the top layer then the arrows would likely become unmanageable.
>>>> On Feb 20, 2022, at 3:24 PM, Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
>>>>
>>>> https://www.ietf.org/media/documents/IETF_Structure_-_February_2022.png <https://www.ietf.org/media/documents/IETF_Structure_-_February_2022.png>
>>>>

---

From: Jay Daley <[email-masked]>
Date: Tue, 22 Feb 2022 11:52:26 +1300

> On 22/02/2022, at 11:23 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> IANA is not just a liaison relationship. It's actually a service provider to the IETF, but under organisational agreements rather than a contract held by the LLC.

Yes, that could be captured.

> Also, should it be inside a box labelled ICANN?

No as it’s the function not the company that needs recording.  The Secretariat and RPC are not inside a box labelled AMS.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Mon, 21 Feb 2022 15:21:14 -0800

Jay,

> On Feb 21, 2022, at 12:17 PM, Jay Daley <[email-masked]> wrote:
> 
>> 

I don’t think that relates to my suggestion.   I think you should distinguish between hiring someone (ISOC CEO, IETF Exec Dir, etc.) and for example, appointing a w.g. chair.   They both currently use dotted lines a text “appoint”.

A general comment, I wonder if this digram is trying to capture so much information in different line styles, box styles, etc., that it is becoming less useful (without a document that explains it).

Bob

---

From: Jay Daley <[email-masked]>
Date: Tue, 22 Feb 2022 16:17:00 +1300

> On 22/02/2022, at 12:21 PM, Bob Hinden <[email-masked]> wrote:
> 
> Jay,
> 

Yes I understood - the difference is captured by the border of the subject of the appointment, where hired roles have the double line border, as do all contracted/legal entities.  However, I have changed "appoints" to "employs" for clarity.

> A general comment, I wonder if this digram is trying to capture so much information in different line styles, box styles, etc., that it is becoming less useful (without a document that explains it).

Ultimately this is only a map, it’s the territory that it is mapping that has the underlying complexity.

New version now up with all the changes people have asked for (I think) including creating a flat structure by moving the NomCom.

Jay

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Mon, 21 Feb 2022 20:55:07 -0800

Jay,

> On Feb 21, 2022, at 7:17 PM, Jay Daley <[email-masked]> wrote:
> 
> 
> 

Good, works for me.

> 	https://www.ietf.org/media/documents/IETF_Structure_-_February_2022.png

Good improvement.

Bob

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 22 Feb 2022 06:27:46 +0000

Hiya,

I do think this effort is worthy and useful. That said...

> https://www.ietf.org/media/documents/IETF_Structure_-_February_2022.png

One comment on the graphic, and one on the thread:

Graphic: I'd suggest s/structure/super-structure/ in the
title because...

On the thread: I don't think one can fit the concepts of an
IETF participant nor of the "volunteers" relationship in any
diagram like this, and those (IMO) are the really central
concepts that are important in understanding (what I think of
as) the important players and relationships.

It is a good thing to better understand how the various
designed components of superstructure relate, but that'd,
if taken alone, (which isn't I'm sure the intent at all),
give a misleading impression.

But, were there a useful graphical way to indicate that
all this hinges on participants who choose to volunteer to
do stuff, then that'd be a useful improvement to the image.

Cheers,
S.

---

From: Jay Daley <[email-masked]>
Date: Wed, 23 Feb 2022 11:36:56 +1300

> On 22/02/2022, at 7:27 PM, Stephen Farrell <[email-masked]> wrote:
> 
> Signed PGP part
> 
> Hiya,
> 

I understand the point but super-structure seems a bit cryptic.  See below for a different suggestions

> do stuff, then that'd be a useful improvement to the image.

Currently, the community is represented as an attribute of the boxes and that is reflected in the key, where five of the six items have the word community in them.  This to me reflects the underlying principle that the IETF is a community organisation and by default community controlled.  This could be made even clearer by adding community into the title, such as "Community structures of the IETF and inter-related organisations"?

I looked at a number of alternatives for representing the community and settled on the mechanism above for the following reasons:

1.  A separate community box. That would definitely be misleading because it would make it seem as if the community was a separate thing that had connections into these bodies rather than these bodies being drawn from and part of the community.  It would also require a bunch of arrows that would clutter the diagram even further.

2.  A big box round everything except the contracted parts that said Community.  This remains a possibility but is quite hard to do without including contracted roles, such as mine, and that would probably lose the point about community control and participation.

Perhaps this could be made clearer still by replacing the word community here with "Volunteer participant" in the key and possibly the title?

Jay

> 
> Cheers,
> S.
> <OpenPGP_0x5AB2FAF17B172BEA.asc>
> 
> 

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 23 Feb 2022 00:08:22 +0000

On 22/02/2022 22:36, Jay Daley wrote:
> 
> Perhaps this could be made clearer still by replacing the word
> community here with "Volunteer participant" in the key and possibly
> the title?
Something like that could be good, yes. But I realise that
there's no way to make such a diagram perfect.

Ta,
S.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 23 Feb 2022 13:43:10 +1300

> there's no way to make such a diagram perfect.
This is a bit of a tangent, but for newcomers to the IETF, whether as
participants or as contractors, the "volunteer" ethos, the "no voting"
rule and the strong dependency on informal channels add up to a major
source of confusion. I don't think that this diagram, which naturally
focuses on well-defined roles and communication channels, can be expected
to help with that confusion.

Probably the Tao and other material aimed at newcomers would help a bit,
but perhaps we need some text explicitly describing the volunteer ethos,
and how community input ultimately determines not only technical outcomes,
but actually *everything* on the diagram.

    Brian