Subject: [Adslmib] rfc2223bis-02.txt ????

From: "Bob Ray" <[email-masked]>
Date: 13 Jun 2002 15:51:53 -0000

Re: www.ietf.org/internet-drafts/draft-rfc-editor-rfc2223bis-02.txt

Has anyone noticed that the table of contents (page 2)
and section 4 (page 17) seem to be in conflict?  That is,
the draft does not seem to follow its own proscriptions.

Does anyone (Randy?) have a suggestion on which format to use?
That is, should I do what they do or do what they say?

Regards,
Bob Ray

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 14 Jun 2002 10:15:54 -0700 (PDT)

Hi -

> Date: 13 Jun 2002 15:51:53 -0000
> Message-ID: <[email-masked]>
> From: "Bob Ray" <[email-masked]>
> To: [email-masked]
> Subject: [Adslmib] rfc2223bis-02.txt ????
> 
...

This list on page 17 just gives the order for the sections.
The information on formating is on pages 20-21, and says:
"No specific format is required, but the following example
illustrates a useful format...."  

My *personal* preference is to number everything (makes
discussion and references easier), though using letters 
instead of numbers for appendices can be helpful.

I've encountered a few other problems in the 2223bis i-d,
and have been sending my comments to its authors.  I suggest
others (both readers and writers of RFCs) do the same.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: "Bob Ray" <[email-masked]>
Date: 14 Jun 2002 17:40:34 -0000

> This list on page 17 just gives the order for the sections.

This is what I was referring to.  Their proscribed order for
the sections (page 17) is:

      1.  First-page header
      2.  Status of this Memo
      3.  Copyright Notice
      4.  IESG Note
      5.  Abstract
      6.  Table of Contents
      7.  Body of memo
      8.  References
      9.  Security Considerations
      10. IANA Considerations
      11. Contributors
      12, Acknowledgments
      13. Authors' Addresses
      14. Full Copyright Statement

but the order of the document itself is:

      1.  First-page header
      2.  Status of this Memo
      3.  Copyright Notice
      4.  IESG Note
      5.  Abstract
      6.  Table of Contents
      7.  Body of memo
      8.  Acknowledgments
      9.  References
     10.  Security Considerations
     11.  Authors' Addresses
     12.  Full Copyright Statement

so... the contributors/acknowledgements and references sections
differ in placement.  I asked because I was reordering the
two drafts (vdsl, hc-tc) at that moment to try to follow this
document per your suggestion.  I ended up doing "what they say".

Regards,
Bob Ray

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 14 Jun 2002 11:30:49 -0700 (PDT)

Hi -

> Date: 14 Jun 2002 17:40:34 -0000
> Message-ID: <[email-masked]>
> To: Randy Presuhn <[email-masked]>
> Cc: [email-masked]
> Subject: Re:  [Adslmib] rfc2223bis-02.txt ????
> 
...
...

That's fine with me.  Please send them a note so this gets
fixed in the next revision of 2223bis.