Subject: RE: [Adslmib] thoughts on the next vdsl mib draft

From: "Faye Ly" <[email-masked]>
Date: Wed, 26 Jun 2002 09:29:16 -0700

Bob,

This does imply that you can have both
fast and interleave channel per interface
though.  Perhaps you should clarify this
in the DESCRIPTION?

-faye

>From: "Bob Ray" <[email-masked]>
>To: [email-masked]
>Subject: RE: [Adslmib] thoughts on the next vdsl mib draft
>Date: 25 Jun 2002 18:41:42 -0000
>
>Sundar Subramanian writes:
>
> >I have a question regarding the vdslLineType object in the vdsl draft 
>MIB:
> >
> >The possible values for vdslLineType are enumerated as:
> >
> >            noChannel(1),         -- no channels exist
> >            fastOnly(2),          -- fast channel only
> >            slowOnly(3),          -- slow channel only
> >            either(4),            -- either fast or slow channel exist
> >            both(5)               -- both fast and slow channels exist
> >            }
> >
> >There is no mention of an Interleave Channel. How would I represent my 
>VDSL
> >line if I have it channelized as an Interleave ??
>
>I think you are right (and I think Moti owes you a beer).  Perhaps we need
>a BITS structure instead of an enumeration?  That is,
>
>     vdslLineType OBJECT-TYPE
>         SYNTAX       BITS
>             {
>             vdslTypeFast(0),     -- fast channel
>             vdslTypeSlow(1),
>             vdslTypeInterleave(2)
>             }
>         MAX-ACCESS   read-only
>         STATUS       current
>         DESCRIPTION
>             "Defines the type of VDSL physical line
>             entity that exists, by defining whether and how
>             the line is channelized.  If the line is channelized,
>             the value will be other than noChannel(1).  This
>             object defines which channel type(s) are supported.
>
>             In the case that the line is channelized, the manager
>             can use the ifStackTable to determine the ifIndex for
>             the associated channel(s)."
>         REFERENCE    "T1E1.4/2000-009R3"    -- Part 1, common spec
>         ::= { vdslLineEntry 2 }
>
>Thoughts????
>
>Regards,
>Bob Ray
>
>
>_______________________________________________
>Adslmib mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/adslmib

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: "Bob Ray" <[email-masked]>
Date: Wed, 26 Jun 2002 17:41:13 -0500

>though.  Perhaps you should clarify this

Not really.  From section 2.3 Structure

>The MIB is structured into following MIB groups:
>
>o   vdslGroup :
>
>This group supports all line code independent MIB objects found
>in this MIB.  The following tables contain objects permitted for
>ifType vdsl(97):
>
>       - vdslLineTable 
>       - vdslPhysTable 

As vdslLineType is in the vdslLineTable, Moti's object applies
only for vdsl(97), not for interleaved(124) and (fast)
(that's a typo in draft 3, btw, page 7)

Then again, of course, I could be all wrong.

Bob